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INTRODUCTION 

Welcome to the fascinating world of SAP. This book helps you crack the tricks of mastering SAP HANA 

Customization 
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Cost Center Accounting 

This section describes the user-specific default settings to be made in Cost Center Accounting (CCA). 

The structure gives you an idea of the configuration sequence. 

Further notes 

For more information on the IMG for "Cost Center Accounting", see the SAP Library under Financials -

> CO Controlling -> Cost Center Accounting under the topics: 

Cost Center Accounting Master Data 

Cost Center Planning 

Actual Cost Calculation and Transaction-Based Allocations 

Funds Commitment 

Period-End Closing 

Cost Center Accounting Information System 

 Requirements 

Before you make settings for cost centers, you must already have processed the following sections: 

The Organization section in the Implementation Guide (IMG) for General Controlling 

The Master data section in the Implementation Guide (IMG) for Cost Element 

Accounting 

If, in Cost Center Accounting you 

Use activity types 

Use statistical key figures 

Make evaluations using the information system 

you must select these application components in addition to Cost Center Accounting when you generate a 

project IMG. 

 Activate Cost Center Accounting in Controlling Area 

In this IMG activity you use the controlling area control indicators to activate Cost Center Accounting ( 

CO-CCA ). 

You use control indicators to activate or deactivate certain cost accounting functions by fiscal year. 



 

 

The control indicators are valid as of the selected fiscal year, up to the fiscal year in which you maintain 

new indicators. 

Requirements 

You have completed the IMG activity Maintain Controlling Areas located in the General Controlling 

section of the IMG under Organization. 

Standard settings 

The standard SAP System includes controlling area 0001, to which company code 0001 is assigned. 

Activities 

Choose the controlling area in which you want to use CCA. 

Choose Activate components/control indicators. 

Activate CO-CCA. Notes on transport 

To transport controlling area settings, a separate function is available in Customizing under Controlling -

> General Controlling. 

 Enterprise Organization 

In this activity you specify the necessary settings for using enterprise organizations 

Further information 

For more information on enterprise organizations, see the SAP Library under AC - Financials -> CO - 

Controlling -> General Controlling -> Contolling Methods -> Enterprise Organization. 

 Set Active Plan Version 

Only one of the plan versions created in the system is active at a given time. The workflow 

system regards this plan version (with its contents) as the only valid plan version. 

Recommendation 

Mark plan version 01 as the active plan version. 

Standard settings 

All SAP workflows supplied are then automatically in the plan version marked as active. 

Activities 

Enter the plan version that you want to use as the active plan version in the field Value 
semantic abbreviation in the parameter group "PLOGI PLOGI". 

Further notes 

Maintaining an active plan version is part of the settings made in automatic Customizing. 
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You should definitely execute automatic Workflow Customizing, because it also makes other important 

settings. You can find automatic Workflow Customizing in the Implementation Guide by choosing SAP 

Business Workflow / Webflow-> Maintain Standard Settings for SAP Business Workflow. 

If you have already set an active plan version, it is not overwritten by automatic Customizing. 

 Enter Settings for Enterprise Organization 

To use the enterprise organization functions for maintaining cost centers or profit center standard 

hierarchy, you must activate enterprise organization per controlling area. 

Note 

If you have activated enterprise organization in a controlling area, the maintenance of the standard 

hierarchy for cost centers or profit centers is limited (the group structure cannot be changed: master data 

can be maintained). 

Activities 

To activate enterprise organization for a new controlling area, choose New entries. 

To change the data on an existing controlling area, select the corresponding controlling area and 

choose Detail. 

Prerequisite: You are in change mode. 

Enter the controlling area. 

To activate the enterprise organization, select Enterprise organization active for the controlling area in 

question. 

Enter the fiscal year interval for which the standard hierarchy is to be classed as complete. 

Note on number of fiscal years 

Specify whether company codes may be assigned to one another hierarchically. 

Note on assigning organizational units 

 Create Enterprise Organization 

If you have not generated the enterprise organization from the standard hierarchy, you will need to 

regenerate the enterprise organization. 

Prerequisites 

You have activated the enterprise organization for the controlling area in question. 

See 



 

 

Customizing for Cost Center Accounting under Enterprise Organization -> Settings for 

Enterprise Organization 

Customizing for Profit Center Accounting under Enterprise Organization -> Settings for 

Enterprise Organization 

Check the preview period. 

This time interval determines the processing period of the enterprise organization and is the preset 

processing period for the CO objects contained. You can change the preview period if necessary. 

Activities 

Creating a root organizational unit 

The standard system contains a new HR organizational unit with the provisional title New 

Organizational Unit that you can use as a root organizational unit. 

In the detail area, overwrite the provisional entries. 

Save your entries. 

Creating Additional HR Organizational Units 

You can created additional HR organizational units: 

In Customizing for the relevant application component by choosing Enterprise 

Organization -> Enter Settings for Enterprise Organization 

In the relevant application component by choosing Master data -> Enterprise organization -> 

Change 

To create further HR organizational units within an organizational structure, in the overview area select 

the organizational unit under which the new object is to be assigned. 

Choose Create -> Organizational unit 

Note 

You can also copy an existing HR oganizational unit. All properties of this organizational unit are 

copied in the process. You then change the data in the detail section as needed. 

To maintain the data for the HR organizational unit, double-click on the unit in the organizational 

structure. 

Creating Cost Centers/Profit Centers 

You can create additional cost centers and profit centers. 

In Customizing for the relevant application component by choosing Enterprise Organization -> 

Enter Settings for Enterprise. 

In the relevant application component by choosing Master data -> Enterprise organization -> 

Change 

To create cost centers/profit centers within an organizational structure, in the overview area, select the 

HR organizational unit to which the cost center/profit center is to be assigned. 

Choose Create -> Cost center (for organizational unit) 

The system displays the master data in the detail area. In so doing, the system transfers the data in 

accordance with the inheritance principle. 

Note 

The system displays the assignment of the cost center/profit center to the HR organizational unit in 

the structure for the overview area 
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At present you can only maintain cost center and profit center master data  in the enterprise 

organization. You can only display the master data for controlling area and company code from the 

organizational structure. 

Creating Cost Center Groups/Profit Center Groups 

You can create additional groups 

In Customizing for the relevant application component by choosing Enterprise 

Organization -> Enter Settings for Enterprise Organization 

In the relevant application component by choosing Master data -> Enterprise organization -> 

Change. 

To create groups within an organizational structure, in the overview area, select the HR organizational 

unit to which the cost center is to be assigned. 

The detail area contains the data on the HR organizational unit for processing. 

In the detail area on the tab strip CO Assignment choose Cost center group -> Create or Profit 

center group -> Create. 

Enter the name of the group along with a description. 

The system transfers the group -> HR organizational unit assignment to the structure in the 

overview area 

Note 

You can change the group name at a later date but only up to the point at which you have not 

generated a standard hierarchy from the enterprise organization. If you have already assigned 

a group or an object  to an HR organizational unit, you cannot assign any further group(s). 

Further notes 

For more information on the enterprise organization, see the SAP Library under Financials - CO - 

Controlling -> Controlling -> Controlling Methods -> Enterprise Organization. 

 Generate Enterprise Organization from Standard Hierarchy 

You can generate the enterprise organization from an existing standard hierarchy. 

You can then continue processing the standard hierarchy using the enterprise organization functions. 

Requirements 

You have activated enterprise organization for the corresponding controlling area in the standard 

hierarchy. 

See also Customizing for Cost Center Accounting under Enterprise Organization -> Enter 

Enterprise Organization. 

Activities 

Specify the target plan version. 



 

 

The system defaults the active plan version in each case, which you can however overwrite. 

See also Customizing for Cost Center Accounting under Enterprise Organization -> Set 

Active Plan Version. 

Specify the controlling area for which the enterprise organization is to be generated. 

The system determines the appropriate standard hierarchy according to this controlling area. 

Specify the key date. 

At which the enterprise organization is to be generated (first generation run) 

As of which all changes in the standard hierarchy are to be transferred to the enterprise organization 

(subsequent generation run) 

The system defaults the current date which you can however overwrite. 

 Generate Standard or Alternative Hierarchy from Enterprise 

Organization 

At a given key date, you can generate the following hierarchies for a cost center from the enterprise 

organization: 

Standard hierarchy 

Alternative hierarchie 

Replace standard hierarchy with alternative hierarchy 

Requirements 

You specified the fiscal year interval in which the objects in the hiearchy in question are to be valid. 

This interval determines which objects are contained in the given hierarchy. 

See also: 

Customizing for Cost Center Accounting under Enter Enterprise Organization 

Customizing for Profit Center Accounting under Enterprise Organization -> Enter Enterprise 

Organization. 

Recommendation 

If the hierarchies are large, generate them in the background. 

If you try to generate large hierarchies online, processing can be stopped due to timeout. 

Activities 

Enter the key date on which the hierarchy is to be generated. 

The system defaults the current date, which you can however overwrite. 

If you want to generate an alternative hierarchy, enter a suffix for this hierarchy. 

Note 
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You can assign a name without a suffix for the standard hierarchy only 

If you want to replace the standard hierarchy with an alternative hierarchy, 

Enter the name of the alternative hierarchy that is to be the standard hierarchy Note 

When it generates this new standard hierarchy, the system automatically shortens the previous 

name by this suffix. 

Enter a suffix for the old hierarchy. 

This becomes an alternative hierarchy. 

Specify whether the hierarchy should be generated for cost center or profit center. 

Specify whether groups that exist in the existing standard or alternative hierarchy should be overwritten 

when the new hiearchy is generated. 

Note on hierarchies 

Specify whether the hierarchy is to be generated for controlling areas or for profit centers. 

Choose Execute 

To generate the hierarchies in the background, choose Execute program in background 

Further notes 

Detail information on time-dependent generation of hierarchies 

 Activate Inactive Master Data 

In this IMG activity, you can activate inactive master record versions for the following organizational 

units within the enterprise organization: 

Cost centers 

Profit centers 

Note on Active and Inactive Master Record Versions 

Activities 

1. Choose the corresponding organizational unit using one of the following criteria: 

<Organizational unit> or <Organizational unit> interval 

<Organizational unit> group 

All <Organizational units> in a controlling area 2. Decide whether to activate 

immediately or in a Test run first. 

Decide whether to activate in the background or online. 

To activate the organizational units, choose Execute. 

Note 

You can go to Profit center activation from Cost center activation and vice versa. 

Further notes 



 

 

For more information, see the SAP Library under Financials -> CO - Controlling -> Methods in 

Controlling -> Enterprise Organization -> Processing The Enterprise Organization -> Activate 
Inactive Master Data. 

 Delete Inactive Master Data 

In this IMG activity, you can delete inactive master record versions within the enterprise organization for 

the following organizational units: 

Cost centers 

Profit centers 

Note on Active and Inactive Master Record Versions 

Activities 

1. Choose the corresponding organizational unit using one of the following criteria: 

<Organizational unit> or <Organizational unit> interval 

<Organizational unit> group 

All <organizational units> of a controlling area 2. Decide whether to delete immediately 

or in a test run first. 

Decide whether to delete in the background, or online. 

To delete the inactive master record versions, choose Execute. 

Note 

You can go directly to Deleting profit centers from Deleting cost centers and vice versa. 

Further notes 

For more information, see the SAP Library under Financials -> CO - Controlling -> Methods in 

Controlling -> Enterprise Organization -> Processing the Enterprise Organization -> Deleting 

Inactive Master Data. 

 Master Data 

In the master data section you make default settings for: 

Cost centers and cost center groups 

Activity types and activity type groups 

Statistical key figures and statistical key figure groups 

You also have the option of creating master data and master data groups. 

Note 

When you create your master data groups you should be aware of the effects on planning, cost allocation, 

and the information system. 
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Further notes 

For more information on master data, see the SAP Library under Financials ->  Controlling (CO) -> 

Cost Center Accounting -> Master Data in Cost Center Accounting. 

 Cost Centers 

In this activity you make settings for cost centers. These include: 

Defining the standard hierarchy 

Defining cost element types 

Creating cost centers 

Defining matchcodes for cost centers 

Selecting time-dependent fields 

Note 

If you have activated the enterprise organization in a controlling area, you can no longer carry out group 

maintenance for the standard hierarchy of cost centers or profit centers. 

For more information, see: 

Enter enterprise organization (cost centers) 

Enter enterprise organization (profit centers) 

Further notes 

For more information on cost centers, see the R/3 Library under  Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data in Cost Center Accounting -> Cost 
Centers 

 Request for a Change to Cost Center Master Data 

In this activity, you make the settings needed for requesting changes to the following master data via the 

Intranet/Internet: 

Cost centers 

Internal orders 

G/L accounts 

Vendors 

Customers 

In the so-called scenarios, you define the process of requesting a master data change. This process 

definition is technically based on messages. 

You can find additional information in the "SAP Library" under Financials -> Controlling 

(CO) -> Cost Center Accounting -> Master Data in Cost Center Accounting -> Processing 
Master Data -> Requesting Master Data Changes in the Internet/Intranet. 



 

 

 Define Own Scenarios for Request to Change Master Data 

In this IMG activity, you define scenarios for the request to change master data. 

Standard settings 

All the scenarios provided by SAP are in the S* namespace. 

For requests to change master data, the following notification types are provided in client 000: 

Notification type 50 for requests for cost centers, orders, and G/L accounts. 

Notification type 70 for requests for vendors and customers. 

Note 

To be able to use these notification types, you need to transfer the settings from client 000 using the 

QISR_SM29 transaction. Then you need to process number ranges for the notification types. 

The notification type contains information on whether the request must be approved, and if so, by 

whom. Note that you can use a notification type for more than one scenario. 

Requirements 

SAP recommends that you use the scenarios provided for master data changes as a reference for creating 

your own scenarios, and then to adapt the copy as required. 

Activities 

To copy a scenario, select is and choose Copy. To create a scenario, choose New entries. 

Enter a key and a description for the scenario. 

Caution 

The scenario key must not be in the SAP (S*) namespace. 

In the general data, make the required entries. 

Take this opportunity to store a long text for the scenario. This description is displayed as an 

explanation when you call up the form. You can also use this description to find a corresponding 

form in the intranet. When you enter the text, you do not have to enter key words as the search 

engine filters the text using not only the words, but also their conjugation or declination. Word 

groups are also used for the search. For more information on the search engine, see the SAP Library 

under Financials -> 

Controlling -> Cost Center Accounting -> Information System -> Interactive Information System, 

and then see  Report Documentation  under Document Search Using The Retrieval System. 

Transfer the scenarios from notification type 50 or 70 accordingly. 

Note that you initially need to transfer the settings for the notification types from client 000 using 

the QISR_SM29 transaction. Then you need to process the number ranges for the notification types. 

Note 

Check whether the follow-up activities provided on the activities menu bar match your 

requirements. We recommend that you use the follow-up activities supplied by SAP. 

Use Entry with form as the entry type. 

You only need to specify an ITS service if you choose the Entry with form entry type. You use an 

HTML form specially designed for the scenario. You also need to assign an Internet service to the 

scenario that contains the required HTML templates, ITS ( Internet transaction server) and 

language-dependent resources. In addition, there is a choice of business add-ins (BADIs) that you 
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can use, in which you can define specific requests. You can assign an Internet service to maximum 

one scenario. To create a new Internet service, choose Generate. You have two options: 

Generate internet service with reference 

When you generate the Internet service, if you specify a scenario with an existing Internet 

service as a reference, the system copies it to the new Internet service name. 

Generate internet service without reference 

If you do not specify a scenario with an existing Internet service as a reference, the system 

copies the default Internet service SR00. An internet service created in this way contains all 

settings required for immediate testing of the scenario definition. The system automatically 

inserts a request data area with corresponding entry fields, for the request-specific 

characteristics that were defined in the scenario. 

Note 

Before you can test the Internet service, you need to publish it manually. This takes you 

automatically to the Internet service processing in the development workbench, where you can 

publish the entire Internet service. Then you can test the ITS service from Customizing using 

Test. 

7. To modify forms, choose Business Add-Ins. You can now change the implementation (create, 

change, delete and so on). 

If you require special initialization or checks on the request for the scenario, you can use a business 

add-in (BADI QISR1). For more information on BADIs, see Basis -> Change and Transport 

System - Overview -> Transactions and Tools -> BC Changes to SAP Standards -> Business Add-

Ins. 

Caution 

SAP recommends that you use the F4 Help to transfer the corresponding Business Add-In from 

the scenario for requests to change master data. In this case, the existing interfaces to the SAP 

system are used automatically. 

Each Business Add-In provided ensures that all of the fields defined in the SAP system (which you 

use on your request form) are integrated with the SAP system, for example, for the purpose of 

consistency checks. You can also copy and enhance the Business Add-In if necessary. 

Do not activate the Cost incurring indicator. 

The scenarios for changing master data do not incur costs. 

Choose Transfer. 

In the next dialog box, choose Copy all. The selection list now provides the scenario that you 

copied. 

Flag your scenario and choose Characteristics in the selection area. 

Enter the fields that you require for the request form. 

Next, select Dictionary category and transfer the structure for each request. All the fields are 

contained here that you can use for the form. You can carry out a search via structure name ISR*. 

In the basic data you use ITS to determine which fields appear on the form, and in which order 

they should appear. You use a Business Add-In to control which fields are filled as default. 

Notes on field selection 

In the cost center structures ISR_COSTCENTER_CREATE (for scenario SRK1 create cost 

centers) and ISR_COSTCENTER_CHANGE for scenarios SRK2 and SRK3 ( change/lock 

cost centers) some of the fields appear twice, but you need to choose the following fields for 

the request form: 



 

 

LOCK_IND_ACT_PRIM_COSTS Lock indicator for primary actual postings 

LOCK_IND_PL_SEC_COSTS Lock indicator for secondary cost planning 

NAME_CC General description 

For a request to create a new cost center, the following are minimum requirements: 

Controlling area 

Cost center key 

Date valid from 

Date valid to 

Description 

Person responsible 

For a request to change  a cost center, the following are the minimum requirements: 

Controlling area 

Cost center key 

Date valid from 

Date valid to 

Choose Tasks in the selection area. 

You specify the processing procedure in the SAP System for the request to change master data by 

using the workflow or worklists. 

Transfer a task for each scenario. 

Enter a processor or a standard role. 

This data is automatically provided when you call up the request form. 

SAP provides you with standard roles for the various requests to change master data. It is 

recommended that you copy these and adapt the copy accordingly. 

Note 

You can use the partner role to control whether a single processor (task processor) is defaulted in 

the request form, or a whole department (department responsible). For more information on the 

role, see the SAP Library under Basis -> Business Management -> Organizational 

Management -> Integration Into The Workflow -> Role Breakdown -> Role Definition -> 
Define Responsiblity Roles. 

Example 

SAP provides the standard role 30014 for requests to change cost center master data. 

Further notes 

More information on master data adjustment requests is available in the SAP Library under 

Financials -> CO Controlling -> Cost Center Accounting -> Master Data in Cost Center 

Accounting -> Processing Master Data -> Master Data Adjustment Requests 
viaInternet/Intranet. 
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 Assign Own Scenarios for Requesting Master Data Changes 

In this activity, you specify for cost centers the request forms that can be accessed from other 

applications. The assignment can be limited by a controlling area. 

The following list contains the applications from which you can access the request forms for cost centers: 

center. 

Enterprise organization, 

Processing of Standard hierarchy, 

Cost centers master data report 

Example 

Controlling area scenario 

0001 SRK1 Request to create a cost center 

0001 SRK2 Request to change a cost center 

0001 SRK3 Request to lock a cost center 

For controlling area 0001, the access is made available from the corresponding applications of cost center 

accounting (Enterprise organization, Processing standard hierarchy and cost center master data report) to 

the forms for creating, changing, and locking a cost center. 

Hinweis 

If you do not enter a controlling area, the assigned scenario is valid for all controlling areas. 

Activities 

Choose New entries. 

Enter the controlling area for which the assignments are to be valid. 

Enter the scenarios that are to be accessed from SAP applications. 

The system automatically adds this to the description of the scenario. 

Save your entries. 

 Define Cost Center Categories 

In this IMG activity you define cost center categories. 

You define the categories yourself (such as P for a production cost center or A for an administration cost 

center), or you can use the cost center categories supplied by SAP. 

Activate or deactivate the following indicators as default values: 

Lock primary postings 

Lock secondary postings 

Lock revenue postings and revenue planning 

Lock commitment update 



 

 

Lock primary cost planning 

Lock secondary cost planning 

Lock consumption quantities 

Enter a functional area as a default value. 

The SAP System defaults this indicator when you create cost center master data from the cost 

center category specified. You can overwrite the default values in each individual cost center 

master record. 

Note 

The Cost center category field is also used in activity type planning. In the activity type master record 

you enter the cost center type for which the activity type can be planned. Enter "*" if the activity type is 

allowed for all cost center categories. 

Example 

You allow activity type PHR (production hours) to be planned on all cost centers with category P ( 

production ). 

This means the activity type cannot be planned on an administration cost center by mistake. 

Standard settings 

A number of categories are included in the standard SAP System. 

Actions 

Check whether the categories supplied by SAP meet your requirements. 

If not, create new categories to classify the cost centers in your company. 

Note on transport 

To transport cost center categories, an individual function is available in Customizing General 

Controlling. 

Additional information 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Master Data for Cost Center Accounting -> Cost Centers. 

 Define Selection Variants for Cost Centers 

A selection variant contains the fields that are to be evaluated in your selection report. These fields 

determine the content and structure of a selection variant. 

The following selection reports are available: 

For cost elements     RKKOASEL 

For cost centers     RKKSTSEL 
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For activity types    RKLSTSEL 

For business processes RKPRZSEL 

For internal orders RKOSEL00 

For projects     RKPSEL00 

You enter the selection values in the corresponding fields, and can overwrite these in the application. 

You can hide the fields that you do not require. 

When you process "variant attributes", you can specify variables for selection variant fields, and so on. 

Example 

If you wish to select your objects by time, then define a selection variant, which only contains master 

data fields for times. 

Standard settings 

The following selection variants are defined for internal orders: 

SAP_01 - SAP_02 - SAP_03 

Activities 

If you wish to create your own selection variants, proceed as follows: 

Enter a name for your variant in the "ABAP: Initial screen for variants" 

Confirm the "Values" default setting in the "Subobjects" group box, and choose "Create". In the "Variant 

maintenance: Report <your selection report>" screen, the system displays the selection fields for the 

corresponding master data. 

Enter the values or variables in the fields that you wish the system to use for selection. 

Choose Continue. 

This takes you to the Attribute maintenance screen for the selection variants. 

You can assign the following field attributes: 

Protected 

The value that you specified for the field can no longer be overwritten in the application. 

Invisible 

The system hides this field from the selection variant. 

Selection variable 

You can define a variable for a field, such as a user-defined selection rule ( compare with the 

"Define selection rule" section). The field is filled with the corresponding value during 

runtime. 

Enter a short text in the "Description" field. 

Save your entries. 

This variant is now available for the corresponding selection report. 



 

 

Transport notes 

You can transport selection variants manually by proceeding as follows: 

Choose "Utilities -> Transport request..." in the "ABAP: Variants - Initial screen" 

Enter the program name 

Enter the name of the variant to be transported 

 Define List Variants for Group Processing 

In this IMG activity, you create screen variants for the layout of the entry screen for the collective 

processing of cost centers . 

You can determine which fields are displayed and in which order for the individual cost centers. 

Default settings 

The standard system includes the following list variants for the collective processing of cost centers: 

Standard one row 

Standard two rows 

Standard three rows 

Standard four rows 

You cannot change these list variants. Standard and custom variants can be selected with the input help 

(F4). 

Activities 

Check whether the list variants delivered meet your requirements. 

If necessary, create new list variants as follows: 

Choose Create. 

Enter a key for the list variant, a corresponding short text, and the number of rows to be displayed 

for each cost center. 

From the list of the possible fields, select the fields which are to appear in the cost center list. 

Note that you must choose the fields Selection and Cost Center. 

If necessary, change the offset in order to change the position of the fields within the row. 

Save your entries, and activate the list variant. 

Further notes 

To ensure that Cost Accounting is active in the given year for the objects in the list variant, you should 

also check the settings in the IMG activity Maintain Controlling Area. 

 Activate Inactive Cost Centers 

In this IMG activity, you can activate the inactive version of a master record. 
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The following master data can be either active or inactive versions: 

Cost centers 

Profit centers 

Business processes 

Note on Active and Inactive Master Record Versions 

Choose the corresponding objects using one of the following criteria: 

<Object> or <object> interval 

<Object> group 

All <objects> in a controlling area 

Decide whether to activate immediately, or in a test run first. 

Decide whether to activate in the background, or online. 

To activate the objects, choose Execute. 

Note 

You can go from the activation of one object into the activation for another object. This means 

that you can go from Activation of cost centers to Activation of profit centers. 

Further notes 

For more information, see the SAP Library, under Financials -> CO - Controlling -> Methods in 

Controlling -> Enterprise Organization -> Processing Enterprise Organization -> Activate 

Inactive Master Data. 

 Delete Inactive Cost Centers 

In this IMG activity, you can delete the inactive version of one of the following master records: 

Cost centers 

Profit centers 

Business processes 

Note on Active and Inactive Master Record Versions 

Activities 

Choose the corresponding objects using one of the following criteria: 

<Object> or <object> interval 

<Object> group 

All <objects> in a controlling area 

Decide whether to delete immediately, or in a test run first. 

Decide whether to delete in the background, or online. 

To delete the inactive master record versions, choose Execute. 



 

 

Note 

You can go from the deletion transaction for one object to that of another object. This means 

that you can go from Deleting cost centers to Deleting business processes and Profit 

centers. 

Further notes 

For more information, see the SAP Library under Financials -> CO - Controlling -> Enterprise 

Organization -> Processing the Enterprise Organization -> Delete Inactive Master Data. 

 Define Cost Center Groups 

You can combine similar cost centers to form cost center groups. You may then combine similar groups 

into further groups to create a cost center hierarchy. 

Note on Cost Center Groups 

The organizational division into cost centers can be displayed in the SAP system with the use of cost 

center groups. 

Cost center hierarchies summarize the decision-making, responsibility, and control areas according to the 

user's requirements. Individual cost centers are the lowest hierarchical level. This ensures that at least one 

group holds all cost centers, and thereby represents the entire organization. Moreover, alternative groups 

can be created which can be divided according to structural or functional standpoints. 

Cost center groups allow valuations according to any desired area of responsibility. 

You can use cost center groups: 

In the information system to create reports for selected cost centers - To process multiple cost 

centers in a single transaction: 

Cost center planning 

Distribution 

Assessment 

You must maintain the standard hierarchy for your controlling area in the master data. Here, you have the 

option of creating and changing other cost center groups. 

Requirements 

Complete the IMG activity Maintain Controlling Area. 

Activities 

Structure the cost centers in your controlling area along cost accounting standpoints. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 
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Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 



 

 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 
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The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 



 

 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To transport cost center groups, there is a separate function in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity period. However, most master data is time-based. 

Further notes 

For more information about cost center groups, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data for Cost Center Accounting -> 
Processing Master Data -> Master Data Groups and also Cost Centers. 

 Define Hierarchy Versions 

Use 

In this Customizing activity, you define hierarchy versions for use with inactive hierarchies. When you 

create an inactive hierarchy using a hierarchy version, the system applies the definition of the hierarchy 

version to the inactive hierarchy. 

By using inactive hierarchies, users can create hierarchies for the future. These inactive hierarchies 

cannot be used in other transactions until they are activated. When an inactive hierarchy is activated, it 

overrides the current effective hierarchy from the specified date. 

Standard settings 

If a hierarchy version is used by an inactive hierarchy, you cannot delete it in this activity. If an inactive 

hierarchy using the hierarchy version has been activated, you cannot change the hierarchy version. 

Activities 

When you define a hierarchy version you must enter the following: 
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- A unique ID for the hierarchy version 

A hierarchy version ID cannot contain special characters. Valid characters include letters (but 

not ö or á), numbers, underscores, and hyphens. - The date on which the hierarchy version 

takes effect 

 Activate Inactive Hierarchies 

Use 

In this Customizing activity, you activate inactive hierarchies whose validity dates have been reached. 

When a hierarchy is activated, the previously effective cost center group hierarchy is superseded by the 

newly activated hierarchy. This allows you to report on the hierarchy, use it in planning applications, and 

allocate using the groups contained within the hierarchy. 

Hierarchies can be maintained in the Web Dynpro application by a central master data team and are 

typically updated periodically, for example, quarterly or yearly. Changes then come into effect on a 

specified validity date. For these types of hierarchies, you define inactive hierarchies for use in the 

future. 

We recommend that you run the report behind this Customizing activity on a regular basis using either a 

background job or the Schedule Manager (SCMA) transaction. 

Requirements 

You have completed the following: 

You have defined a hierarchy version in the Customizing activity Define Hierarchy Versions. 

You have copied your cost center group hierarchy into the inactive hierarchy version using the Web 

Dynpro frontend. 

Activities 

Within this inactive hierarchy you can create new cost center groups and assign cost centers as required. 

Once you are satisfied with the structure of your hierarchy, you can make it active by running the 

activation program. This creates a copy of the hierarchy and makes it effective for reporting, 

planning, allocations, and so on. If you need to report on the previously effective version, you can 

set the parameters in Report Writer to read on an earlier key date. 

Note: 

The system skips over any hierarchies that are locked or for which authorizations are missing. If an 

effective hierarchy is changed after an inactive hierarchy is created, you get a message.  If this 

happens, you have to actively confirm that you want to continue running this report. 

If you schedule this report behind this Customizing activity to run as a background job in test mode, you 

can run transaction CFG1 to read messages raised by the system when activating the hierarchies are 

stored in the application log under the object COOMMD and the subobject COMDACTIVATE. 



 

 

 Define Search Helps for Cost Centers 

In this IMG activity you can maintain or redefine search help for cost centers. 

Notes 

Search help maintenance requires technical knowledge of the ABAP Dictionary. Let system 

administration maintain search help for you. 

Note that large numbers of search helps result to slow system performance. Check which search helps 

you need. Deactivate any search help you do not require. 

Search help is valid for all clients. 

Requirements 

Before maintaining search help, see the SAP Library under Basis Components -> ABAP 

Development Workbench -> ABAP Dictionary -> Search Help for information on how search help 

is constructed in the SAP system and how to create one in the ABAP Dictionary. 

Standard settings 

SAP supplies the following standard search helps: 

Search help ID "N" enables searching for a cost center using the cost center number. 

The search help with the ID "S" enables searching for a cost center using the cost center name. 

Activities 

Check whether the standard search helps satisfy your requirements. 

Supplement the existing search help objects with further search help objects or create new search helps if 

necessary. 

Define Time-Based Fields for Cost Centers 

In this step you determine on the client level, independently of organizational units such as controlling 

area or chart of accounts, whether master data table fields are historically relevant or not. 

You can maintain master data for cost centers, cost elements, activity types, and business processes as 

time-based. Changes to any other time interval are possible at any given time. Data storage is also time-

based. In this way, you can store multiple database records for a master data record, each holding 

different information. 

The time-based dependencies are determined by SAP and cannot be changed. The following 

dependencies are possible: 

Not time-based 

Day-based 

Period-based 

Fiscal Year-based 

In the "Time Dependency" column, you have an overview of the time-based dependencies for individual 

master data fields as set by SAP. 
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For day-based fields, you can set an indicator determining whether fields are historically relevant or not. 

Period-based and year-based fields are always historically relevant. 

If you change fields during master data maintenance which were marked as historically relevant, and 

redefine a new analysis period, the system creates new database records, for the new analysis period and 

for any following periods, and simultaneously restricts the validity period of the existing database 

records. 

Example: 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

Then you change the object by defining other field characteristics from 011997 to 312997. In 

Customizing, you defined the Manager field as historically relevant. 

The SAP system stores three records. You can view them in master data maintenance by placing the 

cursor on the field and choosing Expand: 

One record for the interval 011996 to 312996 Manager: Miller 

One record for the interval 011997 to 312997 Manager: Wang 

One record for the interval 011998 to 312999 

Manager: Miller 

If you change fields during master data maintenance not marked as historically relevant, but without a 

new analysis period, the entire database record changes for the entire analysis period. These changes 

appear in the change log. 

If you change day-based fields not marked as historically relevant, the existing database record also 

changes for the entire selected analysis period. Definition of a new period is not possible. These changes 

appear in the change log. 

Example 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

You then change the object by defining another cost center manager. In Customizing, you defined the 

Manager field as not historically relevant. 

The SAP system changes the record for the Manager field: 

Record for the interval 011996 to 312999 Manager: Wang 

The SAP system documents the changes with date and user name in a change document. 

Fields without time-based dependencies may be changed at any time, with the change applying to the 

entire validity period of the master data. 

Note 

Remember that time-based storage consumes large amounts of data storage space. Designate only 

important fields for time-based dependencies. 

If consecutive fields have identical historically relevant definitions, the SAP system replaces the database 

records with a single record valid for the existence of the individual records. 

Further Notes 



 

 

Time-based master data storage minimizes maintenance effort. You can create master data crossing fiscal 

year boundaries without having to recreate them every year. Changes affecting a single time only can be 

made without direct effects on the other times involved. 

Example: 

You create a cost center with the following data: Cost Center: 41 

Validity Dates: 011996 to 312000 

This entry remains available in the SAP system until 312000. 

However, you may also create: 

Cost Center: 41 

Validity Dates: 011996 to 312996 

The disadvantage here is that you must recreate the cost center for the following years, each year, if 

you still require the cost center. 

The example above uses the yearly borders of a calendar year. However, you can determine validity 

periods that are independent of any given calendar year. This is particularly useful if you define a fiscal 

year variant in Financial Accounting with delayed, extended, or shortened fiscal years, because master 

data is not oriented along fiscal year variant lines. 

Actions 

Determine which fields you want to designate as historically relevant. 

Activate or deactivate the indicators according to your requirements. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

 

Program Enhancements for Cost Center Master Data 

You can add own fields to the cost center master data. The following SAP enhancement is available for 

this purpose: 

COOMKS01 Cost Center: customer-specific additional fields in the master record This 

enhancement includes the following enhancement components: 

EXIT_SAPLKMA1_001 

CO-OM customer exit for PBO of customer-specific subscreen "0399" in SAPLKMA1. 

EXIT_SAPLKMA1_002 

CO-OM customer exit for PAI of customer-specific subscreen "0399" in SAPLKMA1. 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 
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Activate the project 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancements can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function Exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 BAdI: Maintain Cost Center Master Data 

Use 

This Business Add-In (BAdI) is used in the Controlling (CO) component. You can use this BAdI to 

integrate additional fields into master data for cost centers. 

When you implement this BAdI, you override the settings in the Customizing activity Program 

Enhancements for Cost Center Master Data. This is because you cannot use this Customizing activity 

with the new Web Dynpro application. SAP uses Floor Plan Manager and this BAdI to support customer 

enhancement. 

Requirements 

You have created and activated the Customizing Include CI_CSKS. 

Standard settings 

For more information about the standard settings (filters, single or multiple uses), see the Enhancement 

Spot Element Definitions tab in the BAdI Builder (transaction SE18). 

Activities 

For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for 

SAP NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

See also 

BAdI method documentation: 

GET_CUSTFLDS_PROPERTY 

PROCESS_CUSTFLDS_AFTER_INTPUT 

CHECK_CUSTFLDS_BEFORE_SAVE 



 

 

 Activity Types 

In this section you can 

maintain allocation cost elements 

create activity types 

maintain activity type groups 

define matchcodes for activity types 

determine time-dependent fields 

Further notes 

For more information on activity types, see the R/3 Library under " Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data for Cost Center Accounting -> Activity Types". 

 Define Cost Elements for Activity Allocation 

In this IMG activity you create cost elements for activity allocation. 

The cost element takes receiver debits as part of internal activity allocation, for example, direct or 

indirect activity allocations. 

Example 

Example 

Production cost center PROD1 draws on support cost center HELP1 for  mechanic hours of activity type 

MECH. The allocation cost element for mechanic hours is 4710. In the cost center report, the activity is 

identified by value under allocation cost element 4710. 

The cost element for activity allocation, which you enter in the master data of an activity type, is a 

default that you can overwrite during activity type planning. 

Note 

Allocation of an activity type occurs with the cost element you save in activity type planning. 

Activities 

Decide for which business transactions and with which activity types you want to carry out activity 

allocation. You must also decide  under which cost element the activity type is to be displayed in 

your reports. 

Create a secondary cost element of category 43. 

Note on transport 

To transport cost elements, choose the function for this found in "General Controlling" Customizing. 

Further notes 

For more information on creating cost elements, see Maintain Cost Elements. 
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 Define Selection Variants for Activity Types 

A selection variant contains the fields that are to be evaluated in your selection report. These fields 

determine the content and structure of a selection variant. 

The following selection reports are available: 

For cost elements     RKKOASEL 

For cost centers     RKKSTSEL 

For activity types    RKLSTSEL 

For business processes RKPRZSEL 

For internal orders RKOSEL00 

For projects     RKPSEL00 

You enter the selection values in the corresponding fields, and can overwrite these in the application. 

You can hide the fields that you do not require. 

When you process "variant attributes", you can specify variables for selection variant fields, and so on. 

Example 

If you wish to select your objects by time, then define a selection variant, which only contains master 

data fields for times. 

Standard settings 

The following selection variants are defined for internal orders: 

SAP_01 - SAP_02 - SAP_03 

Activities 

If you wish to create your own selection variants, proceed as follows: 

Enter a name for your variant in the "ABAP: Initial screen for variants" 

Confirm the "Values" default setting in the "Subobjects" group box, and choose "Create". In the "Variant 

maintenance: Report <your selection report>" screen, the system displays the selection fields for the 

corresponding master data. 

Enter the values or variables in the fields that you wish the system to use for selection. 

Choose Continue. 

This takes you to the Attribute maintenance screen for the selection variants. 

You can assign the following field attributes: 

Protected 

The value that you specified for the field can no longer be overwritten in the application. 

Invisible 

The system hides this field from the selection variant. 



 

 

Selection variable 

You can define a variable for a field, such as a user-defined selection rule ( compare with the 

"Define selection rule" section). The field is filled with the corresponding value during 

runtime. 

Enter a short text in the "Description" field. 

Save your entries. 

This variant is now available for the corresponding selection report. 

Transport notes 

You can transport selection variants manually by proceeding as follows: 

Choose "Utilities -> Transport request..." in the "ABAP: Variants - Initial screen" 

Enter the program name 

Enter the name of the variant to be transported 

 Define Search Helps for Activity Types 

In this step you can maintain or redefine search help for activity types. 

Notes 

Technical expertise in the ABAP Dictionary is necessary to maintain search help. Let system 

administration maintain them for you. 

Note that large numbers of search helps can slow system performance. Check which search helps you 

need. Deactivate any search help you don't require. 

Search help is valid for all clients. 

Requirements 

Before maintaining search help, see the SAP Library under Basis Components -> ABAP 

Development Workbench -> ABAP Dictionary -> Maintaining Search Help. 

There you will find information on how search help is constructed in the SAP System and how to create 

search help in the ABAP Dictionary. 

Standard settings 

The standard SAP System includes the following search help: 

"N" enables searching through use of the activity type number 

"S" enables searching through use of the activity type name 

Activities 

Check whether the standard search helps satisfy your requirements. 

Supplement the existing search help objects with further search helps, or create new ones if necessary. 
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 Define Time-Based Fields for Activity Types 

In this step you determine on the client level, independently of organizational units such as controlling 

area or chart of accounts, whether master data table fields are historically relevant or not. 

You can maintain master data for cost centers, cost elements, activity types, and business processes as 

time-based. Changes to any other time interval are possible at any given time. Data storage is also time-

based. In this way, you can store multiple database records for a master data record, each holding 

different information. 

The time-based dependencies are determined by SAP and cannot be changed. The following 

dependencies are possible: 

Not time-based 

Day-based 

Period-based 

Fiscal Year-based 

In the "Time Dependency" column, you have an overview of the time-based dependencies for individual 

master data fields as set by SAP. 

For day-based fields, you can set an indicator determining whether fields are historically relevant or not. 

Period-based and year-based fields are always historically relevant. 

If you change fields during master data maintenance which were marked as historically relevant, and 

redefine a new analysis period, the system creates new database records, for the new analysis period and 

for any following periods, and simultaneously restricts the validity period of the existing database 

records. 

Example: 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

Then you change the object by defining other field characteristics from 011997 to 312997. In 

Customizing, you defined the Manager field as historically relevant. 

The SAP system stores three records. You can view them in master data maintenance by placing the 

cursor on the field and choosing Expand: 

One record for the interval 011996 to 312996 Manager: Miller 

One record for the interval 011997 to 312997 Manager: Wang 

One record for the interval 011998 to 312999 

Manager: Miller 

If you change fields during master data maintenance not marked as historically relevant, but without a 

new analysis period, the entire database record changes for the entire analysis period. These changes 

appear in the change log. 

If you change day-based fields not marked as historically relevant, the existing database record also 

changes for the entire selected analysis period. Definition of a new period is not possible. These changes 

appear in the change log. 

Example 



 

 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

You then change the object by defining another cost center manager. In Customizing, you defined the 

Manager field as not historically relevant. 

The SAP system changes the record for the Manager field: 

Record for the interval 011996 to 312999 Manager: Wang 

The SAP system documents the changes with date and user name in a change document. 

Fields without time-based dependencies may be changed at any time, with the change applying to the 

entire validity period of the master data. 

Note 

Remember that time-based storage consumes large amounts of data storage space. Designate only 

important fields for time-based dependencies. 

If consecutive fields have identical historically relevant definitions, the SAP system replaces the database 

records with a single record valid for the existence of the individual records. 

Further Notes 

Time-based master data storage minimizes maintenance effort. You can create master data crossing fiscal 

year boundaries without having to recreate them every year. Changes affecting a single time only can be 

made without direct effects on the other times involved. 

Example: 

You create a cost center with the following data: Cost Center: 41 

Validity Dates: 011996 to 312000 

This entry remains available in the SAP system until 312000. 

However, you may also create: 

Cost Center: 41 

Validity Dates: 011996 to 312996 

The disadvantage here is that you must recreate the cost center for the following years, each year, if 

you still require the cost center. 

The example above uses the yearly borders of a calendar year. However, you can determine validity 

periods that are independent of any given calendar year. This is particularly useful if you define a fiscal 

year variant in Financial Accounting with delayed, extended, or shortened fiscal years, because master 

data is not oriented along fiscal year variant lines. 

Actions 

Determine which fields you want to designate as historically relevant. 

Activate or deactivate the indicators according to your requirements. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 
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 Program Enhancements for Activity Type Master Data 

You can add own additional fields to the activity type master data. The following SAP enhancement is 

available for this purpose: 

COOMLA01 Activity Type: customer-specific additional fields in the master record This 

enhancement includes the following enhancement components: 

EXIT_SAPLKMA6_001 

CO-OM customer exit for PBO of customer-specific subscreen "0399" in SAPLKMA6. 

EXIT_SAPLKMA6_002 

CO-OM customer exit for PAI of customer-specific subscreen "0399" in SAPLKMA6. 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancements can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 BAdI: Activity Type Master Data 

Use 

This Business Add-In (BAdI) is used in the Controlling (CO) component. You can use this BAdI to 

integrate additional fields into master data for activity types. 

When you implement this BAdI, you override the settings in the Customizing activity Program 

Enhancements for Activity Type Master Data. This is because you cannot use this Customizing activity 

with the new Web Dynpro application. SAP uses Floor Plan Manager and this BAdI to support customer 

enhancement. 

Requirements 

You have created and activated the Customizing Include CI_AUFK. 

Activities 



 

 

For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for 

SAP NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

See also 

BAdI method documentation: 

GET_CUSTFLDS_PROPERTY 

PROCESS_CUSTFLDS_AFTER_INTPUT 

 Statistical Key Figures 

In this section you make settings for statistical key figures. 

Further notes 

For more information on statistical key figures, see the R/3 Library under Controlling -> Overhead 

Cost Controlling -> Cost Center Accounting -> Master Data -> Statistical Key Figures". 

 Maintain Statistical Key Figures 

In this IMG activity you create Statistical key figures or change existing ones. 

Statistical key figures serve as a basis for internal allocations and as references in the key figure analysis 

framework. 

You can use statistical key figures for the following transactions: 

Internal allocations 

Distribution 

Assessment 

Creating key figures for cost centers and orders 

Example 

Statistical key figure EMPLYE gives the number of employees per cost center. After creating statistical 

key figure EMPLYE, you can plan the number of employees for each cost center and enter this in actual. 

The numbers can be used for assessment of cafeteria costs to all other cost centers. 

Note on Statistical Key Figures 

Edit Statistical Key Figures 

You can enter statistical key figures in a list screen or in a detailed maintenance screen similar to the 

maintenance functions for cost centers, cost elements, and activity types. 

Maintenance with the detail screen has the following advanages over list maintenance. 

Detailed maintenance is the only way to create a link to the LIS. 

You can use a template to copy from. 
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The segmented entry screen is easier to understand than the list screen. 

LIS Interface 

In master data maintenance for statistical key figures, you can create a link from a key figure in the LIS 

to a statistical key figure in CCA. By means of this link you can lay the groundwork for a later transfer of 

key figures from the LIS to CCA. 

Two methods for finding key figures in the LIS are available. 

Information structures 

Information sets 

Requirements 

Complete the IMG activity Maintain Controlling Area in Customizing for General Controlling under 

Organization. 

Standard settings 

The standard R/3 System includes the following sample key figures. 

Employees 

Square meters 

Telephone charge units 

Activities 

Check whether the standard settings meet your requirements. 

Create your statistical key figures. 

Note on transport 

To transport statistical key figures, see the Customizing functions under Controlling -> General 

Controlling. 

Further notes 

For more information, see the SAP Library under Controlling -> Cost Center Accounting -> Master 

Data in Cost Center Accounting -> Statistical Key Figures. 

 Maintain Statistical Key Figure Groups 

You can combine similar statistical key figures to form statistical key figure groups. You can combine 

similar such groups to form further groups, thereby creating a hierarchy of statistical key figures. 

Statistical key figures are used: 

In the Information System, to create reports for particular key figures 

To maintain multiple key figures in Cost Center Accounting transactions: 



 

 

Cost center planning 

Distribution 

Assessment 

You may combine statistical key figures used in the distribution/assessment framework as 

tracing factors into a single group. 

Requirements 

You completed the IMG activity Maintain Controlling Area, located under General Controlling -> 

Organization. 

Activities 

Structure your statistical key figure groups in the controlling area based on your controlling 

requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 
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You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup node, 

the value, or the value interval, and choose Edit -> Selected entry -> Remove. The affected node 

is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 



 

 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 
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Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To Transport statistical key figure groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting, then Master Data in Center 

Accounting -> Processing  Master Data -> Master Data Groups or Statistical Key Figures -> 

Statistical Key Figure Groups. 



 

 

 Resources 

In this section you define resources. 

For more information on cost centers, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting -> Resources. 

 Planning 

In this section, you make settings for the cost center planning structure. 

Further notes 

For more information on planning, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning. 

 Basic Settings for Planning 

In this section you make the basic settings for cost center planning. The following IMG activities are 

usually made only once for each planning session. You can make changes to planning (changes to the 

sequence in which the individual planning functions are carried out or changes made to exchange rates 

especially) at any time. 

For more information, see the SAP Library under Accounting -> Controlling CO -> Cost Center 

Accounting -> Cost Center Planning -> Cost Center Planning Scope -> Planning 
Sequence/Planning Flow in Cost Center Planning. 

 Define Exchange Rate Types 

In planning, exchange rate types are used to specify exchange rates used for different purposes at the 

same time in the system. Existing entries must not be deleted. 

When exchange rate conversions take place between many different currencies, using a reference 

currency can simplify maintenance of exchange rates. For the exchange rate types concerned, you 

then only have to specify the exchange rates in relationship to the reference currency for all 

currencies. The SAP system then carries out all exchange rate conversions in two steps, using the 

reference currency. 

As well as a buying rate "G", you can also maintain a selling rate "B". 

The buying rate is that under which the average rate "M" is recorded. 

When maintaining a buying rate, enter the appropriate currency type for the average rate. 

This reduces the amount of work required in the conversion table. 

The selling rate is that under which the average selling rate is recorded. The user need only 

maintain the conversions for the average rate. The conversion occurs by determining the average 

rate and then adding the difference between the rates to this rate. 

If an entry for a currency conversion is missing, the indicator Invert ensures that the reversed currency 

relationship, should one exist, is available for the conversion. 
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Standard settings 

The standard system includes exchange rate type P (standard translation for cost center accounting). 

Note 

When you create a controlling area, the system creates version 000 automatically for 5 years. Rate type P 

is defaulted. 

The system uses rate type M for currency conversion during postings and clearings of documents. 

Recommendation 

Before creating your own exchange rate types, check those offered by SAP and use them if appropriate. 

Activities 

Check whether you require further exchange rate types for cost center planning in different versions. 

Create additional exchange rate types if necessary. 

Choose New entries. 

Enter the following data: 

Exchange rate type 

Usage 

Base currency 

Buying rate 

Selling rate 

c) Activate the following indicators if necessary: 

Permit calculation with inverted exchange rate? 

Exchange rate type uses special translation reference 

Exchange rate type uses fixed exchange rates 

Save your entries. Notes on transport 

You can transport settings for exchange rate types manually. To do this, choose Table view -> 

Transport. 

 Define Exchange Rates 

Exchange rates for currency translations are used in several application components. 

For actual and plan postings they are used to: 

Translate foreign currency amounts when posting or clearing 

Manually check a given exchange rate 

Determine the profit and loss from exchange rate differences 

Valuate open items in foreign currency 

Valuate the foreign currency balance sheet accounts 



 

 

Determine the amount in controlling area currency when working with various controlling area 

currencies 

Allow for differing controlling area, sender, or receiver currencies when settling internal orders 

Exchange rates are stored according to time; the rates are valid as of the specified date. 

Note 

Exchange rate definition in CO should be reconciled with that in FI. 

The system uses exchange rates stored under the translation rate type M for currency translations in 

posting and clearing actual transaction data. These exchange rates are valid for all company codes. 

For translation of plan postings, you define the exchange rate type that the system uses for translations in 

plan. This exchange rate type (fiscal year dependent) is defined in the version. 

Requirements 

You have defined the currency key required. 

If you need custom exchange rate types in plan, you must create them beforehand. The standard system 

includes exchange rate type P. 

The exchange rate relations for currency translation are only displayed here. To use other exchange rate 

relations, you must define them first. 

Standard settings 

In the standard system, exchange rates are set as examples with exchange rate type M. 

Recommendation 

SAP recommends using the minimum number of exchange rates required in your system in order to 

minimize system load. 

Activities 

In your organization, define at what intervals the currency translations should be maintained. 

Maintain current exchange rates for exchange rate type M and for your own exchange rate types. Delete 

the entries you do not need. 

Choose New Entries. 

Enter the following data: 

Exchange rate type 

Validity date 

Indirect quotation 

From currency 

Direct quotation 

To currency 

Save your entries. 

Note on transport 

You can transport exchange rates manually by choosing Table view -> Transport. 
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 Define versions 

Versions enable you to have independent sets of planning and actual data. 

In planning, you use versions to configure alternative scenarios based on different assumptions. For 

example, the different versions can represent different employment markets, price and wage increases, or 

sales programs. 

You normally configure the most likely scenario in version 000. The plan data you enter there forms the 

basis for calculating planned prices for activity types, and determines the rates with which activities 

containing actual amounts can be settled. Version 000 also contains all actual data postings. The plan and 

actual data for version 000 can be used in plan/actual comparisons and variance analysis. 

You make settings for version maintenance on a hierarchical basis. 

In this IMG activity, you make the following settings: 

Controlling area settings 

Fiscal year settings 

Note 

The term "version" replaces the earlier term "plan/planning version". 

You can record planning and/or actual data in a version. 

In planning, you must maintain fiscal-year dependent parameters. 

If you use parallel valuations and transfer prices, you define parallel actual versions alongside operational 

version 000 in order to separate different valuations. To do this, you must maintain valuations, by 

carrying out the activity Create Versions for Valuation 

Methods in Customizing under General Controlling -> Multiple Valuation 

Approaches/Transfer Prices 

In Activity-Based Costing, you can manage actual data in different delta versions of activity-based 

costing. To do so, you must specify a version that can be referenced. Once you specify this version, 

the current version is marked as a delta version. 

Complete the IMG activity Maintain Controlling Area. 

Complete the IMG activity Maintain Versions. 

Standard Settings 

When you create a controlling area, the SAP system automatically creates version 000, valid for five 

fiscal years. The first fiscal year depends on the control indicator you set when you created the 

controlling area: 

If the indicator is set for the current year or earlier, the five-year period begins with the current year. 

If the indicator is set for future years, the five-year period begins with the earliest of these years as the 

first year. 

Recommendation 



 

 

If you want to plan in a single version only, use version 000. 

Actual primary cost data entry and actual data from internal acitivty allocation all post to version 000. 

SAP therefore recommends you use this version for all plan/actual comparisons. 

Activities 

To assign versions to authorization groups, define the groups first. These groups determine which users 

can maintain which versions. To assign authorizations, use authorization object "Controlling: 

Version" ( K_KA09_KVS ). Maintain Authorizations 

Make the version settings in the current controlling area. To switch to another controlling area, choose 

Extras -> Set controlling area...  

Change an existing version to meet your requirements. 

Enter a key and a name. 

Specify whether plan and/or actual data may be recorded in the version and activate the 

corresponding indicator. 

You cannot activate the actual data recording indicator for version 001. 

If necessary, enter an authorization group. 

To create a delta version in the Activity-Based Costing component, enter a valid version as the 

reference version. 

Maintain the fiscal year-dependent version parameters. 

If you use a delta version in Activity-Based Costing, use  Reference version to determine which 

transactions the system reads from the reference. The system does not execute these transactions in 

the delta version, but transfers the values from the reference instead. 

Note on transport 

To transport versions, a separate function exists in Customizing under Controlling -> General 

Controlling. ( Transport Settings for Organization. 

Further information 

For more information, see: 

Notes on Version Maintenance 

Fiscal Year-Dependent Version Parameters. 

Delta Versions in Activity-Based Costing 

Further notes 

Notes on Version Maintenance 

The following should be taken into account when maintaining a version: 

In general version definition you decide whether a version is allowed for 

Panning (with the Plan indicator) 

Actual data update (with the Actual indicator) 

Note: In Overhead Cost Controlling, actual data is updated in operational version 0. 
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Actual versions different from 0 are found at present only for delta versions in Activity Based Costing 

(CO-ABC), and when you work with parallel assesment (additional versions): 

A data version from results and WIP determination manages (indicator WIP) 

Another version from variance determination manages (indicator Variance) 

A version for exclusive use (field exclusive application) 

You must maintain the version basic settings for each controlling area in which you want to update 

transaction data. General version definition restricts the settings possible for the controlling area: 

If general version definition does not allow plan and/or actual data update for version, this applies to the 

version in all controlling areas. If plan and/or actual data updating is allowed for a version in 

general definition, this can be reset for each controlling area separately (unmark the plan or actual 

indicator). 

Delta versions in ABC may not be used for parallel valuations in the actual; the same goes for versions 

with exclusive applications. In both cases, the valuation fields may not be maintained. 

To set indicators WIP/Results- or Variance-determination the following conditions apply: 

Both indicators may be set only during setup for the controlling area, when they are already established 

in the higher level general version definition 

If either indicator is already active in the data bank, then the actual indicator may not be subsequently 

activated 

If the actual indicator is inactive and either of these indicators is active, then the valuations in the 

corresponding versions and in version "000" must agree 

If the actual indicator is active, then both indicators must be activated 

Versions 0 and 1 are used regularly for various purposes by the system, which sets the following 

limitations/restrictions: 

Version 0 must always be available. It cannot be used exclusively. The plan and actual indicators must 

always be active. 

The actual indicator may not be activated in version 1. 

If these conditions are violated during version maintenance, error messages are issued. There are three 

types of error message: 

While maintaining the general version definition, you can only make changes if they do not violate the 

conditions outlined above. 

While maintaining the basic settings in the controlling area, the entries must remain consistent with the 

higher level entries. 

You want to maintain version 0 or 1. The restrictions outlined above apply. 

Use the "Extras" menu option to display the structure of the entries in the complex data object version: 

Select a version and choose Extras -> Version use. 

The SAP System shows which controlling areas use this version. 

Select Extras -> Versions in CO area 

This displays all versions used in the current controlling area. 

The subordinate entries in the hierarchy (settings for each fiscal year, strategic Activity-Based Costing: 

transactions for a delta versions) will also be shown for both cases. 



 

 

Fiscal-Year-Dependent Version Parameters 

In a version you define defaults for the following parameters based on the fiscal year: 

Planning 

Lock version 

Integrated planning 

Copying allowed 

Exchange rate type 

Value date 

Integrated planning with Cost Center Accounting and Activity Based Costing 

Version for indirect activity allocation for non-integratedorder/project planning 

Receiver version 

Valuation Variant for CO Resource Planning 

Price Calculation 

Purely iterative price 

Plan price calculation: Determination method 

Actual price calculation: Determination method 

Recalcuation with actual prices 

Cost component structure 

Delta Versions in Activity-Based Costing 

A delta version is an additional statistical version that is linked to a reference version. You create the 

delta version to be able to carry out other allocations for selected transactions. Allocations within a delta 

version do not affect the operative value flow in the system. It follows that you cannot allocate process 

costs within costing, cost object controlling, and Profitability Analysis. Referencing can take place at 

several levels. The reference version can also be a delta version and in turn be linked to another version. 

 Group Maintenance 

In this section you maintain master data groups. You can adapt those groups you created in master data 

maintenance to meet your particular planning needs. 

For more information on group maintenance, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Cost Center Planning -> Master Data in Cost Center 
Accounting -> Master Data Groups -> Processing Master Data Groups. 

 Define Cost Element Groups 

You can combine similar cost elements into cost element groups. Similar cost element groups can be 

combined to form other cost element groups so as to build a cost element hierarchy. 

You can use cost element groups: 

In the information system 
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The row structure of your report is determined by the cost element structure. You can create totals 

for each node in the report. 

When processing of several cost elements in one transaction, such as 

Cost center planning 

If, for example, you wish to display and plan personnel costs in one work transaction, select 

the group "Personnel costs". 

Distribution 

Assessment 

Report totalling takes place via cost element group nodes. To achieve a clear illustration, each node on a 

level must have the same number of subordinate levels. 

Prerequisites 

In Customizing of Financial Accounting (under General Ledger Accounting -> G/L Accounts -> 

Master Data) you have maintained a chart of accounts. 

You must have completed the Customizing activity Maintain Controlling Area in Customizing of 

General Controlling under Organization. 

Default Settings 

Standard cost element group OAS-INT is created for chart of accounts INT (international chart of 

accounts) in controlling area 0001. 

Actions 

Check whether the standard cost element groups meet your requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 



 

 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 



 

WHATSAPP +255738656506 

 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 



 

 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. 

The previous standard hierarchy is required for reporting in the current fiscal year, because it no 

longer matches the structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Notes on transporting 
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A separate activity for transporting cost element groups exists in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information about creating cost element groups, see SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Processing Master Data and Cost Elements -> Cost 

Element Groups. 

 Define Activity Type Groups 

You can combine similar activity types into activity type groups. You can combine groups into further 

groups, thus building an hierarchy of activity types. 

Activity type groups are used: 

In the Information System to create reports for certain activity types - To maintain multiple 

activity types in a CCA transaction: 

Planning 

You can display and plan multiple activity types in one transaction, for example in 

Planning 

You can display and plan several activity types in one transaction. 

Assessment 

You can carry out assessment for chosen activity type groups. 

Requirements 

Complete the IMG activity Maintain Controlling Area to be found under General Controlling -> 

Organization. 

Activities 

Structure activity types in the controlling area according to your controlling requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 



 

 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 
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To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no 

master data exists, a warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 



 

 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 
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Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To transport activity type groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting and the sections Processing Master 

Data -> Master Data Groups and Activity Types -> Activity Type Groups. 

 Define Statistical Key Figure Groups 

You can combine similar statistical key figures to form statistical key figure groups. You can combine 

similar such groups to form further groups, thereby creating a hierarchy of statistical key figures. 

Statistical key figures are used: 

In the Information System, to create reports for particular key figures 

To maintain multiple key figures in Cost Center Accounting transactions: 

Cost center planning 

Distribution 

Assessment 

You may combine statistical key figures used in the distribution/assessment framework as 

tracing factors into a single group. 

Requirements 

You completed the IMG activity Maintain Controlling Area, located under General Controlling -> 

Organization. 

Activities 

Structure your statistical key figure groups in the controlling area based on your controlling 

requirements. 

Enter the group to be created or changed and choose "Enter". 



 

 

In the structure screen, select the node from which the group is to be extended and choose 

"Same level" or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 
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Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 



 

 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 
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There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To Transport statistical key figure groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting, then Master Data in Center 

Accounting -> Processing  Master Data -> Master Data Groups or Statistical Key Figures -> 

Statistical Key Figure Groups. 

 Manual Planning 

This section contains information on the settings required for manual planning. Manual planning 

includes: 

Primary and secondary costs 

Activities and prices 

Statistical key figures 

For more information on manual planning, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Cost Center Planning -> Manual Planning. 

 Enter Settings for Manager's Desktop 

Manager's Desktop is a function originally developed in Human Resources that assists cost center 

managers in performing their administrative and planning tasks. 

Using Manager's Desktop, you can access manual planning on cost centers directly and tailor this 

planning to your own requirements by specifying a selection of those planner profiles and planning 

layouts that you require. 



 

 

The Manager's Desktop offers you direct access to manual planning, in which you find only those 

planning layouts with the parameters that you have pre-set. 

You select these planning layouts by assigning a function code to each planner profile and planning 

layout. 

If you enter particular default parameters in these planning layouts, you can restrict manual planning to 

particular parameters like a version, fiscal year, or cost center, or to activity types and cost elements. 

Example 

You are responsible for planning personnel costs in manufacturing. You therefore need view only those 

cost centers in manufacturing with those cost elements for personnel costs, namely 420000 to 430000. 

Procedure 

Select the planner profile SAPALL and the planning layouts 1-1 and 1-4. When defining the planning 

layout, enter the following values: 

- Cost center group: MANUFACTURING 

- Cost element: 420000 to 430000 

- Version: 000 

- Fiscal year: 1999 

Requirements 

You have defined planner profiles and planning layouts or you use the settings supplied in the standard 

system. 

You implement the Human Resources component to manage the organizational structure. 

One or more cost centers are assigned to your system user. 

Standard settings 

SAP supplies the following function codes for the planner profile SAPALL: 

COCCA1 Primary cost planning 

COCCA2 Secondary cost planning 

COCCA201 Activity planning and price planning 

COCCA301 Statistical key figure planning 

Recommendation 

Define one variable only for the cost center group, not for a range of cost centers. - Use one 

fiscal year only; enter default parameters for other fiscal years. 

Enter default parameters in as many fields as possible or enter user parameters. The system enters default 

values for all other fields, in other words version 000, all cost centers, cost elements, period 1 to 

posting period, fiscal years for planning. 

Activities 

Check whether the settings supplied by SAP meet your requirements. 

If you require further planner profiles and planning layouts, proceed as follows: 
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Choose New entries. 

Enter a name for the function code. 

You can define more than one function code at once. 

Select a planner profile and assign a planner profile with planning layout to each function code. 

(You do this for each planner profile that you require for manual planning). 

In the relevant User-Defined Planner Profiles, enter the required characteristics for the planning 

layouts used. 

Save your entries. 

Under the Customizing settings for Manager's Desktop, carry out the following activities: 

Enhance Function Codes 

Define Object Type-Specific Function Codes 

Define Structure of Function Codes 

Further notes 

For more information, see the 

SAP Library under Financials -> CO Controlling -> Cost Center Accounting -> Cost Center 

Planning -> Manual Planning -> Manager's Desktop. 

SAP Library under HR - Human Resources -> PA - Personnel Management -> 

Manager's Desktop 

Personnel Management  Customizing under Manager's Desktop 

 User-Defined Planning Layouts 

In this IMG activity you define new planning layouts or change existing ones. 

Using the planning layout you specify what contents appear in the header, rows, and columns (elements) 

of your planning screens depending on the specific management requirements made by cost center 

planning. 

The SAP system contains standard SAP planning layouts that satisfy most planning requirements. Only if 

this is not the case do you require your own layouts. 

Standard SAP planning layouts 

SAP offers the following standard planning layouts: 

Cost Center Accounting 

Cost Element/Activity Input Planning 

1-1 CCtr: Cost elements, activity-dependent/-independent 

1-2 CCtr: Activity inputs, activity-dependent/-independent 

1-3 CCtr: Costs/revenues/consumption 

1-4 CCtr: Primary/secondary order costs 



 

 

1-161 CCtr: Cost elements, simplified 

1-162 CCtr: Cost element central planning, simplified 

1-151 CCtr: Cost elements in transaction currency 

1-152 CCtr: Cost element comparison, 2 quarters 

1-153 CCtr: Cost element planning, 2 versions 

1-154 CCtr: Cost elements with display of previous year 

1-155 CCtr: Activity output from sender viewpoint 

1-156 CCtr: Cost element central planning 

1-157 CCtr: Cost element plan/actual comparison 

Activity/Activity Price Planning 

1-201 CCtr: Activity types/prices, standard 

1-201C CCtrs: Activity types/prices, central planning 

1-202 PP planning: Activity types/prices 

1-203 ATyp: Actual activity price indicator and switch structure 

1-204 CCtr: Activity types/prices, attributes 

1-261 CCtr: Activity price, simplified 

1-262 CCtr: Activity price, centralized 

Manual Actual Prices 

1-N01 CCtr: Manual actual prices, cost centers 

Resource Planning 

1-1R1 CCtr: Resource planning 

1-4R1 Orders: Resource planning 

1-7R1 WBS elements: Resource planning 

Dependency planning 

1-1R2: CCtr:   Value-based recipe planning 

1-1R3: KoStellen:   Quantity-based recipe planning 

Statistical Key Figure Planning 

1-301 CCtr: Statistical key figures, standard 

1-302 CCtr: Statistical key figures, activity-dependent 

1-3C CCtr: Statistical key figures, central 

1-361 CCtr: Statistical key figures, simplified 

1-362 CCtr: Statistical key figures, centralized 

Internal Orders 

Cost/Revenue Element Planning 
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1-401 Orders: Cost elements, standard 

1-402 Orders: Activity inputs, standard 

1-402P: Orders: Process inputs 

1-404 Orders: Primary/secondary order costs 

Cost Planning/Activity Input Planning 

1-461 Cost elements: Simplified layout 

1-462 Cost elements: Simplified layout, central 

Statistical Key Figure Planning 
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1-601 Orders: Statistical key figures, standard 

1-603C: Orders: Statistical key figures, central 

1-661 Statistical key figures, simplified 

1-662 Statistical key figures, simplified, central 

Project Cost Controlling 

Cost Element/Activity Input Planning 

1-701 WBS elements: Cost element planning 

1-702 WBS elements: Activity inputs 

1-702P: WBS elements: Process inputs 

1-703 WBS elements: Revenues, revenue cost elements 

1-704: WBS elements: Primary/secondary order costs 

Statistical Key Figure Planning 

1-901 WBS elements: Statistical key figures, standard - 1-903C WBS elements: Statistical key 

figures, central 

1-C01 Networks: Statistical key figures - 1-C02 Networks: Statistical key figures 

1-C03C Networks:Statistical key figures, central 

Activity-Based Costing 

Cost Planning/Activity Input Planning 

1-4P Processes: Primary/secondary order costs, processes 

1-2P Processes: Activity-dependent/-independent process inputs 

1-D01 Processes: Cost elements 

1-D02 Processes: Activity inputs 

1-D02P Processes: Process inputs 

Quantities and Prices 

1-E01 Processes: Quantity planning/price planning 

1-E02 Processes: Tax codes 

Statistical Key Figure Planning 

1-F01 Processes: Statistical key figures, standard - 1-F03C Processes: Statistical key figures, 

central 
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Manual Actual Prices 

1-Q01 Processes: Manual actual prices, business processes 

Cost Object Accounting 

Cost/Activity Input Planning 

1-G01 Cost object: Primary costs 

1-G02 Cost object: Activity inputs, standard 

1-G02P Cost object: Process inputs 

Statistical Key Figure Planning 

1-I01 Cost objects: Statistical key figures, standard 

1-I03C  Cost objects: Statistical key figures, central 

Real Estate 

Cost element allocation/activity allocation 

1-J01-1 Business entity: Cost elements, standard 

1-J01-2 Buildings: Cost elements, standard 

1-J01-3 Property:  Cost elements, standard 

1-J01-4 Rental unit: Cost elements, standard 

1-J01-5 Rental agreement: Cost elements, standard 

1-J01-6 Management contract: Cost elements, standard 

1-J02-1 Business entity: Activity inputs, standard 

1-J02-2 Buildings: Activity inputs, standard 

1-J02-3 Property: Activity inputs, standard 

1-J02-4 Rental unit: Activity inputs, standard 

1-J02-5 Rental agreement: Activity inputs, standard 

1-J02-6 Management contract: Activity inputs, standard 

Further notes 

Procedures for Layout Definition 

With some exceptions, defining planning layouts is similar to defining reports with the Report Painter. 
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The following is essential information on defining a planning layout. For a detailed description of 

functions, see the SAP Library under Financials -> Controlling -> Cost Center Accounting -> 

Information System -> Define Reports -> Creating Reports with Report Painter, or in the 

Implementation Guide for Cost Center Accounting under Information System -> Own Reports -> 

Create reports . 

A planning layout consists of the following components: 

- Header 

Lead and value columns ( elements ) 

Header 

Defining a planning layout begins by entering general selection criteria (Edit -> General selection 

-> Display/Change). These criteria control which characteristics and which characteristic values 

are in the header of the planning layout. 

The General Selections characteristics apply to the whole planning layout. This reduces the 

time required for defining the planning layout and also improves the response times when you 

execute the planning, since the SAP system has to read less data. You have the option of defining 

the characteristics and the lead and value columns as variables. Defining them as variables means 

that these fields are ready for input on the initial screen when you execute the planning. 

In a layout for cost element planning, you would (under general selections) choose the 

characteristics version, period, fiscal year, and cost center. The lead column contains the 

characteristics activity type and cost element. The value columns contain key figures like e.g. 

Plan costs in object currency and actual costs in object currency. 

In a layout for a quarterly comparison, you would for example choose the characteristics Version 

and Fiscal year as general selections. You would enter the period and the cost center  in the lead 

column or value columns. 

In a further step, you can determine the hierarchical order in which characteristics in the general 

selection criteria are used (Edit -> General selection -> Header). Without header entries, the 

hierarchical order given by the SAP system as a default is retained. 

Lead columns and value columns 

You now define the content of the lead and value columns in the planning layout. The layout of the 

columns and rows is based on the selection of particular characteristics that are preset by SAP. You 

assign an attribute to each characteristic. 

Definition of Lead Columns 

When defining lead columns you have two options: 

Definition of one or more lead columns above the column heading 

Definition of one lead column only above the rows 
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Definition of one or more lead columns above the column heading 

Under this type of definition, the system proposes all the possible combinations of characteristic 

values of the lead columns defined for planning. 

You define the first lead column by selecting the column heading, or by placing the cursor on the 

lead column and choosing Edit -> Element -> Define element. By choosing Edit -> Columns -> 

New lead column  you can insert further lead columns. 

Note that the system inserts each new lead column in front of the other lead columns. 

Under this definition method, you can select exactly one characteristic per lead column. 

Example Primary cost planning, 

fast entry 

1st lead column 2nd lead column   1st value column 

Cost center   Cost element Plan costs 

4711 - 4719 400000 - 403000 

420000 - 429000 

The system calculates the rows from the Cartesian product of the values from all lead columns. 

Defining exactly one lead column above the rows 

In this type of definition you must define every row by double-clicking on the row description. The 

definition of the first row determines whether all rows are defined through a key figure with 

characteristics or just with characteristics. You can choose one or more characteristics per row. 

If, for example, you want a complete overview of all key figures in the planning layout, you define 

the lead columns via key figures with characteristics. 

Rows of element type Characteristics are defined by choosing the characteristics and assigning them 

characteristic values. 

Rows of element type Key figure with characteristics are defined by first choosing exactly one key 

figure from the list of all possible key figures. Afterwards, you decide on the characteristics and 

characteristic values. 

The procedure is similar to that for defining value columns. 

Example 

Quarterly planning in several versions 

1st lead column 1st value column 

Version/Quarter Plan costs 

Version1/Quarter1 

Version2/Quarter1 

Version1/Quarter2 

Version2/Quarter2   

... 
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Note on cost element planning 

If you wish to plan activity-dependent and activity-independent costs together in a planning layout, you 

must enter initial for the characteristic activity type. 

The Initial value is set: 

In layout maintenance by entering "#" as the characteristic value 

In the group maintenance dialog window Maintain values... by choosing the Set initial value function 

On the initial screen for planning by entering "*" in the From field if you assigned a group variable 

for the activity type. The system selects all characteristic values for the Activity type field, 

including the initial value. 

Definition of Value Columns 

To define the first value column, select the column heading. Define other value columns by selecting the 

empty space next to the first value column. 

You may also select the corresponding column and choose Define element. 

You can also hide rows and columns from later display. This is useful for those elements necessary for 

calculations but not necessary for report displays. 

You have several options for defining value columns: 

Define column with either a key figure with characteristics or just characteristics 

Define formula column 

Define attribute column 

Define Column with Either a Key Figure with Characteristics or Just Characteristics 

To define a value column, select the column heading. 

The definition of the first value column determines whether all rows are defined by a key figure 

with characteristics or just with characteristics. 

If you defined lead columns with rows using key figures with characteristics, you can define value 

columns only with characteristics. 

If you defined lead columns with characteristics or through the column header, you can define value 

columns only with characteristics. 

The procedure is similar to that for defining lead columns with rows. 

Define Formula Column 
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A formula column is a value column made up of values from previously defined columns. When 

defining a formula, the SAP system provides you with a selection of value columns in a dialog 

box. The system calculates the values for these columns once the value columns used in the 

formula contain values. In the dialog window, choose the element type Formula. 

In the following screen you can create a formula using previously defined value columns with the 

aid of the formula components found in the screen. 

Example 

Planning layout with formula column as 3d value column 

Lead column Value column 1 Value column 2 Formula column 

Cost element Plan curr. year Plan prev. year Variance 

Curr. year 

Prev. year 

Indirect Formulas 

Indirect formulas allow you to enter values in formula columns during planning that the R/3 System 

uses to determine values in another layout column. 

To define indirect formulas: 

Define the planning layout with the desired formula column and save. 

Set the indicator for the column to "Not ready for entry". 

To do so, select the column in question and choose Format -> Entry ready on/off. 

Set the formula column to "Entry ready" in the same manner. 

Generate the indirect formula by choosing Extras -> All indirect formulas -> Generate formulas. 

The SAP system determines the values for the non-entry ready column. 

Example 

You plan a wage increase for employees as a percentage surcharge. The SAP system should 

determine the plan value of the current year from the surcharge and the plan value of the previous 

year. 

Planning Layout 

Define the following layout: 

Key ColumnValue Col. 1 Value Col. 2 Formula Column 

CElm Plan Cur. Year Plan Pre. Year % Raise 

((Plan cur. year - 

Plan pre. year) 
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/Plan pre. year) 

X 0 

Indicate the column "Plan Cur. Year" as not ready for input , the column "% Raise" as ready for 

input. 

Afterwards, generate the reverse formula. 

Planning ( Example ) 

If, before manual planning starts, the previous year plan values are copied to the current year (via 

Planning -> Planning aids -> Copy planning), the new plan costs can be calculated then by 

entering the percentage raise. 

After copying planning: 
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CElm Plan Cur. Year Plan Pre. Year % Raise 

430000 50,00050,000 

After calculating the new plan costs: 

CElm Plan Cur. Year Plan Pre. Year % Raise 

430000 55,00050,000 

Define Attribute Column 

When defining an attribute column, you have two options, depending on the attributes used: 

Attribute columns with direct reference to a value column 

Attribute columns with no direct reference to a value column 

Attribute columns with direct reference to a value column 

You set the Unit, Distribution key and Action attributes in conjunction with a value column. 

You have options for definition: 

Select a previously defined value column and choose Edit -> Columns -> Attach add. fields. This 

inserts selected attribute columns into the planning layout. This method establishes a direct 

reference between the attribute column and the value column. If you wish to change 

characteristics and characteristic values for the value column, the SAP system confirms 

whether the dependent attributes are to be changed and, if so, adjusts the attribute column 

accordingly. 

You can also define characteristic and characteristic values in the attribute column 

independently of the value column. 

Select the free field next to an existing value column and choose the element type Attribute from the 

dialog window. 

The attribute column so defined has no direct connection to a value column. Changes in the 

characteristic values of value columns have no further effects on the attribute column. 

Attribute columns with no direct reference to a value column 

Define other attributes by selecting the free field beside an existing value column, or by choosing 

Define element. 

Having selected the element type Attribute, the system provides you with a list of possible 

attributes, from which you can select one attribute. 

There are two kinds of attribute - display attributes and those that can be maintained during the 

planning process. 

Attributes for all planning areas 

- Unit, maintainable with restrictions 
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Depending on the attribute of the corresponding value column, the SAP system displays either 

the currency unit or the quantity unit. 

Example 

Key figure Plan activity 

Unit: Activity unit from the activity unit master record 

The following units exist: 

Consumption unit in cost element planning, maintainable with restrictions. The consumption 

unit is useful in the activity-dependent and activity- independent planning of both primary and 

secondary costs (without sender reference) and in revenue planning.The SAP system takes the 

value from the cost element master record as the default value. In planning at cost center/cost 

element level, you can overwrite the consumption unit, provided no dependent data exists. 

Activity unit in activity input planning, display attribute. 

The system automatically uses the activity unit belonging to the sender activity type. 

Currency units in cost element planning, display attribute. 

The controlling area, object, and transaction currency are useful where you plan with foreign 

currencies or the object currency differs from the controlling area currency. The different 

currencies cannot be displayed unless you have activated the All currencies indicator in your 

controlling area. Only if you have done this does the system update all currencies. 

Activity unit in activity type planning, display attribute. 

For the key figures plan activity, capacity and scheduled activity the SAP system 

automatically uses the activity unit entered in the activity type master record. 

Output unit in activity type planning, maintainable with restrictions. For the key 

figure plan output you can maintain the output unit at cost center/activity 

type/fiscal year level, provided no dependent data exists. 

Currency units for prices, display attribute. 

Controlling area, object, and transaction currency are especially useful if you plan with 

foreign currency or the object currency differs from the controlling area currency. To be able 

to display the different currencies, you must have activated the All currencies indicator in 

your controlling area, since only then does the system update all currencies. 

Units in statistical key figure planning, display attribute. The SAP system automatically uses 

the unit entered in the key figure master record as the unit for statistical key figures in 

planning. 

- Distribution key, maintainable. 

The SAP System stores plan data per period. If, when planning, you enter an annual value on 

the overview screen, the SAP system distributes this value to the individual periods according 

to a rule that is stored in the distribution key. The standard system includes fixed non-

changeable distribution keys ( standard distribution keys). 
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If you want to use a particular season distribution, you can also define any number of 

individual distribution keys. 

You can define distribution keys per key figure. 

Example 

Fixed plan costs + distribution key for plan costs ( fixed ) Variable plan 

costs + distribution key for plan costs ( variable ). 

Action, maintainable. 

The action determines how the SAP system is to process the values entered. You can add, 

subtract, or replace the entry value for the existing value. 

Caution 

You can define the action per plan record only, and not per key figure. 

Long text exists, display attribute. 

This indicator tells the user that a long text exists for the planning item. This text may be an 

explanation, or a description of the origin of the plan data. 

Attributes for cost element planning 

Transaction, display attribute. 

This indicator shows the business transaction under which the corresponding plan record is 

stored. 

It has two further important functions: 

Document number assignment control 

Lock option per version, fiscal year, and transaction 

Exchange rate type, display attribute. 

If you plan in foreign currencies, you can use the exchange rate type to follow the currency 

translation. The type is determined per version and fiscal year. 

Value date, display attribute. 

If you plan in foreign currencies, you can use the value date to follow the currency translation. 

The date with which the exchange rates are read depends on the contents of the Value date 

field: 

If it is not filled in version maintenance, calculation takes place by period. Each period's 

starting date is used to calculate its own rate, to take possible rate swings within a fiscal year 

into account. 

If a value date is entered, all periods are processed with the same exchange rate calculated with 

this date. 

Record quantites, maintainable. 

This indicator shows whether consumption quantities are recorded on the cost center. 
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Cost element attributes, display attribute. 

A cost element can be characterized independently of the account framework by entereing a 

maximum of eight attributes. The attributes can be drawn upon within reporting for use in 

evaluations. 

In addition, they have no access to control information. 

An indicator is assigned for each attribute. A cost element can be given the following as 

indicators: D  for service costs 

W  for costs affecting payment 

The attribute indicators and their valid combinations are maintained in customizing for 

Cost Center Accounting under Cost 

Element Attributes and Attribute 

Mix. 

A valid combination of the permitted attributes can be defined as follows: 

In the cost element's master data record 

Within cost center planning for the combination cost center/ activity type and varying from the 

entry in the cost element master data record. 

Note that you must always specify one of the attributes valid for the first item 

Detailed planning exists 

The calculation number is the internal number under which detailed planning is stored. 

Value calculation type, maintainable. 

This displays whether plan values are entered manually (1) or through detailed planning (4). 

Since the indicator is maintainable within planning, further manual editing of plan records 

entered via detailed planning is possible. In this case, change the indicator "Value calculation 

type" accordingly. 

Allocation cost element, display attribute. 

Allocation cost elements are used exclusively in activity input planning as attributes. Because 

the cost element characteristic is optional for activity input planning, it can be left out of a 

planning layout for secondary cost planning. By inserting the attribute of the same name, you 

can nevertheless display the allocation cost element. 

Cost element type, display attribute. 

The cost element type determines for which transactions a cost element may be used. 

The following types are differentiated: 

   Primary cost elements Type 01 

   Secondary cost elements Type 21, 41, 43 

   Revenue elements Type 11, 12 

Dependency type, maintainable. 

The dependency type is available only in value-based or quantity-based dependency planning. 

Dependency source type, display attribute 
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The system sets the dependency source type according to the dependency type. 

Attributes for activity type planning 

Along with the attributes for unit, distribution key, action type, long text available, 

transaction, exchange rate type, value date, and cost element attribute, the following 

attributes are available in activity type planning: Two transactions are differentiated here, 

those for: 

Manual and non-allocatable activities 

Automatically allocatable activitites 

The transaction results from the activity type category. 

Production factor, maintainable. 

The production factor gives the relationship of activity quantity to output quantity by means of 

the following formula: 

    Output quantity = Activity quantity x Output factor 

In planning, the output quantity can be calculated with the formula using the function 

Calculate output. 

You may select individual or groups of planning lines for use and begin the calculation. 

Allocation cost element, maintainable with limitations. 

The SAP system automatically uses the allocation cost element from the activity type master 

record as a default value in planning. You can overwrite the default as long as no debit and 

credit records have been posted for the allocation cost element. 

Activity type category, maintainable with restrictions. 

You can maintain the category in the activity type master data record as well as in planning on 

the cost center/activity type/version/fiscal year level. The category serves as a default setting 

for planning. You can switch between the allocatable activity type categories (1, 2, 3) as long 

as no debit and credit records have been posted. 

Actual activity type category, maintainable. 

You can determine a category deviating from plan categories for actual allocations. If no 

actual activity type category is maintained, the SAP system automatically uses the plan 

activity type category. A variant actual category is useful for a planning layout when, for 

example, the plan values must be indirectly calculated due to missing results (such as from 

the power plant), but where the actual values were registered. 

Activity price indicator, maintainable. 

The indicator contains the calculation basis for the plan activity price of a cost center's activity 

type. 

The activity price indicator can take the following values: 

001: 
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The activity type's activity price is automatically calculated on the basis of plan 

activity for the cost center to be planned. Fixed activity 

price: Fixed plan costs / Plan activity 

Variable activity price:Variable plan costs / Plan activity Total activity price:

 Fixed activity price + Variable activity price 

002: 

The activity type's activity price is automatically calculated on the basis of the capacity of the 

cost center to be planned. The capacity serves only for fixed costs as a basis for activity price 

calculation. This is relevant for cost centers that must continually be prepared for maximum 

activity quantity output, such as costs for supplying energy from a power plant. The total 

costs are fixed. Fixed activity price: Fixed plan costs / Capacity 

Variable activity price:Variable plan costs / Plan activity 

Total activity price: Fixed activity price + Variable activity price 

Note 

If you set values 001 or 002, you must carry out plan activity price calculation. 

003: 

The activity type's activity price is set manually. 

If you activate the indicator "ItAcPr" (purely iterative activity price) in the version, the system 

calculates a purely iterative activity price along with the activity price resulting from planning. 

- Actual activity price indicator, maintainable. 

This indicator shows how the activity price's actual activity price for a cost center is calculated. 

If you do not maintain this indicator, the system automatically uses the plan activity price 

indicator value. 

The activity price indicator can take the following values: 

005: 

The actual activity price is calculated by the system on the basis of actual activity. 

If you set this value, you must carry out actual activity price calculation. Indicators 005 and 

006 are useful in planning only if you set revaluation of actual activity with actual activity 

prices in the version. 

006: 

The actual activity price is calculated by the system on the basis of capacity. Cost center 

capacity serves only for fixed costs as a basis for activity price calculation. This is relevant for 

cost centers that must continually be prepared to supply the maximum activity quantity output, 

such as costs for supplying energy from a power plant. The total costs are fixed. 

If you want to execute activity price calculation, you must determine the actual activity price 

indicator. In planning layouts for activity type planning, you must set the attribute for this 

situation. 

- Average activity price, maintainable. 

This indicator ensures that cost center/activity type activity prices remain constant for the 

entire fiscal year. 
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This determination takes place on two levels: Version/fiscal 

year 

For a version, all cost center/activity type activity prices in a fiscal year are held constant. 

During activity price calculation, only plan total costs and total activity for the timeframe are 

used. Monthly swings are ignored. 

Cost center/activity type/version/fiscal year 

If no average activity price is determined for the version, individual cost centers/activity types 

may be assigned a constant allocation activity price for a fiscal year. Activity price calculation 

averages the price swings for this cost center/activity type. Insert the corresponding attribute in 

the activity type planning layout and maintain the indicator in activity type planning. 

Switching layout, maintainable. 

Within price calculation with cost component split, the switching layout is used to change the 

cost component assignment. 

In activity price calculation, cost component splitting utilizes a cost component structure, in 

which is defined which cost elements are steered to which components. You define the layout 

during version maintenance, and per fiscal year. For allocations between cost centers, this cost 

component layering is usually retained. There are, however, cases in which the sender 

components are not to be retained, but where the allocation is to other receiver components. 

Here is where the switching layout is used. The layout stores which sender components are 

allocated to which receiver components. You determine the switching layout in activity type 

planning for the sender, but it must have been defined in Customizing first. 

Fixed cost predistribution, maintainable. 

If you carry out standard costing on a marginal costing basis, the fixed costs are not distributed 

to the cost objects in proportion to the operating rate. In this case, you must work with fixed 

cost predistribution in order to credit fixed costs to the cost centers accepting activity inputs. 

You can overwrite the default value in the indicator Fixed cost predistribution, which 

controls whether the fixed costs (that is, the activity-independent preparation costs) are 

distributed to the cost centers or not. 

Attributes for statistical key figure planning 

In addition to the attributes unit, distribution key, action type, and long text available, the following 

attributes are available for statistical key figure planning: 

Variant, display attribute 

Key figure type, display attribute. 

This indicator controls the entry and updating of statistical key figures. It can take the 

following values: 

Fixed value 

The key figure values are valid as of the period entered for all following periods in the fiscal 

year. Average values are planned. 

Total value 
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The key figure values are not carried over from the period entered to the following periods. 

You can enter new plan values for each period. 

Variant, display attribute 

Origin, display attribute 

Key figure, display attribute 

These attributes are useful in the planning layout when you transfer key figures from the 

Logistics Information System ( LIS ). 

Afterwards, you determine characteristics and characteristic values for the attribute columns. 

Characteristics and characteristic values 

When defining headers, lead columns, and value columns, you must enter one or more characteristics. 

Characteristics are predefined by the SAP system for the corresponding planning area. 

Characteristics 

The following section is a list of the possible characteristics. 

These are divided into optional and required characteristics. 

Version 

Enter one or more individual values or one or more intervals. 

Planning period 

Enter an individual value or an interval. 

Fiscal year 

Enter one or more individual values or one or more intervals. 

Cost center 

Enter one or more individual values, one or more intervals, or one or more cost center groups. 

Version, planning period, fiscal year, and cost center are required characteristics in all planning 

areas. 

Activity type: Required characteristic for activity type planning, optional characteristic for cost 

element and statistical key figure planning 

Enter either one or more individual values, several intervals, or one activity type group. The 

following transactions do not require the characteristic: 

Primary cost planning, activity-independent 

Activity input planning, activity-independent 

Revenue planning 
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Settlement cost planning, activity-independent 

Secondary order cost planning, activity-independent 

Cost element: Relevant only for cost element planning, where it is an optional characteristic which 

can be ignored if plan records only are entered for activity inputs in the affected planning 

layout. 

There the cost element is the sender allocation cost element. 

In primary cost planning the cost element is a required characteristic. 

Enter one or more individual values, one or more intervals, or a cost element group. 

Resource 

This is important for resource planning, where it is a required characteristic. Resource planning is 

primary cost planning on a quantity basis. You can valuate planned consumption quantities and 

determine resulting costs. Resource planning can thus sub-divide cost element planning. You can 

plan on orders and WBS structures. You cannot use resources in the Actual. Use Define resources 

to maintain resources. Enter one or more single values or intervals. 

Sender cost center: Relevant only for cost element planning, where it is an optional characteristic 

The characteristic can be ignored if you do not wish to plan activity inputs with the relevant layout. 

For the following transactions, you do not require the characteristic: 

Primary cost planning, activity-independent and activity-dependent 

Revenue planning 

Settlement cost planning, activity-independent and activity- dependent without sender reference 

Planning credits as surcharges 

Enter one or more individual values, one or more intervals, or a cost center group. 

Sender activity type: Relevant only for cost element planning, where it is an optional characteristic 

The characteristic can be left aside if you do not wish to plan activity inputs with the relevant layout. 

For the following transactions, you do not require the characteristic: 

Primary cost planning, activity-independent and activity-dependent 

Revenue planning 

Settlement cost planning, activity-independent and activity- dependent without sender reference 

Planning credits as surcharges 

Enter one or more single values, one or more intervals, or an activity type group. 

The characteristics sender cost center and sender activity type are only useful in tandem. 

Transaction currency: Relevant only for cost element planning, where it is an optional characteristic. 

Enter one or more individual values or one or more intervals. 

If you do not select the characteristic, the controlling area currency will be set for the field. 

Note 
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If you define a value column in your planning layout for cost element planning via the key figures 

"Total actual costs in controlling area currency" or "Total actual costs in object currency", you must 

include the transaction currency as an additional characteristic in the key columns if actual cost 

postings use a transaction currency which is not the same as the controlling area currency. 

Statistical key figure: Required characteristic for statistical key figure planning Enter one or more 

single values, one or more intervals, or an activity type group. 

After specifying the characteristic, you must determine the characteristic value controlling the data 

selection. 

Characteristic Values 

When defining characteristic values, you have the following options: 

Entry of fixed characteristic values 

You set characteristic values for each element to be used as selection criteria by the SAP system to 

generate the planning screen. 

You can specify a single value, an interval, or a group of values. By choosing More you can enter 

more than one single value or interval. 

Characteristic value parameterization 

You can also use varaibles for the characteristic values. 

Variables enable flexible shaping of the planning layout. The content is determined only after 

planning is executed. 

Note that the system distinguishes between local and global variables, but that you may only use 

local variables for the planning layout. 

Local variables are not permanently in the system, but are valid only in the affected planning layout. 

They may be used more than once the layout. 

Example: 

You create a layout with the following three value columns: 

Column 1: Version, Variable 1 Fis.Y, 1996 

Column 2: Version, Variable 1 Fis.Y, 1995 

Column 3: Version, Variable 2 Fis.Y, 1995 

Local variable 1 is used twice, variable 2 only once. 

You enter a variable for the characteristic value by choosing Indicator for entering variables 

(variables on/off) on the screen Define Element. 

The system changes the size of the input field and marks the field. The local 

variable designation can be set as desired. 

Additionally, you can also parameterize texts under Edit -> Element -> Change text (text 

variable). On the screen Enter Text, enter a local variable beginning with special character "$". 

According to your setting per text variable, the SAP system determines the text automatically from 

the selection of the assigned characteristics. 
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If you set characteristic values as variables, the user will be asked during planning callup to replace 

the variables with values. 

Notes 

Calculated variables 

Variables based on numerical fields may be changed with additive operations. The variable is 

extended with a "+" or "-" and a number (no more than two places). In a formula, for example, 

variable "A" is used in a fiscal year column. The second column should display the previous year. 

Parameter "A-1" is thus maintained as the fiscal year characteristic. In the planning transactions, the 

fiscal year variable "A" is called up as a control date, and the previous year is calculated 

automatically. 

Mandatory/optional variables 

For variables in optional characteristics, you have the choice between 

Replacement through mandatory entry 

Replacement through optional entry 

Use the menu path Extras -> Variables -> Define variable. Choose a variable for an optional 

characteristic and you thereby replace the default Mandatory  with Optional. 

Example 

You set  Activity type as the optional characteristic in the planning layout Cost elements/Activity 

inputs and activate the Optional setting. On the initial planning screen, you have the option of 

selecting activity-dependent and activity-independent planning. Only when you fill the field Activity 

type on the initial screen will activity-dependent planning be executed. 

3. Names/key values of variables 

To give each variable a name, use Extras -> Variables -> Define variables -> Name and use the 

name when prompted in the initial planning screen. 

Examples 

You use 2 versions for an optimistic/pessimistic planning comparison. Using the naming function 

identifies the variables in the different versions. 

You define a period interval. To distinguish between the "From" period and the "To" period on the 

initial planning screen, save the appropriate names for the variables. 

For more information about variables, see the SAP Library under Cross-Application Components -> 

CA - Drilldown Reporting -> Reports -> Variables -> Variables for Characteristic Values, 
Variables for Texts, or Variables for Formulas. 
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 Create Planning Layouts for Activity Type Planning 

To be able to plan activities, you first need to define planning layouts for activity type planning. In these 

planning layouts, you determine the format of the planning screens. 

Requirements 

In the standard SAP System, planning layouts are found only in client 000. To use them as models for 

user-defined planning layouts, they must be taken from client 000 and imported to your production client. 

Use the IMG General Controlling under the section Prepare Production Startup -> Transport 

System Settings -> Transport Planning Settings -> Import Standard Planning Layouts. 

Recommendation 

After installing a new release or update, you should repeat the import of standard planning layouts from 

client 000 in order to access the latest layouts. 

Activities 

Create planning layouts according to your 

requirements for activity type planning. 

Change an existing planning layout. Further 

notes 

Procedure for Creating Planning Layouts 

Note on transport 

For the transport of planning layouts, an individual function is available in Customizing under 

Controlling -> General Controlling -> Production Startup Preparation -> Transport System 

Settings -> Transport Settings for Planning -> Transport Planning Layouts. 

 Create Planning Layouts for Statistical Key Figure Planning 

To be able to plan statistical key figures, you first need to define planning layouts for planning statistical 

key figures. You specify the layout of the planning screens in these planning layouts. 

Requirements 

In the standard SAP System, planning layouts are found only in client 000. To use them as models for 

user-defined planning layouts, they must be taken from client 000 and imported to your production client. 

Use the IMG General Controlling under the section Prepare Production Startup -> Transport 

System Settings -> Transport Planning Settings -> Import Standard Planning Layouts. 

Recommendation 
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After installing a new release or update, you should repeat the import of standard planning layouts from 

client 000 in order to access the latest layouts. 

Activities 

Create planning layouts according to your requirements 

for the planning of statistical key figures. 

Change an existing planning layout. Additional 

Notes 

Procedure for Creating Planning Layouts 

Note on transport 

For the transport of planning layouts, an separate function is available in Customizing for Controlling -> 

General Controlling -> Production Start-Up Preparation -> Transport System Settings -> 
Transport Settings for Planning -> Transport Planning Layouts. 

 Define User-Defined Planner Profiles 

You use planner profiles to control the way planning is carried out. In a planner profile, you specify per 

planning area which planning layout is to be used with which default values. Per planning area, you can 

create as many planning layouts as you require. The profile item determines the order of the planning 

layouts within a planning area and can be used to assign the same planning layout to a planner profile in 

multiple areas, but with a different default setting each time. 

Planner profiles are hierarchically structured as follows: 

Planner Profile 

General Controlling 

Layouts Controlling 

Default Parameters 

Planner Profile 

You can assign an  authorization group to every standard profile and every planner profile that you 

create in the Profile planning overview. 

The combination of authorization groups and locked default settings (see Default layout) results in 

highly detailed authorization assignments for entering planning data. All the planner profiles in the 

system are defaulted. This is regardless of the component in which you wish to call up planner 

profile processing. This enables you to define allowed entries of planner profiles from other 

components, for each component chosen. 

General Controlling 

For each planner profile, the system recommends different planning areas, depending on the 

application component. You can create additional planning areas. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 93 

In CuDK you can enter a default value for a distribution key for currency amounts. 

In QtDK you can enter a default value for a distribution key for quantities. The system uses these 

default values for combinations that have not yet been planned, even if you have not selected a 

distribution key in the definition of the planning layout. 

Layout Controlling 

In each planning area, you determine which planning layouts appear in which sequence. For each 

planning area, you must define at least one profile item and assign a planning layout. 

The Deflt indicator shows whether settings already exist (see: Default settings layout). If you 

deactivate the Over. (=Default settings not protected) indicator, the user must use the entries given 

in planning and may use only the defaulted variables. If the indicator is active, the entries are default 

values which can be overwritten when entering planning. The Excel integration indicator gives you 

the option of entering planning data in an Excel worksheet. If the indicator is active, you can use 

Excel to make your entries. The file description influences the layout of the worksheet. If you move 

the planning data (that you entered in the system) within the worksheet, the file description creates 

the link between the old data and the new location. 

You can also find further information on preparation for planning with Excel in the SAP 

Library under Financials -> CO Controlling -> Cost Center Accounting -> Cost Center 

Planning -> Manual Planning -> Techniques for Supporting Manual Planning -> Integrated 
Excel in Planning. 

- Default parameters 

You can enter default parameters for the selection of planning data of each item in the assigned 

planning layout. 

All variables defined in a layout are referenced during planning as parameters, which you can set 

with values per profile item. 

If you undertake decentralized planning in your organization, the planner profiles assist the organizational 

aspects of the planning process. You can assign particular user groups to profiles in which objects have 

already been preset and precisely delimited. 

Example 

You set general selection criteria (fiscal year, version, periods and transaction currency) in your planning 

layout PRIMARY. 

From an organizational perspective, it was decided that the cost center managers decentrally plan the 

material expenses first, followed by the personnel expenses. 

In the Planning profile overview create the planning profile "PLAN01". 

Choose the planning profile "PLAN01" and CO General Settings. 

Choose the planning area "Cost centers: Cost elements/acty inputs" and Layouts CO general. 

Enter the planning layout "PRIMARY" with both item number 0 and item number 020. 

Choose the item "0" and Default parameters and enter the cost element group for material expenses. 

Choose the item "020" and Default parameters and enter the cost element group for personnel expenses. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 94 

Also assign the cost center managers in the user parameters to planner profile PLAN01 via the parameter 

ID "PPP". To do so, choose System -> User profile -> User parameters. 

When the cost center manager calls up planning by choosing "Planning -> CElems/Actvty input -> 

Change", the system suggests profile PLAN01 and branches to planning layout PRIMARY with the plan 

costs for material expenses. The cost center manager can now enter the plan data and, after it is saved, 

can go to other planning by choosing Next layout. 

Requirements 

To create entire planner profiles, the planning layouts used must be available. Complete the IMG activity 

Create Planning Layout. 

Standard settings 

The standard system includes several defined planner profiles. The names of the profiles begin with SAP. 

These are protected, meaning you cannot create custom profiles beginning with "SAP". 

Note 

Note that as of Release 4A, the planner profile SAP1, SAP2, SAP3, and SAP4 and the planning layouts 1-

1 to 1-4 contained in these profiles are no longer maintained by SAP. 

Activities 

To assign planner profiles to authorization groups, create the necessary groups in the IMG activity 

Create Custom Authorization Groups. You can use the authorization groups to control which users 

have access to which planner profiles. Assign authorizations with the authorization object "CO: Planner 

Profiles" ( K_TKA 50). 

To create planner profiles, proceed as follows 

CO Planner Profile Overview 

To create a new planner profile, choose New entries. 

To copy an existing profile, select a reference and choose Edit -> Copy as. 

Enter a name and explanatory short text for the object. 

If necessary, assign an authorization group to the planner profile. 

General Controlling 

Select the suggested planning area for which you want to make settings and choose Settings for 

General Controlling. 

To create a new planning area, choose New entries. 

Layouts for Controlling 

Select a planning area for which you want to make settings and choose Layouts for General 

Controlling. 
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Choose New entries and enter an item and previously defined layout. 

Activate the indicator Default settings not protected if users may overwrite the defaulted 

variables. 

Activate Excel integration if you want to enter your planning data in an excel worksheet. 

Enter a name for the file description. 

If you do not enter a name, the system automatically assigns a name when you save the file. 

Save your entries and return to the layout overview screen. 

Layout Default Settings 

Select a planning area for which you want to make settings and choose Layout Controlling. 

Set the parameters of the defined variables per profile item for the planning layout. 

Notes 

To define the excel worksheet, at least one row must exist on the screen. For this reason, you 

need to enter example data as dummy data in the SAP System using the planning layout. 

To be able to plan directly using the corresponding planning layout, you may need to reset any 

planner profile that has been set under Planning -> Set planner profile. 

Optional steps: 

Authorizations 

In the IMG activity Authorization Management, set authorizations as required for object 

K_TKA50 and assign the authorizations to the authorization profiles of the appropriate users. 

User parameters 

Assign parameter ID PPP to the users who are to work with the profile in the user parameters 

(choose System -> User profile -> User parameters). 

Deleting planner profiles 

When you delete a planner profile, the system checks whether the profile is also used in other 

components. If it is, you first need to delete the dependent entries for the planner profile in all 

components, before you can delete the planner profile itself. 

Note on transport 

To transport planner profiles, see the General Controlling Customizing -> Production 

Start-Up Preparation -> System Configuration Transport -> Planning Configuration Transport -> 
Transport Other Planning Configurations. You can use this function to transport the complete set of 

planner profiles from a test to a productive client. 

Planner profile maintenance is connected to the automatic recording of transport data. 

This also includes the settings for integrated Excel. The system includes file descriptions and Excel sheet 

templates in the transport request, provided you have created them in Customizing. 

The system also transports the settings for integrated Excel if you have manually included a planner 

profile in - or manually deleted a planner profile from - a transport request (you do both by choosing 

Table View -> Transport). 
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Warning 

When performing the transport, ensure that you have not manually created any integrated Excel settings 

in the target system. 

Only supply the target system by means of transports, otherwise inconsistencies could arise. When 

importing the Excel sheet templates from the source system, the system does not overwrite the 

settings already made in the target system. 

If, however, planner profiles with corresponding Excel sheet templates already exist in the target system, 

you have to delete them before performing any imports. In planner profile maintenance, you can 

delete these Excel sheet templates for specific planner profiles or profile items. 

Further notes 

You can find more information on planner profiles in the SAP Library under Financials -> 

CO Controlling -> Cost Center Accounting -> Cost Center Planning -> Manual Planning -> 
Planning Techniques -> Planning Screen Layout -> Planner Profiles. 

 Define User-Defined Distribution Keys 

You use distribution keys to both simplify and speed up the entry of monthly plan values. The following 

options are available for defining your own distribution keys: 

Distribution keys that refer to a standard distribution key (1, 2, 3, 4, 5, 6, 7). 

Note 

The system also saves distribution keys in the object currency. 

You can also change the distribution key during the runtime. 

Note 

You define a distribution key in which you save the number of shifts (relative factor) per month (period). 

In cost center planning you enter the annual plan activity and combine this with your distribution key. 

Five workers work seven hours per shift. Multipling 35 hours per shift with 680, the maximum number of 

shifts per year, results in annual plan activity of 23,800 hours. 

The following table shows the distribution of activity according to the distribution key used.    -----

------------------------------------------------------------- 

   |                 Plan Activity: 23,800 hours                    | 

   ----------------------------------------------------------------- 

   | Period  | Relative Factor  | Calculation       | Plan Activity | 

   ------------------------------------------------------------------ 

   |    1    |        40        | 23,800 : 680 X 40 =    1,400      | 

   |    2    |        40        | 23,000 : 680 X 40 =    1,400      | 

   |    3    |        40        | 23,800 : 680 X 40 =    1,400      | 
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   |    4    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |    5    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |    6    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    7    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    8    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    9    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |       |        60        | 23,800 : 680 X 60 =    2,0      | 

   |   11    |        40        | 23,800 : 680 X 40 =    1,400      | 

   |   12    |        40        | 23,800 : 680 X 40 =    1,400      | 

   ----------------------------------------------------------------- 

   |         |       680        |                   |   23,800     | 

   ----------------------------------------------------------------- 

Standard settings 

The standard SAP System includes unchangeable default distribution keys. 

Distribution key 0 

Enter the values manually for each period. 

Distribution key 1 

Given plan value is distributed equally to the plan periods. 

Distribution key 2 

Given plan value is distributed according to the previous distribution. 

Distribution key 3 

The value entered is interpreted as a percentage and applied to the previous values. 

Distribution key 4 

The periods containing a value not equal to zero are distributed to the following empty periods. 

Distribution key 5 

The periods containing a value not equal to zero are copied to the following periods. 

Distribution key 6 

The period value entered is copied to the following period 

Distribution key 7 

The total value is distributed to the periods according to the number of calendar days in each period. 

Distribution key 11 

Used only in the Cost Center Controlling component for activity-dependent cost planning or 

activity-dependent statistical key figure planning. 

The given value is distributed based on the plan activity quantity of a cost center. The system uses 

the activity quantities planned at the time you create the distribution key. If you change activity 

quantities afterwards and copy the plan values to another version, the system does not create a new 

distribution automatically. 
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Recommendation 

If the SAP standard keys do not meet your requirements completely, but you want to use certains parts of 

them, you should copy the distribution key and save it as your own key after making changes to it. 

Position the cursor on the standard distribution key you want to use and choose Copy using the context 

menu. 

Enter a new name for your own distribution key. 

Maintain and save your settings. 

Activities 

If necessary, define distribution keys that meet your requirements. 

Place the cursor on 

Referenced, if you want to refer to one of the standard distribution keys (except 11). 

Independent, if you want to create a new distribution key. 

Choose Create or Change using the context menu. 

Assign a key and a description for the new distribution key. 

Maintain the number of posting periods and a relative distribution factor. The system distributes the input 

value to the individual posting periods according to the relative distribution factor. 

Via Suppress zero factor, you can suppress posting periods to which you have assigned a relative 

distribution factor "0". You can display these posting periods again by choosing Display zero 

factor. 

If you subsequently want to set a relative distribution factor in a period to "0", you can recalculate 

the factors of the remaining periods by choosing Calculation. 

You can compare the original version of the distribution key with the new one by choosing 

Compare. 

Notes on transport 

To transport distribution keys, a separate function is available in Customizing under  

Controlling -> General Controlling -> Production Start-Up Preparation -> Transport System 
Settings -> Transport Settings for Planning -> Transport Other Planning Settings. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Manual Planning -> Techniques for Supporting Manual 
Planning -> Distribution Keys. 
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 Detailed Planning of Primary Cost Elements 

In this section, you define the settings for detailed planning of the primary cost elements in Cost Center 

Accounting. 

Detailed planning is carried out beneath the cost element level. This is useful where the actual postings of 

multiple individual actions and transactions are totaled in one cost element. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Manual Planning -> Detailed Planning of Cost Elements. 

 Define Costing Variants 

In detailed planning, you plan the costs of a cost center on a level below the cost element. 

This enables you not only to plan, for example, the costs for the materials (such as bulk materials) staged 

at a cost center as an amount under the primary cost element under which the material costs are updated 

on the cost center, but also to list each material to be staged at the cost center. 

Prices are stored in the accounting and costing views of the material master records. In the costing variant 

you define a strategy for price selection by linking the costing variant to a valuation variant. 

A costing variant contains the following parameters among others: 

costing type 

For detailed planning, the standard system contains costing type 03. This costing type specifies that 

the reference object of costing is a primary cost element. This costing type cannot be changed. 

valuation variant 

The valuation variant contains a strategy sequence for selecting prices from the material master, 

such as: 

Planned price 1 

Standard price 

Moving average price 

Note 

The results of detailed planning are written to the database as a costing document. You should therefore 

avoid having two costing variants with the same costing type and valuation variant (even though that is 

technically possible) to prevent data from being overwritten. The reason for this is that the key structure 

for the costing results in the database uses the costing type and the valuation variant, rather than the 

costing variant. 

Standard settings 
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The standard system contains the predefined costing variant PP for detailed planning. This costing variant 

points to costing type 03 and valuation variant 013. 

SAP recommendation 

You should assign a different valuation variant to each costing variant with which you intend to save cost 

estimates. 

This one-to-one assignment enables you to change the valuation strategies later as desired. 

Actions 

Decide whether the costing variant provided in the standard system meets your requirements. 

To create a new costing variant: 

Enter an alphanumerical key and a text for the costing variant. 

In the detail screen, assign a costing type and a valuation variant to the costing variant. 

If you want to use your own parameters, you must carry out the steps under Define valuation 

variants. 

Note on transport 

To transport costing variants manually, choose "Table view -> Transport". 

 Define Valuation Variants 

You create a valuation variant that contains the parameters for the valuation of the costing items in 

detailed planning of the primary cost elements of a cost center. 

You create valuation strategies for the materials that are used at the cost center. You define the sequence 

in which the system searches for prices in the accounting view and the costing view in the material master 

record to valuate the materials. 

Strategy sequences 

You define the individual valuation bases of the valuation variant as strategy sequences. For the valuation 

of the material components, for example, you define a strategy sequence that reads the fields of the 

material master record in the following sequence: 

Planned price 1 

Standard price 

Moving average price 

The first price that is not zero is used to valuate the material component. 
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To be able to use the valuation variant in costing, you must assign the valuation variant to a costing 

variant. 

Standard settings 

The standard system contains predefined valuation variants. You can modify these valuation variants to 

suit your requirements by changing the standard strategy sequences. Seventeen price strategies are 

currently available for material valuation. You can select up to five strategies for each valuation variant. 

Actions 

Enter an alphanumeric key and a text for the new valuation variant. 

Define a valuation strategy for material components by entering up to five values as the search sequence. 

Assign the valuation variant to a costing variant. 

Note on transport 

To transport valuation variants manually, choose Table view -> Transport. 

 Resource Planning 

In this section, you make the settings for price calculation of resource prices in resource planning. 

Where only the quantities of used resources are known, resource planning enables you to plan primary 

activity-independent and activity-dependent costs. The SAP system multiplies the planned quantity by the 

resource price 

Price calculation is based on the conditions method and enables you to control access to resource prices in 

line with your requirements. To do so, you can specify your own criteria for price calculation. 

Price calculation depends on the following settings: 

Condition type 

Condition table 

Access sequence 

Costing sheet 

Valuation variant 

For more information on resource planning, see the SAP Library under Financials -> Controlling (CO) 

-> Cost Center Accounting -> Cost Center Planning -> Manual Planning -> Primary Cost 
Planning -> Resource Planning. 

Notes regarding Transport 
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You can import the settings for resource planning from client 000 into your operating client. A separate 

function is available in General Controlling Customizing under Production Start-Up Preparation -> 

Transport System Settings -> Transport Settings for Planning -> Import Standard Settings for 
Resource Planning. 

 Define Price Tables 

Price table are special condition tables for resource planning. 

In a condition table you specify the combination of fields for which you can create condition records. 

Recommendation 

You should not make any changes to the price tables contained in the SAP standard. Instead, you should 

first copy them and then make any changes to meet your requirements. 

Standard settings 

The following price tables are stored for resource planning in the SAP standard: 

132 Price per cost center 

136 Price per controlling area 

137 Price per country / region 

138 Price per company code / business area 

139 Price per profit center 

Activities 

Check whether the control elements in the SAP standard delivery meet your requirements. If this is not 

the case, proceed as follows: 

1. Define your own price tables based on the field catalog supplied by SAP. 

To define price tables proceed as follows: 

Enter a key (from 501 to 999). 

Add an explanatory text. 

Selected the desired fields from the field catalog sequentially using "Edit -> Select field and then move 

them to the "Selected fields" dialog box by choosing "Edit -> Move". 

In a user-defined price table you must always select the fields "Controlling area" and "Version" and 

"Resource", in this sequence, at the start, as otherwise the prices cannot be locked per version if 

planning is to be locked. 

Save your entries. 
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The namespace of the user-defined price tables begins with 501. 

You cannot change the field catalog. 

Your user-defined price tables must begin with the field combination of controlling area / version / 

resource. If you have defined a table with other fields the system issues an error message. 

In this case, delete the table and create a new one using the fields mentioned above. 

A price table cannot consist of more than ten hierarchy levels (including the obligatory fixed fields 

controlling area / version / resource). 

Save your entries. 

 Define Access Sequences 

An access sequence is a search strategy that the system uses during pricing to search for valid prices for 

each condition type. It refers via the condition tables contained in the access sequence to the fields 

relevant for the price determination. 

If you want the SAP System to end its search as soon as it has found a price, you should set the 

Exclusive indicator for the Access Sequence. 

Examples 

The access sequence K001 is defined with price table 132 for resource pricing. This access sequence 

ensures that the system searches by the criteria "Controlling area", "Version" and "Cost center". 

Recommendation 

You should not change the access sequences contained in the SAP standard version. Instead, you should 

copy them and make changes to the copy in line with your requirements. 

If you define your own access sequence, the key should begin with "Z" (user namespace). 

Standard settings 

The access sequence K001 is supplied by SAP in the standard for cost center resources. 

Activities 

If the control elements delivered in the standard do not meet your requirements, you should define your 

own access sequences. 

To define access sequences proceed as follows: 

Choose New entries and fill the following fields: 

Access sequence, maximum four characters, alpha-numeric. 

Name 
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Save your entries. 

To maintain accesses, select an access sequence and choose Accesses. 

Choose New entries and fill the following fields: 

Access number 

Condition price table 

By entering the price table in the access sequence, you create a link between the condition 

type, access sequence and condition record. 

See also Create Price Tables. 

You do not need to enter a condition. 

Exclusive 

Save your entries. 

To maintain fields for an access, select an access and choose Fields. 

The system displays the fields of the price table assigned to this access. You can 

change the access fields in Create price fields. 

Fill the following fields: 

Source of constant 

Initial value 

Processing type in access 

Priority 

Save your entries. Notes on transport 

If you want to import standard settings for resource planning, you can use a separate function in 

Customizing Controlling -> General Controlling -> Production Start-Up Preparation -> Transport 

System Settings-> Transport Settings for Planning -> Import Standard Settings for Resource 
Planning. 

 Define Condition Types 

In this IMG activity you define condition types. 

You use the condition types to define which types of resource prices exist in the SAP system. These can 

be: 

Absolute amounts 

Percentage values 

Manually specified prices 

Prices determined by the system using search strategies (for example, from the material master data) 
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To determine which fields the system should check to find a valid condition record, you enter an access 

sequence in each condition type. 

Note 

It is not possible to edit scale prices in resource planning. 

The system can only take material prices from the material master for the resource valuation if you have 

entered a material in the Resource Master Data. 

Condition types are not relevant if you have entered a price in the material or base object master record. 

In this case, the system always uses the material or base object price to valuate the resource 

consumption. 

Recommendation 

Do not change the condition types contained in the SAP standard version. Instead, you should copy them 

and make any necessary changes in the copy. 

If you define your own condition types, the key should begin with "Z" (user namespace). 

Standard settings 

The following condition types are stored in the standard delivery: 

CQ01 Resource prices 

CQ02 Resource price for materials 

Activities 

If the condition types supplied by SAP do not meet your requirements, you can define your own condition 

types. 

Define condition types 

To define condition types proceed as follows: 

Choose New entries. 

Enter data in the following fields: 

Condition type, maximum of four characters, alphanumeric 

Description 

Access sequence 

You can also enter your own access sequences. 

Save your entries. 

To process condition types that were already defined, proceed as follows : 

Select a condition type and choose Condition records in the dialog structure. 
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Choose an access for the access sequence. 

Enter a controlling area, a version and a fiscal year. 

The SAP system selects the corresponding entries and displays them in the list of condition records. 

Note 

You can also copy existing condition types by selecting the condition type to be copied and choosing Edit 

-> Copy as. 

Enter a target entry (a name under which the copy is to be stored). 

Notes for transport 

To import standard settings for resource planning, you can use a function in Customizing under 

Controlling -> General Controlling -> Production Start-Up Preparation -> Transport Planning 
Settings -> Import Standard Settings for Resource Planning. 

 Define Valuation Variants 

Valuation variants control pricing for resource planning in the Controlling component ( CO ). 

The valuation variants are hierarchically structured as follows: 

Valuation variant 

Costing sheets 

Costing sheet rows 

Valuation variants 

A valuation variant can contain one or more costing sheets. 

Costing Sheets 

In the costing sheet you specify which condition types, and in what sequence, the system should 

consider. For pricing, the SAP system automatically determines which costing sheet is valid for a 

business transaction. It then processes sequentially the condition types contained in the costing 

sheet. Costing sheets can consist of one or more costing sheet rows. 

Costing Sheet Rows 

The costing sheet rows refer to condition types. You can use the condition types defined by SAP or 

define your own. The level numbers determine the order of the condition types in the costing sheet. 

You can use condition type CQ02 to maintain your own prices or search for prices from the material 

master record. 

Requirements 

In the Implementation Guide for Cost Center Accounting, section Planning -> Basic Settings, IMG 

activity Maintain versions you must have maintained the fiscal year-dependent version parameters. 
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Standard settings 

SAP supplies the valuation variant 0 in the standard for resource planning. 

Recommendation 

You should use the valuation variants and costing sheets supplied by SAP as much as possible. 

Do not change the valuation variants and costing sheets supplied by SAP in the standard system. 

Activities 

To create a valuation variant, proceed as follows: 

Choose New entries. 

Enter a key for a new valuation variant. 

Activate the Cost analysis indicator, if you want to follow the price determination on the screen. 

Enter a description for your valuation variant. 

Save your entries. Notes for transport 

For the import of standard settings for resource planning, you can use a special function in 

Customizing under Controlling -> General Controlling -> Production Start-Up Preparation -> 

Transport Planning Settings -> Import Standard Settings for Resource Planning. 

 Assign Costing Sheets To Valuation Variants 

In this IMG activity you assign one or more costing sheets to your valuation variant. 

Activities 

To assign costing sheets to a valuation variant, you should proceed as follows: 

Change the existing assignments to meet your requirements or create new ones. 

To create new assignments choose "New entries". 

Enter the following: 

The key of a valuation variant 

Costing sheet to be assigned 

Sequence 

Save your entries. 
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 Assign Valuation Variants to the Version 

You enter a valuation variant in the fiscal year-dependent parameters of your  version. The system uses 

the valuation variant stored in the version to calculate the resource prices. 

Activities 

Enter a valuation variant in fiscal year-dependent parameters for your version. 

Save your entries. 

 Formula Planning 

This section contains information on creating a Templates for formula planning on cost centers, use plan 

primary costs and statistical key figures. 

For more information on formula planning, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Cost Center Planning -> Formula Planning 

Notes on Transports 

You can transport the settings for templates. A function is available for this in General Controlling 

under Production Start-Up Preparation -> Transport System Settings -> Transport Settings for 

Templates. 

 Define Environments and Function Trees 

In this step you maintain: 

Function trees 

Structure nodes - Function references - Functions. 

The basis for the maintenance of the object is always the chosen environment. 

Environment 

The Template's environment determines the information of the SAP-environment and the external system 

that can be accessed. Basically, the functions relevant to each context are already provided in the 

corresponding environment. Environments always contain a row of sub-environments which group 

functions by theme; these include material, BOM, routing, and others. 

The standard system delivers the following environments: 

Template allocation (for cost objects, profitability segments, 

business processes, cost centers/activity types) 
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Formula planning (business processes, cost centers, profit centers) 

Standard cost estimates 

Process quantity determination ( SOP/LTP ) 

Easy Cost Planning/Internal Service Request 

Recommendation 

Use the sub-environments provided by SAP as much as possible. When you assign an function to a sub-

environment, it is automatically available in all the main environments containing this sub-environment. 

Further notes 

For more information on environments and a list of these and their sub-environments go to the help for 

applications of Activity-Based Costing under "Template -> Template Environment". 

Function Tree 

A function tree is a user-defined hierarchy which structures or groups functions. With the Help for 

function trees, you can structure groups of functions available in each environment according to their 

their theme or emphasis. Functions are then processed from here on. 

A function tree is assigned to an environment and consists of nodes and function nodes. 

Environments: all environments are displayed when you call up the n transaction. Environments 

themselves cannot be changed or deleted. The creation of new environments is also not possible. 

Function trees: the first level under environments. You can subordinate nodes or function nodes to a 

function tree. 

Nodes: nodes are always subordinate to function trees or other nodes. You can subordinate other nodes to 

a node or function node. In function trees SAP1, nodes contain sub-environments. 

Function nodes are always subordinate to function trees or nodes. They always refer to a function. 

SAP standard delivery for all environments includes function tree SAP1 (for example, for environment 

001, function tree SAP1-001). This contains all standard nodes ( sub-environments ) and function nodes 

(with reference to the respective function). 

Activities 

The transaction provides you with left and right screens. The left one displays the existing environments. 

You can expand the hierarchy and view the function trees, nodes and function nodes in their hierarchical 

structure. Place the curser on an object you want to process. 

The right screen details of the chosen object (environment, function tree, nodes or function nodes) in list 

form. If you double click on a funciton node you will see the maintenance screen for the functions. 
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Further notes 

For more information see Application help for Activity-Based Costing: 

AC-Financials -> CO-Controlling -> Activity-Based Costing -> Template -> 

Function tree -> Maintain function tree or Template -> Template environment -> Maintain 

functions 

AC-Financials -> CO-Controlling -> Cost center accounting -> Cost center planning -> Aids -> 
Formula planning -> Template -> Template environment. 

 Define Templates 

You define templates for planning primary costs and statistical key figures using formula planning. 

Purpose 

Templates are also used outside of Cost Center Accounting. Particular environments exist for each use 

(application) of a template. Before you create a template, choose Maintain Environments and Function 

Hierarchies. One of the things the environment determines is which row and column types you can 

choose from in the template to be created. 

The following uses (applications)/receiver objects are possible: 

Template allocations to cost objects or use in standard cost estimates for cost objects and materials 

(environments 001 - 012) 

Template allocation to business process, cost center or cost center/ activity type 

(environments SBP, SCI, SCD) 

Template allocation to profitability segments (environment PAC) 

Formula planning (environments CPI, CPD, BPP) 

Determination of output quantities (environment SOP) 

Planning templates are independent of the cost center. 

You can use a given planning template for more than one cost center. At the time of evaluation, the 

system uses a determination strategy to decide which planning template should be used to calculate 

the plan values. 

You can define the costs to be evaluated as variables. 

You also define formulas with which the system can determine the costs dynamically at the time of 

evaluation. 

You can define the quantity as a variable. 

You can use formulas to specify the consumption quantity that is to be claimed by the cost center. 

The SAP system calculates these formulas at the time of evaluation. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 111 

You can set individual rows (items) of the planning template as active or inactive. If you want to plan 

individual cost elements only on specified cost centers, you can use methods to set them as active or 

inactive. The system only considers the active items for evaluation. 

You can use subtemplates. 

You can define relationships that are required in multiple planning templates just once and then use 

them again as subtemplates. 

Structure of the planning template 

A planning template consists of rows (items) and columns. The following columns are possible: 

Object type, item category, for example, cost element, subtemplate, calculation row 

Name of the item 

Object, such as, name of cost element, subtemplate, calculation row 

Costs 

Costs for activity-independent planning 

Fixed costs, variable costs per activity unit for activity-dependent planning 

Quantity, such as, consumption 

Overall quantity for activity-independent planning 

Fixed quantity, variable quantity per activity unit for activity-dependent planning 

Activating values 

For activity allocations, the following columns are also available: 

Plan quantity factor variable 

Plan quantity fixed 

Actual quantity factor variable 

Actual quantity fixed 

You can either specify the values as fixed in the columns or define mathematical formulas and 

methods, whose values are determined dynamically by the system during the planning template 

evaluation. 

Requirements 

To be able to create a planning template, you must already have defined your cost centers. 

If you want to use user-defined functions, you must have created these in the IMG activity Maintain 

Environments. For some functions you need to maintain, for example, statistical key figures. 

Activities 
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To maintain a planning template, you need to enter data on an initial screen and an overview screen, from 

which you can branch to the various editors. 

Initial screen 

Enter the name of the planning template you want to create or maintain. 

Enter the environment of the planning template, such as "Activity-independent cost center planning". 

Overview screen 

Enter a description for the new planning template. 

Select the item category. 

Enter a description for the item. 

Depending on the specified item category, enter the object (for example, cost element). For the category 

cost element, you can specify a fixed cost element as the object or let the system determine the cost 

element dynamically at the time of evaluation. 

In items of category cost elements, you should specify how often they are to be claimed by the cost 

center. 

You can define this quantity either as a constant value or let the system calculate it dynamically 

during evaluation. 

Specify under which preconditions the item is to be activated. 

To activate an item, you can specify the values as Active or Inactive or define a method that is 

returned as Active or Inactive by the system at the time of evaluation. Further notes 

For more information on templates see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Utilities -> Formula Planning -> Templates. 

 Assign Templates for Cost Centers 

You create the link between cost center and formula planning in the master record of the cost center in 

question. 

You assign templates to those cost centers for which you want to determine planned values using 

formulaplanning, or which are to be receiver objects for template allocations. 

Activities 

You can also define templates when maintaining master data. 

In the cost center master record, choose the Templates tab. 

On the Templates tab, choose Create. 
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You can now change or display existing templates or display an allocation structure with the 

template. 

If you have already defined templates, you can enter these on corresponding tab. 

If you want to determine activity-independent planned costs for the relevant cost center, enter an 

activity-independent template in the Aty-ind. formula temp. field. 

If you want to determine activity-dependent planned costs for the relevant cost center, enter an 

activity-dependent template in the Aty-dep.formula tmp. field. 

If you want to carry out an activity-dependent activity allocation for the cost center in question, 

enter an activity-dependent template in the Aty-dep.alloc.tmp field. 

If you want to carry out an activity-independent activity allocation for the cost center in question, 

enter an activity-independent template in the Aty-ind.alloc.tmp field. 

Save your entries. 

Further notes 

For more information on cost center master data, see the "SAP Library" under Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data in Cost Center Accounting -> Cost 

Centers -> Cost Center Master Data. 

 Planning Aids 

This section contains information on defining planning aids such as reposting or revaluation. 

 Define Revaluation 

Versions can be revalued according to various criteria. The SAP system determines a revaluation amount 

from the percentage rate of the revaluation. This amount is added to or subtracted from the initial 

amount ( = costs, consumption quantities). 

You can revalue data as often as you wish and the data can be reset using the reversal function. 

You can execute the revaluation for the whole fiscal year and for individual periods. 

You can use cost center groups or cost element groups for the revaluation. 

The SAP system, however, offers the option of creating, changing, or displaying master data groups 

during the definition of the revaluation. To do so, position the cursor on the desired group and choose 

Extras -> Create/change/display group. 

Note 

All currency fields for which values were determined in planning are revaluated by the SAP system. 

In the current release, all cost elements that can be planned using primary cost and revenue planning 

can be revaluated. These are activity-independent and activity-dependent respectively. 
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Primary cost elements (category 1) 

Revenue elements (categories 11 and 12) 

Primary order cost elements (category 22) 

Accrual cost elements (categories 3 and 4), cost elements for internal activity allocation (category 

43), and assessment cost elements (category 42) cannot be revaluated. 

Recommendation 

SAP recommends that you perform the revaluation in a version created specifically for it. 

Actions 

Create a revaluation for a version or change a previously defined assessment. 

Enter the cost centers and cost elements that you wish to revaluate (single values or groups). 

Set the rules according to which the revaluation will be executed. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

For more information on revaluation, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Utilities -> Revaluing Cost Center Planning. 

 Periodic Repostings 

In this section, you make settings for periodic repostings in the plan. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Planning -> Utilities -> Periodic Repostings. 

 Determine Sender/Receiver Types for Periodic Reposting 

When making periodic repostings you can specify which table fields are active and whether, in cycles for 

these fields, a single value, an interval, or a group can be entered. 

You make these settings per controlling area and separately for plan and actual data respectively. 
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If you change the attributes for a field that is already used in cycles then if you change: 

Individual values, groups, and intervals that have a "to" value, the system deletes the corresponding data 

records from the table. 

Intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use periodic reposting for cost centers, but want to use only cost center groups as 

receivers. 

Remove the table field indicator "Cost Center" in the fields for individual value entry readiness 

and in the receiver area interval to ensure that you can only enter groups as cost center 

receivers during cycle definition. 

 Allocation Cat: Periodic Reposting 

 Actual/Plan:  Actual 

Field Characteristics: 

Field:  Cost Center 

Active Indicator Entry-Ready   Entry-Ready   Entry-Ready 

+ Sender X  Indv. Valu X  Interval  X  Group 

+ Receiver  _  Indv. Valu _  Interval  X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of a periodic reposting as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 
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Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Note on transport 

To transport periodic reposting field attributes manually, choose Table view -> Transport. 

 Define Periodic Repostings 

Periodic reposting reduces the number of postings in Financial Accounting for document entry. 

The assignment of costs to cost centers in line with the source of these costs occurs in 

Controlling. The complete amount is first assigned to an allocation cost center (such as telephone costs). 

During reposting to the originating cost center, the posting document is given all controlling-relevant data 

but no sender information. 

Example of Periodic Reposting 

All phone costs (cost element 4731) are collected in cost center 2130 (Telephone Central). 

At period-end closing, the costs are reposted to the other cost centers on the basis of statistical key figure 

LDC (Long-Distance Calls). 

The sender cost center is Telephone Central (CCtr 2130). The receivers are all cost centers in the 

organization. 

Recommendation 

Check whether assessment can be used instead of periodic reposting, as this leads to considerably better 

system performance. 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 
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Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that must 

be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 
Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create a cycle for periodic reposting by proceeding as follows: 

Enter a name for the cycle. 

Enter a validity period for the cycle. 
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Maintain the header data for the cycle by determining the following: 

Which currencies are used for allocation 

Whether consumption is to be allocated 

Whether negative tracing factors are scaled or not 

Whether cycle processing takes place iteratively 

The version from which plan data is to be taken 

Define the cycle segments, where the following information is stored: 

The sender cost element to be reposted 

The criteria for distributing the costs onto the receiver 

The sender objects 

The receiver objects 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Periodic reposting 

Periodic reposting is a cost controlling aid equivalent to manually- posted cost transfer Periodic 

reposting can be used for plan or actual postings. 

To simplify cost center planning, you can enter plan values for one center and repost them to other CO 

objects. 

For actual postings, you can enter controlling-relevant postings in Financial Accounting which the 

system collects on an allocation cost center, which minimizes account assignments during 

document entry. At the end of a period, you can repost the collected costs to other CO objects. 

Reposting uses keys (fixed values or calculated tracing factors) for allocation to the corresponding 

receiver objects (cost centers, internal orders, and so on). 

The original primary cost element remains intact in periodic reposting. The line items do not receive 

updated information about senders and receivers. 
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For more information on periodic reposting, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Period-End Closing -> Periodic Allocations -> Defining Periodic 
Repostings or Periodic Allocations. 

 Develop Authorization Enhancements for Periodic Repostings 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the SAP 

original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Accrual Calculation 

In this section you learn how to enter settings for accrual calculation. Two methods are available: 

The percentage method 
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The target=actual method 

For more information, see the SAP Library under 

Financials -> CO Controlling -> Cost Center Planning -> Utilities -> Plan Accrual Calculation 

Financials -> CO - Controlling -> Cost Center Accounting -> Period-End Closing 

-> Accrual Calculations 

 Determine Order Types for Accrual Orders 

In the same way as for cost centers, internal orders can be used as accrual objects to which the monthly 

credits that result from accrual calculation can be posted. 

Accrual calculation requires an order type with order category 02 (accrual order). 

An order type has a large amount of control information important to order management. This 

information includes a range of default values that are used when you create a new order with this order 

type. 

You need to assign each order to an order type that transfers certain parameters to the order. 

The order depends on the client, meaning that each order type can be used in all controlling areas. 

If you want to sort your order types by controlling area, you need to create separate order types for each 

controlling area, for example: 

Order types 00 to 0199 for controlling area "0001" 

Order types 0200 to 0299 for controlling area "0002" The order type determines the following: 

The order category 

You need to assign each order type to an order category. The order category cannot be changed in 

the individual orders. 

The order categories are defaulted in the SAP System and characterize the technical characteristics 

of the order. An order category, for example, specifies the transactions that you can use to process 

an order. 

Internal orders, for example, are category one (category two is used for cost center accruals), model 

orders are category three. 

Number assignment 

You need to assign a number range to each order type. Number assignment is made centrally for all 

orders with this order type. 

Control indicator 

You can change the control indicator for all orders of this order type centrally. 

CO Partner update 
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You can determine whether the partner information remains the same during allocations 

between orders and other CO objects (such as, cost centers, or projects), and if the system is 

to write a totals record for each order. Caution: This can significantly increase the data 

volume. 

Order classification 

You can specify that the orders of this order type are to be classified. You only require 

classification for reporting purposes, and for the Maintenance of free characteristics. You 

can also use order classification retrospectively. For order summarization, you can have 

user-defined master data fields instead of classification. To transfer classification data in 

user-defined fields, choose the IMG activity on Replacing Classification With User-

Defined Fields. 

Commitments Management 

For each order type, you need to specify whether you require Commitments Management. 

Revenue postings 

Posting costs is generally allowed on each order. You also need to specify if revenue postings 

are allowed for an order type. 

Orders with revenues can be settled to G/L accounts, profitability segments, sales orders, 

billing elements, and other orders with revenues. 

Integrated planning 

If you want to update the planned activity input for an order type directly on the sending cost 

sender, you can activate integrated planning as a default value. 

Settlement profile 

In the settlement profile you store the objects which the orders in this order type are allowed to 

settle to. You can also assign a settlement profile to an order type at a later date. It is also possible to 

change the settlement profile in the order. 

Planning profile 

This profile contains parameters and default values for overall planning. You can also assign a 

planning profile to an order type at a later date. 

Budget profile 

This profile contains parameters and default values for budgeting. You can also assign a budget 

profile to an order type at a later date. 

Reference order, from which default values are taken. 

The reference order is used as a template for creating a new order. You can either enter the number 

of a "normal" order, or of a model order (category three). This can be done at any time, also at a 

later date. 

Status management 
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An order can go through more than one status. One of the functions of the status is to determine 

which business transactions are allowed on the order. 

For more information on the various possibilities provided by status management, see the SAP 

Library, under Financials -> CO - Controlling -> Internal Orders -> Master Data in Internal 

Orders -> Status Management for Internal Orders. 

You can make a field selection that is not dependent on status, for the fields available in the order 

master data. 

Note 

General SAP status management is also used in other areas (such as, projects, or production orders). The 

old order status management will soon become obsolete. 

Order residence times in the system 

This is where you define how long your closed orders stay in the system before being archived. 

Choose the residence times so that you are sure that orders not used during the residence time will 

also not be needed at a future date. Note that for plan-integrated orders, you can only determine 

prices for the controlling area if the orders still exist in the system. 

You can change the residence times for all orders of this order type centrally. 

Master data display 

You can determine the order layout for the master data. You determine which subscreens are to be used 

for order master data, and with which group boxes. 

You can specify which print form is to be used for printing order master data. 

You can modify the characteristics of certain fields in the order master depending on 

the order type. 

These modifications are however, are overridden by the field selection, and the field field 

modifications, which you cannot influence. 

The structure of an internal order is not permanently defined. Depending on the purpose of your orders, 

you will not always use all of, or the same fields. 

You can use field selection to define fields as display or input fields, or to hide them altogether. Hidden 

fields do not appear on the screen. 

You can use the field selection to define the field selection for the whole order. However, if you wish to 

use order status management, you can also define the field selection per status. The field characteristics 

for the status then supersede those for the order type. 

The active fields also differ in other ways, such as 

Hide 

Hidden fields are not displayed. 

Display 
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Fields specified as "Display" fields cannot be filled. They are used to display information which 

cannot be changed (such as the order type). 

Entry 

You can fill these fields, but they are not checked, 

Because they are mainly for information (example: text), or 

Because they must match a particular value (for example,you can only enter a particular status if this is 

also defined for the order type) or will be checked for validity (example: dates). 

Required entry 

If you do not make any entries required entry fields, the system issues an error message and you 

cannot continue processing until you make the entry. Such fields usually contain a question mark, 

unless they are additional input fields for other fields which you have filled. 

Highlight 

Highlighted fields stand out optically. 

Activities 

Split your orders according to their usage (order type, default values and so on). 

Check whether the order types delivered meet your requirements. 

If necessary, define new order types that match your needs. 

Notes for Transport 

Ensure during the transport of order types, that in the target system there are the same number of number 

range groups and in the same sequence as in the source system. 

Otherwise, it could happen that in the target system some order types are assigned to other number ranges 

than in the source system. In this case, you have to manually maintain the assignment of the order types 

to the number range groups. 

Notes on transport 

To manually transport order types for accrual cost orders, choose Edit -> Transport. 

 Create Order Layout for Accrual Orders 

In this workstep you define the layout for the order master data. You can assign a layout to each order 

type. 

The system displays the order master data as a tab with a series of tab pages. On the tab pages there are 

group boxes with a series of fields for the order master data. The group boxes are defined by the system. 
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You can specify, 

Which title the individual tab cards should receive and 

which group boxes should be displayed in which position on the tab pages. 

The tab pages are numbered from left to right with "TabPage 01" to "TabPage xx". On every tab page 

there are five positions, which you can assign individually to a group box. One of the group boxes can 

contain user-defined master fields (see workstep "Develop enhancements for order master data"). 

Use each group box only once in a layout. 

Tab pages to which you assign neither a title or a group box, do not appear in the order master data. 

To ensure that the display of order master data from the system occurs in a specified layout, enter the 

layout required in the order type. See the workstep: "Define order types". 

Standard settings 

Layout SAP0 corresponds to the default settings. You can copy this layout if you want to make changes 

to the default settings. 

Activities 

Check whether you need your own layouts. If you only want to make small changes to the standard 

delivery, you can copy layout SAP0 and use it as the basis for your layout. 

If you want to create a new layout, choose "New entries". 

Enter a name and a description for your layout. 

Choose "Tab page title" and "New entries", to specify the title for your tab pages. 

Enter the number for each of the tab pages. 

Enter for which language the title is to be used. 

Enter the title of the tab page. 

Choose "Position group boxes on tab pages" and "New entries", to specify which group boxes should 

appear in which position on the tab pages. 

Enter the number for each of the tab pages. 

Enter the position on each of the tab pages. 

Enter the group box that should appear on the specified position on the tab page. 

Save your entries. 

 Target=Actual Method 

In this section you make settings for the target=actual method in accrual calculation. 
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Whereas you can only use the percentage method in the plan, because no actual values are available in 

which target values can be set, both methods can be used in the actual. 

 Create Accrual Cost Elements 

Accrual cost elements are primary cost elements. 

For the percentage method of accrual calculation, use cost element category 03, "Accrual cost element, 

percentage". 

For the target=actual method, use cost element category 04, "Accrual cost element, target=actual". 

Special cost elements are used in accrual calculation for posting the accrual amounts. 

In the percentage method, overhead is posted under the accrual cost element. 

In the target=actual method, accrual cost elements are used for the affected cost centers for executing 

activity-dependent primary cost planning. The system calculates the target costs during accrual 

calculation for the affected cost center and sets the target values in the actual values. 

Requirements 

Complete the IMG activity Maintain Controlling Area located under General Controlling -> 

Organization. 

Create G/L accounts in FI for the primary cost elements. 

Activities 

Define the primary cost elements. 

You can store the following indicators: 

Cost element category 

 Primary 

 Secondary 

Record quantities 

Quantity unit 

Save default account assignments for cost centers or orders 

Note on transport 

To transport cost elements, a separate function is available in General Controlling Customizing. 

Further notes 

For more information on creating cost elements, see the SAP Library under Financials -> Controlling -> 

Cost Center Accounting -> Master Data for Cost Center Accounting -> Cost Elements. 
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 Percentage Method 

In this section you make settings for the percentage method in accrual calculation. 

The percentage method can only be used in planning, as actual values do not yet exist ( in which target 

values could be placed). However, you can use the percentage method and the target=actual method for 

actual data. 

 Create Accrual Cost Elements 

Accrual cost elements are primary cost elements. 

For the percentage method of accrual calculation, use cost element category 03, "Accrual cost element, 

percentage". 

For the target=actual method, use cost element category 04, "Accrual cost element, target=actual". 

Special cost elements are used in accrual calculation for posting the accrual amounts. 

In the percentage method, overhead is posted under the accrual cost element. 

In the target=actual method, accrual cost elements are used for the affected cost centers for executing 

activity-dependent primary cost planning. The system calculates the target costs during accrual 

calculation for the affected cost center and sets the target values in the actual values. 

Requirements 

Complete the IMG activity Maintain Controlling Area located under General Controlling -> 

Organization. 

Create G/L accounts in FI for the primary cost elements. 

Activities 

Define the primary cost elements. 

You can store the following indicators: 

Cost element category 

 Primary 

 Secondary 

Record quantities 

Quantity unit 

Save default account assignments for cost centers or orders 

Note on transport 

To transport cost elements, a separate function is available in General Controlling Customizing. 
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Further notes 

For more information on creating cost elements, see the SAP Library under Financials -> Controlling -> 

Cost Center Accounting -> Master Data for Cost Center Accounting -> Cost Elements. 

 Maintain Overhead Structure 

The overhead structure controls the overhead calculation. Keys are determined for all controlling areas 

and, in a further step (separate for plan and actual accrual), are characterized at the controlling area level. 

You must define the following keys in the structure, valid for all controlling areas in a client: 

- Calculation Base 

Definition 

Key identifying different calculation bases. 

The calculation base is used to determine those cost elements that are drawn upon to calculate the values 

of accrual cost elements. 

- Overhead 

Definition 

Customizing profile key identifying different overhead. 

The overhead is used to determine the overhead rates used to determine accrual calculation values, 

according to the calculation base. You can maintain differentiated overhead based on the dependency 

used. 

- Credit Key 

Definition 

Key identifying a credit posting. 

The credit posting determines: 

Which overhead cost element is posted 

Which cost center/order the credit includes 

Sample Overhead Structure 

Personnel costs "Vacation" and "Bonus" are accrued equally based on wages and salaries in plan and 

actual. 

The keys A-B1 WAGES (cost elements 420000 and 4200) and A-B2 SALARIES (cost element 430000) 

make up the calculation base for the overhead. 
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For reconciliation with FI, the system collects credits monthly to an order or cost center ( credit object). 

In FI, the complete expense is posted once to the order. You can then display the order balance anytime 

between CO and FI. 

The accrual objects here are stored in the following credit keys: 

    ------------------------------------------------------- 

    | Credit           |  Valid To  | Cost Elem | Order   | 

    ------------------------------------------------------- 

    | E11 Vacation     |  001 1999   | 434 000   | 9A99    | 

    | E12 Bonus        |  001 1999   | 435 000   | 9A99    | 

    ------------------------------------------------------- 

The link between calculation base and credit key is created in the overhead structure SAP000:     ---

-------------------------------------------------------------- 

    |Row   | Base  | Overhead | Frm | To  | Cred. | Name            | 

    ----------------------------------------------------------------- 

    | 1  | A-B1  |          |     |     |       | Wages           | 

    | 120  | A-B2  |          |     |     |       | Salaries        | 

    ----------------------------------------------------------------- 

    | 190  |       |          | 1 | 120 |       | Calc. base      | 

    ----------------------------------------------------------------- 

    | 2  |       | A-Z1     | 190 |     | E11   | Vacation pay    | 

    | 220  |       | A-Z2     | 190 |     | E12   | Bonus pay       | 

    ----------------------------------------------------------------- 

    | 390  |       |          | 200 | 380 |       | Overhead        | 

    | 400  |       |          |     |     |       | Total personnel | 

    ----------------------------------------------------------------- 

This overhead structure determines that vacation and bonus money is calculated using the calculation 

base (step 190). 

The following overhead to wages and salaries appear here: 

Vacation money for all employees:  % 

Gratuities 

For all employees: 5 % 

For assembly line employees: 7 % 

(Cost centers 43 and 4320) 

An overhead key is created for each accrual cost element: 

    -------------------------------------------------------------- 
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    |  Overhead Key             |      | Perc. | Dependency      | 

    -------------------------------------------------------------- 

    |  A-Z1 Vacation            | Act  | %   | CO area         | 

    |                           | Plan | %   |                 | 

    -------------------------------------------------------------- 

    |  A-Z2 Bonus               | Act  |  5%   | CO area/cost    | 

    |                           | Plan |  5%   | center          | 

    |    Cost Center 43       | Act  |  7%   |                 | 

    |                           | Plan |  7%   |                 | 

    |    Cost Center 4320       | Act  |  7%   |                 | 

    |                           | Plan |  7%   |                 | 

    -------------------------------------------------------------- 

Overhead calculation for a particular cost center is based on dependencies. 

For the key with dependency "CO area", the system checks whether the controlling area overhead type 

(actual/plan) has overhead rates and uses these. This is the case with base A-Z1. 

For the key with dependency "CO area/cost center", the procedure takes place in two steps. 

In the first access, the SAP system checks whether the current controlling area has overhead rates 

maintained in the overhead for the given cost centers. This is the case for 43 and 4320, with rates of 

7% for each. 

For the others, no overhead exists, and the procedure moves to the second step, searching for overhead in 

the entire controlling area. 

Here, in plan and actual, the system finds a rate of 5% that applies to all employees. 

The sample accrual SAP000 can be displayed or used as a reference copy for a custom overhead 

structure. 

Requirements 

To change an existing overhead structure, you need authorization for changing structures in all controlling 

areas using this structure. 

To create a new overhead structure, you need authorization for creating structures for the controlling area 

to which you want to assign the structure. 

Standard settings 

The standard system includes overhead structure SAP000. 

Activities 

Create an overhead structure or change an existing one. 
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To create a new overhead structure, choose Create. 

Enter the key and name and choose Save. 

Go to the detail screen of your overhead structure. 

Specify a separate row number for each calculation base. 

Enter a key for the calculation base. 

If you specify a calculation base that does not exist yet, the SAP system will propose creating it 

automatically. 

Maintain the overhead. 

Specify a separate row number for each overhead key. 

Determine on which calculation bases the overhead will be calculated. 

If the overhead key does not exist, you can have the system create it automatically. Then enter 

the dependency with which the overhead rates are to be determined. 

Maintain the credit key for every row with an overhead key. You can have the SAP system create 

this as well, if it does not exist yet. 

Assign the overhead structure to a controlling area. 

Note on transport 

To transport accrual calculation data, a separate function is available in Customizing under Controlling -

> General Controlling. 

Further notes 

Business Aspects of Accrual Calculation 

Business expenses are often allocated differently in Financial Accounting than in Cost Accounting. 

If the expense is incurred for the whole fiscal year, you must allocate it in Cost Accounting to reflect the 

relevant periods and origins. This allocation lets you avoid cost fluctuations within Cost Accounting. 

We refer to the uniform distribution of a one-off expense as "accrual calculation". You can use accrual 

calculation to take into account anticipated costs. 

For more information on accrual calculation, see the SAP Library under AC - Financials -> CO - 

Controlling -> Cost Center Accounting -> Period-End Closing -> Accrual Calculations. 

Utilities for Maintenance of Accrual Calculation 

Access to accrual calculation maintenance is made through a tree structure in which you will find an 

access screen with a list of all available overhead structures and their uses in the different controlling 

areas. You can create menu-controlled alternative views of these lists, such as a controlling-area-related 

display. The list steps for the overviews can be expanded or contracted interactively. 

A number of utilities, briefly explained below, are available for the maintenance for calculating accrual. 

Assignments of overhead structures 
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If you select an overhead structure from the list and choose Allocations -> Display assignments -> 

To overhead structure, you receive an overview of the controlling areas, posting periods, and 

versions the structure is assigned to. 

Assignments to the controlling area 

The function To controlling area likewise displays in which controlling areas the structure appears. 

Assignments of unused structures 

Choose Assignments -> Structures not used for an overview of the structures not assigned to 

controlling areas. You can choose a structure from the list to make an assignment. 

Delete overhead structure 

Choose Overhead structure -> Delete structure to delete existing structures and/or assignments to 

the controlling area. 

When selecting this function, you receive a selection list and can determine which data is to be 

deleted. 

Change name 

Choose Edit -> Change name to change the structure name. The structure's key ( for example, 

SAP000) cannot be changed. 

To change the key, you must copy the structure to a new name and then delete the origin structure. 

These functions are located under Overhead structure. 

Set controlling area 

If you make controlling area-dependent settings, the SAP system requests that you choose a 

controlling area. For subsequent data maintenance in other controlling areas, you must choose Extra 

-> Set controlling area. 

Assignments to controlling area 

To assign overhead structures to the "set" controlling area, choose Allocations -> controlling area 

depending on posting periods. 

Actual postings 

For actual postings, assign exactly one overhead structure to the controlling area. 

Plan postings 

For plan accrual, assign the overhead structure of the version. 

Note that you cannot assign the structures to special periods. The system uses the structure of the 

last posting period for accrual calculation in special periods. 

Environment data 

Choose Environment data to branch to other processes and the maintenance of further object 

components: 

Calculation base 

Overhead rates 

Credit 

Target=actual credit 

The SAP system branches each time to an overview screen where you can change or delete the 

available keys, create new keys, and store controlling area-specific definitions. Alternatively, you 
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can directly select the key for the base, the overhead, and the credit in the detail screen of the 

overhead structure to allocate values for the set controlling area. 

If you want to maintain credits for all business areas, proceed as follows: 

Choose Maintain accrual calculation. 

Select the overhead structure. 

Choose Structure. 

Select a row in which a credit is displayed. 

Choose Goto -> Credit. 

Enter the controlling area. 

 Program Enhancements for Copying Plan and Actual Data 

In addition to the standard function for copying planning or actual data, SAP provides the enhancement 

COOMKPT4, with which you can adapt the above-mentioned programs to your specific requirements: 

COOMKPT4 

Before the data that is imported for copying is transferred to the planning data interface for checking and 

updating, you can process this data. Callup the enhancement per planning transaction (RKP1, RKP2 etc.). 

This SAP enhancement includes the following enhancement components: 

EXIT_SAPMGPT4_0  Copying costs 

EXIT_SAPMGPT4_020  Copying quantities and prices 

Example 

SAP supplies the following examples on using the enhancement components for copying actual data to 

planning: 

Grouping of detailed cost elements in actual with cost elements in plan 

Using sets 

Entering missing data in actual periods in plan with average values from actual 

These example routines can be found in report program LXKPT4F01 

Activities 
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Create the enhancement. 

You can edit the SAP enhancement in SAP enhancement management. For this purpose, choose 

Tools -> ABAP workbench -> Utilities -> Enhancements -> Project management Create either a 

new project or use an available project. 

Activate the project. 

Only through activation does your enhancement becomes effective. 

Further notes 

Unlike modifications, enhancements are generally compatible with any release because they are not part 

of the SAP original and reside in a name range reserved for the customer. 

Information on the procedure when using enhancements can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function Exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You can find 

it in the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Plan Data Transfer 

In this section you make settings for transferring plan data from other SAP applications. You can 

transfer plan data from the following modules: - Personnel costs from HR (Human Ressources) 

Depreciation and interest from AA (Assets Management) 

Key figures from the LIS (Logistics Information System) 

Scheduled activity from PP (Product Planning) 

For more information on transferring planning data, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Cost Center Planning -> Utilities -> Transferring Plan 
Values from Other Application Components. 

 Transfer Personnel Costs from HR 

You can transfer planned personnel costs from Personnel Cost Planning in HR ( Human Resources) to 

Cost Center Planning, where these two applications exist in two systems both at Release 4A or later. 

In pre-4A Releases, the user initiates transfer of planning data from HR manually. As of 4A, the system 

transfers personnel costs to cost center accounting automatically provided a cost center is set in personnel 

cost planning. 

The settings that you make for data transfer are hierarchically structured in the system as follows: 

Planning source 

     Settings per fiscal year 

          Settings per source system 
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               Settings per source version 

In the plan source you enter the source of the data that you want to transfer from personnel cost planning 

to cost center accounting. You can specify the plan source in more detail using the following settings: 

Settings per fiscal year 

Under Settings per fiscal year you define in which controlling area, fiscal year, up to which date, 

and in which version of the SAP system, personnel costs are to be transferred to cost center 

accounting. 

Settings per source system 

Under Settings per source system you specify which logical system you want to use to transfer 

data. You maintain this level of the structure tree whenever you use multiple HR systems and you 

want to transfer the personnel costs in these systems to different CO versions. 

Settings per source version 

If you want to transfer personnel costs from several HR systems into cost center accounting, you use 

externally defined reference keys to specify what data is to be transferred to cost center accounting. 

You enter these reference keys under Settings per source version. 

At each navigation level of the structure tree, you can specify whether the system 

Overwrites the data that exists before transfer takes place, or 

Adds the values transferred to the existing data 

Requirements 

You are working in a scenario with different systems. 

Activities 

To make your settings for transferring personnel costs to cost center accounting, proceed as follows: 

Check the settings in the standard system. 

If you are not able to use these settings because they do not meet your requirements, proceed as 

follows: 

Choose New Entries and define a new plan source. Enter an explanatory text. 

Select a plan source and choose Settings per fiscal year from the structure tree. 

Choose New Entries and enter a controlling area, a fiscal year, a date, and a version. 

Select a row and choose Settings per source system in the structure tree. 

Choose New Entries and enter a logical system, a date, a version, and an explanatory text. 

Select a row and choose Settings per source version in the structure tree. 

You can narrow down the work area by entering reference keys. 
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Save your entries. 

Note 

You do not need to maintain every level of the structure tree. 

The resulting transfer scenarios vary according to your system landscape which in turn determine which 

levels you run through when making your settings for data transfer. 

Further notes 

For more information on transferring planning data from HR and on special settings in HR, see the SAP 

Library under Human Resources -> PA Personnel Management -> Compensation Management 

(PA-CM) -> Personnel Cost Planning -> Integration with Controlling (CO). 

 Transfer Depreciation, Interest and Investments from FI-AA 

Here, you transfer the depreciation and interest that is periodically calculated for a fixed asset in Asset 

Accounting, together with the planned investments in an asset. You transfer these values to primary cost 

planning in Cost Center Accounting. 

Further notes 

For more information on the procedure for transferring data, see the "SAP Library" under 

Financials -> CO Controlling -> Cost Center Accounting -> Cost Center Planning -> 

Utilities -> Transferring Plan Values From Other Application Components -> The Cost 

Center Accounting/Asset Accounting Interface -> Transferring Data from the AA 

Application Component, and under Financials -> FI Financial Accounting -> FI Asset Accounting -

> Processing for Closing -> Primary Cost Planning -> Carry out Cost Planning. 

 Transfer Scheduled Activities from PP 

In Production Planning, you carry out preliminary planning based on individual work center capacity. 

You can copy PP scheduled activity to Cost Center Accounting. You specify parameters for a version and 

a fiscal year at the CO area level. The parameters control the transfer of scheduled activity: 

Further notes 

For more information about the transfer of scheduled activities from PP, see the SAP Library under 

Financials -> Controlling -> Cost Center Accounting -> Cost Center Planning -> Utilities -> 
Transferring Plan Values from Other Application Components -> 

Transfer Services Required by Production -> Transferring Production Activity Requirements 

Notes on Transport 

A separate function exists for transporting the parameters for transferring scheduled activities from PP. 

This function is located under General Controlling in Customizing. 
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 Statistical Key Figure Transfer From LIS 

In this section, you learn how to transfer plan key figures from the Logistic Information System (LIS) to 

cost centers and cost center/ activity types. 

Further notes 

For more information on the search strategy for LIS key figures, see the SAP Library under Financials -

> CO Controlling -> Cost Center Accounting -> Master Data in Cost Center Accounting -> 
Statistical Key Figures. 

 Define Link Between Statistical Key Figures and LIS 

To be able to transfer statistical key figures from the Logistics Information System (LIS) to Cost Center 

Accounting (CCA), you need to create a link between the statistical key figure in CCA and that in LIS. 

You can activate the interface in the master data of the relevant statistical key figure in CCA. This enables 

the later automatic transfer of key figures from the LIS to CCA. 

To find key figures in the LIS, two methods are available: 

Find via info-structures 

Info-structures are database tables administered by the SAP System and automatically updated with 

the different LIS key figures from a particular area or application. 

Find via info-sets 

Info-sets also serve to divide the LIS key figures. Here, however, even finer differentiation can take 

place. 

Info-structures and info-sets are defined within Logistics Controlling. 

Requirements 

You have completed the Customizing activity Activate Cost Center Accounting in Controlling Area. 

Activities 

Enter the statistical key figure for which you want to create a link to the LIS. 

Choose the pushbutton "Link LIS". 

Decide whether to use info-structures or info-sets in the search for the key figure in the LIS. 

Find the desired key figure in the LIS. 

The search via info-structures takes place through the choice of application and info-structure. 

The serarch via info-sets takes place through the continuing choice of info-sets. 
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The information on the corresponding LIS key figure are displayed in the statistical key figure basic 

screen. 

Notes on transport 

To transport statistical key figures, a separate function is available in General Controlling Customizing. 

 Define Assignment of Cost Centers to Key Figures 

In this IMG activity, you maintain the assignment of one or more statistical key figures to a cost center. 

You thereby determine which key figure from the LIS is transferred to which cost center. 

The assignment takes place via a variant, which you can create in the assignment framework. Variants 

can be used to delimit with characteristic values the LIS database area from which the key figures are to 

be transferred. Characteristic values are 

Sold-to party 

Material - Division 

Sales organization 

Distribution channel 

Example 

You wish to transfer the number of invoice receipts for cost centers of Accounts Payable. 

Cost center 1 maintains customers A-K and cost center 2 L-Z. 

The corresponding definitions ensure that cost center 1 receives the invoice receipts for customers 

A-K and cost center 2 those for customers L-Z. 

Afterwards, the key figures are transferred from the LIS via a transfer transaction and posted on the 

cost centers a statistical key figures. 

Periodic allocations such as assessment can be used for these key figures as tracing factors. It is 

possible to assess the costs of data processing based on the automatically transferred key figures and 

charge them to cost centers 1 and 2. 

Requirements 

The LIS and the modules from which the key figures are to be transferred are active. 

You have created statistical key figuresand set up a link to the LIS. 

You have created the cost centers for which the key figures are to be transferred. 

Activities 

Determine which key figures are to be transferred from the LIS. 

Determine which key figure is to be transferred to which cost center. 

Enter a cost center, version, and fiscal year for which the key figures are to be transferred. 
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Create variants. 

If you do not enter any delimitations via the characteristic values, the SAP system chooses the key 

figure from the entire LIS database. 

Assign a variant to each key figure. 

Save your entries. 

Note on transport 

For the transport of the settings for transporting activity-independent key figures from the LIS, an 

individual function is available in Customizing under Controlling -> General Controlling. 

 Define Assignment of Cost Centers/Activity Types to Key 

Figures 

By maintaining the assignment of one or more statistical key figures to a cost center ( dependent on an 

activity type), you determine which key figure is transferred to which cost center/activity type. 

The assignment is made with a variant, which is created in the assignment framework. A variant can be 

used to delimit the area of the LIS database from which key figures are taken using characteristic values: 

Sold-to party 

Material - Division 

Sales organization 

Distribution channel 

Example 

You want to adopt the statistical key figure for order items (AUFPOS) for cost center "Purchase", activity 

type "Test". To do so, create the link to the Logistics Information System (LIS) in the master data: 

Select value source "A" (Automatic Selection of Key Figure) 

Select info structure "S001 Customer". 

Select LIS key figure ANZAUPOS. 

For the data adoption, enter statistical key figure AUFPOS as well as a variant. 

The SAP system uses the value in ANZAUPOS from the LIS for statistical key figure AUFPOS for the 

given combination of cost center and activity type. 

Requirements 

The LIS and modules from which key figures are taken must be active. 

You have created statistical key figures and linked them to the LIS. 
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You created the objects (cost centers, activity types) for which the key figures will be transferred. 

You have completed activity type planning for the cost centers and activity types for which you wish to 

transfer key figures. 

Activities 

Determine which key figures will be transferred from the LIS. 

Determine which key figure will transfer to which cost center/activity type. 

Enter a cost center,  version, and  fiscal year for which key figures are transferred. 

Create the variants. 

If you do not make any limitations on the characteristic values selected, the SAP system takes the 

corresponding key figures from the entire LIS database. 

Assign a variant to each key figure. 

Save your settings. 

Note on transport 

For the transport of settings for the transfer of activity-dependent key figures from the LIS, an individual 

function is available in Customizing under Controlling -> General Controlling. 

 Data Transfer from External Systems 

During external data transfer, the system distinguishes between 

plan data 

actual data 

The SAP system checks the data to be transferred just as in the corresponding dialog functions. 

Transferring external data to the SAP system requires ABAP programming experience, as you have to 

create your own transfer program. SAP provides sample programs to make this task easier. These sample 

programs contain callups for function modules that control the data transfer. 

Further information 

Detailed information on the procedures and execution of external data transfer can be found in the SAP 

Library under Financials -> Controlling (CO) -> Controlling -> CO External Data Transfer. 

 Allocations 

In this section you make settings for the allocation of plan data. 
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 Define Plan Overhead Rates 

You can calculate both plan and actual overhead rates 

For details of how to define overhead rates, see the section Actual Postings -> Overhead Rates. 

Activities 

Define your overhead rates in the plan. 

For more information, see the "SAP Library" under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Periodic Allocations -> Planning Overheads. 

 Distribution 

In this section, you make settings for plan distribution. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 
Accounting -> Cost Center Planning -> Periodic Allocations -> Distribution. 

 Specify Receiver Types for Distribution 

When making distributions you can specify which table fields are active and whether, in cycles, a single 

value, an interval, or a group can be entered for these fields. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 

If you change intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 
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Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 
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Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 

 Define Distribution 

In this activity, you define distributions in the form of cycles by specifying rules for the settlement of 

primary costs on a cost center. 

Recommendation 

Check whether distribution can be replaced here by periodic reposting or assessment in order to achieve 

better system performance. 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations 

that must be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 
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Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create a plan distribution cycle by proceeding as follows: 

Determine a name for the cycle. 

Determine a validity period for the cycle. 

Maintain the header data for the cycle by entering the following. 

Which currencies are to be used in the allocations 

Whether consumption is to be allocated or not 

Whether negative tracing factors are scaled or not 

Whether cycle processing is to be iterative 

In which version the allocation is to take place 

Define cycle segments in which you store the following information. 

Sender cost element to be distributed 

Criteria for cost distribution to the receiver 

Sender objects 

Receiver objects 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 
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To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Distribution 

During distribution, the following information remains: 

Original primary cost element. 

Information on the sender cost center is noted in the receiver cost center or receiver order. 

Information on the receiver cost center or order is noted in the sender cost center. 

For more information, see the "SAP Library" under Financials -> CO Controlling -> Cost Center 

Accounting -> Period-End Closing -> Defining Periodic Repostings or Periodic Allocations. 

 Develop Authorization Enhancements for Distribution 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the SAP 

original and reside in a namespace reserved for the customer. 
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Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Assessment 

In this section you make settings for plan  assessment. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Periodic Allocations -> Assessment. 

 Specify Receiver Types for Assessment 

When making assessments you can specify which table fields are active and whether, in cycles a single 

value, an interval, or a group can be entered for these fields. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 

If you change intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 

Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 
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Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 
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 Create Assessment Cost Elements 

In assessment, the R/3 System converts the original cost elements cumulatively or in groups into 

assessment cost elements. The original cost elements are lost in this process. 

Assessment cost elements are secondary cost elements. 

Requirements 

- Complete the IMG activity Maintain Controlling Area, found in the General Controlling section of 

the IMG under Organizaton. 

Activities 

Create secondary cost elements of category 42 (assessment cost element). 

Note 

For more information, see Maintain Cost Element. 

 Define Allocation Structures 

If the assessment for each segment is not made with a pre-defined assessment cost element, you can 

assign the source cost elements to the desired assessment cost element in the allocation structure. During 

cycle definition, enter the allocation structure instead of an assessment cost element in the segment. 

An allocation structure for the assessment consists of at least one assignment, stating the assessment cost 

element to which the source element is assigned. The original cost elements will already have 

assignments in the source. 

Requirements 

To define the assessment cost elements required for the allocation structures, you must first complete the 

IMG activity "Create Assessment Cost Elements". 

Activities 

Creating an allocation structure. 

To create an allocation structure, proceed as follows: 

Choose "New Entries". 

Enter a name and text for the allocation structure. 

Save the allocation structure. 

Enter the assignments for each allocation structure. To make the assignments, proceed as follows: 
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Select the allocation structure, and then choose "Assignments". 

Choose "New Entries". 

Enter a name and text for the assignment. 

Save the assignment. 

Specify the source for each assignment. 

To specify the source for an assignment, proceed as follows: 

Select the assignment, then choose "Source". 

Enter a cost element interval or a cost element group. 

Save the source. 

Enter the assessment cost element for each assignment. 

To specify an assessment cost element for an assignement, proceed as follows: 

Select the assignment, then choose "Assessment cost element". 

Enter the assessment cost element you require. 

Save your entries. 

Further notes 

For more information on the allocation structure, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Period-End Closing -> Periodic Allocations -> 
Assessment. 

 Define Assessment 

You define assessments as cycles by specifying rules for allocating primary and secondary costs in the 

plan. 

Requirements 

You have completed the IMG activity Create Assessment Cost Elements. 

If you are using an allocation structure, you must have completed the IMG activity  Maintain Allocation 

Structure. 

Recommendation 

When using assessment, distribution, and periodic reposting, note the following: 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 
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Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that must 

be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create an plan assessment cycle by proceeding as follows: 

Enter a name for the cycle 

Enter a validity timeframe for the cycle 
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Maintain the header data for the cycle by entering the following: 

In which currencies the costs should be charged 

Whether consumption quantities should be charged 

Whether negative tracing factors should be scaled 

Whether the cycle should be processed iteratively 

In which version the cycle is valid 

Create segments for the cycle that contain the following information: 

The sender cost element to be distributed 

Criteria to distribute the costs among the receivers 

Sender objects 

Receiver objects 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Additonal Notes 

Notes For Working With A Delta Version 

Please note the following during cycle definition: 

If you select a delta version, the following additional allocation characteristics are available for segment 

definition: 

Business processes and/or groups 

External value added 

Internal value added 

Type 

The receiver objects "order" and "WBS element" become invalid. 
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 Develop Authorization Enhancements for Assessment 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This enhancement 

includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle 

This enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the SAP 

original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Activity Allocation 

In this section you make settings for activity allocations and for splitting. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Periodic Allocations. 
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 Indirect Activity Allocation 

In this section you make your settings for the indirect activity allocation  of plan values. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Periodic Allocations -> Indirect Activity Allocation. 

 Determine Send/Recv Categories for Indirect Acty Allocation 

For indirect activity allocation  you can determine which table fields are active and whether, in cycles you 

can enter a single value, an interval, or a group for these fields. 

You make these settings per controlling area, and separately for plan and actual data respectively. 

Example 

You use indirect activity allocation for cost centers, but want to use only cost center groups as 

receivers. 

Remove the table field indicator "Cost Center" in the fields for individual value entry readiness 

and in the receiver area interval to ensure that you can only enter groups as cost center 

receivers during cycle definition. 

 Allocation Cat: Indirect Activity Allocation 

 Actual/Plan:  Actual 

Field Characteristics: 

Field:  Cost Center 

Active Indicator Entry-Ready   Entry-Ready   Entry-Ready 

+ Sender X  Indv. Valu X  Interval  X  Group 

+ Receiver  _  Indv. Valu _  Interval  X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an indirect activity allocation as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 
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Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport indirect activity allocation field attributes manually, choose Table view -> Transport. 

 Define Activity Types for Indirect Activity Allocation 

You use indirect activity allocation for those activity types for which activity quantities cannot easily be 

determined. 

It is important to distinguish between the following cases: 

Sender activities can be summarized 

The sender allocates activities to the receivers based on receiver tracing factors. 

Sender activities imposssible or difficult to determine The sender allocates these activities: 

Using receiver tracing factors and sender weighting factors 

Using specified fixed amounts 

Activities 
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Create activity types of category 3 for sender activities which can be summarized. 

Create activity types of category 2 for sender activities which are impossible or difficult to determine 

Note 

For more information, see Create activity types. 

 Define Indirect Activity Allocation You determine rules for indirect activity 
allocation in the form of cycles. 

For cost centers with activities that cannot be measured or measured only with great difficulty, 

the activity quantities can be determined indirectly. 

In indirect activity allocation, the usage of sender activities (cost center/activity type) is determined via 

tracing factors from the viewpoint of the activity receivers. 

The tracing factors are defined as in assessment or distribution. 

Requirements 

You must maintain activity types for indirect allocation in actual and plan. 

The requirement for indirect activity allocation in actual and planning data is that all senders and all 

receivers of the cost object cost center/activity type are included in activity type planning for activity 

type category 3. 

You enter activity quantities for activity type category 3 ("Manual entry, automatic allocation") for 

planning data with activity type planning. 

Note: 

Planning activity quantities with the aid of activity type planning is only possible for activity 

type category 3. For activity type category 2 the SAP system automatically creates a cost 

center/activity type record. Sender activity quantities are indirectly determined from the 

receiver tracing factors and through fixed quantities. 

For actual data, a posted sender activity quantity can be created by entering non-allocatable activities. 

Note: 

Entering posted activity quantities for activity type category 3 is not possible, since the 

activity quantities are indirectly determined. 

The requirement for indirect activity allocation in actual and planning data for activity type category 2 is 

that a value NOT equal to zero is entered in the segment definition for the sender-specific weighting 

factors with the function Sender values. Only then will the corresponding record be included in the 

activity allocation. Examples for Indirect Activity Allocation 

Activity types of category 3, "Manual entry, indirect allocation" 

The cost center "Quality control" produces 00 hours of activity type "Test". Activities go to cost 

centers "Goods receipt" and "Finished products". The allocation is made on the basis of the tracing 
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factor "Number of test items" (NI). For "Goods receipt" these are 4000 items, for "Finished 

products" 6000. 

Price per activity unit for "Quality control" equals 50 USD/hr. The resulting costs of activity 

production equal USD 50,000. 

The receiver centers are debited according to the tracing factor  with the following costs: 

Goods receipt:     (50,000 X 4000 NI) / ,000 NI = $ 20,000 

Finished products: (50,000 X 6000 NI) / ,000 NI = $ 30,000 

Activity types of category 2, "Indirect entry, indirect allocation" 

Activity determination for the sender takes place via receiver tracing factors and weighting factors 

defined for each sender. The sender rule here is usually "Indirectly determined quantities"; receiver 

rule can be any rule. 

Using the example above, the receiver tracing factors are: 

                           "Goods receipt"        4000 NI 

                           "Finished products"    6000 NI 

                            Total               ,000 NI 

The sender is credited with ,000 test items. This amount can be valuated with weighting factors 

defined per sender activity type. Weighting factor, activity type "Test": 0 

Debiting of the sender and the activity type "Test" are thus equal to 

       (50,000  / ,000 NI) X ,000 NI X 0,4 = $ 20,000 

Activities 

Create a cycle for indirect activity allocation as follows: 

Determine a name for the cycle. 

Determine a date as of which the cycle is to be valid. 

Maintain the header data of the cycle by specifying the following: 

an explanatory text 

the date to which the cycle is to be valid 

whether negative tracing factors are to be standardized 

Define cycle segments in which you store the following information: 

a name and text for each segment 

the sender values 

the tracing factor 
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the selection criteria (sender objects and receiver objects) 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Periodic Allocations -> Indirect 

Activity Allocation or in Period-End Closing -> Defining Periodic Repostings or Periodic 

Allocations. 

Information for Indirect Activity Allocation  

Indirect activity allocation consists of two subfunctions which you can enter as required in a cycle. 

However, one segment can cover only one subfunction in each case: 

Sender activity quantities are known and can be entered as totals. Using indirect activity allocation, the 

posted activity quantities are distributed from senders to receivers according to the tracing factors 

defined in the segment. 

segment uses this method if Posted quantities (rule 1) is the sender rule and Fixed quantities 

(rule 2) is NOT a receiver rule. 

In a segment to distribute posted sender amounts, you can use activity types of category 3 manual 

entry, indirect allocation only. 

Sender activity quantities are not known because measurement is either impossible or not feasible (for 

example, a joint office working for several cost centers). However, the SAP system can derive 

sender activity quantities indirectly, based on receiver tracing factors adjusted with a sender-specific 

weighting factor. 

segment uses this method if Indirectly determined quantities (rule 3) is the sender rule, or if 

Fixed quantities (rule 2) is a sender or receiver rule. Using the Sender values function, you can 

determine sender-specific weighting factors for the sender rule Indirectly determined quantities. 

The default value is "1". 

In segments for indirect calculation of sender activity quantities you can only use activity types of 

category 2 indirect entry, indirect allocation. 

Senders and receivers in indirect activity allocation 

In indirect activity allocation for actual and plan data, senders  can be objects of the category cost 

center/activity type or business processes. 

In a given segment, you can use category 2 or category 3 activity types only. 
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In indirect activity allocation for plan data, all usual CO objects are possible (cost center, cost 

center/activity type, orders, projects, etc.) as receivers 

All of these receiver categories can appear in a cycle. However, cost objects of the category cost 

center/activity type may not be combined with other receiver categories. 

In indirect activity allocation for actual data, you can use the same cost objects as receivers as in 

manual activity allocation, meaning no cost centers/activity types. 

Fixed and variable activity references; evaluating activity quantities 

In indirect activity allocation for actual data, all quantities are posted as total quantities. The division 

into fixed and variable quantity parts is carried out through actual cost splitting. 

In indirect activity allocation for plan data, the determination of fixed and variable quantity quotas 

depends on the receiver category: 

Receivers of the category cost center/activity type post all activity quantities as variable quantities, with 

tracing factors dividing actual and plan activity into fixed and variable quantity parts. 

For all other receivers the receiver quantities are posted as fixed. 
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If an activity price is available for a sender object, the activity quantities of the sender and the 

corresponding receivers are valuated using this activity price. 

Updating the databases 

The activity quantity updated on the senders is determined either from read/posted sender 

quantities (subfunction 1) or from indirectly calculated activity quantities based on receiver tracing 

factors or predefined sender quantities/receiver quantities (subfunction 2). The activity quantity 

thus determined is posted to the respective sender as activity output (quantity credit) and to the 

respective receiver as activity-dependent or activity-independent activity input in relation to their 

tracing factors (quantity debit). The indefinite credit rate is updated for plan data as well (with 

activity type category 2). 

Additionally, the following activity postings are based on the sender activity quantities: 

If available quantities are distributed (subfunction 1), the scheduled quantity are updated. If the 

sender activity quantities are indirectly determined or fixed, the activity quantity is also updated in 

addition to the scheduled quantity. 

In actual indirect activity allocation, all quantities are treated as fixed quantities. 

You use indirect activity allocation in activity price calculation. 

 Develop Authorization Enhancements for Indirect Activity 

Allocation 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 
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Unlike modifications, enhancements are compatible with any release because they are not part of the SAP 

original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Template Allocation: Plan 

In this section you make your settings for template allocation of plan values. For information on creating 

a template see the SAP Library under Financials -> CO Controlling -> Cost Center Accounting -> 

Cost Center Planning -> Periodic Allocations -> Template Allocation in Plan. 

You can use the template to make allocations for cost centers/activity types, and to allocate processes to 

cost centers. Special environments exist for each way in which a template can be used. 

The environment determines what row and column types are available to you in the template to be 

created. 

 Define Environments and Function Trees 

In this step you maintain: 

Function trees 

Structure nodes - Function references - Functions. 

The basis for the maintenance of the object is always the chosen environment. 

Environment 

The Template's environment determines the information of the SAP-environment and the external system 

that can be accessed. Basically, the functions relevant to each context are already provided in the 

corresponding environment. Environments always contain a row of sub-environments which group 

functions by theme; these include material, BOM, routing, and others. 

The standard system delivers the following environments: 

Template allocation (for cost objects, profitability segments, 

business processes, cost centers/activity types) 

Formula planning (business processes, cost centers, profit centers) 
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Standard cost estimates 

Process quantity determination ( SOP/LTP ) 

Easy Cost Planning/Internal Service Request 

Recommendation 

Use the sub-environments provided by SAP as much as possible. When you assign an function to a sub-

environment, it is automatically available in all the main environments containing this sub-environment. 

Further notes 

For more information on environments and a list of these and their sub-environments go to the help for 

applications of Activity-Based Costing under "Template -> Template Environment". 

Function Tree 

A function tree is a user-defined hierarchy which structures or groups functions. With the Help for 

function trees, you can structure groups of functions available in each environment according to their 

their theme or emphasis. Functions are then processed from here on. 

A function tree is assigned to an environment and consists of nodes and function nodes. 

Environments: all environments are displayed when you call up the n transaction. Environments 

themselves cannot be changed or deleted. The creation of new environments is also not possible. 

Function trees: the first level under environments. You can subordinate nodes or function nodes to a 

function tree. 

Nodes: nodes are always subordinate to function trees or other nodes. You can subordinate other nodes to 

a node or function node. In function trees SAP1, nodes contain sub-environments. 

Function nodes are always subordinate to function trees or nodes. They always refer to a function. 

SAP standard delivery for all environments includes function tree SAP1 (for example, for environment 

001, function tree SAP1-001). This contains all standard nodes ( sub-environments ) and function nodes 

(with reference to the respective function). 

Activities 

The transaction provides you with left and right screens. The left one displays the existing environments. 

You can expand the hierarchy and view the function trees, nodes and function nodes in their hierarchical 

structure. Place the curser on an object you want to process. 

The right screen details of the chosen object (environment, function tree, nodes or function nodes) in list 

form. If you double click on a funciton node you will see the maintenance screen for the functions. 
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Further notes 

For more information see Application help for Activity-Based Costing: 

AC-Financials -> CO-Controlling -> Activity-Based Costing -> Template -> 

Function tree -> Maintain function tree or Template -> Template environment -> Maintain 

functions 

AC-Financials -> CO-Controlling -> Cost center accounting -> Cost center planning -> Aids -> 

Formula planning -> Template -> Template environment. 

 Maintain Templates 

Here you maintain templates. 

Applications 

Each purpose (application) of a template requires a special environment. Before creating a template, 

choose an environment. The environment determines which row and column types are available, for 

example. 

The available applications include the following: 

Template allocation to cost objects, or use in standard cost estimates for cost objects and materials 

(environments 001 - 012) 

Template allocation to business processes, cost centers, or cost centers/activity types 

(environments SBP, SCI, SCD) 

Template allocation to profitability segments (environment PAC) 

Formula planning (environments CPI, CPD, BPP, PCA) 

Calculation of output quantities (environment SOP) 

Easy Cost Planning/Internal Service Requests (environment 200 - 299) 

Structure 

A template consists of rows (items) and columns. The row and column types available to you depend on 

the environment. 

Columns available include: 

Type of row, such as business process, cost element subtemplate, or calculation row 

Name of the item 
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Object, such as the name of the process, cost element, subtemplate, or calculation row 

Quantity (actual/plan), such as the process quantity or statistical key figure quantity 

Activation ( actual/plan ) 

Allocation event (template for cost objects) 

Activities 

To maintain a template, you must edit the initial and overview screens, from which you can access 

various editors. 

Initial screen 

Enter the name of the template that you want to create or edit. 

Enter the environment of the template. 

Choose Enter. 

Overview screen 

If the template is new, enter a name for it. 

Select the row type. 

Enter a name for the row. 

Edit the other columns. Use the mouse or the tab key to reach the individual columns. Double-clicking on 

particular column types (such as object, quantity, activation, or allocation event) brings you to the 

editor or function selection. 

Once you have entered or edited all rows, choose Template -> Save. 

Further notes 

Detailed information is available in the Application Help for the transaction, or in the SAP Library under 

Financials -> Controlling -> Activity-Based Costing -> Template -> Maintaining Templates. 

 Assign Templates for Cost Centers 

You create the link between cost center and formula planning in the master record of the cost center in 

question. 

You assign templates to those cost centers for which you want to determine planned values using 

formulaplanning, or which are to be receiver objects for template allocations. 

Activities 

You can also define templates when maintaining master data. 
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In the cost center master record, choose the Templates tab. 

On the Templates tab, choose Create. 

You can now change or display existing templates or display an allocation structure with the 

template. 

If you have already defined templates, you can enter these on corresponding tab. 

If you want to determine activity-independent planned costs for the relevant cost center, enter an 

activity-independent template in the Aty-ind. formula temp. field. 

If you want to determine activity-dependent planned costs for the relevant cost center, enter an 

activity-dependent template in the Aty-dep.formula tmp. field. 

If you want to carry out an activity-dependent activity allocation for the cost center in question, 

enter an activity-dependent template in the Aty-dep.alloc.tmp field. 

If you want to carry out an activity-independent activity allocation for the cost center in question, 

enter an activity-independent template in the Aty-ind.alloc.tmp field. 

Save your entries. 

Further notes 

For more information on cost center master data, see the "SAP Library" under Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data in Cost Center Accounting -> Cost 
Centers -> Cost Center Master Data. 

 Splitting 

In this section you define a splitting structure, used to split activity-independent costs ( belonging to cost 

centers) between activity types. You assign this structure to the corresponding cost centers. 

For more information on cost splitting, see the "SAP Library" under Financials -> CO Controlling -> 

Cost Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Cost Splitting. 

 Define Splitting Structure 

Splitting structure determine how and what selected activity-independent costs from a cost center are 

divided between the activity types. This applies to both plan and actual costs. 

A splitting structure consists of one or more assignments, which define the connection between the cost 

element(s) or cost element group to be split and the splitting rule used to divide the 



 

 

costs. 

Each splitting rule is based on a splitting method; for example, splitting costs based on statistical key 

figures. 

After you define a splitting structure, you must assign it to the cost centers on which you want to split 

costs according to the given rules. You can assign a structure to: 

All cost centers 

All cost centers in a given group 

All cost centers in a given interval 

The structure can apply to a single version or to all versions in a controlling area for a fiscal year. 

Splitting Example 

Activities 

Create a splitting structure or change an existing structure. 

To create a splitting structure: 

In the overview screen for structure maintenance, choose New entries. 

Enter a two-character key for the structure, a text, and save your entries. 

Define assignments for the splitting structure. 

Select a structure and choose Assignments in the structure tree. 

Choose New entries and include the required entries with a two-character key and descriptive text. 

For the assignment, define according to which rule splitting should be carried out. You can define new 

rules or use existing ones. 

Select an assignment and choose Selection for assignment in the structure tree. 

Choose New entries and define which cost element, which cost element interval, or which cost element 

group is valid for this assignment. 

Save your settings. 

Define splitting rules 

To create new splitting rules, proceed as follows: 

Select an assignment and choose Splitting rules in the structure tree. 

Choose New entries and enter a key for the rule along with a text and procedure. Use the 

"Weighting" indicator to control whether cost splitting uses weighting of tracing factors. 

Define the selection criteria for the splitting rule. 

Select a splitting rule and choose Selection for rules. Choose New entries. 

If necessary, enter a version. 

If the splitting method is based on statistical key figures, you   must enter a statistical key 

figure, a key figure interval, or a key figure group as the selection criterion. Save the selection 

criteria. 

Additional Information 



 

 

Check your structure to ensure that no inconsistencies could arise during splitting. 

Inconsistencies can result from: 

Overlaps or redundancies between individual values, intervals, and groups 

Deletions of selection criteria, rules, assignments, or structures 

In contrast to actual cost splitting, plan cost splitting consists of only a single splitting step. Splitting 

based on target costs is not possible in planning because actual data is not yet available for creating 

target costs. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Cost 

Splitting and under Period-End Closing -> Variance Calculation -> Actual Cost Splitting. 

Note on transport 

To transport splitting layouts, a separate function is available in the General Controlling section of the 

IMG. 

 Assign Splitting Structure to Cost Centers 

If you want to split costs in the cost center to the activity types, you must assign a splitting structure to 

this cost center. 

The SAP System splits costs per the rules that you set in the splitting structure. 

Requirements 

You have defined a Splittung Structure. 

Activities 

Determine the type of assignment to be defined: 

Assignment of splitting structure for each cost center group 

Assignment of splitting structure for all cost centers 

Select the corresponding criteria in the initial screen. 

Along with cost center/group, you can determine whether to make the assignment valid for one 

version or for all versions. The assignment is made for one fiscal year. 

Choose additional cost centers from the list of non-assigned centers. 

Choose the splitting structure (cursor) to which you wish to assign the cost center(s). 

Choose Assign or Edit -> Assign to assign the cost centers the structure. 

Save your entries. 

Note on transport 

The transport of assignments of cost centers to a splitting structure is accomplished by transporting the 

structure itself. A separate function is available the Customizing under CO Controlling -> Controlling. 



 

 

 Price Calculation 

In this activity, you make settings for price calculation. 

For more information on price calculation, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Price 
Calculation. 

 Change Basic Settings for Price Calculation 

You can change the following SAP default control parameters for price calculation. 

Indicator Generate. 

Controls report generation for iterative price calculation. 

Before running price calculation, the system generates the corresponding report on the execution. 

The number of entries in the associated internal tables is generated, as well as the parallel 

processing of field groups. 

By entering realistic figures during performance problems, the storage capacities and runtimes can 

be improved significantly. 

Because generation also requires some time, you should activate this indicator only for very large 

processing runs when problems occur. If the indicator is active, entering numbers in the fields 

mentioned above can be left aside. 

Number of senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of relationships between senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of cost centers in the controlling area 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of significant digits in the price unit 

To achieve more accurate results, the price unit can be set. The activity price is thereafter not based 

on units of 1, but on units of , 0, 00, or 000. If the activity price per unit is already relatively high, 

but you nevertheless want greater accuracy for your prices, this results in even higher values. With 

the number of significant digits, you can limit this development. The moving of digits takes place 

until the number of significant digits is reached. 

Example 

If the price per unit is 333333333, and the significant digit number was set to 6, the price unit 

remains 1 and the price 333. For 12 significant digits, the unit would be 000 and the price 

,333,333333. 

Indicator for deactivating the optimization of the price unit 

Deactivates the significant digit settings mentioned in the previous point. If this is chosen, the price 

unit is 1. 

Tolerance percentage for reconciliation of actual and scheduled activity Activity planning should be 

reconciled when price calculation is called up. The plan activity of the activity type should equal the 

scheduled receiver activity quantity. Only in this way will a sensible price be determined. All 

activity types are checked for reconciliation and, if necessary, issues warnings or error messages. 

Due to planning rounding differences, especially in period distribution, minimal variances may 

occur nevertheless. 

Enter the percentage by which plan activity may vary from scheduled activity. 



 

 

Indicator Post anyway. 

Indicator for posting of price calculation results even if errors occur. 

Exceptions are serious system errors resulting in program termination and errors occurring in 

update preparation (such as integration or document assignment problems). Normally, errors 

prevent update booking of postings. In online processing, the update can be repeated from the 

results list. In background processing, this is not the case. 

Standard settings 

Use the function Set standard to set the parameter values defaulted by the SAP system. 

Recommendation 

SAP recommends using the standard settings unchanged. 

Changing settings to meet the requirements of your organization is useful only if your results vary greatly 

from the SAP default values. 

The changes in generation factors can worsen the runtimes of price calculation. 

Activities 

Maintain the settings for price calculation according to your requirements. 

Additional Notes 

For more information about price calculation, see the SAP Library under Financials -> Controlling 

(CO) -> Cost Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Price 
Calculation. 

Note on transport 

To transport settings for price calculation, there is a function available in Customizing under Controlling 

-> General Controlling. 

 Settings for Cost Component Split 

In this section you make settings for price calculation using cost component splitting. 

 Define Cost Component Structure 

You require a cost component structure to calculate prices using cost component split. 

For each cost component structure you define a cost component such as energy, personnel, or raw 

materials. The components combine all costs occuring for a particular cost element area. In this way, you 

ensure greater cost transparency in activity price calculation when putting together the activity type 

prices - for example, it becomes easier to find how much of the activity price is taken up by the material 

costs. 



 

 

In activity allocation, the cost component structure remains constant, meaning that the receiver takes on 

the sender cost elements and that the allocated costs are posted in the same cost components in the 

receiver as in the sender. 

A cost component structure can have a maximum of 40 defined cost components. 

Cost components are assigned to cost elements. You thereby determine which cost elements go to which 

rows in the structure, and how these components are updated in price calculation. 

The cost component structure must be stored independently of fiscal year in the version. 

You can transfer cost component splitting directly as primary cost splitting to product costing, or you can 

use a transfer structure to transport it to the Product Cost Controlling component ( CO-PC ). 

Note 

You need only carry out the steps named in "Activity". Further settings for cost components are not 

necessary, as they are relevant for product costing only. 

Activities 

To use cost component splitting for price calculation: 

Create a cost component structure or change an existing one. 

To create a new structure, enter a two-character key and an explanatory text. 

Otherwise, choose an existing structure and maintain it in the following steps. 

Save the cost component structure. 

Define cost components 

Select the structure and choose the navigation level "Cost components with characteristics". 

If no components exist, choose "New entries". Otherwise, maintain the existing elements. 

Enter the structure, a key, and a short text for the component. 

Save your entries. 

Assign the cost elements to the cost components. 

Branch to the navigation level "Assign Cost Component - Cost Element Interval". 

If no assignments exist, choose "New entries". Otherwise, maintain the existing elements. 

For each component, enter the structure, the chart of accounts, and the relevant cost element or cost 

element interval. 

Save your entries. 

Enter the cost component structure in the fiscal year dependent part of the version's detailed information. 

Further notes 

For more information about the cost component structure, and price calculation using cost component 

splitting, see the SAP Library under Financials -> CO Controlling -> Cost Center Accounting - 

Period-End Closing -> Actual Price Calculation -> Price Calculation using Cost Component 
Splitting. 

Notes on transport 



 

 

To transport cost component layouts, a separate function is available in Customizing under CO 

Controlling -> Controlling. 

 Define Switching Structure 

You need to define a switch scheme, if within cost component split for price calculation you do not want 

a cost component split for primary costs only. In other words, where for an activity allocation, the 

allocated costs on the receiver are entered on a cost component different from that of the sender. You 

then determine which sender cost element is to be entered on which receiver cost element. 

In price calculation, a cost component structure is used for price component splitting. This structure 

stores which cost elements are to be directed into which component. 

For example, you can note in the cost component structure that material cost elements assigned to the 

sender component "Raw materials" and wage costs assigned to the sender component "Personnel" can be 

directed to the receiver component "Energy". 

As the structure is used only with a specific combination of cost center/activity type, it is entered in the 

activity type planning of the sender. The corresponding planning structure for activity type planning 

using a switching structure is found in planner profile SAP4. 

Activities 

Create a switching structure if you require one To do 

so, proceed as follows: 

Assign an existing cost component structure to a switching structure. 

Assign the structure's components to target components. 

Save your entries. 

Further notes 

For more information and an example, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Period-End Closing -> Actual Price Calculation -> Price Calculation 
with Cost Component Split. 

Note on transport 

You can also transport switching structures manually. To do this, choose Table View -> transport. 

 Budget Management 

In this section you make settings for budget management. 

For more information, see the SAP Library under Financials -> CO - Controlling -> Cost Center 

Accounting-> Cost Center Planning -> Manual Planning -> Budget Planning. 



 

 

 Define Budget Planning Profiles 

To prepare budget management, you need to: 

Create new budget profiles 

Maintain the field contents of cost-center-specific detailed information for the created profiles (= texts) 

With the detailed configurations you can also list the defined budget profiles for budget planning of 

orders and financial planning along with the budget profiles for Cost Center Accounting. 

Once you have created a budget profile, you can maintain the following detailed configurations for this 

profile relevant for Cost Center Accounting. 

Budgeting analysis period 

Past 

Valid analysis period extending into the past 

Future 

Valid analysis period extending into the future 

Start 

Annual values, allowing annual value planning 

Period values, allowing period value planning 

Distribution key 

Display 

Decimal places 

Scaling factor 

Note 

If budget planning is carried out in annual values and the budget profile is switched over at a later time to 

period values, the annual values will continue to be displayed. 

The profiles do not have version features at this time. 

Actions 

Check whether the delivered profiles meet your requirements. 

Create a new profile, if necessary, by choosing New entries,  or copy an existing profile. 

Enter a key for your budget profile. 

Enter a description for your budget profile. 

Maintain the detailed configurations for your profile by carrying out the following IMG activitys: 

Choose your profile from the list of all budget profiles available for CCA. 

Maintain the cost-center-relevant fields for your budget profile. 

Save your entries. 

Note on transport 



 

 

To transport budget planning profiles, a separate function is provided in Customizing under Controlling -

> General Controlling. 

 Commitments and Funds Commitments 

In this section you make the settings necessary to activate Commitments Management, together with 

those required for Funds Commitments in Cost Center Accounting. 

For more information on commitments management, see the "SAP Library" under Financials -> CO 

Controlling -> Controlling -> Controlling Methods -> Commitments Management. 

For more information on Funds Commitments see the "SAP Library" under Financials -> PS 

Project System -> Costs -> Funds Commitments (Cost Centers, Internal Orders, Projects). 

 Activate Commitments Management 

To be able to use commitments management, you need to carry out the following steps: 

Activate commitments management in the controlling area 

Save a default value for commitments management in cost center types 

Overwrite, if necessary, the default value in cost center maintenance 

Requirements 

You have completed the IMG activity Activate Cost Center Accounting in Controlling Area. 

If you require user-defined cost center types, you must create these first. 

Activities 

Activate commitments management in the control indicators of your controlling area. 

Store a default value per cost center type for the commitment management indicator. When creating new 

cost centers of this type, you can accept or change the default value. 

If necessary, overwrite the default value in cost center maintenance. To do so in collective maintenance 

of cost centers, use Goto -> Indicator. 

Note on transport 

To transport controlling area settings, a separate function is available in Customizing under Controlling -

> General Controlling. 

 Define Document Types for Funds Commitment 

In this IMG activity, you maintain document types for funds commitment to classify the documents in 

Controlling. You can specify characteristics for every document type. These characteristics control the 

entries for the document or are themselves noted in the document. 

For controlling, document type "CO" and field status group "G003" are allowed for in the standard. The 

field status group defines which fields are ready for input when you post documents in your controlling 

area. It defines which fields you need to fill and which are to be hidden. 



 

 

Make the following entries: 

Number range interval 

If you wish to archive the posted documents, enter a residence time for each document type. 

If required, you can specify which field contents should be transferred from the reference document. 

Requirements 

You need to define the number range interval in the IMG activity "Define Number Ranges for Funds 

Commitment ". 

Notes 

The Workflow is not supported by Controlling. 

 Define Number Ranges for Funds Commitment 

In this IMG activity, you can change the number range interval for funds commitment. 

This number range interval applies to all controlling areas and is assigned to number range object 

"Internal AC document". 

Standard settings 

The following number range intervals are reserved in the standard system: 

Business transaction Number range interval 

Funds commitment 01 

Fixed price agreement  

Fixed price allocation 11 

Recommendations 

Use the number range intervals supplied if possible. 

Changes to number range intervals from which numbers have already been used may cause problems, 

therefore you need to check carefully before making such changes. 

Activities 

Change number range interval 05 as required. 

Check the other number range intervals, as there cannot be any overlaps. 

Notes on the transport 

You transport number range objects as follows: 

Choose Interval -> Transport in the accounting document Number Range screen. 

All intervals for the selected number range object are deleted in the target system first. After the import, 

only the intervals you export are present. The number statuses are imported with their values at the time 

of export. 



 

 

Dependent tables are not transported or converted. 

 Field Control for Funds Commitment 

 Define field status variant 

You can create and delete field status variants in this step. 

You must then assign a field status variant to each FM area. You can enter a field status variant to as 

many FM areas as you want. 

By assigning a field status variant and field status group to a field selection string, you can control the 

document entry for the various business transactions very differently in your FM areas. The field 

selection string determines which fields are optional, required or hidden when you enter documents. 

Activities 

Use the New entries option to create at least one field status variant. 

Then use the step "Assign field status variants to FM area" to assign the field status variants to your FM 

areas. 

Then use the step  "Assign field selection string" 

to assign field status variants and field status groups to the field selection strings. 

If there are any field status variants you do not need any more, you can delete them by choosing Edit-> 

Delete . 

 Assign field status variant to company code 

In this step, you assign a field status variant to each of your company codes. You can assign a 

field status variant to as many company codes as you want. 

Activities 

Make the assignments. 

 Define field status groups 

In this step, you define field status groups. You must assign the field status groups, along with a field 

status variant, to a field selection string, and enter them when defining document types. 

By defining the field selection string, you determine which fields are optional, required or hidden when 

you enter documents. The document types classify the business transactions ( such as funds blocking and 

funds commitments) in Funds Management. 

You can define separate field status groups for the various business transactions and control document 

entry by defining the field selection and document type accordingly. 



 

 

Standard settings 

There are field status groups defined in the standard. 

Activities 

Check the field status groups delivered in the standard system. 

Choose Edit -> New entries  to create new field status groups. There is a copy function available. To 

use it, select an entry in the standard list and choose Edit -> Copy as. 

In the step Define field selection string, assign the field status group and the field status variant to a field 

selection string. 

Remember to specify the field status group you need in the step Define document types. 

 Define field selection string 

In this step, you can define the field selection strings - that is, you can specify which fields are ready for 

entry, required or hidden during Earmarked funds and transfers. In another step, you must assign a field 

status variant and field status group to the field selection string. 

Activities 

Determine which fields on the doucment entry screen are 

ready for input 

required 

to be hidden 

displayed only 

Use the New entries option to create a field selection string, then choose Maintain field status for field 

selection string. 

Choose a desired field status for each field. 

If you mark the following fields as required entry, the fields are preassigned when entering an FM 

document and cannot be changed by the user: 

FM account assignment changeable in the follow-on document 

Use may exceed reserved amount without limit 

Reduction only in local currency 

Statistics indicators Funds Management 

Subsequently, assign a field status variant and a field status group to the field selection string in the step 

"Define Field Selection String". 

 Assign field selection string 

In this step, you assign a field status variant and field status group to a field selection string you want to 

use. 



 

 

Activities 

Enter the assignments you need. 

 Actual Postings 

In this section you define general settings for actual postings. You can distinguish between: 

Manual actual postings 

Automatic actual data transfer 

From other SAP applications 

External systems 

Period-end closing 

Variance calculation 

Further notes 

For more information on actual postings, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Manual Actual Postings or Manual Actual Postings -> Funds 

Reservation or Period-End Closing. 

 Manual Actual Postings 

In this section you make settings for manual actual postings. 

 Edit Automatic Account Assignment 

In this IMG activity you define automatic additional account assignments for postings to primary cost 

elements. 

Automatic assignment occurs during postings in external accounting (within the FI, MM, or SD 

components) if you did not enter a CO account assignment object (cost center, order, or project) for a 

cost accounting relevant posting. This is always the case if the system automatically created the line 

item in question. 

Examples of Automatically Created Items 

Discounts, exchange rate differences, and banking fees in FI 

Price differences and minor differences in MM 

Possible automatic additional account assignments include: 

Cost center 

Order 

Profit center (for revenue postings) 

You can differentiate the additional assignment according to various criteria (such as company code, 

valuation area, business area). 



 

 

Requirements 

Complete the following IMG activities: 

Activate Cost Center Accounting in Controlling Area 

Maintain Cost Elements (for automatic assignments) 

Create Cost Centers 

In addition to cost centers, you must create the additional objects (such as orders or profit centers) if the 

system is to use these in automatic account assignment. 

Activities 

Enter the cost elements, including the company codes. 

If you want account determination to run on the company code level, also enter the corresponding CO 

object (cost center, order, profit center) to complete the line items. 

If you want account determination to run on the valuation or business area level, find the column 

"Mandatory fields for account assignments" and enter 1 (Valuation area mandatory) 

or 2 (Business area mandatory). 

Choose "Detail by business/valuation area". 

For each valuation or business area, enter the corresponding CO object (cost center, order, profit 

center) to complete the line item. 

If you want account determination to run on the profit center level, find the column "Mandatory fields for 

account assignments" and enter 3 (Profit center mandatory). 

Choose "Detail by profit center". 

For each profit center, enter the corresponding CO object (cost center, order) to complete the line 

item. 

Set the Priority business area indicator to ensure that the business area of the CO account assignment 

overrides other business areas. 

Note on transport 

To transport automatic account assignments, see the separate function in Customizing under Controlling 

-> General Controlling. 

Further notes 

Automatic Account Determination and Default Account Assignment 

You can define automatic account assignments and defaults in the cost element master data record (Cost 

Center Accounting menu "Master data -> Cost element") or in the IMG using step "Maintain automatic 

account assignment". The cost element master data record can determine these assignments per 

controlling area, and the IMG per company code, business area, and/or valuation area. Both information 

sources appear for valuation at the following times: 

Before new posting row data is entered (for example, during row-by-row entry of an FI document), the 

default account assignment is determined on the basis of company code and account number. The 

SAP R/3 System creates an assignment which is then displayed in front of the posting row and can 

be overwritten. Account assignment follows these rules: 



 

 

If you used the IMG step for definition per company code, account, and business area or valuation 

area, the system does not find an assignment since neither business nor valuation area are 

known. 

If you used the IMG step to save an automatic assignment per company code and account, this 

becomes the default. 

If you did not save an automatic assignment in the IMG step, the defaultis taken from the cost 

element master data record. 

If you do not enter a CO account assignment object for a CO-relevant row, the system searches for an 

automatic assignment. This is the case in particular for automatically created posting rows, such as 

for price differences, small amounts, exchange rate differences, or discounts. 

The derivation uses the most detailed assignment available, meaning: 

The SAP R/3 System searches first in the IMG assignment per company code, account, business 

area and/or valuation area. This is possible only if the business/valuation area is known for the 

posting row. 

If the system finds no assignment, it continues by using the account saved in the IMG step, by 

company code and account. 

Should this fail, the system uses the default value from the cost element master data record. 

Automatic Account Determination for Business Areas 

If you use business areas, as a rule you store an account assignment for a cost element not by company 

code, but by company code and business area. You can thus ensure that each posting row is confirmed 

with an error message, if you forgot to make an account assignment for the business area. 

This procedure has the following exceptions: 

Management decisions 

In some cases it is intended that an automatically generated posting row assigns costs to a single cost 

center and thus to only one business area, even when the automatically generated row displays 

differentiated business areas derived for it. 

Example 

You should post all exchange rate differences to a general cost center. 

To do this, store the cost center for the corresponding cost element at the company code level and 

activate the indicator "Priority to business area". 

System-related exceptions that are required 

If a customer or vendor row cannot be uniquely assigned to a company code, FI automatically generates 

posting rows without business areas. Therefore, automatic account assignments must be stored at the 

company code level. The system uses this to derive a business area for the posting row. 

For discounts and exchange rate differences, you can choose from the following to make periodic 

postings to business areas and CO account assignment objects: 

You wish to post discounts and exchange rate differences to different business areas. Only the CO 

account assignment object that you assigned automatically to each business area is of relevance to 

Controlling. 

You make postings directly to the business area (that you uniquely assigned the posting to) and the 

assigned CO account assignment object. 



 

 

You subsequently make a profit and loss adjustment by distributing all other postings to the 

business areas, which are assigned to the posting expenses. When you distribute, the system uses 

the automatic CO account assignments that you stored for each company code and business area. 

Here, you should only make the profit and loss adjustment of the account assignment object for the 

business area (see Profit and Loss Readjustment). In this case, you can store the automatic account 

assignments on the controlling area level as well as the controlling area and business area  level. 

You wish to post discounts and exchange rate differences to different business areas and account 

assignment objects for which you make a non- statistical account assignment. To do this, you only 

need to make an initial assignment of all postings to one cost center. You then distribute the 

postings from this cost center as a subsequent profit and loss adjustment to the business areas and 

CO account assignment objects. The business areas and account assignment objects are those which 

you assigned to the expense and revenue rows in the invoices. 

To do this, store a default account assignment on the controlling area level, but do not store a 

detailed account assignment on the business area level. You need to set the "Priority to business 

area" indicator. 

You cannot use the default account assignment, if you wish to distribute discounts and exchange rate 

differences on Profit Center level as well as on business area level. 

Instead, you have the following options: 

Distribution of discounts and exchange rate differences on the profit center level, not the business area 

level, is not possible with the account assignment function offered. 

However, you do have the following options: 

Do not create the discount accounts as cost elements and assign them at period-end as claims and 

payables to the corresponding profit centers. For more information, see the SAP Library under "AC 

- Financials -> EC - Enterprise Controlling" in the "Profit Center Accounting -> Actual Postings -> 

Cash Discount Expenses/Income and Exchange Rate Differences" section. 

Using substitution, you can define a custom account assignment that derives a cost center for the cost 

element per company code and profit center, where the cost center itself must be assigned to the 

profit center. 

Automatic Account Determination by Profit Center 

You can also store the automatic account assignment for each profit center individually. 

You need the automatic account assignment per profit center -- for example, if you want to post price 

variances in the Materials Management component (MM) to the profit center of the material. 

Without the automatic account assignment, you can do this only if you do not define the price variance 

account as a cost element. 

Within the automatic account assignment you define a product cost center for each product profit center. 

The R/3 System derives this cost center from the profit center during automatic account assignment. 

 Define Own Screen Variants for Postings in Controlling 

You use screen variants to define the layout of the screen on which you make one of the 

following postings: 
Manual reposting of costs 

Manual reposting of revenues 



 

 

Activity allocation 

Manual cost allocation 

Statistical key figures 

A screen variant consists of variants for the individual transactions in manual actual postings (reposting 

costs or activity allocation for example). 

Note: 

Authorization object K_PVARIANT controls whether the screen variants can be accessed. 

Requirements 

Check the settings in activity Maintain Controlling Area to check that cost accounting for the objects 

that you want to include in the screen variant is active in the relevant fiscal year. Examples of these 

objects include: 

Cost centers 

Order management 

Projects 

Cost objects 

Sales and distribution documents 

Standard settings 

SAP supplies a wide variety of screen variants for the postings mentioned above. 

Note 

You cannot make changes to the standard system. If, however you need to make only minor changes, 

you should copy the standard delivery and adjust the copy to meet your requirements. 

Activities 

The screen variants supplied by SAP are displayed on the initial screen. 

To create your own screen variants, proceed as follows: 

Creating screen variants 

Determine what postings you want to make. 

Choose New entries. 

Enter a key and an explanatory text for the screen variant. 

Save your entries. 

Assigning variants for individual transactions 

Select a screen variant and, in the navigation tree, double-click on Define screen variants per 

business transaction. 



 

 

Choose New entries. 

Choose the transaction you require. 

Select the fields that you want to have included on the entry screen for the posting. 

The system provides different fields depending on the transaction 

Field selection is broken down into General fields, Sender fields and Receiver fields. 

Specify whether you want to use Individual entry or List entry. 

To do so, select the appropriate option in the  Initial screen field under Additional data. 

Recommendation 

For complex postings, choose Individual entry. If you have selected a lot of fields for the entry 

screen, individual entry helps you retain a better overview. 

Selecting display variants for lists 

For the Overview list, you can select all line items for a display variant. To do so, under Additional data 

choose a variant. 

You can access the overview list from either the individual entry screen or the list entry screen. 

You can select a display variant for the navigation list by choosing a variant under Further data. 

Under individual entry, you can switch between posting records using the navigation list. 

Note 

In the display variant for the overview list and the navigation list you specify what columns are 

to be displayed, their width, and the order in which they are displayed. You can create your own 

display variants in the respective entry transaction. These are then displayed here and can be 

selected. 

You can select a transaction variant. 

To do so, under Further data choose a variant. 

Using the transaction variant and for both individual entry and list entry you can 

Define default values for particular fields 

Display or hide fields 

Change the order of the fields 

Save your entries. 

Further notes 

You can transport the screen variants straight away. 

To do so, choose Table view -> Transport and enter the screen variants in a Customizing request. 

 BAdI: Implement External Valuation of Activity Allocations 

Use 

This Business Add-In is used for the valuation of internal activity allocations. You can use it to specify 

the valuation of the activity allocation (different from the standard valuation done by the system). You 



 

 

can either specify the price used for valuating the allocated activity quantity, or the direct value of the 

activity allocation. The price and the value can be specified with fixed and variable portions. 

Requirements 

The implementation of the BAdI must transfer the valuation of the activity allocation in the EXT_PRICE 

output structure. This structure (category COEXPRICE) has the following components: 

PRICE_TOTAL - Total price per unit of measure 

PRICE_FIX   - Fixed price per unit of measure 

PRICE_VAR   - Variable price per unit of measure 

PRICE_TKE   - Price unit 

EX_CURR     - Currency key 

VALUE_TOTAL - Total value 

VALUE_FIX   - Fixed value 

VALUE_VAR   - Variable value 

In the PRICE_xxx components, you can specify the price to be used for valuating the allocated activity 

quantity. In the VALUE_xxx components, you can specify the value of the activity allocation. 

EX_CURR specifies the currency that the values in the output structure refer to. 

In the MESSAGES structure (category MESG), you can transfer a message to the caller ( for example, an 

error message). 

The importing parameters SENDER (category COBL_SENDER), RECEIVER ( category 

COBL_RECEIVER) and GENERAL (category COBL_GENERAL) provide you with information on the 

context of the activity allocation to be valuated. 

The BAdI has the following exceptions: 

VALUATION_NOT_FOUND - No valuation could be found 

VALUATION_ZERO      - Valuation 0 was found 

GENERAL_ERROR       - General error in processing 

The exceptions must be removed by using message ... raising .... 

Standard settings 

If there is no active BAdI implementation, the standard valuation is done by the system. 

Activities 

Create an implementation for the EXT_VALUATION_IAA definition and implement the GET method. 

 Actual Data Transfer 

In this section you learn how to transfer actual key figures from the Logistics Information System (LIS) 

to cost centers and cost center/ activity types. 



 

 

 Transfer of Personnel Costs from Human Resources ( HR ) 

In this section, you make the settings for transferring personnel costs from the SAP Human Resources 

(HR) component to the Controlling (CO) component. 

 Assign Personnel Costs to Cost Centers 

In this IMG activity you assign selected personnel costs to given allocation cost centers or internal 

orders. 

In Payroll Accounting, the costs incurred are normally debited on the causing cost center or job. This is 

usually the master cost center of the employee. 

For some accounts, it may be desirable to gather the costs on an allocation cost center or on an internal 

order instead. 

In these cases, enter the required allocation cost center or an internal order for each company code and 

cost element. If you subdivide a company code into business areas, you can also enter the allocation cost 

center or the internal order for each company code, business area, and cost element. 

Examples 

Overhead costs for all employees as employer's contribution to Social Security or costs due to pregnancy 

leave. 

If accrual was calculated in CO for costs such as vacation bonuses, the actual costs must be assigned to 

the accrual calculation order. 

 Define Substitute Cost Centers for Payroll 

In this IMG activity you maintain alternative cost centers for Payroll Accounting. 

In Payroll Accounting, the costs incurred are normally debited on the originating cost center or job. If 

postings can no longer be made to the cost center or job at the time of settlement, postings are made to 

the master cost center of the employee instead, and this account assignment change is recorded in the 

settlement log. 

Payroll Accounting will terminate if it is not possible to post to a master cost center. Therefore, you can 

store an alternative cost center here for each company code. This alternative cost center is then assigned 

instead of master cost centers that you cannot post to. 

By means of the messages in the settlement log, you can take suitable measures after the settlement to 

transfer the costs from the alternative cost center to the originating cost center in 

CO. 

 Statistical Key Figure Transfer From LIS 

In this section you learn how to transfer actual key figures from the Logistics Information System (LIS) 

for cost centers and cost center/ activity types. 



 

 

 Define Link Between Statistical Key Figures and LIS 

To be able to transfer statistical key figures from the Logistics Information System (LIS) to Cost Center 

Accounting (CCA), you need to create a link between the statistical key figure in CCA and that in LIS. 

You can activate the interface in the master data of the relevant statistical key figure in CCA. This 

enables the later automatic transfer of key figures from the LIS to CCA. 

To find key figures in the LIS, two methods are available: 

Find via info-structures 

Info-structures are database tables administered by the SAP System and automatically updated with 

the different LIS key figures from a particular area or application. 

Find via info-sets 

Info-sets also serve to divide the LIS key figures. Here, however, even finer differentiation can take 

place. 

Info-structures and info-sets are defined within Logistics Controlling. 

Requirements 

You have completed the Customizing activity Activate Cost Center Accounting in Controlling Area. 

Activities 

Enter the statistical key figure for which you want to create a link to the LIS. 

Choose the pushbutton "Link LIS". 

Decide whether to use info-structures or info-sets in the search for the key figure in the LIS. 

Find the desired key figure in the LIS. 

The search via info-structures takes place through the choice of application and info-structure. 

The serarch via info-sets takes place through the continuing choice of info-sets. 

The information on the corresponding LIS key figure are displayed in the statistical key figure basic 

screen. 

Notes on transport 

To transport statistical key figures, a separate function is available in General Controlling Customizing. 

 Define Assignment of Cost Centers to Key Figures 

In this IMG activity, you maintain the assignment of one or more statistical key figures to a cost center. 

You thereby determine which key figure from the LIS is transferred to which cost center. 

The assignment takes place via a variant, which you can create in the assignment framework. Variants 

can be used to delimit with characteristic values the LIS database area from which the key figures are to 

be transferred. Characteristic values are 

Sold-to party 

Material - Division 



 

 

Sales organization 

Distribution channel 

Example 

You wish to transfer the number of invoice receipts for cost centers of Accounts Payable. 

Cost center 1 maintains customers A-K and cost center 2 L-Z. 

The corresponding definitions ensure that cost center 1 receives the invoice receipts for 

customers A-K and cost center 2 those for customers L-Z. 

Afterwards, the key figures are transferred from the LIS via a transfer transaction and posted on the 

cost centers a statistical key figures. 

Periodic allocations such as assessment can be used for these key figures as tracing factors. It is 

possible to assess the costs of data processing based on the automatically transferred key figures 

and charge them to cost centers 1 and 2. 

Requirements 

The LIS and the modules from which the key figures are to be transferred are active. 

You have created statistical key figuresand set up a link to the LIS. 

You have created the cost centers for which the key figures are to be transferred. 

Activities 

Determine which key figures are to be transferred from the LIS. 

Determine which key figure is to be transferred to which cost center. 

Enter a cost center, version, and fiscal year for which the key figures are to be transferred. 

Create variants. 

If you do not enter any delimitations via the characteristic values, the SAP system chooses the key 

figure from the entire LIS database. 

Assign a variant to each key figure. 

Save your entries. 

Note on transport 

For the transport of settings for the transfer of activity-independent key figures from the LIS, an 

individual function is available in Customizing under Controlling -> General Controlling. 

 Define Assignment of Cost Centers/Activity Types to Key 

Figures 

By maintaining the assignment of one or more statistical key figures to a cost center ( dependent on an 

activity type), you determine which key figure is transferred to which cost center/activity type. 

The assignment is made with a variant, which is created in the assignment framework. A variant can be 

used to delimit the area of the LIS database from which key figures are taken using characteristic values: 

Sold-to party 

Material - Division - Sales organization 



 

 

Distribution channel 

Example 

You want to adopt the statistical key figure for order items (AUFPOS) for cost center "Purchase", 

activity type "Test". To do so, create the link to the Logistics Information System (LIS) in the master 

data: 

Select value source "A" (Automatic Selection of Key Figure) 

Select info structure "S001 Customer". 

Select LIS key figure ANZAUPOS. 

For the data adoption, enter statistical key figure AUFPOS as well as a variant. 

The SAP system uses the value in ANZAUPOS from the LIS for statistical key figure AUFPOS for the 

given combination of cost center and activity type. 

Requirements 

The LIS and modules from which key figures are taken must be active. 

You have created statistical key figures and linked them to the LIS. 

You created the objects (cost centers, activity types) for which the key figures will be transferred. 

You have completed activity type planning for the cost centers and activity types for which you wish to 

transfer key figures. 

Activities 

Determine which key figures will be transferred from the LIS. 

Determine which key figure will transfer to which cost center/activity type. 

Enter a cost center,  version, and  fiscal year for which key figures are transferred. 

Create the variants. 

If you do not make any limitations on the characteristic values selected, the SAP system takes the 

corresponding key figures from the entire LIS database. 

Assign a variant to each key figure. 

Save your settings. 

Note on transport 

For the transport of settings for the transfer of activity-dependent key figures from the LIS, an individual 

function is available in Customizing under Controlling -> General Controlling. 

 Data Transfer from External Systems 

 BAdI: Implement Transfer of External CO Actual Data 

Use 

This Business Add-In transfers external actual posting data to Overhead Cost Controlling. This 

implements the uploading of the posting data into the SAP system. 



 

 

Requirements 

You can transfer actual posting data for the following business transactions: 

Activity allocation 

Primary cost reposting - Revenue reposting 

Manual cost allocation 

Non-allocable activities 

Statistical key figures 

Reversal 

Depending on the transaction, the BAdI implementation transfers the uploaded posting data to the 

following output tables: 

aa_headers and aa_items for activity allocations ( BAPIAAHDR or BAPIAAITM) , 

rc_headers and rc_items for primary cost repostings ( BAPIRCHDR or BAPIRCITM) , 

rr_headers and rr_items for revenue repostings (structure BAPIRRHDR or 

BAPIRRITM) , 

ma_headers and ma_items for manual cost allocations (BAPIMAHDR or BAPIMAITM) , 

ia_headers and ia_items for non-allocable activities (BAPIIAHDR or BAPIIAITM) , 

skf_headers and skf_items for statistical key figures ( BAPISKFHDR or 

BAPISKFITM) or 

rev_headers for reversals (BAPIDOCHDRR) 

In addition, if profitability segments are to be assigned: 

send_crit (BAPISCRIT) and - recv_crit (BAPIRCRIT). 

The output tables for the document headers (xx_headers) have the same structure as the 

corresponding interface paramter of the BAPIs for these transactions. This is specified above in 

parentheses. 

The output tables for the document items (xx_items) have the following components: 

CO_AREA - controlling area 

DOC_NO - document number - ITEMS - document items. 

The document number is initially used for assigning the document headers to document items. If you do 

not set the External Document Number Assignment for the data transfer, these document numbers are 

replaced by numbers from the internal number range related to the transaction. If you set this indicator, 

the documents are posted with the specified document numbers. You need to ensure that the specified 

document numbers are in teh correct external number ranges. 

The document item component is a table with the same structure as the corresponding interface paramter 

of the BAPI for this transaction. This is specified above in parentheses. 

Actual posting data for more than one transaction can be transferred at the same time. To enable this, the 

BAdI implementation must fill the corresponding output tables. 

Standard settings 



 

 

If there is no active BAdI implementation, the system does not transfer any actual posting data. 

Activities 

Create an implemenation for the EXT_CO_ACTUAL_DATA definition and implement the IMPORT 

method. 

Example 

An example for uploading posting data that was entered in Excel and saved as a tab-separated text file 

has been implemented in the CL_IM_EXT_CO_DATA_EXAMPLE class ( implementation name 

EXT_CO_DATA_EXAMPLE). 

The following data format is required for this example: 

A data block is started off with a header and ended by an empty row. 

The header is in the first cell of the row and the rest of the cells in this row are empty. 

The header defines the structure of the following data rows and must also contain the name of one of the 

BAPI structures mentioned above (BAPIxxHDR, BAPIxxITM etc.). 

The row that comes after the header contains the names of the fields used in the following data rows. 

The following data rows contain the posting data, whereby the field name row described above is the 

"table header". 

Example: 

BAPIRCHDR 

CO_AREA   DOC_NO     POSTGDATE  TRANS_CURR 

0001      0000000001 200101   EUR 

          0000000002 200921   EUR 

          0000000003 200819   EUR 

BAPIRCITM 

CO_AREA   DOC_NO     SEND_CCTR  REC_CCTR   VALUE_TCUR COST_ELEM 

0001      0000000001 R-KS1      R-KS2      0        0000417000 

                     R-KS3      R-KS2      120        0000420000 

                     R-KS1      R-KS4      50         0000417000 

          0000000002 R-KS5      R-KS2      200        0000420000 

          0000000003 R-KS1      R-KS3      40         0000420000 

                     R-KS2      R-KS1      160        0000417000 

 Period-End Closing 

In Periodic Allocations you define: 

Accrual calculation 

Periodic actual allocations, by using sender-receiver relationships in cycles such as: 

Periodic reposting 

Distribution 



 

 

Assessment 

Indirect activity allocation 

Variance calculation 

Activity price calculation 

Note 

Periodic allocation methods are classified as indirect because user- defined keys, not activity exchanges 

between cost centers, form the basis of allocation. These methods are easy to use because, as a rule, you 

define sender-receiver relationships only once. 

Additional information 

Periodic allocations 

The SAP System writes line items for the following period-related allocations: 

Periodic transfer posting 

Distribution 

Assessment 

Indirect activity allocation 

You cannot restrict line item updating in the SAP System. When a period-related allocation is repeated, 

the SAP System reverses the line items in the period. 

 Periodic Reposting 

In this section you make settings for periodic repostingin the actual. 

 Determine Sender/Receiver Types for Periodic Reposting 

When making periodic repostings you can specify which table fields are active and whether, in cycles for 

these fields, a single value, an interval, or a group can be entered. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then if you change: 

Individual values, groups, and intervals that have a "to" value, the system deletes the corresponding data 

records from the table. 

Intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use periodic reposting for cost centers, but want to use only cost center groups as 

receivers. 

Remove the table field indicator "Cost Center" in the fields for individual value entry readiness 

and in the receiver area interval to ensure that you can only enter groups as cost center 

receivers during cycle definition. 

 Allocation Cat: Periodic Reposting 



 

 

 Actual/Plan:  Actual 

Field Characteristics: 

Field:  Cost Center 

Active Indicator Entry-Ready   Entry-Ready   Entry-Ready 

+ Sender X  Indv. Valu X  Interval  X  Group 

+ Receiver  _  Indv. Valu _  Interval  X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of a periodic reposting as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Note on transport 

To transport periodic reposting field attributes manually, choose Table view -> Transport. 



 

 

 Define Periodic Repostings 

Periodic reposting reduces the number of postings in Financial Accounting for document entry. 

The assignment of costs to cost centers in line with the source of these costs occurs in Controlling. The 

complete amount is first assigned to an allocation cost center (such as telephone costs). 

During reposting to the originating cost center, the posting document is given all controlling-relevant 

data but no sender information. 

Example of Periodic Reposting 

All phone costs (cost element 4731) are collected in cost center 2130 (Telephone Central). 

At period-end closing, the costs are reposted to the other cost centers on the basis of statistical key figure 

LDC (Long-Distance Calls). 

The sender cost center is Telephone Central (CCtr 2130). The receivers are all cost centers in the 

organization. 

Recommendation 

Check whether assessment can be used instead of periodic reposting, as this leads to considerably better 

system performance. 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large 

distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that 

must be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 



 

 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------

- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create a cycle for periodic reposting by proceeding as follows: 

Enter a name for the cycle. 

Enter a validity period for the cycle. 

Maintain the header data for the cycle by determining the following: 

Which currencies are used for allocation 

Whether consumption is to be allocated 

Whether negative tracing factors are scaled or not 

Whether cycle processing takes place iteratively 

The version from which plan data is to be taken 

Define the cycle segments, where the following information is stored: 

The sender cost element to be reposted 

The criteria for distributing the costs onto the receiver 

The sender objects 

The receiver objects 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Periodic reposting 



 

 

Periodic reposting is a cost controlling aid equivalent to manually- posted cost transfer 

Periodic reposting can be used for plan or actual postings. 

To simplify cost center planning, you can enter plan values for one center and repost them to other CO 

objects. 

For actual postings, you can enter controlling-relevant postings in Financial Accounting which the 

system collects on an allocation cost center, which minimizes account assignments during 

document entry. At the end of a period, you can repost the collected costs to other CO objects. 

Reposting uses keys (fixed values or calculated tracing factors) for allocation to the corresponding 

receiver objects (cost centers, internal orders, and so on). 

The original primary cost element remains intact in periodic reposting. The line items do not receive 

updated information about senders and receivers. 

For more information on periodic reposting, see the SAP Library under Financials -> CO Controlling -

> Cost Center Accounting -> Period-End Closing -> Periodic Allocations -> Defining Periodic 
Repostings or Periodic Allocations. 

 Develop Authorization Enhancements for Periodic Repostings 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement 

transaction CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 



 

 

 Accrual Calculation 

In this section you learn how to enter settings for accrual calculation. Two methods are available: 

The percentage method 

The target=actual method 

For more information, see the SAP Library under 

Financials -> CO Controlling -> Cost Center Planning -> Utilities -> Plan Accrual Calculation 

Financials -> CO - Controlling -> Cost Center Accounting -> Period-End Closing 

-> Accrual Calculations 

 Determine Order Types for Accrual Orders 

In the same way as for cost centers, internal orders can be used as accrual objects to which the monthly 

credits that result from accrual calculation can be posted. 

Accrual calculation requires an order type with order category 02 (accrual order). 

An order type has a large amount of control information important to order management. This 

information includes a range of default values that are used when you create a new order with this order 

type. 

You need to assign each order to an order type that transfers certain parameters to the order. 

The order depends on the client, meaning that each order type can be used in all controlling areas. 

If you want to sort your order types by controlling area, you need to create separate order types for each 

controlling area, for example: 

Order types 00 to 0199 for controlling area "0001" 

Order types 0200 to 0299 for controlling area "0002" The order type determines the following: 

The order category 

You need to assign each order type to an order category. The order category cannot be changed in 

the individual orders. 

The order categories are defaulted in the SAP System and characterize the technical characteristics 

of the order. An order category, for example, specifies the transactions that you can use to process 

an order. 

Internal orders, for example, are category one (category two is used for cost center accruals), model 

orders are category three. 

Number assignment 

You need to assign a number range to each order type. Number assignment is made centrally for all 

orders with this order type. 

Control indicator 

You can change the control indicator for all orders of this order type centrally. 

CO Partner update 



 

 

You can determine whether the partner information remains the same during allocations 

between orders and other CO objects (such as, cost centers, or projects), and if the system 

is to write a totals record for each order. Caution: This can significantly increase the data 

volume. 

Order classification 

You can specify that the orders of this order type are to be classified. You only require 

classification for reporting purposes, and for the Maintenance of free characteristics. You 

can also use order classification retrospectively. For order summarization, you can have 

user-defined master data fields instead of classification. To transfer classification data in 

user-defined fields, choose the IMG activity on Replacing Classification With User-

Defined Fields. 

Commitments Management 

For each order type, you need to specify whether you require Commitments Management. 

Revenue postings 

Posting costs is generally allowed on each order. You also need to specify if revenue postings 

are allowed for an order type. 

Orders with revenues can be settled to G/L accounts, profitability segments, sales orders, 

billing elements, and other orders with revenues. 

Integrated planning 

If you want to update the planned activity input for an order type directly on the sending cost 

sender, you can activate integrated planning as a default value. 

Settlement profile 

In the settlement profile you store the objects which the orders in this order type are allowed to 

settle to. You can also assign a settlement profile to an order type at a later date. It is also possible 

to change the settlement profile in the order. 

Planning profile 

This profile contains parameters and default values for overall planning. You can also assign a 

planning profile to an order type at a later date. 

Budget profile 

This profile contains parameters and default values for budgeting. You can also assign a budget 

profile to an order type at a later date. 

Reference order, from which default values are taken. 

The reference order is used as a template for creating a new order. You can either enter the number 

of a "normal" order, or of a model order (category three). This can be done at any time, also at a 

later date. 

Status management 

An order can go through more than one status. One of the functions of the status is to determine 

which business transactions are allowed on the order. 



 

 

For more information on the various possibilities provided by status management, see the SAP 

Library, under Financials -> CO - Controlling -> Internal Orders -> Master Data in Internal 

Orders -> Status Management for Internal Orders. 

You can make a field selection that is not dependent on status, for the fields available in the order 

master data. 

Note 

General SAP status management is also used in other areas (such as, projects, or production orders). The 

old order status management will soon become obsolete. 

Order residence times in the system 

This is where you define how long your closed orders stay in the system before being archived. 

Choose the residence times so that you are sure that orders not used during the residence time will 

also not be needed at a future date. Note that for plan-integrated orders, you can only determine 

prices for the controlling area if the orders still exist in the system. 

You can change the residence times for all orders of this order type centrally. 

Master data display 

You can determine the order layout for the master data. You determine which subscreens are to be used 

for order master data, and with which group boxes. 

You can specify which print form is to be used for printing order master data. 

You can modify the characteristics of certain fields in the order master depending on the order type. 

These modifications are however, are overridden by the field selection, and the field field 

modifications, which you cannot influence. 

The structure of an internal order is not permanently defined. Depending on the purpose of your orders, 

you will not always use all of, or the same fields. 

You can use field selection to define fields as display or input fields, or to hide them altogether. Hidden 

fields do not appear on the screen. 

You can use the field selection to define the field selection for the whole order. However, if you wish to 

use order status management, you can also define the field selection per status. The field characteristics 

for the status then supersede those for the order type. 

The active fields also differ in other ways, such as 

Hide 

Hidden fields are not displayed. 

Display 

Fields specified as "Display" fields cannot be filled. They are used to display information which 

cannot be changed (such as the order type). 

Entry 

You can fill these fields, but they are not checked, 

Because they are mainly for information (example: text), or 

Because they must match a particular value (for example,you can only enter a particular status if this is 

also defined for the order type) or will be checked for validity (example: dates). 



 

 

Required entry 

If you do not make any entries required entry fields, the system issues an error message and you 

cannot continue processing until you make the entry. Such fields usually contain a question mark, 

unless they are additional input fields for other fields which you have filled. 

Highlight 

Highlighted fields stand out optically. 

Activities 

Split your orders according to their usage (order type, default values and so on). 

Check whether the order types delivered meet your requirements. 

If necessary, define new order types that match your needs. 

Notes for Transport 

Ensure during the transport of order types, that in the target system there are the same number of number 

range groups and in the same sequence as in the source system. 

Otherwise, it could happen that in the target system some order types are assigned to other number 

ranges than in the source system. In this case, you have to manually maintain the assignment of the order 

types to the number range groups. 

Notes on transport 

To manually transport order types for accrual cost orders, choose Edit -> Transport. 

 Create Order Layout for Accrual Orders 

In this workstep you define the layout for the order master data. You can assign a layout to each order 

type. 

The system displays the order master data as a tab with a series of tab pages. On the tab pages there are 

group boxes with a series of fields for the order master data. The group boxes are defined by the system. 

You can specify, 

Which title the individual tab cards should receive and 

which group boxes should be displayed in which position on the tab pages. 

The tab pages are numbered from left to right with "TabPage 01" to "TabPage xx". On every tab page 

there are five positions, which you can assign individually to a group box. One of the group boxes can 

contain user-defined master fields (see workstep "Develop enhancements for order master data"). 

Use each group box only once in a layout. 

Tab pages to which you assign neither a title or a group box, do not appear in the order master data. 

To ensure that the display of order master data from the system occurs in a specified layout, enter the 

layout required in the order type. See the workstep: "Define order types". 

Standard settings 



 

 

Layout SAP0 corresponds to the default settings. You can copy this layout if you want to make changes 

to the default settings. 

Activities 

Check whether you need your own layouts. If you only want to make small changes to the standard 

delivery, you can copy layout SAP0 and use it as the basis for your layout. 

If you want to create a new layout, choose "New entries". 

Enter a name and a description for your layout. 

Choose "Tab page title" and "New entries", to specify the title for your tab pages. 

Enter the number for each of the tab pages. 

Enter for which language the title is to be used. 

Enter the title of the tab page. 

Choose "Position group boxes on tab pages" and "New entries", to specify which group boxes should 

appear in which position on the tab pages. 

Enter the number for each of the tab pages. 

Enter the position on each of the tab pages. 

Enter the group box that should appear on the specified position on the tab page. 

Save your entries. 

 Create Accrual Orders 

In this IMG activity you define orders to be used as credit objects in accrual calculation. These orders 

collect monthly credits. The output to FI is also posted on the credit object. 

In this manner, the balance between FI and CO can be displayed at any time by the accrual order. 

If you use cross-company-code cost accounting, the accrual orders must be created in all company codes 

in which accrual calculation for cost centers takes place. 

To generate business area balances, you must create accrual orders in all business areas in which accrual 

calculation for cost centers takes place. 

Requirements 

You completed the Create order types for accrual orders step. 

Actions 

Create accrual orders. 

Additional information 

For more information on master data maintenance for orders, see the SAP library under Financials -> 

CO - Controlling -> Overhead Cost Controlling -> Internal orders -> Master data for internal 
orders. 



 

 

Note on transport 

No standard transport function is supported for accrual orders. 

 Create Accrual Cost Centers 

Accrual cost centers collect monthly credits created during accrual calculation. Ouput to FI is also posted 

to the credit object. 

The balance between CO and FI can be displayed in the accrual cost center at any time. 

In the following section you learn how to create cost centers . 

Note on Cost Centers 

Cost centers are created to support differentiated assignment of overhead costs, to calculate overall costs 

of sales (cost calculation function), and to carry out detailled control of costs occuring within the 

organization (cost controlling function). 

Cost centers are grouped into higher-level decision, control, and responsiblity areas on the basis of 

overhead Controlling standpoints. 

Requirements 

You have completed the step Maintain controlling area in the IMG General Controlling under 

Organization. 

You have maintained the necessary cost center types. 

You defined a standard hierarchy. 

Activities 

Create your cost centers. 

Note on transport 

To transport cost centers, a separate function is available in the IMG General Controlling. 

Addtional information 

For more information on creating cost centers, see the SAP Library under Controlling -> Cost Center 

Accounting -> Cost Center Accounting Module Administration -> Cost Centers and Cost Center 

Groups -> Maintaining Cost Centers. 

 Target=Actual Method 

In this section you make settings for the target=actual method for accrual calculation. 

The target=actual method is used for activity-dependent and activity-independent costs. Planning of the 

dependent and independent primary costs is made with an accrual cost element 

for the cost centers for which accrual is to be calculated 



 

 

for the interval in which accrual is to be calculated 

The SAP system calculates target costs and enters these costs in the actual value fields. 

This method is useful when accrual can be planned periodically. 

If you calculate activity-independent accrual, use a plan=actual method. No target costs can be 

calculated. The SAP system enters plan costs in the actual value fields. 

 Create Accrual Cost Elements 

Accrual cost elements are primary cost elements. 

For the percentage method of accrual calculation, use cost element category 03, "Accrual cost element, 

percentage". 

For the target=actual method, use cost element category 04, "Accrual cost element, target=actual". 

Special cost elements are used in accrual calculation for posting the accrual amounts. 

In the percentage method, overhead is posted under the accrual cost element. 

In the target=actual method, accrual cost elements are used for the affected cost centers for executing 

activity-dependent primary cost planning. The system calculates the target costs during accrual 

calculation for the affected cost center and sets the target values in the actual values. 

Requirements 

Complete the IMG activity Maintain Controlling Area located under General Controlling -> 

Organization. 

Create G/L accounts in FI for the primary cost elements. 

Activities 

Define the primary cost elements. 

You can store the following indicators: 

Cost element category 

 Primary 

 Secondary 

Record quantities 

Quantity unit 

Save default account assignments for cost centers or orders 

Note on transport 

To transport cost elements, a separate function is available in General Controlling Customizing. 

Further notes 

For more information on creating cost elements, see the SAP Library under Financials -> Controlling -

> Cost Center Accounting -> Master Data for Cost Center Accounting -> Cost Elements. 

 Percentage Method 

In this section you make settings for the percentage method in accrual calculation. 



 

 

 Create Accrual Cost Elements 

Accrual cost elements are primary cost elements. 

For the percentage method of accrual calculation, use cost element category 03, "Accrual cost element, 

percentage". 

For the target=actual method, use cost element category 04, "Accrual cost element, target=actual". 

Special cost elements are used in accrual calculation for posting the accrual amounts. 

In the percentage method, overhead is posted under the accrual cost element. 

In the target=actual method, accrual cost elements are used for the affected cost centers for executing 

activity-dependent primary cost planning. The system calculates the target costs during accrual 

calculation for the affected cost center and sets the target values in the actual values. 

Requirements 

Complete the IMG activity Maintain Controlling Area located under General Controlling -> 

Organization. 

Create G/L accounts in FI for the primary cost elements. 

Activities 

Define the primary cost elements. 

You can store the following indicators: 

Cost element category 

 Primary 

 Secondary 

Record quantities 

Quantity unit 

Save default account assignments for cost centers or orders 

Note on transport 

To transport cost elements, a separate function is available in General Controlling Customizing. 

Further notes 

For more information on creating cost elements, see the SAP Library under Financials -> Controlling -

> Cost Center Accounting -> Master Data for Cost Center Accounting -> Cost Elements. 

 Maintain Overhead Structure 

In this IMG activity you define an overhead structure for accrual calculation. 

The overhead structure controls the overhead calculation. Keys are determined for all controlling areas 

and, in a further step (separate for plan and actual accrual), are characterized at the controlling area level. 

You must define the following keys in the structure, valid for all controlling areas in a client: 



 

 

Calculation base 

At the controlling area level you allocate cost elements whose overhead value is calculated to the 

key "Calculation base". 

Overhead 

You always define this key with respect to one or several calculation bases. Here you set the 

dependency with which the SAP system is to determine the overhead. The dependency controls 

with which sequence and which combinations (controlling area, cost center, business area, and so 

on) overhead rates apply. 

At the controlling area level you allocate percentages to the key "Overhead", used to derive the 

values of the accrual calculation from the values of the calculation base, dependent on posting 

periods and with respect to the defined dependency. 

Credit key 

When carrying out accrual calculation, the cost centers on which costs of the tracing factors 

have incurred are debited with the calculated overhead. Via the credit keys, you determine 

the following at the controlling area level: 

The cost element under which the overhead is posted (accrual cost element) 

The CO object (cost center or order) to be credited with overhead 

The validity period of the credit code ("valid to") 

Sample Overhead Structure 

Employee benefits "Vacation bonus" and "Other bonus" are calculated in plan and actual based on wages 

and salaries. 

The condition records "A-B1 WAGES" (cost elements 420 000 and 421 000) and "A-B2 SALARIES" 

(cost element 430 000) are used jointly to calculate surcharges. 

To balance accounts with financial accounting, the SAP System collects the credits for each month on an 

order. 

In financial accounting you post the total expense in one sum to the order. You can display the balance 

between cost accounting and financial accounting at any time. 

The imputed cost objects for this example are defined in the following credit keys: 

    -------------------------------------------------------- 

    | Cr. key    | Imp. cost object    | CElem   | Order   | 

    -------------------------------------------------------- 

    |   E11      | Vacation bonus      | 434 000 | 9A99    | 

    |   E12      | Other bonus         | 435 000 | 9A99    | 

    -------------------------------------------------------- 

The link between the calculation base and the imputed cost key is set up in the costing sheet "SAP000": 

    ---------------------------------------------------------------- 

    | Level| Cond. | Name                 | From  | To   | Credit  | 

    |      | Record|                      | level | level| key     | 

    ---------------------------------------------------------------- 

    | 1  | A-B1  | Wages                | 0     | 0    |         | 

    | 120  | A-B2  | Salaries             | 0     | 0    |         | 



 

 

    | 190  |       | Calculation base     | 1   | 120   |         | 

    | 2  | A-Z1  | Vacation bonus       | 190   | 0    | E11     | 

    | 220  | A-Z2  | Other bonus          | 190   | 0    | E12     | 

    | 390  |       | Surcharges           | 200   | 380  |         | 

    | 400  |       | Total personnel costs| 0     | 0    |         | 

    ---------------------------------------------------------------- 

This costing sheet specifies that the vacation bonus and other bonus is calculated using the calculation 

base (level 190). 

The following surcharges to wages and salaries are made in this example: 

Vacation bonus for all employees:  % 

Other bonus 

for all employees: 5 % 

for employees in assembly: 7 % 

(cost centers 43 and 4320) 

A surcharge condition is defined for each cost element whose imputed costs are calculated:     -----

------------------------------------------------------ 

    |  Surcharge condition      | S type   | S rate| Acc.seq. | 

    ------------------------------------------------------- --- 

    |  A-Z1 Vacation bonus      | 1 (Act)  | %   | ZF01     | 

    |                           | 2 ( Plan) | %   |          | 

    |  A-Z2 Other bonus         | 1 (Act)  |  5%   | ZF11     | 

    |                           | 2 ( Plan) |  5%   |          | 

    |       CCtr  43      "E" | 1 (Act)  |  7%   |          | 

    |                       "E" | 2 (Plan) |  7%   |          | 

    |        CCtr 4320      "E" | 1 (Act)  |  7%   |          | 

    |                       "E" | 2 (Plan) |  7%   |          | 

    ----------------------------------------------------------- 

The access sequence determines which surcharge is charged to which cost center. 

For surcharge conditions with access sequence ZF01 the system checks if a surcharge rate exists for the 

controlling area and the surcharge type (1=actual and 2=plan). In this example this is the case for 

condition A-Z1. 

The access sequence ZF11 is a two-level access sequence: 

Level 1 

In Access No.  the system checks if surcharge rates for certain cost centers are maintained for the 

surcharge type in the current controlling area. The system finds a surcharge of 7% for the cost 

centers 43 and 4320. The exclusive indicator "E" is set for Access No. , so the system does not 

look for further surcharge rates for these cost centers. 

Level 2 

The system cannot find any surcharges for the remaining cost centers in Access No.  and so looks in 

Access No. 20 for surcharges of the surcharge type for the controlling area. 

The system finds a surcharge of 5% in both plan and actual which applies to all employees. 



 

 

The example for imputed cost calculation is set up in client 000, controlling area 0001, with transaction 

Display Cost Center Imputed Cost Calculation. 

Requirements 

To change an existing overhead structure, you need authorization for changing structures in all 

controlling areas using this structure. 

To create a new overhead structure, you need authorization for creating structures for the controlling area 

to which you want to assign the structure. 

Standard settings 

The standard system includes overhead structure SAP000. 

Activities 

Create an overhead structure or change an existing one. 

To create a new overhead structure, choose "Create". 

Enter the key and name and choose "Save". 

Go to the detail screen of your overhead structure. 

Specify a separate row number for each calculation base. 

Enter a key for the calculation base. 

If you specify a calculation base that does not exist yet, the SAP system will propose creating it 

automatically. 

Maintain the overhead. 

Specify a separate row number for each overhead key. 

Determine on which calculation bases the overhead will be calculated. If the overhead key does not 

exist, you can have the SAP system create it automatically. Then enter the dependency with 

which the overhead rates are to be determined. 

Maintain the credit key for every row with an overhead key. You can have the SAP system create 

this as well, if it does not exist yet. 

Assign the overhead structure to a controlling area. 

Note on transport 

To transport accrual calculation data, a separate function is available in Customizing under Controlling -

> General Controlling. 

Further notes 

Business Aspects of Accrual Calculation 

Business expenses are often allocated differently in Financial Accounting than in Cost Accounting. 

If the expense is incurred for the whole fiscal year, you must allocate it in Cost Accounting to reflect the 

relevant periods and origins. This allocation lets you avoid cost fluctuations within Cost Accounting. 

We refer to the uniform distribution of a one-off expense as "accrual calculation". You can use accrual 

calculation to take into account anticipated costs. 



 

 

For more information on accrual calculation, see the SAP Library under AC - Financials -> CO - 

Controlling -> Cost Center Accounting -> Period-End Closing -> Accrual Calculations. 

Utilities for Maintenance of Accrual Calculation 

Access to accrual calculation maintenance is made through a tree structure in which you will find an 

access screen with a list of all available overhead structures and their uses in the different controlling 

areas. You can create menu-controlled alternative views of these lists, such as a controlling-area-related 

display. The list steps for the overviews can be expanded or contracted interactively. 

A number of utilities, briefly explained below, are available for the maintenance for calculating accrual. 

Assignments of overhead structures 

If you select an overhead structure from the list and choose Allocations -> Display assignments -> 

To overhead structure, you receive an overview of the controlling areas, posting periods, and 

versions the structure is assigned to. 

Assignments to the controlling area 

The function To controlling area likewise displays in which controlling areas the structure 

appears. 

Assignments of unused structures 

Choose Assignments -> Structures not used for an overview of the structures not assigned to 

controlling areas. You can choose a structure from the list to make an assignment. 

Delete overhead structure 

Choose Overhead structure -> Delete structure to delete existing structures and/or assignments 

to the controlling area. 

When selecting this function, you receive a selection list and can determine which data is to be 

deleted. 

Change name 

Choose Edit -> Change name to change the structure name. The structure's key ( for example, 

SAP000) cannot be changed. 

To change the key, you must copy the structure to a new name and then delete the origin structure. 

These functions are located under Overhead structure. 

Set controlling area 

If you make controlling area-dependent settings, the SAP system requests that you choose a 

controlling area. For subsequent data maintenance in other controlling areas, you must choose 

Extra -> Set controlling area. 

Assignments to controlling area 

To assign overhead structures to the "set" controlling area, choose Allocations -> controlling area 

depending on posting periods. 

Actual postings 

For actual postings, assign exactly one overhead structure to the controlling area. 

Plan postings 

For plan accrual, assign the overhead structure of the version. 

Note that you cannot assign the structures to special periods. The system uses the structure of the 

last posting period for accrual calculation in special periods. 

Environment data 

Choose Environment data to branch to other processes and the maintenance of further object 

components: 

Calculation base 



 

 

Overhead rates 

Credit 

Target=actual credit 

The SAP system branches each time to an overview screen where you can change or delete the 

available keys, create new keys, and store controlling area-specific definitions. Alternatively, you 

can directly select the key for the base, the overhead, and the credit in the detail screen of the 

overhead structure to allocate values for the set controlling area. 

 Develop Enhancements for Percentage Method 

The following SAP enhancement is available if you are using the percentage method during accrual 

calculation: 

COOM 0002   User Exits for cost center accrual calculation 

This User Exit lets you transfer the following to overhead calculation: 

Values and quantities of a calculation base 

Percentage rates or amounts per unit of measure for an overhead rate 

A credit cost element and a credit cost center or a credit order This enhancement contains the 

following enhancement components: 

EXIT_SAPLKASC_011 

Calculation base 

EXIT_SAPLKASC_012 

Overhead base 

EXIT_SAPLKASC_013 

Credit 

You can find examples in the documentation of the relevant enhancement components. 

Activities 

Create an enhancement 

You can either create a new project or use an existing one. 

Activate the project 

The enhancement only works once you have activated it. 

Further notes 

Unlike modifications, enhancements are suitable for release, as they are not part of the original SAP 

software, but are in the user-defined name space. 

For more information on general procedures for creating enhancements, see the enhancement transaction 

under "Help -> Application help". 

For documentation on enhancements, see the enhancement transaction under "SAP Documentation". 



 

 

 Overhead 

This section tells you how to define all the parameters which determine the calculation of overhead rates 

for cost centers (including activity types), business processes, orders, projects, products and such like. 

Overhead rates are used to pass on costs to cost centers that do not directly reference the activity used. 

Thus you can, for example, distribute the costs from a warehouse cost center to orders for which material 

was taken from the relevant warehouse. 

Overhead costing differs from internal activity allocation in that you cannot express cost center output in 

quantities. Instead, the costs for the cost center are passed on via overhead rates to the cost centers 

(including activity types), orders, projects products, and so on. 

The tracing factor for the overhead costing can be either the amount of particular direct costs (such as 

direct material costs for a production order) or a total of direct costs and overhead cost of goods 

manufactured. 

You can also calculate percentage or quantity-based overhead rates, which lead to an actual credit being 

posted to a cost center and a debit to the order, project etc. 

You can use this function to calculate both plan and actual overhead, rates, and overhead rates for 

commitments (business processes do not use commitments). 

Plan overhead rates are determined as part of cost center planning, business process planning, order 

planning, preliminary costing, project planning, product costing or unit costing. 

Actual overhead rates and commitment overhead rates are calculated as part of period-end closing based 

on the actual costs incurred or the commitments set up. 

The parameters for overhead costing are summarized in a costing sheet. Overhead costing is only carried 

out for objects, for which a costing sheet is maintained. (See IMG activity Define Costing Sheet) 

For cost centers, you enter the costing sheet in the master data of the cost center. 

For business processes, you enter the costing sheet in the master data of the business processes. 

For internal orders and production orders without quantity structures, the costing sheet can be referenced 

from a model order. 

For production orders, process orders, product cost collectors, maintenance orders, maintenance orders 

and service orders, you default the costing sheet using a valuation variant. 

For projects, you enter the costing sheet in the project profile. 

For products, you select the costing sheet using the valuation variant. 

For Cost object-ID numbers you default the costing sheet using the cost object profile. 

For sales document items, you default it using the requirements class. 

Standard Settings 

The standard SAP system contains various costing sheets, which you can use as reference models for 

defining your own costing sheets. 

To work with these costing sheets, you need to: 

Ensure that all the relevant cost elements are in the calculation bases 

Check the conditions for overhead calculation 

Include the cost centers or overhead cost orders for your company in the credit keys 



 

 

Ensure that the costing sheet is defaulted in master data maintenance 

If the preconfigured calculation bases, overhead rates and credits are not enough for your requirements, 

you can create new ones or change the existing ones. 

The SAP standard system contains the following costing sheets: 

A00000 Standard 

You can use this costing sheet to determine material, production, administration and sales overhead. 

The conditions in the sheet are controlling area-dependent. In this sheet, you can determine plan, 

actual and commitment overhead. 

A00001 Standard 1/overhead key 

You can use this costing sheet to determine material, production, administration and sales overhead. 

The conditions for the overhead determination are dependent on the overhead keys you enter in the 

orders, projects and so on. This means that you can create separate keys for each project or for 

particular products or orders. You can determine plan or actual overhead. 

A00002 Standard 2 /Plant 

You can use this costing sheet to determine material, production, administration and sales 

overhead. The conditions in the sheet depend on the plant. You can determine plan or actual 

overhead and can use this sheet as the base for entering different overhead conditions for each 

plant in your business. 

A00003 Standard 3/Company code 

You can use this costing sheet to determine material, production, administration and sales overhead. 

The conditions in the sheet depend on the company code. You can determine plan or actual 

overhead and can use this sheet as the base for entering different overhead conditions for each 

company code in your business. 

A00004 Standard 4/Business area 

You can use this costing sheet to determine material, production, administration and sales overhead. 

The conditions in the sheet depend on the business area. You can determine plan or actual overhead 

and can use this sheet as the base for entering different overhead conditions for each business area 

in your business. 

A00005 Standard 5/Order type 

You can use this costing sheet to determine material, production, administration and sales 

overhead. The conditions in the sheet depend on the order type. You can determine plan or actual 

overhead and can use this sheet as the base for calculating overhead dependent on the purpose of 

the order (capital investment measure, production order, service order). 

A00006 Standard 6/Order category 

You can use this costing sheet to determine material, production, administration and sales overhead. 

The conditions in the sheet depend on the order category. You can determine plan or actual 

overhead and can use this sheet as the base for calculating overhead in orders, to make overhead 

conditions dependent on the technical character of the order ( PP order, PM order etc.). 

PP-PC1 PP-PC Standard 

You can use this costing sheet to determine material and production overhead. This sheet is usually 

used to determine the production costs for a product. The conditions in the sheet depend on the 

controlling area. You can determine plan, actual and commitment overhead. 



 

 

PP-PC2 PP-PC Overheads on cost of goods manufactured 

You can use this costing sheet to determine material, production, administration and sales 

overhead. This sheet is usually used to determine the cost of goods sold for a product. The 

conditions in the sheet depend on the controlling area. You can determine plan, actual and 

commitment overhead. 

 Define Overhead Cost Elements 

To allocate overhead to cost centers (including activity types), business processes, orders, projects or 

products, you need to define overhead cost elements. The SAP system then posts the overheads within 

these overhead cost elements. 

In this IMG activity, you create secondary cost elements for overhead. 

Activities 

Create secondary cost elements of type 41 ( overhead ). 

Note on transport 

In Customizing, under Controlling -> General Controlling, there is a separate function for cost element 

Transport. 

 Define Costing Sheets 
In this IMG activity you define a costing sheet. 

The costing sheet integrates all elements of overhead costing. It consists of the following rows that are 

processed during the calculation: 

Base rows 

Base rows contain the calculation base of the overhead costing: the cost elements and origins to 

which overhead is to be applied. 

You can take the calculation bases directly from the costing sheet and then maintain them as 

necessary, or define them separately in the IMG activity Define Calculation Base. 

Overhead rows 

You define the overhead rows by assigning an overhead rate to them. An overhead row references 

one or more base rows or totals rows. The amount contained in these rows, along with the 

percentage rate calculated using the overhead rates, determines the overhead amount. 

You can take the overhead rates directly from the costing sheet and then maintain them as 

necessary, or define them separately in the IMG activities Define Percentage Overhead Rate or 

Define Quantity-Based Overhead Rate. 

The overhead row contains a credit key that defines which object (cost center or order) is credited 

during the overhead calculation. 

You can either take the credit keys directly from the costing sheet and then maintain them as 

necessary, or define them separately in the Define Credit activity. 

- Totals Rows 

No calculation bases or overhead rates are assigned to the totals rows. They are used only to form 

subtotals or end totals. 



 

 

Prerequisite 

You should already have read the "Define overhead costs" section. 

Activities 

Check whether the delivered costing sheets meet your requirements. 

If necessary, change the standard costing sheets to meet your requirements, or define your own 

sheets. 

If you want to create a costing sheet, you have the following possibilities in the "Change Costing Sheet: 

Overview" screen: 

If you want to copy an existing sheet, select the sheet you want to copy and choose "Copy as...". 

If you want to create a new sheet, choose  "New entries". 

Enter a sheet abbreviation and a name, and choose "Enter". The new costing sheet appears in the 

overview. 

To define the sheet, proceed as follows: 

Select the sheet you want and choose "Costing sheet rows". 

Define a base row 

Enter a row number and a calculation base. 

You can either enter an existing calculation base or create a new one. If you enter a 

new calculation base, choose "Base" in the "Navigation" group box. 

Create a new Calculation base. 

Enter a four-character key in the "Base" field in the "Costing Sheet: Change Rows: 

Overview" screen and select the row. 

Choose "Base" in the "Navigation" group box and create your new base. 

You can specify individual cost elements or cost element intervals as your calculation 

base. If you have subdivided your cost elements into origins, you can also specify 

individual origins or origin intervals. Origins are subdivisions of cost elements and 

permit you to, for example, conduct separate analyses of materials belonging to the 

same cost element. 

Save your entries. 

You can define or change individual cost elements independently of the costing sheets 

(see "Define calculation base"). 

Define overhead row 

To define an overhead row, proceed as follows: 

Enter a row number and an overhead key. 

Enter "from" and "to" rows to determine which rows you apply overhead to. See the F1 

help on how to determine row totaling. 

Enter a credit key. 

You can either enter existing overheads and credits, or define new ones. If you want to 

define a new overhead, choose "Overhead" in the "Navigation" group box. 

If you want to define a new credit, choose "Credit" in the "Navigation" group box. 



 

 

Define an Overhead Rate 

Enter a four-character key in the "Overhead" field in the "Costing Sheet: Change Rows: 

Overview" screen and select a row. 

Choose "Overhead" in the "Navigation" group box and create your new overhead key. 

Assign a dependency to your overhead and choose "Enter". 

Specify the individual overhead rates. 

Each record comprises a validity period, the controlling area, the overhead type (actual, plan, 

commitment), a percentage, and a number of condition fields derived from the appropriate 

condition tables via the chosen dependency. 

Save your overhead. 

You can also define or change individual overhead rates, independently of the costing sheet 

(see "Define percentage/quantity-based overhead rates"). 

Define a Credit 

Enter a three-character key for your credit in the "Credit" field in the "Costing Sheet: 

Change Rows: Overview" screen and select a row. 

Choose "Credit" in the "Navigation" group box and create your new credit. You have 

the option of entering credit records with validity periods, overhead cost elements, 

origins, and credit object. 

The overhead cost element must have cost element type "41". 

For your credit object, you can enter either a cost center or an order or a business process. 

You cannot make several entries at once. 

Save your entries. 

You can also define or change individual credits independently of the costing sheet (see 

section "Define credits"). 

Define a Totals row 

If you do not assign a calculation base or an overhead to a row, it is defined as a totals row. 

Totaling is controlled via the "from" and "to" row fields. See the F1 help on how to control 

totaling. 

Additional information 

Choose "Sheet -> List" to display a detailed breakdown of your costing sheet. The function breaks 

down each row and shows all the entries you have made for the relevant costing sheet. 

Choose "Edit -> Check" to check whether your sheet is fully defined and free of errors. 

Dependencies 

Your costing sheet is linked with the relevant condition tables via a dependency (= access sequence). 

This makes it possible for you to look for valid overhead records. 

A dependency consists of one or more condition tables and, by assigning condition tables, determines the 

order in which overhead records are read. 

Dependency example 

You want to make your overhead percentage dependent on the overhead key in the order and order type. 



 

 

You can use standard condition table 14 for the overhead key and table 36 for the order types for this 

purpose. 

If you put table 14 in the first position and table 36 in the second, the system first looks for a percentage 

which is dependent on the overhead key, and then for one which is dependent on the order type. 

Use "Exclusive indicator" to control whether the SAP System continues to search for valid records after 

successfully accessing the first one. 

If you do not set this indicator, the system searches for all valid percentages and adds them together. 

Standard settings 

The standard SAP System contains examples of assignments of dependencies for overhead. 

Activities 

To use the dependencies supplied, proceed as follows: 

Do not change table assignments. 

Change the dependency names to meet your requirements. 

To define new dependencies, proceed as follows: 

Choose "Extras -> Dependency". 

The SAP System displays an overview of all the existing dependencies. 

Enter an abbreviation and a name for your new dependency. 

Choose "Enter". 

The new dependency is incorporated in the list. 

Choose "Goto -> Detail screen" to access the detail screen. 

Assign condition tables as required. 

Ensure that you assign the tables in the sequence "from specific criteria to general criteria". 

Return to the overview screen. 

Activate your dependency. 

You can create a dependency without activating it. However, if you use an unactivated 

dependency in an overhead, the SAP System will not be able to find any valid records for this 

dependency. 

Condition tables 

A condition table defines the structure of an overhead record. The field contained in a table lays down the 

conditions according to which overhead percentage rates are calculated. 

You define a condition table by selecting the fields you want in the order you want from the stock of 

permitted fields. 

An overhead line can hold a maximum of three fields. If you select more than three fields, the SAP 

System automatically puts the last three selected into the overhead line. The remaining fields appear in 

the specified order in the screen header. 

Example 



 

 

You want to use the fields "Company code", "Business area", and "Plant" as condition for calculating 

your overheads. 

To do this, you must create a new condition table and select the three fields you want from the list of 

permitted fields. 

Standard settings 

The standard SAP System contains examples of dependency assignments for condition tables. They are 

in the range up to number 500 and cannot be changed. 

Recommendation 

For performance reasons, you should preserve the following field sequence: 

Controlling area 

This only applies if you have more than one controlling area. 

Overhead type 

This only applies if your actual and plan percentages might be different. 

Group-specific condition fields 

Choose the sequence of these fields so that the fields filled most frequently appear first. 

Activities 

To create new condition tables, proceed as follows: 

Choose "Extras -> Condition table". 

Enter a number between 501 and 999. 

Choose "Condition -> Create". 

Enter a name for your condition table. 

Choose the fields you want in the sequence you want. 

Generate your condition table. 

NOTE 

If you want to maintain credits for all business areas, proceed as follows: 

Choose Maintain accrual calculation. 

Select the overhead structure 

Choose Structure 

Select a row in which a credit is displayed 

Choose Goto -> Credit. 

Enter the required controlling area. 

 Costing Sheet: Components 

In this section you can edit the details for costing sheet maintenance separately. These are: 

Calculation bases 

Percentage overhead rates 



 

 

Quantity-based overhead rates 

Credits 

In contrast to the costing sheet, you can enter several of these detail data types at one time. You can then 

include the newly entered records in any costing sheet at a later date. 

Additionally, there is an enhancement to working with overhead rates. 

 Define Calculation Bases Referring to Cost Element and Origin 

In this IMG activity you define a calculation base for overhead costing. The calculation base determines 

to which cost elements overhead is applied together. 

For each controlling area, you assign individual cost elements or cost element intervals, or origins or 

origin intervals, to the calculation bases. 

For production overhead costs, you can differentiate between fixed and variable costs for the calculation 

base. In this way, you can charge the fixed and variable portions of the activity price differently for 

activity types. 

For  material overhead costs, you can differentiate the materials used. If you want to define different 

material overhead costs for particular raw materials, you can define origin groups and define your 

own calculation bases for particular origin groups. 

Requirements 

You have defined the origin groups: 

Define origin groups 

Note 

If you do not specify any origins for a cost element interval, the SAP System considers all the origins in 

the relevant interval. 

Activities 

To define a calculation base, proceed as follows: 

Choose "New entries" to create a new calculation base. 

Enter any four-character key you want, and a name for the new calculation base. 

Select a row and choose "Detail" 

Enter the individual cost elements or cost element groups. 

If you have subdivided your cost elements into origins, you can also specify individual origins or 

origin intervals. 

Save your entries. 



 

 

 Define Calculation Bases Referring to Cost Center and 

Activity Type 
Use 

This step shows how you define a calculation base for overhead calculation. The calculation base defines 

the cost centers and activity types to which overheads are to be applied. 

For each controlling area you assign the calculation base of individual cost centers or cost center ranges 

or individual activity types  or activity type ranges. 

- For production overheads you can differentiate the calculation base by fixed and variable costs. 

This enables you to apply different overheads to the fixed and variable shares of the activity type 

tarifs. 

Note 

If you do not specify activity types for a cost center range, all activity types are included from the 

affected range. 

Activities 

You define a calculation base as follows: 

Choose "New Entries" to create a new calculation base. 

Enter a four figure identifier of your choice and a description for the new calculation base. 

Select the line and choose "Detail". 

Enter the individual cost centers or cost center range. 

If you want to break down cost centers in activity types, you can also specify individual activity 

types or activity type ranges. If you enter an upper limit for an activity type range, all activity types 

up to this limit are selected. 

Save your entries. 

 Define Percentage Overhead Rates 

An overhead rate specifies the conditions under which overhead is applied to an object. 

In this IMG activity you define percentage overhead rates, for example, 25% in controlling 

area 0001. You can also define quantity-based overhead rates ($0 per piece). 

Percentage overhead rates are recommended if, for example, you want to calculate quantity-independent 

overhead on costs for particular cost elements in a cost center. Quantity-based overhead rates , on the 

other hand, are calculated for each unit of measure of a cost element. 

You can combine the two by assigning a % overhead rate, for example, to a cost element and an 

additional rate pf $3 per hour. 

Overhead rates are limited in duration and can be adapted to meet your requirements as part of current 

settings. 

You must assign a Dependency to each overhead rate. The content of particular order fields for a cost 

center, a business process or an order can be moved back as dependencies. The system prescribes which 



 

 

fields you can use.  For example: if you enter "plant" as a condition, a defined overhead rate is calculated 

for each plant. 

Using this condition, the system can access the relevant condition fields in the appropriate 

Condition Tables.  All the condition tables delivered in the standard contain the fields "Controlling area", 

"Overhead type" and at least one field from the cost center master data, business process master data or 

order master data (see below). 

Plan, actual, and commitment overhead can be calculated. The overhead type distinguishes between the 

three. Business processes do not use commitments. 

Standard settings 

The SAP standard system contains overhead rates with the following dependencies: 

Controlling area 

Company code 

Order type 

Plant 

Order type 

Order category 

Plan version 

Overhead type 

Overhead key 

To define order-dependent overhead rates, you create an overhead key and enter this key in the order 

master data. 

To define product-dependent overhead rates, create an overhead key and link this key to an overhead 

group. This group is then entered in the costing view of the material master record. 

Activities 

To define a percentage overhead rate, proceed as follows: 

Choose "Create" to create a new overhead rate. 

Enter a four-character identification code and a description for the new overhead rate and assign a 

condition to it. 

Select the row and choose "Detail" 

Specify the individual overhead rates. 

Each record consists of a validity period, a percentage rate and several condition fields, which are 

taken from the the condition tables. 

Save your overhead rate. 

 Define Quantity-Based Overhead Rates 

An overhead rate determines the conditions under which overhead is allocated to an object, and how 

much overhead is allocated. 



 

 

In this step you define quantity-based overhead rates, such as $0 per piece. You can also define 

percentage-based rates (such as 25% in controlling area 0001) in the previous step. 

Percentage overhead rates are recommended if you want to allocate overhead to particular cost elements 

for a cost center independent of the quantity. In contrast, a quantity-based rate allocates overhead per unit 

of measure of a cost element. You can combine percentage and quantity-based rates. For example, you 

could define a rate of % on a cost element plus an additional $300 for every 0 hours. 

Overhead rates have a time-based validity. You can adapt them to your requirements using the current 

settings. 

You need to assign a dependency to each overhead rate. You can use the contents of particular fields of 

an order, cost center, or business process as dependencies. The fields you can use are predefined by the 

system. For example, you can apply a defined overhead rate for each plant by specifying a plant 

dependency. The fields you choose to define your dependency are saved in a condition table (price 

table). All condition tables in the system contain the fields "controlling area" and "overhead type", plus 

a maximum of one additional field (see below) for the order master, the cost center master, or the 

business process master. 

You can apply overhead rates in plan data, actual data, and commitments. The overhead type 

differentiates accordingly between plan, actual, and commitment overhead. Business processes do not 

use commitments. 

Standard settings 

The standard SAP system provides overhead rates with the following dependencies: 

Controlling area 

Company code 

Business area 

Plant 

Order type 

Order category 

Plan version - Profit center 

Responsible cost center 

Overhead type 

Overhead key 

To define order-dependent overhead rates, create an overhead key and enter it in the order master data. 

To define product-dependent overhead rates, create an overhead key and link it to an overhead group. 

Then enter the overhead group in the costing view of the material master record. 

Activities 

To define a quantity-based overhead rate: 

Choose New entries. 

Enter any four-character identification code and a description for the new overhead rate, and assign a 

dependency to it. 

Select the line and choose "Detail". 



 

 

Specify the individual overhead rates. 

Each record consists of a validity period, several condition fields taken from the price tables, and an 

amount to be applied to the base costs as overhead. 

Save your overhead rate. 

Additional Information 

To apply quantity-based overhead rates, the units of measure must be updated in Controlling ( CO ). 

You have two options: 

Set the Record Quantity indicator in the cost element master data. 

If you want to assign different materials to an object (order, cost center, business process, WBS element, 

etc.) under the same cost element but with different units of measure, set the Material Origin  

indicator in the costing view of the material's master record. In addition, materials with different 

units of measure must have different entries in the "Origin Group" field. 

With quantity-based overhead rates, the system only includes input materials and activities with units of 

measure that are updated in CO. For materials, these are the base units of measure. 

Conversions between units of measure are based on the rules stored in the global settings in Customizing 

(step Check Units of Measurement). Quantity conversions (such as those that you define in the material 

master) are disregarded. 

For example, the system applies overhead in $ per kilogram to input materials with the base unit of 

measure "G" but not to materials with the unit "pallet". 

 Define Credits 

Cost allocation is part of the process of determining overhead rates. If this leads to an object being 

debited with actual costs, another object in Cost Accounting must be credited at the same time. This can 

be either a cost center, order or a business process. This type of posting is recorded under a secondary 

cost element of cost element category 41 (overhead rates) in the SAP System. 

When you define credits, you also specify which credit object is to be credited under which cost element 

when overhead is to be applied to an object in the actual. 

You can also define what percentage of the overhead is to be allocated as fixed costs. 

Activities 

To define a credit, proceed as follows: 

Choose New entries to create a new credit. 

Enter a three-character key and a name for the new credit. 

Select the row and choose "Detail". 

You have the option of entering credit definitions that contain the following: 

A validity period 

An overhead cost element 

The overhead cost element must have cost element category 41. 



 

 

An origin group 

You must specify an origin group if you want to see both the overhead cost element and the 

origin of the overhead in cost accounting 

The percentage of the overhead to be allocated as fixed costs. 

"*": The fixed portion of the costs is determined in the same way as the portion of fixed costs 

for the debit object. 

A credit object 

You can enter either a cost center or an order, or a business process as a credit object, but not 

more than one at the same time. 

Save your entries. 

NOTE 

If you want to maintain credits for all business areas, proceed as follows: 

Choose Maintain accrual calculation. 

Select the overhead structure 

Choose Structure 

Select a row in which a credit is displayed 

Choose Goto -> Credit. 

Enter the required controlling area. 

 Extras: Dependencies/Condition Tables 

In this section you maintain dependencies and condition tables. You need dependencies and condition 

tables to specify under which conditions overheay should be assigned. 

The SAP standard delivery includes dependencies and condition tables which cover most requirements. 

If you have extra requirements, you can include further entries. 

 Define Dependencies 

In this IMG activity, you maintain dependencies. You specify the conditions for overhead calculation, 

and can use the contents of certain fields in an order, cost center, or a business process. The fields that 

can be used are provided by the system. For example, you can use a dependency from the plant to 

determine that a defined overhead is calculated per plant. 

To define a particular dependency, select from the usable fields those fields that your overhead is 

dependent on. The fields you select are saved in a condition table in the system. 

A dependency consists of one or more condition tables. To complete the definition of the dependency, 

specify the condition tables in the order (access order) in which they are to be read. Enter the 

dependencies defined in this way in your costing sheet. The system determines the valid overhead rates 

during runtime. 

Example 



 

 

You want to make your overhead percentage dependent on the overhead key in the order, and on the 

order type. 

To do this, you can use standard condition table no. "14" for the overhead key, and no. "36" for the order 

types. 

If you have table no. "14" in first place, and table no. "36" in second place, then the system starts by 

looking for a percentage during overhead calculation. This percentage is dependent on the order type. 

Standard settings 

The SAP standard system contains examples of assignments of dependencies to overheads. 

Activities 

To use the dependencies provided by SAP, proceed as follows: 

Do not change the table assignments. 

Change the names of the dependencies according to your requirements. 

If you require new dependencies with new condition tables, you need to define one or more of your own 

condition tables , and as described below, corresponding new dependencies. 

To define new dependencies, proceed as follows: 

The system displays an overview of all existing dependencies (access sequences). 

Choose "New entries" to create a new dependency. 

Enter an identifier and a name for your dependency. 

Choose "Accesses" 

Specify a sequence number, and the condition table whose field contents are to be uesd for 

calculating overhead. 

If more condition tables are to be checked, specify these with correspondingly higher 

sequence numbers in more rows. This type of condition table listing is an access sequence. 

Ensure that the tables are assigned in order, ranging from specific to general criteria. You can 

use the exclusive indicator to ensure that the system stops its search for more valid records 

once it has successfully accessed a table. If you do not set this indicator, the system includes 

all specified condition tables. 

Select each row with a condition table, and choose "Fields" to specify fields whose contents are to 

be used for overhead calculation. 

Save your entries. 

In the access sequence overview, choose "Utilities" to generate your dependency. You can create a 

dependency without generating it. However, if you use a non-generated dependency in an 

overhead, the system is not able to determine any valid records for this overhead. 

Further notes 

If you process dependencies, change a cross-client table. All changes that you make apply to all clients in 

your SAP system. 



 

 

 Define Condition Tables 

In this IMG activity you maintain condition tables. A condition table defines the construction of an 

overhead rate. In the condition table, you enter the fields on which you want to make the overhead rates 

dependent. 

You define a condition table by selecting the fields you require in a specified sequence from the list of 

permitted fields. This list is preset. You can then enter the condition tables you have thus defined in a 

Dependency. 

Example 

You want to use the fields "Company code", "Business area" and "Plant" as conditions for calculation of 

your overhead. 

To do this, you must create a new condition table and select the three fields specified from "Allowed 

fields". 

Standard settings 

In the SAP standard delivery, there are examples of Condition Tables. They are in the number range 001 

to 500 and cannot be changed. 

Activities 

If you want to create new condition tables, proceed as follows: 

To create a new condition table, choose "Condition -> Create". 

Enter a number between "501" and "999". 

Confirm the creation of a condition table for internal orders with a validity period and table type 

"T". 

Enter a name for your condition table. 

Select the desired fields in the desired sequence. 

Generate your condition table. 

Further notes 

To improve system performance, you should keep to the following field sequence: 

Controlling area 

This applies only when you have more than one controlling area. 

Overhead type 

This only applies when your actual percentage rates and your plan percentage rates are different. 

Business-organizaion specific condition fields 

Select the sequence for these fields so that the fields filled most frequently appear first. 



 

 

 Develop Enhancements for Overhead Rates 

The following SAP enhancement is now available for overhead rates: 

COOM0001  User Exits for Overhead Rates 

You can use the user exists to transfer the following to overhead costing: 

Values and quantities for a calculation base 

Percentages or amounts per unit of measure for an overhead rate 

A credit cost element and a credit cost center or credit order This enhancement contains the 

following components: 

EXIT_SAPLKASC_001 

Calculation base 

EXIT_SAPLKASC_002 

Overhead rate 

EXIT_SAPLKASC_003 

Credit 

Look at the documentation for the individual components for examples of how to use them. 

Activities 

Create an enhancement 

You can either create a new project or use an existing one. 

Activate the project 

The enhancement only works once you have activated it. 

Further notes 

Unlike modifications, enhancements are suitable for release, as they are not part of the original SAP 

software, but are in the user-defined name space. 

For more information on general procedures for creating enhancements, see the enhancement transaction 

under "Help -> Application help". 

For documentation on enhancements, see the enhancement transaction under "SAP Documentation". 

 Define Selection Variants for Overhead Rates 

A selection variant contains the fields that are to be evaluated in your selection report. These fields 

determine the content and structure of a selection variant. 

The following selection reports are available: 

For cost elements     RKKOASEL 

For cost centers     RKKSTSEL 

For activity types    RKLSTSEL 

For business processes RKPRZSEL 



 

 

For internal orders RKOSEL00 

For projects     RKPSEL00 

You enter the selection values in the corresponding fields, and can overwrite these in the application. 

You can hide the fields that you do not require. 

When you process "variant attributes", you can specify variables for selection variant fields, and so on. 

Example 

If you wish to select your objects by time, then define a selection variant, which only contains master 

data fields for times. 

Standard settings 

The following selection variants are defined for internal orders: 

SAP_01 - SAP_02 - SAP_03 

Activities 

If you wish to create your own selection variants, proceed as follows: 

Enter a name for your variant in the "ABAP: Initial screen for variants" 

Confirm the "Values" default setting in the "Subobjects" group box, and choose "Create". In the "Variant 

maintenance: Report <your selection report>" screen, the system displays the selection fields for the 

corresponding master data. 

Enter the values or variables in the fields that you wish the system to use for selection. 

Choose Continue. 

This takes you to the Attribute maintenance screen for the selection variants. 

You can assign the following field attributes: 

Protected 

The value that you specified for the field can no longer be overwritten in the application. 

Invisible 

The system hides this field from the selection variant. 

Selection variable 

You can define a variable for a field, such as a user-defined selection rule ( compare with the 

"Define selection rule" section). The field is filled with the corresponding value during 

runtime. 

Enter a short text in the "Description" field. 

Save your entries. 

This variant is now available for the corresponding selection report. 

Transport notes 



 

 

You can transport selection variants manually by proceeding as follows: 

Choose "Utilities -> Transport request..." in the "ABAP: Variants - Initial screen" 

Enter the program name 

Enter the name of the variant to be transported 

  

 Activate Realtime Overhead Calculation 

Use 

Activate Realtime Overhead Calculation for controlling area. 

 Activate Overheads for Controlling Area and Business 

Transaction 

Use 

In this IMG activity you activate transaction-based calculation of overhead for certain business 

transactions. For more information, see SAP Library under SAP ERP Central Component -> Financials -

> Controlling (CO) -> Cost Center Accounting (CO-OM-CCA) -> Period-End Closing (CO-OM-CCA) -

> Overheads -> Transaction-Based Calculation of Overhead. 

Standard settings 

In the standard system, transaction-based calculation is not activated for any business transactions. 

Activities 

In the period when you first activate transaction-based calculation, if you have already posted business 

transactions for which you have activated transaction-based calculation, you must calculate the overhead 

for these transactions by starting transaction RTOHC_UPGRADE. 

 Activate Date From Time Sheet as Document Date for Confirmation 

Use 



 

 

In this IMG activity, you activate for each controlling area that the date from the time sheet is to be used 

as the document date for confirmation documents. 

Together with the settings for the valuation date and activation of transaction-based overhead, you can 

use this activation to be able to carry out the activity allocation and overhead calculation based on the 

document date instead of the posting date. 

Requirements 

So that the document date is used, you have to carry out not just the activation in this IMG activity, but 

also Determine and Assign the Settings for the Valuation Date . For the overhead calculation, it is also 

necessary that you have activated the Transaction-Based Overhead. 

Example 

In a closed period, an adjustment of the confirmation is made in the time sheet. By activating the date of 

the time sheet as document date, the adjustments can be made with the prices and overhead that were 

valid on the day for which the adjustment was made. Without this activation, the adjustment would be 

made with current prices and overhead in the current period. 

 Special Valuation Date Settings 

Use 

In this IMG activity, you decide for each controlling area whether the document date or a date 

determined using a BAdI is to be used as the valuation date for the activity allocation or the transaction-

based calculation of the overhead rate. If you do not opt for either of these for a controlling area, the 

standard system uses the posting date of the activity allocation and transaction-based overhead 

calculation. 

Dependent on the valuation date is, for example, the price used: the price valid on this date is the one 

used. Consequently, it is particularly important with corrections in periods already closed that a date 

other than the posting date is used as the valuation date, because only then the prices are used for the 

adjustment posting that were valid in the past. 

You can assign the valuation date selected here to the following business transactions: 

Manual cost allocation ( KAMV ) 

Actual activity allocation ( RKL ) 

Repost costs ( RKUI ) 

Repost revenue ( RKU 2) 



 

 

Requirements 

If you want to use the valuation date for the transaction-based calculation of overhead, you have to have 

the transaction-based calculation activated. 

To be able to use the document date as the valuation date for confirmations, you have to have activated 

the date of time sheet as document date for confirmations activated. 

 BAdI: Maintain Valuation Date 

Use 

Within Cost Accounting, configuration allows the use of special valuation date for certain business 

transactions, with an option that this date be filled by user exit. This enhancement supports filling the 

special valuation date during creation of CO documents, and controlling whether direct input of the 

special valuation date is permitted during manual entry of activity allocation documents. 

Requirements 

Configuration of view cluster TKSVD_VC. 

Activities 

Implementation of the BAdI method SET_VAL_DATE is mandatory to provide the value for the special 

valuation date. 

Implementation of the BAdI method ALLOW_MANUAL_INPUT is optional to allow users to modify 

the special valuation date during transaction entry. 

 Distribution 

In this section you make settings for actual distribution. 

 Specify Receiver Types for Distribution 

When making distributions you can specify which table fields are active and whether, in cycles, a single 

value, an interval, or a group can be entered for these fields. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 

If you change intervals with "From" values, the "To" values are deleted from the table. 

Example 



 

 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 

Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 



 

 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 

 Define Distribution 

In this activity, you define distributions in the form of cycles by specifying rules for the settlement of 

primary costs on a cost center. 

Recommendation 

Check whether distribution can be replaced here by periodic reposting or assessment in order to achieve 

better system performance. 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large 

distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that 

must be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 



 

 

--------------------------------------------------------

- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create a plan distribution cycle by proceeding as follows: 

Determine a name for the cycle. 

Determine a validity period for the cycle. 

Maintain the header data for the cycle by entering the following. 

Which currencies are to be used in the allocations 

Whether consumption is to be allocated or not 

Whether negative tracing factors are scaled or not 

Whether cycle processing is to be iterative 

In which version the allocation is to take place 

Define cycle segments in which you store the following information. 

Sender cost element to be distributed 

Criteria for cost distribution to the receiver 

Sender objects 

Receiver objects 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Distribution 

During distribution, the following information remains: 

Original primary cost element. 

Information on the sender cost center is noted in the receiver cost center or receiver order. 



 

 

Information on the receiver cost center or order is noted in the sender cost center. 

For more information, see the "SAP Library" under Financials -> CO Controlling -> Cost Center 

Accounting -> Period-End Closing -> Defining Periodic Repostings or Periodic Allocations. 

 Develop Authorization Enhancements for Distribution 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Assessment 

In this section you make settings for actual assessment. 

 Specify Receiver Types for Assessment 

When making assessments you can specify which table fields are active and whether, in cycles a single 

value, an interval, or a group can be entered for these fields. 



 

 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 

If you change intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 

Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 



 

 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 

 Create Assessment Cost Elements 

In assessment, the R/3 System converts the original cost elements cumulatively or in groups into 

assessment cost elements. The original cost elements are lost in this process. 

Assessment cost elements are secondary cost elements. 

Requirements 

- Complete the IMG activity Maintain Controlling Area, found in the General Controlling section of 

the IMG under Organizaton. 

Activities 

Create secondary cost elements of category 42 (assessment cost element). 

Note 

For more information, see Maintain Cost Element. 

 Define Allocation Structures 

If the assessment for each segment is not made with a pre-defined assessment cost element, you can 

assign the source cost elements to the desired assessment cost element in the allocation structure. During 

cycle definition, enter the allocation structure instead of an assessment cost element in the segment. 

An allocation structure for the assessment consists of at least one assignment, stating the assessment cost 

element to which the source element is assigned. The original cost elements will already have 

assignments in the source. 

Requirements 

To define the assessment cost elements required for the allocation structures, you must first complete the 

IMG activity "Create Assessment Cost Elements". 



 

 

Activities 

Creating an allocation structure. 

To create an allocation structure, proceed as follows: 

Choose "New Entries". 

Enter a name and text for the allocation structure. 

Save the allocation structure. 

Enter the assignments for each allocation structure. To make the assignments, proceed as follows: 

Select the allocation structure, and then choose "Assignments". 

Choose "New Entries". 

Enter a name and text for the assignment. 

Save the assignment. 

Specify the source for each assignment. 

To specify the source for an assignment, proceed as follows: 

Select the assignment, then choose "Source". 

Enter a cost element interval or a cost element group. 

Save the source. 

Enter the assessment cost element for each assignment. 

To specify an assessment cost element for an assignement, proceed as follows: 

Select the assignment, then choose "Assessment cost element". 

Enter the assessment cost element you require. 

Save your entries. 

Further notes 

For more information on the allocation structure, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Period-End Closing -> Periodic Allocations -> 
Assessment. 

 Maintain Assessment 

In the IMG activity "Define Assessment" you set rules in the form of cycles to allocate primary and 

secondary costs in the actual. 

Requirements 

You must already have completed the IMG activity Create Assessment Cost Elements. 

If you are using an allocation structure, you must have completed the IMG activity Define Allocation 

Structure. 

Recommendation 



 

 

When using assessment, distribution, and periodic reposting, note the following: 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large 

distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that 

must be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------

- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create an actual assessment cycle as follows: 

Enter a name for the cycle 

Enter a validity timeframe for the cycle 



 

 

Maintain the header data for the cycle by entering the following: 

In which currencies the costs should be allocated 

Whether the cycle is to be processed iteratively and/or cumulatively. 

Create segments for the cycle that contain the following information: 

The cost element to be assessed or the cost element of the sender allocation structure 

Criteria for the distribution of costs among the receivers 

Whether negative tracing factors are to be scaled 

Criteria for determining the sender values 

The sender objects and the receiver objects 

The selection criteria for the receiver tracing factors 

The selection criteria for the sender values 

Receiver weighting factors for receiver rule 1 (variable portions): 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Additonal information 

Notes for working with a delta version 

Please note the following during cycle definition: 

If you select a delta version, the following additional allocation characteristics are available for segment 

definition: 

Business processes and/or groups 

External value added 

Internal value added 

Type 

The receiver objects "order" and "WBS element" become invalid. 

For more information on defining an assessment, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Period-End Closing -> Periodic Allocations or Periodic 
Repostings. 

 Develop Authorization Enhancements for Assessment 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 



 

 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Activity Allocation 

In this section you make settings for activity allocations and for splitting. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Periodic Allocations. 

 Direct Activity Allocation 

In this section you make settings for direct activity allocation in the actual. 

 Indirect Activity Allocation 

In this section you define the settings for actual indirect activity allocation. 



 

 

 Determine Send/Recv Categories for Indirect Acty Allocation 

For indirect activity allocation  you can determine which table fields are active and whether, in cycles 

you can enter a single value, an interval, or a group for these fields. 

You make these settings per controlling area, and separately for plan and actual data respectively. 

Example 

You use indirect activity allocation for cost centers, but want to use only cost center groups as 

receivers. 

Remove the table field indicator "Cost Center" in the fields for individual value entry readiness 

and in the receiver area interval to ensure that you can only enter groups as cost center 

receivers during cycle definition. 

 Allocation Cat: Indirect Activity Allocation 

 Actual/Plan:  Actual 

Field Characteristics: 

Field:  Cost Center 

Active Indicator Entry-Ready   Entry-Ready   Entry-Ready 

+ Sender X  Indv. Valu X  Interval  X  Group 

+ Receiver  _  Indv. Valu _  Interval  X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an indirect activity allocation as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field 

attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 



 

 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport indirect activity allocation field attributes manually, choose Table view -> Transport. 

 Define Activity Types for Indirect Activity Allocation 

You use indirect activity allocation for those activity types for which activity quantities cannot easily be 

determined. 

It is important to distinguish between the following cases: 

Sender activities can be summarized 

The sender allocates activities to the receivers based on receiver tracing factors. 

Sender activities imposssible or difficult to determine The sender allocates these activities: 

Using receiver tracing factors and sender weighting factors 

Using specified fixed amounts 

Activities 

Create activity types of category 3 for sender activities which can be summarized. 

Create activity types of category 2 for sender activities which are impossible or difficult to determine 

Note 

For more information, see Create activity types. 

 Define Indirect Activity Allocation You determine rules for indirect activity 
allocation in the form of cycles. 

For cost centers with activities that cannot be measured or measured only with great difficulty, the 

activity quantities can be determined indirectly. 

In indirect activity allocation, the usage of sender activities (cost center/activity type) is determined via 

tracing factors from the viewpoint of the activity receivers. 

The tracing factors are defined as in assessment or distribution. 



 

 

Requirements 

You must maintain activity types for indirect allocation in actual and plan. 

The requirement for indirect activity allocation in actual and planning data is that all senders and all 

receivers of the cost object cost center/activity type are included in activity type planning for 

activity type category 3. 

You enter activity quantities for activity type category 3 ("Manual entry, automatic allocation") for 

planning data with activity type planning. 

Note: 

Planning activity quantities with the aid of activity type planning is only possible for activity 

type category 3. For activity type category 2 the SAP system automatically creates a cost 

center/activity type record. Sender activity quantities are indirectly determined from the 

receiver tracing factors and through fixed quantities. 

For actual data, a posted sender activity quantity can be created by entering non-allocatable activities. 

Note: 

Entering posted activity quantities for activity type category 3 is not possible, since the 

activity quantities are indirectly determined. 

The requirement for indirect activity allocation in actual and planning data for activity type category 2 is 

that a value NOT equal to zero is entered in the segment definition for the sender-specific weighting 

factors with the function Sender values. Only then will the corresponding record be included in 

the activity allocation. Examples for Indirect Activity Allocation 

Activity types of category 3, "Manual entry, indirect allocation" 

The cost center "Quality control" produces 00 hours of activity type "Test". Activities go to cost 

centers "Goods receipt" and "Finished products". The allocation is made on the basis of the tracing 

factor "Number of test items" (NI). For "Goods receipt" these are 

4000 items, for "Finished products" 6000. 

Price per activity unit for "Quality control" equals 50 USD/hr. The resulting costs of activity 

production equal USD 50,000. 

The receiver centers are debited according to the tracing factor  with the following costs: 

Goods receipt:     (50,000 X 4000 NI) / ,000 NI = $ 20,000 

Finished products: (50,000 X 6000 NI) / ,000 NI = $ 30,000 

- Activity types of category 2, "Indirect entry, indirect allocation" 

Activity determination for the sender takes place via receiver tracing factors and weighting factors 

defined for each sender. The sender rule here is usually "Indirectly determined quantities"; receiver 

rule can be any rule. 

Using the example above, the receiver tracing factors are: 

                           "Goods receipt"        4000 NI 

                           "Finished products"    6000 NI 

                            Total               ,000 NI 

The sender is credited with ,000 test items. This amount can be valuated with weighting factors 

defined per sender activity type. Weighting factor, activity type "Test": 0 

Debiting of the sender and the activity type "Test" are thus equal to 

       (50,000  / ,000 NI) X ,000 NI X 0,4 = $ 20,000 



 

 

Activities 

Create a cycle for indirect activity allocation as follows: 

Determine a name for the cycle. 

Determine a date as of which the cycle is to be valid. 

Maintain the header data of the cycle by specifying the following: 

an explanatory text 

the date to which the cycle is to be valid 

whether negative tracing factors are to be standardized 

Define cycle segments in which you store the following information: 

a name and text for each segment 

the sender values 

the tracing factor 

the selection criteria (sender objects and receiver objects) 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Periodic Allocations -> Indirect Activity Allocation 

or in Period-End Closing -> Defining Periodic Repostings or Periodic Allocations. 

Conceptional Information for Indirect Activity Allocation 

Indirect activity allocation consists of two subfunctions which you can enter as required in a cycle. 

However, one segment can cover only one subfunction in each case: 

Sender activity quantities are known and can be entered as totals. Using indirect activity allocation, the 

posted activity quantities are distributed from senders to receivers according to the tracing factors 

defined in the segment. 

segment uses this method if Posted quantities (rule 1) is the sender rule and Fixed quantities 

(rule 2) is NOT a receiver rule. 

In a segment to distribute posted sender amounts, you can use activity types of category 3 manual 

entry, indirect allocation only. 

Sender activity quantities are not known because measurement is either impossible or not feasible (for 

example, a joint office working for several cost centers). However, the SAP system can derive 

sender activity quantities indirectly, based on receiver tracing factors adjusted with a sender-

specific weighting factor. 



 

 

segment uses this method if Indirectly determined quantities (rule 3) is the sender rule, or if 

Fixed quantities (rule 2) is a sender or receiver rule. Using the Sender values function, you can 

determine sender-specific weighting factors for the sender rule Indirectly determined quantities. 

The default value is "1". 

In segments for indirect calculation of sender activity quantities you can only use activity types of 

category 2 indirect entry, indirect allocation. 

Senders and receivers in indirect activity allocation 

In indirect activity allocation for actual and plan data, senders  can be objects of the category cost 

center/activity type or business processes. 

In a given segment, you can use category 2 or category 3 activity types only. 

In indirect activity allocation for plan data, all usual CO objects are possible (cost center, cost 

center/activity type, orders, projects, etc.) as receivers 

All of these receiver categories can appear in a cycle. However, cost objects of the category cost 

center/activity type may not be combined with other receiver categories. 

In indirect activity allocation for actual data, you can use the same cost objects as receivers as in 

manual activity allocation, meaning no cost centers/activity types. 

Fixed and variable activity references; evaluating activity quantities 

In indirect activity allocation for actual data, all quantities are posted as total quantities. The division 

into fixed and variable quantity parts is carried out through actual cost splitting. 

In indirect activity allocation for plan data, the determination of fixed and variable quantity quotas 

depends on the receiver category: 

Receivers of the category cost center/activity type post all activity quantities as variable quantities, with 

tracing factors dividing actual and plan activity into fixed and variable quantity parts. 

For all other receivers the receiver quantities are posted as fixed. 

If an activity price is available for a sender object, the activity quantities of the sender and the 

corresponding receivers are valuated using this activity price. 

Updating the databases 

The activity quantity updated on the senders is determined either from read/posted sender 

quantities (subfunction 1) or from indirectly calculated activity quantities based on receiver tracing 

factors or predefined sender quantities/receiver quantities (subfunction 2). The activity quantity 

thus determined is posted to the respective sender as activity output (quantity credit) and to the 

respective receiver as activity-dependent or activity-independent activity input in relation to their 

tracing factors (quantity debit). The indefinite credit rate is updated for plan data as well (with 

activity type category 2). 

Additionally, the following activity postings are based on the sender activity quantities: 

If available quantities are distributed (subfunction 1), the scheduled quantity are updated. If the 

sender activity quantities are indirectly determined or fixed, the activity quantity is also updated 

in addition to the scheduled quantity. 

In actual indirect activity allocation, all quantities are treated as fixed quantities. 

You use indirect activity allocation in activity price calculation. 



 

 

 Develop Authorization Enhancements for Indirect Activity 

Allocation 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 Template Allocation 

This activity contains information on the structure of a template for template allocation. 

You can use the template to carry out allocations for cost centers/ activity types and for processes on cost 

centers. 

For each way in which a template is used, particular environments exist which determine which rows and 

column types can be used in the template to be created. 

Additional Information 

For more information on using templates, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Period-End Closing -> Periodic Allocations -> Template Allocation in 
Actual. 



 

 

 Define Environments and Function Trees 

In this step you maintain: 

Function trees 

Structure nodes - Function references - Functions. 

The basis for the maintenance of the object is always the chosen environment. 

Environment 

The Template's environment determines the information of the SAP-environment and the external system 

that can be accessed. Basically, the functions relevant to each context are already provided in the 

corresponding environment. Environments always contain a row of sub-environments which group 

functions by theme; these include material, BOM, routing, and others. 

The standard system delivers the following environments: 

Template allocation (for cost objects, profitability segments, 

business processes, cost centers/activity types) 

Formula planning (business processes, cost centers, profit centers) 

Standard cost estimates 

Process quantity determination ( SOP/LTP ) 

Easy Cost Planning/Internal Service Request 

Recommendation 

Use the sub-environments provided by SAP as much as possible. When you assign an function to a sub-

environment, it is automatically available in all the main environments containing this sub-environment. 

Further notes 

For more information on environments and a list of these and their sub-environments go to the help for 

applications of Activity-Based Costing under "Template -> Template Environment". 

Function Tree 

A function tree is a user-defined hierarchy which structures or groups functions. With the Help for 

function trees, you can structure groups of functions available in each environment according to their 

their theme or emphasis. Functions are then processed from here on. 

A function tree is assigned to an environment and consists of nodes and function nodes. 

Environments: all environments are displayed when you call up the n transaction. Environments 

themselves cannot be changed or deleted. The creation of new environments is also not possible. 

Function trees: the first level under environments. You can subordinate nodes or function nodes to a 

function tree. 

Nodes: nodes are always subordinate to function trees or other nodes. You can subordinate other nodes to 

a node or function node. In function trees SAP1, nodes contain sub-environments. 

Function nodes are always subordinate to function trees or nodes. They always refer to a function. 



 

 

SAP standard delivery for all environments includes function tree SAP1 (for example, for environment 

001, function tree SAP1-001). This contains all standard nodes ( sub-environments ) and function nodes 

(with reference to the respective function). 

Activities 

The transaction provides you with left and right screens. The left one displays the existing environments. 

You can expand the hierarchy and view the function trees, nodes and function nodes in their hierarchical 

structure. Place the curser on an object you want to process. 

The right screen details of the chosen object (environment, function tree, nodes or function nodes) in list 

form. If you double click on a funciton node you will see the maintenance screen for the functions. 

Further notes 

For more information see Application help for Activity-Based Costing: 

AC-Financials -> CO-Controlling -> Activity-Based Costing -> Template -> 

Function tree -> Maintain function tree or Template -> Template environment -> Maintain 

functions 

AC-Financials -> CO-Controlling -> Cost center accounting -> Cost center planning -> Aids -> 
Formula planning -> Template -> Template environment. 

 Maintain Templates 

Here you maintain templates. 

Applications 

Each purpose (application) of a template requires a special environment. Before creating a template, 

choose an environment. The environment determines which row and column types are available, for 

example. 

The available applications include the following: 

Template allocation to cost objects, or use in standard cost estimates for cost objects and materials 

(environments 001 - 012) 

Template allocation to business processes, cost centers, or cost centers/activity types 

(environments SBP, SCI, SCD) 

Template allocation to profitability segments (environment PAC) 

Formula planning (environments CPI, CPD, BPP, PCA) 

Calculation of output quantities (environment SOP) 

Easy Cost Planning/Internal Service Requests (environment 200 - 299) 

Structure 



 

 

A template consists of rows (items) and columns. The row and column types available to you depend on 

the environment. 

Columns available include: 

Type of row, such as business process, cost element subtemplate, or calculation row 

Name of the item 

Object, such as the name of the process, cost element, subtemplate, or calculation row 

Quantity (actual/plan), such as the process quantity or statistical key figure quantity 

Activation ( actual/plan ) 

Allocation event (template for cost objects) 

Activities 

To maintain a template, you must edit the initial and overview screens, from which you can access 

various editors. 

Initial screen 

Enter the name of the template that you want to create or edit. 

Enter the environment of the template. 

Choose Enter. 

Overview screen 

If the template is new, enter a name for it. 

Select the row type. 

Enter a name for the row. 

Edit the other columns. Use the mouse or the tab key to reach the individual columns. Double-clicking on 

particular column types (such as object, quantity, activation, or allocation event) brings you to the 

editor or function selection. 

Once you have entered or edited all rows, choose Template -> Save. 

Further notes 

Detailed information is available in the Application Help for the transaction, or in the SAP Library under 

Financials -> Controlling -> Activity-Based Costing -> Template -> Maintaining Templates. 

 Splitting 

In this section you define a splitting structure, used to split activity-independent costs ( belonging to cost 

centers) between activity types. You assign this structure to the corresponding cost centers. 

 Define Splitting Structure 

Splitting structure determine how and what selected activity-independent costs from a cost center are 

divided between the activity types. This applies to both plan and actual costs. 



 

 

A splitting structure consists of one or more assignments, which define the connection between the cost 

element(s) or cost element group to be split and the splitting rule used to divide the costs. 

Each splitting rule is based on a splitting method; for example, splitting costs based on statistical key 

figures. 

After you define a splitting structure, you must assign it to the cost centers on which you want to split 

costs according to the given rules. You can assign a structure to: 

All cost centers 

All cost centers in a given group 

All cost centers in a given interval 

The structure can apply to a single version or to all versions in a controlling area for a fiscal year. 

Splitting Example 

Activities 

Create a splitting structure or change an existing structure. 

To create a splitting structure: 

In the overview screen for structure maintenance, choose New entries. 

Enter a two-character key for the structure, a text, and save your entries. 

Define assignments for the splitting structure. 

Select a structure and choose Assignments in the structure tree. 

Choose New entries and include the required entries with a two-character key and descriptive text. 

For the assignment, define according to which rule splitting should be carried out. You can define new 

rules or use existing ones. 

Select an assignment and choose Selection for assignment in the structure tree. 

Choose New entries and define which cost element, which cost element interval, or which 

cost element group is valid for this assignment. 

Save your settings. 

Define splitting rules 

To create new splitting rules, proceed as follows: 

Select an assignment and choose Splitting rules in the structure tree. 

Choose New entries and enter a key for the rule along with a text and procedure. Use the 

"Weighting" indicator to control whether cost splitting uses weighting of tracing factors. 

Define the selection criteria for the splitting rule. 

Select a splitting rule and choose Selection for rules. Choose New entries. 

If necessary, enter a version. 

If the splitting method is based on statistical key figures, you   must enter a statistical key 

figure, a key figure interval, or a key figure group as the selection criterion. Save the selection 

criteria. 



 

 

Additional Information 

Check your structure to ensure that no inconsistencies could arise during splitting. 

Inconsistencies can result from: 

Overlaps or redundancies between individual values, intervals, and groups 

Deletions of selection criteria, rules, assignments, or structures 

In contrast to actual cost splitting, plan cost splitting consists of only a single splitting step. Splitting 

based on target costs is not possible in planning because actual data is not yet available for creating 

target costs. 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Cost 

Splitting and under Period-End Closing -> Variance Calculation -> Actual Cost Splitting. 

Note on transport 

To transport splitting structures, a special function is available in Customizing under Controlling -> 

General Controlling. 

 Assign Splitting Structure to Cost Centers 

If you want to split costs in the cost center to the activity types, you must assign a splitting structure to 

this cost center. 

The SAP System splits costs per the rules that you set in the splitting structure. 

Requirements 

You have defined a Splittung Structure. 

Activities 

Determine the type of assignment to be defined: 

Assignment of splitting structure for each cost center group 

Assignment of splitting structure for all cost centers 

Select the corresponding criteria in the initial screen. 

Along with cost center/group, you can determine whether to make the assignment valid for one 

version or for all versions. The assignment is made for one fiscal year. 

Choose additional cost centers from the list of non-assigned centers. 

Choose the splitting structure (cursor) to which you wish to assign the cost center(s). 

Choose Assign or Edit -> Assign to assign the cost centers the structure. 

Save your entries. 



 

 

 Price Calculation 

In this section you make the following settings for price calculation: 

Basic Settings for Price Calculation 

Cost Component Structure 

Switching Structure 

 Change Basic Settings for Price Calculation 

You can change the following SAP default control parameters for price calculation. 

Indicator Generate. 

Controls report generation for iterative price calculation. 

Before running price calculation, the system generates the corresponding report on the execution. 

The number of entries in the associated internal tables is generated, as well as the parallel 

processing of field groups. 

By entering realistic figures during performance problems, the storage capacities and runtimes can 

be improved significantly. 

Because generation also requires some time, you should activate this indicator only for very large 

processing runs when problems occur. If the indicator is active, entering numbers in the fields 

mentioned above can be left aside. 

Number of senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of relationships between senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of cost centers in the controlling area 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of significant digits in the price unit 

To achieve more accurate results, the price unit can be set. The activity price is thereafter not based 

on units of 1, but on units of , 0, 00, or 000. If the activity price per unit is already relatively high, 

but you nevertheless want greater accuracy for your prices, this results in even higher values. With 

the number of significant digits, you can limit this development. The moving of digits takes place 

until the number of significant digits is reached. 

Example 

If the price per unit is 333333333, and the significant digit number was set to 6, the price unit 

remains 1 and the price 333. For 12 significant digits, the unit would be 000 and the price 

,333,333333. 

Indicator for deactivating the optimization of the price unit 

Deactivates the significant digit settings mentioned in the previous point. If this is chosen, the price 

unit is 1. 

Tolerance percentage for reconciliation of actual and scheduled activity Activity planning should be 

reconciled when price calculation is called up. The plan activity of the activity type should equal the 

scheduled receiver activity quantity. Only in this way will a sensible price be determined. All 

activity types are checked for reconciliation and, if necessary, issues warnings or error messages. 

Due to planning rounding differences, especially in period distribution, minimal variances may 

occur nevertheless. 

Enter the percentage by which plan activity may vary from scheduled activity. 



 

 

Indicator Post anyway. 

Indicator for posting of price calculation results even if errors occur. 

Exceptions are serious system errors resulting in program termination and errors occurring in 

update preparation (such as integration or document assignment problems). Normally, errors 

prevent update booking of postings. In online processing, the update can be repeated from the 

results list. In background processing, this is not the case. 

Standard settings 

Use the function Set standard to set the parameter values defaulted by the SAP system. 

Recommendation 

SAP recommends using the standard settings unchanged. 

Changing settings to meet the requirements of your organization is useful only if your results vary greatly 

from the SAP default values. 

The changes in generation factors can worsen the runtimes of price calculation. 

Activities 

Maintain the settings for price calculation according to your requirements. 

Additional Notes 

For more information about price calculation, see the SAP Library under Financials -> Controlling 

(CO) -> Cost Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Price 
Calculation. 

Note on transport 

To transport basic settings for price calculations, see Customizing under Controlling -> General 

Controlling. 

 Settings for Cost Component Split 

In this section you make settings for price calculation using cost component splitting. 

 Define Cost Component Structure 

You require a cost component structure to calculate prices using cost component split. 

For each cost component structure you define a cost component such as energy, personnel, or raw 

materials. The components combine all costs occuring for a particular cost element area. In this way, you 

ensure greater cost transparency in activity price calculation when putting together the activity type 

prices - for example, it becomes easier to find how much of the activity price is taken up by the material 

costs. 



 

 

In activity allocation, the cost component structure remains constant, meaning that the receiver takes on 

the sender cost elements and that the allocated costs are posted in the same cost components in the 

receiver as in the sender. 

A cost component structure can have a maximum of 40 defined cost components. 

Cost components are assigned to cost elements. You thereby determine which cost elements go to which 

rows in the structure, and how these components are updated in price calculation. 

The cost component structure must be stored independently of fiscal year in the version. 

You can transfer cost component splitting directly as primary cost splitting to product costing, or you can 

use a transfer structure to transport it to the Product Cost Controlling component ( CO-PC ). 

Note 

You need only carry out the steps named in "Activity". Further settings for cost components are not 

necessary, as they are relevant for product costing only. 

Activities 

To use cost component splitting for price calculation: 

Create a cost component structure or change an existing one. 

To create a new structure, enter a two-character key and an explanatory text. 

Otherwise, choose an existing structure and maintain it in the following steps. 

Save the cost component structure. 

Define cost components 

Select the structure and choose the navigation level "Cost components with characteristics". 

If no components exist, choose "New entries". Otherwise, maintain the existing elements. 

Enter the structure, a key, and a short text for the component. 

Save your entries. 

Assign the cost elements to the cost components. 

Branch to the navigation level "Assign Cost Component - Cost Element Interval". 

If no assignments exist, choose "New entries". Otherwise, maintain the existing elements. 

For each component, enter the structure, the chart of accounts, and the relevant cost element or cost 

element interval. 

Save your entries. 

Enter the cost component structure in the fiscal year dependent part of the version's detailed information. 

Further notes 

For more information about the cost component structure, and price calculation using cost component 

splitting, see the SAP Library under Financials -> CO Controlling -> Cost Center Accounting - 

Period-End Closing -> Actual Price Calculation -> Price Calculation using Cost Component 
Splitting. 

Note on transport 



 

 

To transport of cost component structures, an individual function is available Customizing under CO - 

Controlling -> Controlling. 

 Define Switching Structure 

You need to define a switch scheme, if within cost component split for price calculation you do not want 

a cost component split for primary costs only. In other words, where for an activity allocation, the 

allocated costs on the receiver are entered on a cost component different from that of the sender. You 

then determine which sender cost element is to be entered on which receiver cost element. 

In price calculation, a cost component structure is used for price component splitting. This structure 

stores which cost elements are to be directed into which component. 

For example, you can note in the cost component structure that material cost elements assigned to the 

sender component "Raw materials" and wage costs assigned to the sender component "Personnel" can be 

directed to the receiver component "Energy". 

As the structure is used only with a specific combination of cost center/activity type, it is entered in the 

activity type planning of the sender. The corresponding planning structure for activity type planning 

using a switching structure is found in planner profile SAP4. 

Activities 

Create a switching structure if you require one To do 

so, proceed as follows: 

Assign an existing cost component structure to a switching structure. 

Assign the structure's components to target components. 

Save your entries. 

Further notes 

For more information and an example, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Period-End Closing -> Actual Price Calculation -> Price Calculation 
with Cost Component Split. 

Note on transport 

You can also transport switching structures manually. To do this, choose Table View -> transport. 

 Variances 

In this section you make settings for the variance calculation. 

Variance calculation in Cost Center Accounting displays the differences between actual costs and 

allocated actual costs in different variance categories. The system calculates the individual categories on 

a cumulative basis; the total of individual variances corresponds to the total balance of the cost center. 

Variance calculation distinguishes between input side and output side of the cost center. 

The input side contains all debits and all credits of the cost center except the credits from activity 

allocations. The system compares actual costs (control costs) with target costs. It can then calculate the 

following variance categories: 

Input price variance 



 

 

Input quantity variance 

Resource usage variance 

Remaining input variance 

The output side contains the activity allocations of the cost center. The SAP system compares allocated 

actual costs with the target costs or plan costs. It can then calculate the following variance categories: 

Output price variance 

Output quantity variance 

Fixed cost variance 

Volume variance 

Secondary fixed cost variance 

Remaining variance 

In Cost Center Accounting, you can post actual costs to cost centers only, not to the activity types on the 

cost center. To be able to compare actual costs with target costs, and to display the variances on the 

activity types, the actual costs must be distributed (split) on the activity types. Splitting takes place in 

several steps: 

In the first splitting step, actual costs distribute to activity types on the basis of target costs or quantities. 

This is divided by cost element. If no target costs exist on a cost element, the system determines the 

target costs of the corresponding cost element group. If target costs exist on this group, these are 

used as the basis for the first splitting step. 

A second splitting step is then necessary: 

If no target costs or quantities exist for the cost element or cost element group In this case, the 

tracing factor for splitting is missing. 

If activity-independent target costs or quantities exist 

In this case, the share of the actual costs remains on the cost center, which corresponds to the 

portion of the activity-independent target costs (target quantities) of the entire target costs 

(target quantities). 

In the second splitting step, the actual costs distribute to the activity types based on splitting rules. 

You can determine these splitting rules yourself. If no rules exist for a cost center, the actual costs 

distribute on the basis of the activity type equivalence numbers. 

Further notes 

For more information, see the SAP Library under Financials -> Controlling (CO) -> Cost Center 

Accounting -> Period-End Closing -> Variance Calculation. 

In addition, see the following IMG activities: 

Maintain Target Cost Version 

Maintain Splitting Structure 



 

 

 Determine Primary Data Input Price Variances 

The SAP System identifies input price and quantity variances even if the recording and posting of 

consumption quantities is too involved, or not required. 

In this IMG activity you create a variance percentage rate for a cost element, based either on the 

controlling area or on a period interval within a fiscal year. 

After defining the variance percentage rate, the system records costs and variances involved during 

primary postings. The quantity variance is thereby identified as remaining input variance. 

Note 

Remember that the variance percentage rates are based on the costs to be determined, without variances. 

Example 

You post $00 to account 400000. For this account you have defined a primary input price variance of %, 

or $0. 1% equals $10. 

Requirements 

Complete the following IMG activities: 

Activate Cost Center Accounting in Controlling Area Here, activate 

variance calculation. 

Create Cost Elements 

To do this see the Implementation Guide under Cost Element Accounting -> Master Data -> 

Cost Elements -> Create Cost Elements. 

Activities 

Create the price variance in accordance with your requirements. 

Note on transport 

To transport primary data price variances, see the IMG under Controlling -> Controlling General. 

 Check Units of Measure in Cost Element Master Data 

In order to calculate input price and quantity variances, the system requires the consumption quantities in 

addition to actual and plan costs. Only then can it distinguish between variance categories. 

To assign consumption quantities to an account, you must define a quantity unit in the cost element 

master data. You can also assign quantities to accounts using a quantity unit you define as convertible to 

the unit stored in the cost element master data. 

In addition, if you set the indicator Record quantities in the cost element and cost center master data, 

the system issues an error message if you do not enter quantities. 

The deciding factor for variance calculation, however, is solely the quantity unit. 

Example of Input Quantity Variance 

To provide the activity type "Machine Hours", you define the consumption of  liters of grease as a ratio 

of the activity quantity. At an operating rate of 1%, actual postings record the consumption of 12 liters. 

The input quantity variance therefore equals 1 liter because the cost center activity consumed more than 



 

 

provided for in the adjusted plan (target) costs. Consumption as based on the operating rate equals 11 

liters. 

Note 

Cost elements with frequent price fluctuations require consumption quantities for differentiated 

calculation of input price and quantity variances and their assignment to accounts. 

You can determine input price variances for cost elements with relatively stable prices. To do so, 

complete the IMG activity Determine Primary Cost Input Price Variance. The input quantity variance is 

identified here. 

Activities 

Maintain a quantity unit in the cost element master data for cost elements with frequent price 

fluctuations. 

Note on transport 

To transport cost elements, there is a separate Customizing function under Controlling -> General 

Controlling available (Transport Settings for Master Data. 

 Define Variance Variants 

In this IMG activity you define the variance variant determining the variance categories to be calculated. 

You can calculate the following variance categories: 

Input Side Variance: 

Input price variance 

Resource-usage variance 

Input quantity variance 

Remaining input variance Output Side Variance: 

Output price variance 

Fixed-cost variance, itself divided into: 

Volume variance 

Secondary fixed cost variance 

Remaining variance 

The system calculates variances for all categories chosen. 

The values from variance categories not chosen are added onto the following variance category. 

Fixed cost variance is calculated as a whole and not sub-divided. 

If you do not select variance categories, the two remaining variance categories hold all the variances as 

totals. 

You define the variance variant in the target version of each controlling area. 

Default settings 



 

 

The standard system includes default variance variant 001. 

Actions 

Check whether the standard variance variant meets your requirements. If you require a new variance 

variant: 

Choose New entries and enter a key and a corresponding short text for the new variance variant. 

Select the corresponding variance categories. 

Save the variance variant. 

Note on transport 

To transport variants, choose "Table view -> Transport". 

Further notes 

For more information on and examples of variance categories, see the SAP Library under Financials -> 

CO - Controlling -> Cost Center Accounting or Activity Based Costing -> Period-End Closing -> 

Variance Calculation -> Variance Categories. 

 Define Cost Element Groups 

In variance calculation, the first splitting step distributes the activity-independent actual costs on the basis 

of the target costs and quantities by cost element to the activity types. If no target costs are given for a 

cost element, the SAP System determines target costs for the corresponding cost element group. These 

target costs are then used as the basis for the first splitting step. 

You may use either the defined cost element groups or define new cost elements for the special 

requirements of variance calculation. 

You can combine similar cost elements into cost element groups. Similar cost element groups can be 

combined to form other cost element groups so as to build a cost element hierarchy. 

You can use cost element groups: 

In the information system 

The row structure of your report is determined by the cost element structure. You can create totals 

for each node in the report. 

When processing of several cost elements in one transaction, such as 

Cost center planning 

If, for example, you wish to display and plan personnel costs in one work transaction, select 

the group "Personnel costs". 

Distribution 

Assessment 

Report totalling takes place via cost element group nodes. To achieve a clear illustration, each node on a 

level must have the same number of subordinate levels. 

Prerequisites 

In Customizing of Financial Accounting (under General Ledger Accounting -> G/L Accounts -> 

Master Data) you have maintained a chart of accounts. 



 

 

You must have completed the Customizing activity Maintain Controlling Area in Customizing of 

General Controlling under Organization. 

Default Settings 

Standard cost element group OAS-INT is created for chart of accounts INT (international chart of 

accounts) in controlling area 0001. 

Actions 

Check whether the standard cost element groups meet your requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose 

"Same level" or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 



 

 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 



 

 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 



 

 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Notes on transporting 

A separate activity for transporting cost element groups exists in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information about creating cost element groups, see SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Processing Master Data and Cost Elements -> Cost 

Element Groups. 

 Define Target Cost Versions 

In this IMG activity you maintain a target cost version for variance calculation. 

To carry out variance calculation in Cost Center Accounting, you must first create a target cost version 

for the respective controlling area. 

You determine the following by means of the target cost version: 

the version from which plan and actual data is read 

the version in which the target costs are calculated 



 

 

the version to which the split actual costs are posted 

the version in which the variances are updated 

In the target cost version you also store 

which cost element group is used for the first splitting step 

according to which variant the variances are determined 

Keep in mind that currently only version 000 is allowed as an entry for all versions ( plan, actual, and 

target). The standardization of variance calculation in Cost Center Accounting and Product Cost 

Accounting, however, makes the use of the target cost version necessary. 

Activities 

Create a target cost version. 

Enter a variance variant for your controlling area. 

Activate the target cost version by setting the "Active" indicator on the overview screen of the target cost 

versions. 

Note on transport 

Target versions can be manually transported by choosing "Table view -> Transport". 

 Information System 

In this activity you make the settings for the cost center accounting information system. You do so by: 

Maintaining master data groups for the information system 

Adding to the available pool of standard reports 

Creating user-defined reports with Report Painter 

Specifying the initial screen for executing user-defined reports 

Specifying user settings 

Further notes 

For more details on the information system, see the SAP Library under Financials -> CO Controlling -

> Cost Center Accounting -> Information System in Cost Center Accounting. 

 Group Maintenance 

In this IMG activity, you adapt master data groups to the specific  requirements of the information 

system. 

For more information on group maintenance, see the SAP Library under Financials -> CO Controlling 

-> Cost Center Accounting -> Cost Center Planning -> Master Data in Cost Center Accounting -
> Master Data Groups -> Processing Master Data. 



 

 

 Define Cost Element Groups 

You can combine similar cost elements into cost element groups. Similar cost element groups can be 

combined to form other cost element groups so as to build a cost element hierarchy. 

You can use cost element groups: 

In the information system 

The row structure of your report is determined by the cost element structure. You can create totals 

for each node in the report. 

When processing of several cost elements in one transaction, such as 

Cost center planning 

If, for example, you wish to display and plan personnel costs in one work transaction, select 

the group "Personnel costs". 

Distribution 

Assessment 

Report totalling takes place via cost element group nodes. To achieve a clear illustration, each node on a 

level must have the same number of subordinate levels. 

Prerequisites 

In Customizing of Financial Accounting (under General Ledger Accounting -> G/L Accounts -> 

Master Data) you have maintained a chart of accounts. 

You must have completed the Customizing activity Maintain Controlling Area in Customizing of 

General Controlling under Organization. 

Default Settings 

Standard cost element group OAS-INT is created for chart of accounts INT (international chart 

of accounts) in controlling area 0001. 

Actions 

Check whether the standard cost element groups meet your requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 



 

 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup node, 

the value, or the value interval, and choose Edit -> Selected entry -> Remove. The affected node 

is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 



 

 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 



 

 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 



 

 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Notes on transporting 

A separate activity for transporting cost element groups exists in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information about creating cost element groups, see SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Processing Master Data and Cost Elements -> Cost 

Element Groups. 

 Define Cost Center Groups 

You can combine similar cost centers to form cost center groups. You may then combine similar groups 

into further groups to create a cost center hierarchy. 

Note on Cost Center Groups 

The organizational division into cost centers can be displayed in the SAP system with the use of cost 

center groups. 

Cost center hierarchies summarize the decision-making, responsibility, and control areas according to the 

user's requirements. Individual cost centers are the lowest hierarchical level. This ensures that at least one 

group holds all cost centers, and thereby represents the entire organization. Moreover, alternative groups 

can be created which can be divided according to structural or functional standpoints. 

Cost center groups allow valuations according to any desired area of responsibility. 

You can use cost center groups: 

In the information system to create reports for selected cost centers - To process multiple cost 

centers in a single transaction: 

Cost center planning 

Distribution 

Assessment 

You must maintain the standard hierarchy for your controlling area in the master data. Here, you have the 

option of creating and changing other cost center groups. 

Requirements 

Complete the IMG activity Maintain Controlling Area. 



 

 

Activities 

Structure the cost centers in your controlling area along cost accounting standpoints. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 



 

 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups To copy groups, 

you have the following options: - Copy Entire 

Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 



 

 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 



 

 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To transport cost center groups, there is a separate function in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity period. However, most master data is time-based. 

Further notes 

For more information about cost center groups, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data for Cost Center Accounting 

-> Processing Master Data -> Master Data Groups and also Cost Centers. 

 Define Activity Type Groups 

You can combine similar activity types into activity type groups. You can combine groups into further 

groups, thus building an hierarchy of activity types. 

Activity type groups are used: 

In the Information System to create reports for certain activity types - To maintain multiple 

activity types in a CCA transaction: 

Planning 

You can display and plan multiple activity types in one transaction, for example in 

Planning 



 

 

You can display and plan several activity types in one transaction. 

Assessment 

You can carry out assessment for chosen activity type groups. 

Requirements 

Complete the IMG activity Maintain Controlling Area to be found under General Controlling -> 

Organization. 

Activities 

Structure activity types in the controlling area according to your controlling requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 



 

 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 



 

 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 



 

 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To transport activity type groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting and the sections Processing Master 

Data -> Master Data Groups and Activity Types -> Activity Type Groups. 

 Define Statistical Key Figure Groups 

You can combine similar statistical key figures to form statistical key figure groups. You can combine 

similar such groups to form further groups, thereby creating a hierarchy of statistical key figures. 

Statistical key figures are used: 

In the Information System, to create reports for particular key figures 



 

 

To maintain multiple key figures in Cost Center Accounting transactions: 

Cost center planning 

Distribution 

Assessment 

You may combine statistical key figures used in the distribution/assessment framework 

as tracing factors into a single group. 

Requirements 

You completed the IMG activity Maintain Controlling Area, located under General Controlling -> 

Organization. 

Activities 

Structure your statistical key figure groups in the controlling area based on your controlling 

requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 



 

 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, 

select the highest subgroup node or individual node, select the reference node, and choose Same 

level or Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 



 

 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 



 

 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 

To Transport statistical key figure groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 



 

 

Center Accounting -> Master Data in Cost Center Accounting, then Master Data in Center 

Accounting -> Processing  Master Data -> Master Data Groups or Statistical Key Figures -> 

Statistical Key Figure Groups. 

 Define Selection Variants 

You use selection variants to select master data using one or more master data attributes. The variant 

contains the fields that the SAP system evaluates in your selection report. These fields determine both the 

content and layout of a selection variant. 

The following selection reports exist: 

RKKOASEL  for cost elements 

RKKSTSEL  for cost centers 

RKLSTSEL  for activity types 

RKPRZSEL  for business processes 

RKOSEL00  for internal orders 

RKPSEL00  for projects 

You enter the selection values in the appropriate fields. You can overwrite these fields in the application; 

you can also hide those fields that you do not require. 

When maintaining the variant attributes you can also specify variables for selection variant fields. 

You need enter the selection criteria for selecting the objects only once, and then save these criteria as a 

selection variant. You can then use this variant to call up the master data of the selected objects. 

Example 

If you want to display reports in the information system for objects with given selection values, you can 

also enter the <name of the selection variant> under the group. 

If you want to define reports using selection variants, enter the <name of the selection variant> as the 

characteristic value under group. You can then for instance display all the cost centers for a 

company code in the report. 

Activities 

If you want to define more than one selection variant, proceed as follows: 

Enter a name for your variant in ABAP: Variants: Initial Screen. 

Transfer the Values default in the Subobjects group box and choose Create. The system displays the 

selection fields for the given master data on the screen Variant Maintenance: Report <your 

selection report>. 

Enter the values by which you want to select the desired fields. 

Choose Continue. 

You branch to the attribute maintenance in the selection variant. 

Enter a short text in the Description field. 



 

 

Save your entries. 

Notes on transport 

You can transport selection variants manually: 

Choose Variants -> Transport request.. 

Enter the program name. 

Enter the name of the variant to be transported. 

 Standard Reports 

In this activity, you add to the list of standard reports. You do so by: 

Importing standard reports into your production system 

Specifying report languages 

Generating standard reports 

 Import Standard Reports 

In this IMG activity, you import SAP standard reports from  client 000, online or in background, to the 

client in which you are working. 

You have the following import options: 

Import some reports 

Select the required standard reports from the list of all report groups offered. 

Import all reports 

Determine a time of low system use to create a background job for importing all reports. 

Repeat the import of standard reports from client 000 after each update or new release. 

Note 

Do not change the standard objects in the target client. Rather, use them as models for your own objects. 

This ensures that changes are not overwritten by the next transport of standard objects. 

Standard settings 

The standard system includes all default reports for the components. 

Activities 

To import only some of the reports: 

Choose Online. 

Select the standard reports for the system to import. 

Choose Copy. 



 

 

To import all reports: 

Determine a time of low system use 

Choose Background 

Enter a job name. 

Transfer reports from the defaulted source client 000. 

Enter the desired start time and date, or activate the Start now indicator to instantly begin the job. 

The system plans the job and selects all available standard reports automatically. 

Further notes 

For more information on CCA standard reports, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Information System -> Important Standard Reports. 

Information is also available by choosing Extras -> Documentation  after running a report program. 

 Specify Report Languages 

Report Writer can generate a report in up to 32 languages simultaneously. When generating a 

report group, the system adopts the language-dependent report parts (such as rows or column texts) in the 

languages set by you in the report. In addition, the logon language is taken into account. 

Note 

The languages that you specify are valid for all Report Writer reports and in all clients. 

To improve performance, only enter the languages required. The more languages specified, the longer it 

takes for the system to execute the report. 

Activities 

Determine the languages you need for your reports. 

Enter the required languages. 

choose New entries 

Enter a language key and the corresponding description. 

Save your entries. 

 Generate Standard Reports 

SAP standard reports that you have imported must also be generated. Only then is an executable 

program created that can be run in the information system. 

The following generation options are available: 

Generate some reports 

You receive a list of all report groups. From the list of standard reports, you can designate those 

required for your reporting needs. 



 

 

Generate all reports 

If you want to generate all reports, create a background job for times of low system use. 

Standard settings 

All standard reports for an application are defaulted in the standard SAP System. 

Activities 

To generate only some of the reports, proceed as follows. 

Choose Online. 

Mark the standard reports that the SAP System is to generate. 

Choose Generate. 

To generate all reports, create a background job for times of low system use. To do so, proceed as 

follows. 

Choose Background 

Enter a job name. 

Enter the desired start time and start date, or activate the indicator Start now to execute the job 

immediately. 

The SAP System plans the job and automatically selects all available standard reports. 

Further notes 

Non-generated reports are generated online automatically during report callup. 

 Enhancements for Line Item Reports 

You can enhance line item reports by adding custom fields. The SAP system includes the following 

standard enhancements: 

COOMEP01  CO-OM: Info System -> Line Items: Custom Fields This 

enhancement includes the following components: 

EXIT_SAPLKAEP_001 

Line Item Report, Actual: Custom Fields in Layout 

EXIT_SAPLKAEP_002 

Line Item Report, Plan: Custom Fields in Layout 

EXIT_SAPLKAEP_003 

Line Item Report, Commitments: Custom Fields in Layout 

EXIT_SAPLKAEP_004 

Line Item Report Budget/Cost Center Budget: Custom Fields in Layout 

EXIT_SAPLKAEP_005 

Line Item Report, Actual: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_006 

Line Item Report, Plan: Customer-specific Authorization Checks 



 

 

EXIT_SAPLKAEP_007 

Line Item Report, Commitment: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_008 

Line Item Report Budget/Cost Center Budget: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_009 

Line Item Reports: Customer-specific Formatting of the Lists. 

You can use this enhancement to protect layouts or to modify column headings. You can call up 

the transaction for reposting actual costs (posted to cost centers) directly from the actual line 

item report and actual document display. The system adds the new records to the reports. 

Activities 

Create the enhancement 

To do so, create a new project or use an existing project. 

Activate the project 

The enhancement is valid only after activation. 

Further notes 

Unlike modifications, enhancements are compatible with all Releases because they are not part of the 

original SAP system but part of the name range reserved for customers. 

For more information on using enhancements, use the enhancement transaction CMOD by choosing 

Utilities -> Online handbook in the section Function Exits. 

For more information on the enhancement, see the enhancement documentation in CMOD by choosing 

Display SAP documentation. 

 User-Defined Reports 

In this section you learn how to quickly and easily create user-defined reports. 

 Specify Report Languages 

Report Writer can generate a report in up to 32 languages simultaneously. When generating a report 

group, the system adopts the language-dependent report parts (such as rows or column texts) in the 

languages set by you in the report. In addition, the logon language is taken into account. 

Note 

The languages that you specify are valid for all Report Writer reports and in all clients. 

To improve performance, only enter the languages required. The more languages specified, the longer it 

takes for the system to execute the report. 

Activities 

Determine the languages you need for your reports. 



 

 

Enter the required languages. 

choose New entries 

Enter a language key and the corresponding description. 

Save your entries. 

 Define Libraries 

In this IMG activity, you can maintain previously defined libraries or create new ones. You must assign 

each report that you define to a library. 

A library is a selection of characteristics, key figures, and predefined columns from the list of all options 

in the Report Writer table. In Controlling, table CCSS is used. 

A characteristic (in earlier releases field or dimension) is a non-numerical field, for example, Account, 

Cost center, and Business area . 

A key figure (new as of Release 3) is a numerical value field, such as Amount in local currency, Total 

costs, and Activity quantity. 

A default column (in earlier releases Data-set-entry is made up of a key figure and one or more 

characteristics. With default columns, you can define standard columns that can be used more than 

once in your reports, for example, Actual costs in current fiscal year and Plan costs in closed 

fiscal year. 

Four screens are available for library maintenance: 

Header 

Key figures 

Characteristics 

Default columns 

Activities 

Check whether the standard libraries satisfy your requirements. If not, proceed as follows: 

Enter a name for the library and the name of the table to which the library is assigned. 

To copy and change an existing library, enter the name of the reference library in the field of the same 

name. 

Enter a description for your library. 

Determine which key figures are to be used in the library. 

Determine which characteristics are to be used in the library. 

Determine which default columns are to be used in the library. 

For steps 2 to 4, if necessary, enter the ranking order (position) in which the characteristics, default 

columns, and key figures are to appear in the selection lists of the Report Painter. 

Note on transport 

To transport libraries, an separate function is available, Transport Report Writer Objects, in the IMG for 

Financial Accounting under Special Purpose Ledger -> Tools -> Transport. 

Further notes 



 

 

For more information, see the SAP Library under Financials -> Financial Accounting ( FI ) -> 

Special Purpose Ledger -> Libraries. 

 Import Templates 

You import standard SAP templates for report rows or columns from client 000, online or in the 

background, to the client you are using. 

Templates are one-dimensional report modules in which complete row or column blocks are predefined, 

and which can be placed in reports during definition. 

The following options are available: 

Import a certain number of templates 

The system displays a list of all templates, from which you select those required for your 

information system. 

Import all templates 

Importing all templates should be done during times where system usage is at a minimum, using a 

background job. 

After installing a new release or update, repeat the import of templates from client 000 in order to access 

the changes. 

Standard settings 

The standard system defaults all templates. 

Activities 

To import only some of the templates, proceed as follows: 

Choose Online. 

Mark the templates that the SAP system should import. 

Choose Copy. 

To import all templates, create a background job and schedule it as follows: 

Choose Background. 

Enter a job name. 

Keep the defaulted value "000" as source client. 

Enter the desired start time and date, or use the indicator Start now to execute the job immediately. 

The system plans the job and automatically selects all existing templates. 

Further notes 
For more information, see the SAP Library under  Financials -> CO Controlling -> Cost Center 

Accounting -> Information System -> Report Definition -> Report Painter. 



 

 

 Create Reports 

Many reporting requirements are solved by standard system reports. If, however, non-standard 

requirements remain unfulfilled, you can use Report Painter for simple, quick definition of user-defined 

reports. 

You can also use standard references objects to construct your own reports: libraries, standard layouts, 

default columns, and row and column models, all in the standard system, and available for custom 

reports. 

A report can consist of several "logical" pages. This is useful if you wish to construct managerial key 

figures, such as costs per employee. You can switch between logical pages and carry out calculations 

with them. 

Report Painter report definition requires several Preparatory Steps, depending on the complexity of the 

report to be generated. 

Requirements 

To create reports for user-defined libraries with Report Painter, you must maintain the Libraries first. 

Standard settings 

The standard system includes many standard layouts and column and row models, as well as default 

columns for libraries 1VK, 1GK, 1AB, 1RU, and 7KK. As a rule these standard modules are sufficient 

for report definition. 

Recommendation 

Do not change a standard report because any changes will be overwritten when importing new reports 

from client 000 (which supplies standard reports). 

- To make small changes to a standard, use the report as a model, copy it to another name, and 

change the copy only. Choose Report -> Copy. 

You can use reports as models in one library only, but you can copy reports from other libraries. 

Activities 

The procedure when defining a Report Painter report depends on how far the supplied standards satisfy 

your requirements. 

1. If the libraries, layouts, row and column models, and default columns in the standard system are 

sufficient: 

a) Define report columns by using the supplied default columns and characteristics as 

well as formulas and standard layouts in the standard library. 

You can construct columns from characteristics, formulas, or predefined columns. Predefined 

columns can be changed by inserting further characteristics. You can also use variables, but 

only those already defined in Report Writer. 

Select a column by double-clicking. 

Choose Key figure with characteristics or Default columns for the column structure. 

If you choose Key figure with characteristics, use the dialog box to mark the key figure to 

be used in the report. 

In the following dialog box, choose the characteristics to be used in the column and afterwards 

specify the characteristic values as individual values, groups, intervals, or variables. 



 

 

To define all possible values for a chosen characteristic, enter an asterisk (*); to define an 

initial value, enter a pound sign ( # ). 

To use variables, choose Variables on/off. The SAP system automatically indicates the 

appropriate field and automatically adjusts the field length. Choose "Possible entries" to 

display all existing variables. 

If you choose Default columns, specify one of the standard default columns in the dialog 

box. You can then change or expand upon the suggested characteristics and characteristic 

values. 

To define a further report column, select the element type Formula in the dialog box. Use the 

formula editor to select other report columns and predefined cells to define a formula which 

calculates a value for the column. 

Enter a column text. Choose Copy to copy the short text to the fields Middle and Long as 

well. 

You can also use variables in a column text. To store a variable, enter an ampersand (&) 

followed by a variable name. When you activate Key as text type in the standard report layout 

under Column text, the report issues the current value of the variable. If you activate Name, 

the report issues the name of the current value. 

b) Define report rows by using the characteristics or row models available in the standard 

library. 

All steps in row definition are similar to those in column definition. 

If the libraries, layouts, and row and column models do not meet your requirements: 

If necessary, maintain the corresponding library. 

If necessary, create a new layout or change an existing one. 

If necessary, maintain the standard default columns. 

In Report Painter, choose Set maintenance -> Data set entries -> Maintenance. 

If necessary, create new row and column models. 

Proceed as described in the definition of report rows and columns. 

For further report definition proceed as described in step 1. 

Determine general selections 

General selections include the characteristics according to which you select data for a report, but 

which are not to be identified in report rows or columns. 

Save your report. 

Insert your report into a report group. 

Further Notes 

Note the following when defining reports with Report Painter: 

The SAP System stores reports created with Report Painter in a special storage area, in the same name 

range as Report Writer reports. When generating the related report group or copying to a Report Writer 

report, Report Painter reports are converted to Report Writer format. This results in the following: 

- Report Painter reports can only be changed or displayed with Report Painter. 

To subsequently change a report with Report Writer, first copy the report to a Report Writer report 

under a different name. Then modify the report with Report Writer. The SAP system automatically 

generates the necessary sets during copying. 

It is possible to execute a Report Painter report with Report Writer and to assign Report Painter reports 

to a mixed report group, that is, to a report group that contains both Report Writer and Report Painter 

reports. 



 

 

Additional editing functions 

Below is an overview of functions and work techniques in Report Painter that will facilitate you report 

definitions. 

F2 key 

To define individual report columns or rows, select the specific column or row (in the report to be 

defined) by double clicking on the corresponding text (Column1, etc. or Row1 etc.) or with the F2 

key. 

Directories 

You can display existing objects (defined by SAP or yourself) for layouts, libraries, row or column 

models as well as predefined columns. 

Create with model 

If you want to define your own libraries, reports, layouts, row or column models, you can use the 

standard objects delivered by SAP to aid you and then adjust them to your needs. 

The following functions are available to structure and format the rows and columns of your reports: 

Working with row and column models 

When defining multiple reports with similar structure, it is useful to work with models. Models are 

one-dimensional, predefined modules for rows and columns, maintained with the the function 

"Model". To incorporate individual models into your report, choose "Edit -> Rows/Columns -> Get 

row/column model...". 

Formula editor 

You can define formulas to calculate a column, row or cell. 

Changing text 

You can make subsequent changes to column and row texts. Position on the desired object and 

choose the text function. 

Changing characteristic values 

You can make subsequent changes to characteristics of columns and rows. Position on the desired 

object and choose "Edit -> Change char.values". 

Expanding rows 

To expand groups down to the single value level, choose "Edit -> Rows -> Expand". You can then 

maintain totals levels. If you do not provide for expanding groups in the rows, the groups cannot be 

expanded in the report display. 

Note 

Formatting defined for expanded rows of a group is carried out for all sub-groups of the same summation 

level (indicated by the identical number of asterisks). Formatting includes color and underlining, for 

example. 

Markings for cell calculation undertaken in the expanded rows of a group are always based on the 

highest summation level of the group. If you require a subgroup, you must define an additional 

report row for the subgroup, mark the desired cell, and afterwards hide the additional row again. 

Show or hide rows/columns 

You can show or hide one or more rows or columns. You can show hidden rows/columns again, 

change them or delete them. 

Number formats 



 

 

With this function you can define the scaling and the number of decimal places (only for columns). 

Delete 

To delete rows or columns, position on the object to be deleted and choose the delete function. 

Select 

You can select one or more rows or columns to then delete, copy, cut, etc. the selected set. 

Maintain report texts 

You can enter a title page, last page, header or footing for each report. 

Note 

It is much easier to enter report texts in the finished report after you have finished defining it. 

Overview function 

With this function you can create an overview of all characteristics, indicators, predefined columns 

and rows with details (name, last person to change it, date of change). 

Goto 

You can branch between the sections of a report as well as create new sections. You can combine 

multiple rows and columns of a report. 

Format changes 

Report Painter provides five column formats, corresponding to the print classes of Report 

Writer. 

You can assign a standard layout to a report, as well as additional format changes, such as reversing 

the sign, row format changes or column width. Format changes always affect all columns with the 

same format; this means columms cannot be changed individually. 

Note on transport 

To transport Report Painter reports, see the IMG activity Transport Report Writer Objects in the IMG 

for Financial Accounting under Special Purpose Ledger -> Tools -> Transport. 

For more information on user-defined reports, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Information System -> Defining Reports. 

 Generate Reports 

You must generate the reports that you created in the current client or in a different client. Having 

defined the report, it only by generating it that a program capable of being run in the information system 

is created. 

Those reports that you created in a different client must first be imported into your current client. 

You have the following generation options: 

Generate some reports 

From a list of all reports, you select those that you want to generate. 

Generate all reports 

To generate all reports, you should create a background job for times of low system use. 



 

 

Activities 

Enter one or more report groups for generation. 

Use selection criteria to further delimit the reports to be generated. 

If you want to generate only a small number of reports, proceed as follows: 

Choose Program -> Execute. 

a) Select the report groups that the SAP System is to generate and choose Generate. 

To generate all reports, create a background job by choosing Program -> Execute in background. 

Further notes 

A report created with Report Painter is automatically generated when the report is started from report 

definition using Report -> Execute. In do doing, you assign a report to a report group. 

You can also generate report groups by choosing Report Painter -> Report Writer -> Execute report 

group. 

 User Settings 

In this activity, you define the default settings for calling up Report Painter reports. 

You can store the default settings either as a default setting for all users or as a user-specific setting. 

The user settings include: 

Settings for the report currency and for currency translations (report currency) 

Presettings for the selection criteria during the report call (selection criteria) 

Agreements on the work with extracts during the report call (settings for extract management) 

 Specify User Settings 

In this IMG activity, you specify the following user settings for the information system: 

Basic data 

Planning time frame 

Report time frame 

Report currency 

Other information, such as version and actual valuation 

You can store the basic data, planning and report time frames as user- specific or standard settings. The 

standard settings are valid for all users without user-specific settings. 

You thus determine the default values for the report selection screens. 

These settings are only valid for reports in components within Controlling or Cost Element Accounting. 



 

 

In the basic data, you can set the following default values: 

Controlling area 

Report objects, such as cost center groups, statistical key figure groups, activity type groups, cost element 

groups, or individual values or intervals for cost centers. 

You can determine the planning time frame as follows: 

Fiscal year 

The fiscal year can be the current year, previous year, or a year that you defined. 

If you choose No profile, the system takes the user-profile parameters for the selection. 

Note 

Maintain the User profile as follows: 

Choose System -> User defaults -> User data and the Parameters tab index. 

Period 

The period can be the current period, previous period, or a period interval that you specified. 

You can decide on the interval from period one to the current, or previous period. The current 

period, or the previous period is therefore defaulted for reports that you do not run during a period 

interval. 

If you choose No profile, the system uses the user-profile for parameter selection. 

You can specify the report time frame as follows: 

Fiscal year 

This can be the current fiscal year, the previous year, or an interval that you specify. If you 

choose No profile, the system uses the user-profile for parameter selection. 

Period 

The period can be the current period, previous period, or a period interval that you specified. 

The period can be the interval between period one to the current or previous period. The current or 

previous period is therefore defaulted for reports that you do not run during a period interval. 

If you choose No profile, the system uses the user-profile for parameter selection. 

You can store the report currency, either user-defined, or as a standard setting. The standard setting is 

valid for all users without user-defined settings. 

You use the report currency to specify which currency is used for Report Painter reports, line item 

reports or planning overviews, and to determine how the currency is translated. 

The settings are valid in Controlling and Cost Element Accounting for all planning overviews and Report 

Painter reports that have the Cost, Secondary cost, Actual cost, and Variable cost key figures, in 

which the currency is not defaulted 

In line item reports for Controlling, the settings are valid for the following columns: Cost in report 

currency, Variable costs in report currency, and Fixed costs in report currency. 

These settings are valid, regardless of the component used to define the report currency. 

You can display reports 

in Cost Element Accounting in: 

The company code currency 

The group currency 



 

 

The controlling area currency - A target currency that you specified - The 

Overhead Cost Controlling components in: - The controlling area currency 

The object currency 

The transaction currency 

A target currency that you specified 

In totals reports using report currency, if you call up another report using the report-report interface then 

the system displays both reports in the same currency. 

When you enter a target currency, specify which reference currency is to be used for the currency 

translation. In Cost Element Accounting, the reference currency can be the company code currency, 

group currency, or controlling area currency. In the Controlling components, it can be the controlling 

area currency, the object currency, or the transaction currency. 

You also need to enter the following: 

Key date for translation 

Translation for each exchange rate date 

Translation on a fixed date 

Period-specific translation on the last day of each period 

The exchange rate type that you require 

You can use the exchange rate type to differentiate between buying rate, bank selling rate, or the 

average rate. 

To display reports in euro for all users, for example, you need to specify this in the standard settings. 

Further entries 

Versions 

Default the plan version that you require for the reports. 

Actual valuation 

You enter settings for either legal, group, or profit center valuation. 

Requirements 

You need to process the Currencies IMG activity in the Implementation Guide under Global Settings. 

Activities 

Make default settings 

If you want to create or change default settings, you do not have to enter a user. Choose Execute. 

Choose Change standard. 

Make your entries choose Confirm to exit the dialog box. 

Save your entries. 

Make settings for one, several, or all users 

If you want to create or change the settings for one or more users, enter the corresponding user or users. 

To enter several users, choose Multiple selection. 



 

 

The system then displays a list of all users. 

Select the users you want to edit, then choose Copy to leave the dialog box. The settings 

of all selected users can now be edited. 

If you want to edit the settings for all users with user-specific settings, enter "*". The system 

displays a list of all users with user-specific settings. 

Choose Execute. 

If you selected users without any settings, you can transfer the settings from the default settings by 

choosing "Yes". 

If you want to enter new settings, choose "No". 

To create new user settings, proceed as follows: 

You want to create new settings for a user. 

Choose Create and enter the name of the user. 

You want to copy the settings for a user from those of an existing user. 

Select the existing user. Choose Copy and enter the name of the new user. 

You want to copy the settings for a user from the standard settings. Choose Copy from standard 

and enter the name of the user. 

To change user settings, proceed as follows: 

You want to change the settings of a user. Double-click the relevant line. 

You want to edit the settings of several users. 

Select the relevant lines and double-click one line. In the dialog box, you can display the 

settings for the selected users by choosing Previous user or Next user. 

You want to make the same settings for several users. 

Mark the relevant users. 

You can select all users, for example, with Select all. 

Position the cursor on a line in the column you want to change and choose Multiple replace. 

You want to change a certain setting for all users, who fulfill certain filter criteria. Upon fiscal year 

change, for example, you changed a cost element group and you would like to store the new 

group as a selection criterion for all users, who have used the old cost element group up to 

now. 

Select the column header to apply the filter to that column. 

Choose Set filter. 

Enter the filter criteria and choose Copy. The system displays a list of the users who fulfill the 

filter criteria. 

Choose Select all. 

Position the cursor on a line in the column you want to change and choose Multiple replace. 

Enter the required settings, and choose Copy to exit the dialog box. 

Save your entries. 



 

 

Notes on transporting 

To transport the default settings, choose Default settings -> Transport. 

To transport the settings for individual users, mark the corresponding users, and choose User settings -> 

Transport. 

Further notes 

To edit lists, use the ABAP List Viewer functions. For information on these, see the SAP Library: 

Cross-Application Components -> General Application Functions ( CA-GTF )-> ABAP List 
Viewer. 

 Generation of Virtual InfoProvider Cost Centers 

Use 

In this activity, you can generate a virtual InfoProvider on the basis of a controlling area. 

Using a virtual InfoProvider, you can execute queries for cost center line items in your ERP system by 

accessing the embedded BW functions available without having to first extract these from a BI system. 

Consequently, you can use for your data analyses not only the classic cost center line item report but also 

all SAP BusinessObjects BI clients, BEx tools, and other BI clients that are certified on the MDX 

interface for BW. 

Authorization Management 

Define Authorizations and Profiles 

Introduction to Procedure for Creating Activity Groups 

The following information describes the standard procedure for creating simple activity groups. 

It covers processing of an activity group with the option Basic maintenance in transaction 

PFCG. 

Step 1 

Create the activity group. 

Step 2 

In the Description field, enter a description of the function the activity group is to perform. 

Step 3 

On the Menu tab, assign transactions to the activity group. 

You can either enter the transactions directly. 

Alternatively, you can use the Menu selection key to assign menu options from the company menu 

(provided that this menu has already been generated in the current release). 

The activities selected from this menu are displayed in the session manager for all users assigned to 

the activity group as a user menu. 



 

 

Step 4 

On the Authorizations tab, choose Change authorization data 

Depending on which transactions you selected, a dialog box may appear on which you are 

requested to maintain the Org. levels. These organizational levels are authorization fields that 

appear simultaneously in many authorizations and which can be maintained together this way. 

An example here is the company code, which appears in many authorization objects. By 

assigning values to the organizational levels, you are also maintaining the corresponding 

authorization fields for all authorizations in the overview tree that follows. 

The system displays an overview tree of all authorizations that SAP suggests for the transactions 

selected. Some of these authorizations already contain values. 

For those authorizations where an amber traffic light is displayed, authorization values must be 

manually entered. You enter these values by clicking on the white line to the right of the 

authorization field. Once you have maintained the values, the authorizations are classed as 

manually modified and are not overwritten if you include more transactions and reprocess 

authorizations. By clicking on the traffic lights, you can assign the full authorization for all 

non-maintained fields for the hierarchy level in question. 

A red traffic light indicates that organizational levels exist that do not yet contain any values. You 

can enter/change these values by choosing Org. levels. 

If you require further functions in the overview tree like copying or combining authorizations, you 

can display additional functions by choosing Utilities -> Settings. 

Generate an authorization profile for the authorizations. To do so, choose Authorizations -> 

Generate. 

The system now asks you to enter a name for the authorization profile that now arises and defaults a 

name that exists in the customer name range. 

Once the profile has been generated, exit the overview tree. 

If you make changes to the menu selections and then call up the overview tree for the 

authorizations, the system tries to add the authorizations for the new transactions to the 

existing authorizations. In so doing, traffic lights can be changed back to amber 

becauseauthorizations that are not fully defined appear once more in the overview tree. You 

then need to enter values manually for these authorizations or to delete them if they are not 

required. 

To delete an authorization you must first deactivate it. 

General authorizations like spool display and printing are not generally defined for the transactions. 

For this reason, authorization templates exist that you can add to the existing data. To do so, 

from the menu choose Edit -> Insert auth. -> From template... and choose one of the 

templates from (for example SAP_USER_B Basic authorization for application users or 

(for example SAP_PRINT Print authorization). Alternatively, you can also create a 

separate activity group for these general authorizations, simplifying handling. 

Step 5 

On the User tab, assign users to the activity group. 

For the users assigned, the menu items belonging to the activity group are displayed in the session 

manager as a user menu. 

In addition, the generated authorization profiles are automatically 

entered in the user master record when you carry out the User master comparison. To do so, 

choose User compare on the User tab and then choose the option Cpmplete compare. 



 

 

If you do not narrow down the selections by specifying a particular period, but instead use the 

period defaulted by the system (current date to 12/31/9999) no further action is necessary. If 

you specify a particular period, then you need to ensure the report program 

PFCG_TIME_DEPENDENCY is scheduled periodically every day. This report 

automatically updates the user master records. You also need to schedule this report if using 

Organizational Management (no further details on this are entered into here). 

It is extremely important that you never enter generated authorization profiles directly in the user 

master records (as is the case for manually created authorization profiles). You can only link 

generated profiles to users by assigning the users to the 

corresponding activity group and then running a compare on the user master data. When the 

system runs the compare, it enters the profiles of the activity group for all users belonging to 

the activity group. 

Step 6 

If you want to transport the activity group into another system, you now need to enter the activity 

group in a transport request. 

To do so, choose Activity group -> Transport.. You can now specify whether the user assignment 

should also be transported. 

The authorization profiles are also transported (unless you specified that you do not want them to 

be transported). 

Following the import in the target system, you then need to carry out a full user master compare for 

the imported activity groups. You can either start this comparison yourself or it can be carried 

out automatically by report program 

PFCG_TIME_DEPENDENCY (assuming this report is scheduled to run periodically in the 

target system). 

Detail information 

See also the general documentation on the Profile Generator in the SAP Library. Choose: 

Basis Components -> Computing Center Management System -> Users and Roles or in the 

Implementation Guide (IMG), choose: Basis Components -> System Administration -> Users and 

Authorizations -> Maintain Authorizations and Profiles using Profile Generator. 

Develop Authorization Enhancements for Periodic Reposting and 

Allocations 

The following SAP enhancements are available for authorization checks during periodic transfer, 

distribution, assessment and indirect activity allocation: 

SAPMKAL1 Allocations: Authorization check during cycle maintenance This 

enhancement includes the following enhancement component: 

EXIT_SAPMKAL1_001 

Customer exit for the cycle maintenance authorization check 

SAPMKGA2 Allocations: Carry out authorization check for cycle This 

enhancement includes the following enhancement component: 

EXIT_SAPMKGA2_001 

Execute customer exit for cycle authorization check 



 

 

Activities 

Create the enhancement 

To do so, either create a new project or use an available project. 

Activate the project. 

Your enhancement becomes effective only through activation. 

Further notes 

Unlike modifications, enhancements are compatible with any release because they are not part of the 

SAP original and reside in a namespace reserved for the customer. 

Information on the procedure when using enhancemnts can be found in the enhancement transaction 

CMOD under "Utilities -> Online manual" in the section "Function exits". 

For more information on the enhancement, refer to the documentation of the enhancement. You find it in 

the CMOD enhancement transaction by choosing "Display SAP documentation". 

 





 

 

 


