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15.5 Bank Accounting 

15.5.1 Account Balance Interest Calculation 

In the following steps, you make all the settings necessary for account interest calculate on. 

 

 

 

15.5.1.1 Define Interest Indicators (Int.Calc.Type) 

In this activity you make the following settings for 

- Interest terms that are stored 

- Under an interest calculation indicator, or - specifically for an account. 

The interest calculation indicator is entered in the master record. 

For account-specific terms, SAP recommends setting up variables, such as xy, to store terms for just 

one account. 

- Interest calculation types that are used to 

- calculate interest on arrears ( by item), or 

- Calculate account balance interest (interest scale). 

Activities 

1. Define an interest indicator with a two-character ID. 

2. Enter a name for each interest calculation indicator. 

3. Select "New ICID" if the interest terms are stored specifically for an account. 

4. Specify the interest calculation type. 

15.5.1.2 Specify General Terms 

In this activity you specify the general terms for each interest calculation indicator. For all accounts 

included in automatic interest calculation, you must 

- Specify the calendar type 

- Define the day of settlement for account balance interest calculation 

- Specify the interest calculation frequency 

In the master record, you can also store the interest calculation frequency specifically for an account. 



 

 

Furthermore, you can 

- Define the minimum/maximum amount from which the system should calculate interest 

- Set the features controlling the interest calculation indicator 

Actions 

1. Specify the calendar type, day of settlement, and interest calculation frequency for each interest 

Calculation indicator. 

2. Define the controlling features for each interest calculation indicator according to your requirements. 

15.5.1.3 Specify Time-Based Terms 

In the "Time-dependent terms" step, you store the interest rates or interest references for the "Interest 

calculation indicator", "Currency" and "Amount as of" key fields. Terms can also be set so that they are 

dependent on the amount. 

Amount-dependent interest references or rates are to be stored together per transaction type and "Date as 

of."  The interest references and rates stored per transaction type and "Date as of" determine the interest 

references valid as of that date and their amount-based scaling. 

An interest rate can also be stored independently of a reference interest rate. 

Note 

All data previously stored is considered invalid after this date. 

This means that when you change the individual rates, you always have to maintain all rates belonging to 

this transaction type, this interest indicator, and this currency in the "Date as of" field. 

Activities 

1. For each "Interest calculation indicator", "Currency", and "Date as of", store 

- the transaction type code you defined 

- a reference interest rate 

- a surcharge 

To store an interest rate independently of a reference interest rate, make no entry in the 

"Reference interest rate" field and enter a positive value in the "Surcharge" field. 

2. If necessary, you can also store amount-dependent interest references and rates for each transaction 

type and "Date as of". 

15.5.1.4 Reference Interest Rates 

In the following steps you define an ID for each reference interest rate and enter the appropriate value for 

each validity date. 
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15.5.1.4.1 Define Name for Reference Interest Rates 

In this step, you enter a name for the reference interest rates. 

Actions 

Enter a long text and a short text for each reference interest rate. You can also enter the currency, the 

financial center, and the date from which the interest rate is effective. 

15.5.1.5 Define Transaction Type Name 

In this step, you define transaction types for the interest rate determination.  You can change the name of 

the transaction types (long text and short text). 

The ID you store here is used to determine the time-dependent terms. 

Default Settings 

The following transaction types are delivered with the standard system: 

- Calculation of interest(int) on arrears: interest credit CREIR 

- Acct balance int calculation: interest credit  C_SAL 

- Calculation of int on arrears: interest debit  DEBIR 

- Acct balance int calculation: interest debit  D_SAL 

Actions 

Enter a long and a short text for each transaction type defined. 

15.5.1.6 Maintain Posting Specs/Account Determination for Int. Calc. 

In this step, you store the posting rules for each business transaction you need for calculating interest on 

your G/L accounts. 

In addition to the "Business transaction" account determination key, you can define different posting 

methods for three additional account determination keys: 

- company code 

- interest indicator 

- business area 

You then select the account determination and set up an account symbol for each posting transaction. 

Account symbols are used to group together similar business transactions (for example, posting interest 

income) and to direct them, if necessary, to different accounts depending on the currency. Therefore, you 

can have flexible account determination when revenue and expense accounts are to be posted to differently. 



 

 

As a rule, you create at least one posting method for the interest received posting and the interest expense 

posting. If you are using interest splitting, you must create at least one posting method for the following 

postings: 

- past period with post-entered value dates, minus debit interest; past period with post-entered 

value dates, minus credit interest 

- past period with post-entered value dates, debit interest; past period with post-entered value 

dates, credit interest 

- settlement period, debit interest; settlement period, credit interest 

Actions 

1. Store the posting rules for your business transactions. 

2. Create account symbols for similar business transactions. 

3. Allocate to the accounts the account symbols for the respective interest received or interest expense 

accounts. 

When posting to balance sheet accounts, you can use a partially-masked entry. 

Further Information 

General information on account determination can be found in the text on the Posting interface. 

15.5.2 Bank Accounts 

In the following activities you make the settings for bank accounts. 

15.5.2.1 Define House Banks 

Each house bank of a company code is represented by a bank ID in the SAP system, every account at a 

house bank by an account ID. 

In the SAP system, you use the bank ID and the account ID to specify bank details. These specifications 

are used, for example, for automatic payment transactions to determine the bank details for payment. 

Standard settings 

Several house banks are supplied as examples in the standard system in order to enable configuration of 

the payment program. 

Note 

For domestic banks, you should enter the bank number in the "bank key" field and for foreign banks, you 

should enter the SWIFT code in this field. 

For Belgium, the first three house bank ID items must be numeric. 

Do not forget to create a G/L account for the specified bank account. The G/L account is to be managed in 

the same currency as the account at the bank. 
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Activities 

1. Work out the specifications you have to enter in the system for your house banks. 

2. Define your house banks and the corresponding accounts in the system under a bank ID or an account 

ID. 

Additional information 

If you have already carried out the step   "Copy bank directory", you have already created house banks in 

the system or have updated the house bank data that already existed. 

If this is the case, in this step you only have to create the house banks that were not created in the "Copy 

bank directory" step. You can also add any data that may be required to house banks that were copied 

along with the bank directory. 

15.5.2.2 Check Post Office Bank Branch Numbers 

Specify the valid numbers of the post office bank branches for each country. These specifications are used 

to check the post office bank current account numbers. 

Standard settings 

The numbers of the post office bank branches in Switzerland and Germany are contained in the system. 

Activities 

1. Check the numbers of the post office bank branches specified in the system. 

2. Add missing numbers if necessary. 

15.5.2.3 Enter Name of Building Society 

In this step, you enter the name of the Building Society for each bank or bank account. This is valid for 

Great Britain. 

In order to guarantee that every transaction is carried out within two days, the name of the Building Society 

must be entered in the data carrier. 

Activities 

Please enter the name of the Building Society to make identification of the bank key and account 

Number easier. 



 

 

15.5.2.4 Define Lockboxes for House Banks 

In this step, you define your lockbox accounts at the house banks. Thus, on the outgoing invoice you can 

inform your customer of the lockbox to which payment is to be made. By specifying this, you can optimize 

the payment transactions. The lockbox procedure is currently used only in the USA. 

Activities 

1. Specify your lockbox links (company code; key of the lockbox to which the customer is to pay; house 

bank ID; lockbox number at your house bank). 

2. For customer master data, you can determine to which lockbox number the customer is to pay in the 

application menu ("Payment Transactions / Company code data"). 

3. Include two new fields in table VBDKRZ, for example, ZZBANK for the house bank ID at which 

you have the lockbox, and ZZLOCK for the lockbox number. Note that the names of these fields must 

begin with "ZZ" since SAP has left these name ranges free for new, user-defined fields. 

4. The user interface for the outgoing invoice needs to be expanded. To do this, you have to enhance 

program V05NZZEN as follows: 

            TABLES: KNB1, T049L. 

            SELECT SINGLE * FROM KNB1 WHERE KUNNR = VBDKR-KUNRG                                       

AND BUKRS = VBRK-BUKRS. 

            SELECT SINGLE * FROM T049L WHERE BUKRS = VBRK-BUKRS                                       

AND LOCKB = KNB1-LOCKB. 

            VBDKR-ZZLOCK = T049L-LCKNR. 

            VBDKR-ZZBANK = T049L-HBKID. 

5. Include the new fields VBDKR-ZZBANK (key of the house bank at which you have the lockbox) and 

VBDKR-ZZLOCK (lockbox number) in the form for the customer invoices (SD application). 

15.5.2.5 Develop Enhancements for Bank Account Numbers 

The following SAP enhancements are available for the "Bank account" area: 

- SAPLSSRV prior to checking the validity of the bank account number 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 

to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 

In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 
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For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

15.5.2.6 Develop Enhancements for Bank Data 

The following SAP enhancement is available for bank data: 

- SAPLBANK Prior to Checking the Validity of Bank Address Data 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 

to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 

In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 

For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

15.5.2.7 Changes Display 

In the following steps, you make the settings for displaying the bank master data changes. 

15.5.2.7.1 Define Field Groups for Bank Master Data 

In this step, you define the field groups for the program for the change display of the bank master data. 

For this, you store the following information: 

- Key (one-digit to two-digit, numeric) for the field group 

- Name for the field group 

Activities 

Define your field groups. 



 

 

Further notes 

For more information on the display of change documents for the bank master data across all banks, please 

refer to the report documentation (program RFBKABL0). 

15.5.2.7.2 Group Bank Master Record Fields 

After you defined the field groups here, you allocate the required master record fields to the field groups. 

You specify the complete identification code of the fields from the Data Dictionary as well as a field 

description. 

Example 

You group together, for example, the master record fields BNKA-BANKA (financial institution) and 

BNKA-ORT01 (city) under the field group 1. 

Activities 

1. Allocate the fields to the groups. 

2. Then enter the corresponding field groups into program RFBKABL0. 

15.5.2.8 Define Orbian Details 

In this activity, you define the Orbian bank details if you use the Orbian payment system for your payment 

transactions. 

Orbian provides you with an electronic means of payment for paying your vendors. When this means of 

payment is due, you transfer the money to the Orbian bank details that you define here. 

You can only see the assignment of the Orbian Active Account to the respective Orbian Reserve Account 

in this view. 

You specify the Orbian details specific to the following: 

- Company code 

- House bank 

Enter the Orbian house bank ID that you created previously in Customizing for Bank Accounting. 

(See the Prerequisites section). 

- Orbian Reserve Account 

Specify the Orbian Reserve Account ID that you previously created in Customizing for Bank 

Accounting (see the Prerequisites section). 

- Orbian Active Account 

Specify the Orbian Active Account ID that you previously created in Customizing for Bank 

Accounting (see the Prerequisites section). 

Requirements 
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1. You have created Orbian as a financial institute in the SAP System. To do this, execute transaction 

FIOR. 

2. You have created Orbian as house bank in customizing for Bank Accounting in the activity Define 

House Banks. 

3. You have created the corresponding Orbian Reserve Account and Orbian Active Account as 

accounts of the Orbian house bank in the activity Define House Banks. 

4. You have activated Orbian payments at client level in customizing for Bank Accounting in the activity 

Activate Orbian Payments. 

5. You have made the Settings for the Automatic Payment Program in Customizing for Accounts 

Receivable and Payable. 

15.5.2.9 Country-Specific Functions 

15.5.2.9.1 Brazil 

15.5.2.9.1.1 Assign ISPB Codes to Bank Codes 

Use 

In this Customizing activity, you can assign an ISPB code to a payee's bank code. 

During payment run, the system includes the ISPB code in the output payment file if the following 

conditions are satisfied: 

- Output payment file is generated by DME Brazil - A/P (RFFOBR_U)  report 

- Output payment file is based on Febraban 8.7 file layout version 

15.5.3 Bank Chains 

In the following activities you make the settings for the bank chain function. 



 

 

15.5.3.1 Define Scenario 

Use 

In this activity you define scenarios for determining bank chains. A scenario specifies the way in which a 

bank chain is to be determined: 

- generally, i.e. not dependent on certain business partner bank details (general search) 

- dependent on the business partner (recipient-specific search) 

- with which fields and in which order 

Standard settings 

The SAP standard system contains a number of standard procedures (scenarios). 

You cannot make changes to the standard system. If, however you need to make only minor changes, you 

should copy the standard delivery and adjust the copy to meet your requirements. 

Activities 

1. Check whether you can use one of the scenarios provided. 

2. If you cannot, define your own scenario in a separate name range (starting with Y, Z or 9). 

Note 

Please note that this can slow performance considerably, because secondary indexes have only been 

created for the relevant database tables for the scenarios provided. If you want to create indexes, you 

should contact SAP. 

a) Choose Edit -> New entries. 

b) Enter the data necessary for defining a scenario: 

- an ID for the scenario (0003, for example) 

- a description of the scenario (general bank chain determination, for example) 

3. Select Gen.Search if payments to be made are not dependent on the partner's bank details, and 

Rec.Search if the payments are to be dependent on the bank details. 

Note 

If you select both search options when determining the bank chain, the system first runs a search for 

a recipient-specific (that is, partner-dependent) bank chain, and then for a general bank chain. 

4. Select the defined scenario, and choose Scenario characteristics by double-clicking. Enter the 

necessary data. 

Example:  

ScenarioRanking SenderBank RecipCntry RecipBank Currency 

0003 0 yes yes                  ye 

0003 1 yes yes 

0003 2 yes 
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Further notes 

For more information on bank chains, see the SAP Library under FI - Financial Accounting -> Bank 

Accounting -> Bank Chains. 

15.5.3.2 Activate Bank Chain 

Use 

In this activity you activate the bank chain function. In doing so, you specify that a bank chain is to be 

determined for a payment. In the activity Define Scenario, you decided whether to use an existing scenario 

to determine the bank chain, or whether to define a new scenario. You specify that scenario here. 

Activities 

Enter the required scenario (such as 0003) for determining the bank chain for the current client. 

Further notes 

For more information on bank chains, see the SAP Library under FI - Financial Accounting -> Bank 

Accounting -> Bank Chains. 

15.5.3.3 Create General Bank Chain 

Use 

In this activity you define general bank chains. This means that payments can be processed via a general 

bank chain and are not dependent on the business partner's bank details. 

Activities 

1. Define the sequence of banks and the accounts from which payments are to be made. Select the 

line containing the data you have entered, then choose Bank chain. Enter the required data. 

Example: 

BankChn No. Cat Corr.ctry Corr.bank key Bank acct 

00001 1 1 DE  111555 123123123 

00001 2 2 US  222444 456456456 

00001 3 3 US  333666 321321321 

2. Define the bank chain to be used for a predefined combination of the following criteria: 

- Currency 



 

 

- Sender bank country 

- Sender bank key 

- Recipient bank country 

- Recipient bank key 

- Payment method supplement 

Choose Edit -> New entries and enter the required data. 

Example: 

Crcy BankCtryS BankKeyS RecipCtry BankKeyR Bank chain 

DEM 

00001 

Further notes 

For more information on bank chains, see the SAP Library under FI - Financial Accounting -> Bank 

Accounting -> Bank Chains. 

15.5.4 Business Transactions 

In the following activities you make all the settings necessary for business volume in banking-related 

accounting. 

15.5.4.1 Check Deposit 

In the following steps you will make all the settings necessary for check deposit. 

15.5.4.1.1 Create and Assign Business Transactions 

In this step you store transaction indicators for check deposit and allocate these indicators to a posting rule. 

You specify this indicator in the "Transaction" field on the initial screen of check deposit. 

Account Modification 

You may want to post individual transactions to an account different from the one provided by the posting 

method for the posting rule in question. To do this, you create an account modification. 

By specifying an account modification, you can control account determination so that the system posts the 

transaction to a modified subaccount and not to the standard account. For more details on account 

determination see the section "Define posting rules for check deposit". 

Actions 

1. Define transaction indicators. 
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2. Allocate a posting rule to each transaction indicator. 

3. If necessary, set up an account modification. 

15.5.4.1.2 Define Posting Keys and Posting Rules for Check Deposit 

In this activity you store the posting keys and posting rules for check deposit. 

Creating Keys for Posting Rules 

Under this node, you define a posting rule for check deposits. The key determines the posting rules for 

general ledger and sub ledger accounting.  The posting rule represents the business transactions typical of 

the check deposit, such as: 

- Incoming check to check clearing 

- Check clearing to customer 

- Bank to incoming check 

Defining Posting Rules 

You specify the posting rules for either one or two posting areas, depending on whether the posting 

transaction affects only the general ledger or also the sub ledger. 

For example, you need only one posting area if you do not use any clearing accounts, but instead directly 

debit the bank account and credit the incoming check account. 

Creating Account Symbols 

You then control the account determination for each posting transaction and set up an account symbol for 

this. 

In account determination, an account symbol previously setup depending on various modification factors 

is replaced by an account to be posted to. 

Account symbols are used to group together similar business transactions (such as incoming checks) and 

to direct them to different accounts according to a pre-determined differentiation. This enables you to have 

flexible account determination for clearing accounts that are to be posted to differently. 

Examples of flexible account determination 

1) You want to manage incoming checks in foreign currency (e.g., DEM) in a clearing account different 

from the account where you manage incoming checks in local currency (e.g., US$). You can do this with 

the following setup: 

Account symbol Currency G/L account  

Incoming checks + ++++++++09 ( LC cash inflow ) 

Incoming checks DEM ++++++++14 ( FC cash inflow ) 

The completely masked entry (++++++++++) in the "G/L account" field would lead to the outgoing 

account entered during check deposit. 

2) You want to direct checks from the US to an account different from the one intended for incoming checks 

in US$. To do this, you must create an account modification for this business transaction and specify the 

account to post to: 



 

 

Account symbol Account modification G/L account 

Incoming checks Checks USA 0000099999 ( checks USA ) 

Incoming checks + ++++++++08( other checks 

In US$) 

Actions 

1. Depending on the posting transaction, create one or two posting areas: 

a) one for the bank posting 

b) One for the sub ledger posting. 

2. Store the posting rules for each posting area. 

3. Create account symbols for the required transactions. 

4. Store account determination rules for the affected account symbols. 

Additional Information 

You will find general information about account determination in the text on the posting interface. 

15.5.4.1.3 Define Variants for Check Deposit 

In this step you can create your own account assignment variants for check deposit in order to modify the 

arrangement and/or selection of account assignment fields according to your company-specific 

requirements. 

One variant is delivered as a default. It cannot be changed. 

If you do not want to work with the standard variant, you can deactivate it. New variants must be activated 

after you create them. 

Actions 

1. To create a new variant, select Variant --> New variant --> Create.... 

2. In the pop-up window, enter the variant ID, description and the number of account assignment lines. 

On the next screen, you see the possible account assignment fields in the right column. The fields for 

the account assignment variant you will use are to be entered in the left column. The field Amount is 

predefined as a required field. 

3. Select the required fields from the list of possible fields. 

The fields you select are transferred to the list of current fields and displayed one after the other (up 

to 80 characters). The offset column provides information on how many characters are needed in an 

account assignment field. 

4. Save your account assignment variant and then activate it. 

Changing a Variant 

Variants that are created can be modified at any time. 

1. To delete an account assignment field, select Edit --> Delete field. 
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2. To add a new account assignment field, place the cursor on the preceding field and select the field 

You require from the possible fields in the right column. 

If necessary, adjust the field positions by using the function "Change offset". 

15.5.4.1.4 Define Value Date Rules 

In this activity, you make the following specifications for certain bank-related transactions (for example, 

bill of exchange presentation, and incoming checks) for each house bank and each account: 

- Reference date for determining the value date 

This date forms the basis of the agreement made with the bank as to when the value date is to occur. 

- Rules for determining the precise value date 

The value date is determined as follows: You first enter a certain number of days. The system 

determines the value date from this number of days starting from the reference date. 

It is also possible to determine this date according to a calendar identification (= K1) you have 

defined. If you enter a calendar ID, only working days are taken into account when determining the 

date. If you do not enter a calendar, the system not only takes working days but also weekends and 

public holidays into account. 

In a second step, the date determined by the system is now checked according to a second calendar 

ID as to whether it is a Sunday or public holiday. This can be the case: 

- If you did not proceed according to a certain calendar ID when determining the date, that is, all 

days, including weekdays and public holidays were taken into account when determining the 

date 

- If a certain day (for example, Corpus Christi) is a working day according to the first calendar 

ID (for example, in Berlin), and yet is a public holiday according to the second calendar (for 

example, in Bavaria). 

If it is actually a weekend day or a public holiday, the system moves forwards or backwards within a 

given time until it finds a working day according to the second calendar ID you entered. The system 

has thus calculated the final value date. 

Activities 

Define the necessary data for each house bank, account, and transaction for determining the value date. 

15.5.4.1.5 Define Forms 

In this step you specify a form for the check deposit list. You may need several forms for various banks. 

Actions 

1. Check whether you can use the standard form, "F_M40S_CHEQUE". 



 

 

2. If necessary, enter this form name in the "Form" field. 

3. Otherwise, define your own forms with SAP script and store them here. 

If you use several forms, enter a form ID for each one. 

15.5.4.2 Bill of Exchange Transactions 

In this section you can make the system settings for bill of exchange transactions. 

15.5.4.2.1 Bill of Exchange Receivable 

In the following activities, you make settings for bills of exchange receivable. 

15.5.4.2.1.1 Request bill of exchange Receivable 

15.5.4.2.1.1.1 Bill of Exchange Payment Request Dunning 

In the following steps, you make the settings for dunning bill of exchange requests. 

15.5.4.2.1.1.1.1 Define Form Names for bill of exchange Pmnt Request Dunning 

In this step, you define the form names for the multi-level dunning of bill of exchange payment requests 

to your customers. 

This procedure is common in France. 

Activities 

1. Determine the names of the standard forms. 

2. Check whether you can use these forms. Define and translate your own forms, if necessary. 

3. Define the names of the forms. 

 

15.5.4.2.1.1.1.2 Define Headers and Footers for Bill/Ex.Pmnt Request Dunning 

In this step, you define the texts which are to be used for the letter header, the letter footer and the signature 

line of the forms dependent on company code. 

Note 
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This procedure is useful if you use one form for several company codes. In this case, you have to store the 

company code-specific texts separately. 

Activities 

1. Create your standard texts. 

2. Specify the texts that are to be used for the individual company codes. 

15.5.4.2.1.2 Post bill of exchange Receivable 

15.5.4.2.1.2.1 Make and Check Document Settings 

You can make new document settings here, or check existing settings, so that they correspond to the 

business transaction you are currently processing: 

- If you have already made document settings in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that those settings are correct here. 

- If you have not yet made any document settings, you can do so here. 

15.5.4.2.1.2.1.1 Define Document Types 

In this activity you create document types for customer, vendor and general ledger business transactions in 

Financial Accounting. Document types differentiate business transactions and control document filing. 

You specify a number range for each document type. Document numbers are chosen from this number 

range. You can use one number range for several document types. 

Document types are valid for all clients. You specify a number range key for each document type. You 

create the desired number range intervals for each number range key based on the company code. This 

means that you can specify intervals of different sizes for the same number range. 

Example 

You defined a document type for incoming invoices. In company code 0001 there are a lot of invoices to 

be posted. Thus you create a large number interval for the number range in this company code. In another 

company code there are only a few incoming invoices that need to be posted. For this company code you 

can define a small number interval for the same number range. 

If a document type is not used in a company code, do not store a number interval for that company code. 

Note 

To use the net method of posting documents, you need a net document type (for example, KN). In this 

document type, you have to set the "Net document type" indicator found under the "Control" area. You 

can define a common document type (for example, AB) and a common number range for clearing open 

items in accounts receivable, payable and G/L accounts. 



 

 

For automatic posting transactions (for example, transfer postings with clearing), you have to define a 

clearing document type (for example, AB). If you do not want to use the standard setting AB for the 

clearing document type, you can delete it and define your own. Under the document type properties, you 

can assign an individual reverse document type to each document type. For document types with external 

number ranges, you have to define an individual reverse document type because the system can make 

automatic reverse entries only in document types that have internal number assignment. 

Standard settings 

The pre-set document types cover business transactions 

- in Financial Accounting for: 

- General ledger accounting 

- Accounts receivable 

- Accounts payable 

      - Asset accounting 

- Consolidation 

- in Materials Management and Sales and Distribution for: 

- Goods receipt and issue 

- Incoming and outgoing invoices 

- Physical inventory ( stocktaking ) 

- Invoicing 

Activities 

1. Find out whether you can use the standard settings. 

2. Change or extend the default settings, if necessary. 

3. Check the specified document number ranges via the "Define document number ranges" activity if 

you use the standard document types. 

These number ranges must be created for your company codes and contain the number intervals you 

require. 

 

 

15.5.4.2.1.2.1.2 Define Posting Keys 

In this activity you define posting keys. Users specify a posting key before entering a line item. The posting 

key controls how the line item is entered and processed. 

For each posting key, you define among other things: 

- which side of an account can be posted to, 

- which type of account can be posted to, and 
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- Which fields the system displays on the entry screens and whether an entry must be made (field 

status). 

Note 

The system also uses the field status group you specify in a G/L account to determine the status of fields 

in document entry. Field status groups are defined within a field status variant. 

Recommendation 

Use the posting keys delivered with the standard system. 

Activities 

1. Check the standard settings. 

2. Modify them if necessary. 

In particular, you may need to make changes to customer and vendor posting keys if a different field 

status is required. 

15.5.4.2.1.2.1.3 Validation in Accounting Documents 

In this activity, you define additional checks for accounting documents in the form of validations for each 

of your company codes. You can assign a validation for the document header and one for the line items to 

each company code. The assigned validations are valid both for manual entry of documents as well as for 

the automatic creation of documents (for example, payment program). 

For every company code to which you want to assign a validation, you store the following information: 

- Validation callup point 

Here you enter key "1" for "Check document header" and key "2" for "Check line item". 

- Validation 

Here there are the names of validations which already exist which you can display or change. A new 

Validation must firstly be created by you. Afterwards the name appears in the overview. 

- Description of the validation 

- Activation level 

Here you enter key "0" for inactive, key "1" for active and key "2" for active except for batch input. 

Example 

For example, you can use the validation for the following situation: You want to make sure that postings 

to the expense account "Telephone costs" can only be posted to the services cost center "Telephone". You 

can carry out the checks needed for this by using the validation. 

Activities 



 

 

If you want to define new validations, go through the following activities: 

1. Place the cursor on a line in which company code and callup point are entered (you can enter company 

code and validation callup point via Edit -> New entries). 

2. Afterwards select Environment -> Validation. You reach the first screen for maintaining a 

validation. 

3. Select Validation -> Create. Enter the required name. After pressing ENTER, you come to an 

overview screen of the validation activities belonging to the validation. 

4. Select Insert entry. On the next screen you can describe a new validation activity. You describe the 

check requirements and the actual check for this. The syntax to be used for this is described in the 

online help (F1 help) for the input fields for Requirements and Check. You can also define a 

message (warning or error message) which is sent if the check is not successful. 

If you want to change validations which already exist, proceed as follows: 

1. Place the cursor on an already existing entry and select Goto -> Validation. 

2. On the next screen select Validation -> Display or Validation -> Change. After pressing ENTER, 

you get to the overview screen of the validation activities belonging to the validation. If you select 

Insert entry, you can carry out changes if necessary. 

15.5.4.2.1.2.1.4 Define Texts for Line Items 

In this activity, you can store texts under keys which can be transferred to the line item. When entering a 

document, the key is entered in the text field. 

Note 

If you wish, the texts can be transferred to the customers in payment notices. 

Activities 

1. Find out which texts are to be stored. 

2. Enter these texts into the system under a key. 

15.5.4.2.1.2.1.5 Define Default Values 

In this activity, you define default values for document types and posting keys which otherwise must be 

entered by the user when processing business transactions. Your specifications depend on the function 

code. 

Example 

When posting outgoing invoices, you use the document type "DR" and posting key "01". You can store 

these specifications in the system. They are proposed by the system when you call up the corresponding 

transaction. 

Activities 
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Define the required default values. 

15.5.4.2.1.2.1.6 Define Field Status Variants 

In this activity you can define and edit field status variants and groups. You group several field status 

groups together in one field status variant. You assign the field status variants to a company code in the 

activity Assign Company Code to Field Status Variants. This allows you to work with the same field status 

groups in any number of company codes. 

You can also define and process field status groups. You must define a field status group in the company 

code-specific area of each G/L account. The field status group determines which fields are ready for input, 

which are required entry fields, and which are hidden during document entry. Bear in mind that additional 

account assignments (i.e. cost centers or orders) are only possible if data can be entered in the 

corresponding fields. 

Standard settings 

Field status variant 0001 is entered for company code 0001 in the standard SAP software. Field status 

groups are already defined for this variant. 

Note 

You cannot attach a field status to some fields, such as those in the document header. You can, however, 

switch between required and optional entry field designations in the document type for some of these 

header fields. 

The field status group you enter in the reconciliation accounts affects postings to the related customer or 

vendor accounts. You cannot enter a field status group in the customer or vendor accounts. Field status 

groups are determined for customer and vendor accounts from their respective reconciliation accounts, via 

the G/L account number in their master records. 

There are other factors, besides the field status group itself, which have an influence on the field status. 

Among these are: 

- The field status defined for the posting key. 

The status "optional entry field" was assigned to posting keys 40 and 50 in the standard system. These 

are the standard posting keys for G/L account postings. The "optional entry field" status has no effect 

on the field status. 

- Specifications for the document type. 

You can specify here that a reference number and document header text must always be entered, for 

example. 

Recommendation 

Designate field status via the field status groups in the G/L accounts. This allows you a more account-

specific screen layout. You cannot differentiate by posting key, since there are only two such keys for 

postings to G/L accounts. 



 

 

The situation with reconciliation accounts is different. You do not make any differentiated field status 

definition via the master record for these special G/L accounts. You use the debit and credit posting keys 

instead. 

Activities 

1. Create new field status variants using Edit -> New entries. You can also use the copy function to 

create new field status variants. To do this, select Edit -> Copy as. When copying field status 

variants, the accompanying field status groups are also copied. 

2. Look at the standard field status groups. 

3. Find out which fields on the entry screens should be 

- ready for input 

- required entry fields 

- Hidden for the G/L accounts in your company. 

You do not make this definition for each account, but rather for groups of accounts. This is why you 

may want to adapt the field status groups included in the standard system. 

4. If necessary, change the standard field status groups, or define your own for each field status variant. 

5. You can delete field status variants that are no longer required via Edit -> Delete. The accompanying 

field status groups will also be deleted. 

 

15.5.4.2.1.2.1.7 Assign Company Code to Field Status Variants 

Use 

In this IMG activity, you assign the company codes in which you want to work with identical field status 

groups to the same field status variant. 

You define your field status group per field status variant. For more information, see Define Field Status 

Definition Groups. 

Standard settings 

In the SAP standard, a field status variant of the same name is assigned to company code 0001. 

Activities 

Assign the company codes concerned to the same field status variant. 

15.5.4.2.1.2.1.8 Screen Variants for Document Entry 

The screen variant which you specify for each company code addresses special screens for documents for 

several specific functions. You determine the screen variant dependent on the company code. 
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Example 

In an Italian company code, for example, a screen with fields for withholding tax is required when entering 

a vendor item. You therefore have to select a special screen variant for Italian company codes. 

Standard settings 

A corresponding variant was selected for the standard company codes. 

Activities 

Check whether the required variants have been selected for your company codes. 

 

 

15.5.4.2.1.2.1.9 Define Subscreens for Coding Blocks 

Use 

In this IMG activity, you can define your own subscreens for posting transactions. In posting transactions, 

the account assignment objects are displayed on subscreens. If the fields on a subscreen are not sufficient 

for your purposes, you can define your own subscreen. 

Note 

For more information about defining your own subscreens, see the general section Define Subscreens for 

Account Assignment Block. 

15.5.4.2.1.2.1.10 Substitution in Accounting Documents 

In this activity, you define possible changes regarding your accounting documents in the form of 

substitutions of individual fields for your company codes. You can make changes both in the document 

header and in the line item. The substitutions are valid for both the manual entry of documents and for the 

automatic creation of documents (for example, payment program). 

For each company code to which you want to assign a substitution, define the following information: 

- Time of substitution 

Here you enter the key "1" for substitution within the document header, the key "2" for substitution 

within the line item and the key "3" for the whole document. 

- Substitution 

Here you can change or display the names of substitutions which already exist. You have to create a 

new substitution. The name then appears in the overview afterwards. 

- Name for the substitution 



 

 

- Activation level 

Here you enter the key "0" for inactive, the key "1" for active and the key "2" for active (except for 

in batch). 

Activities 

If you want to define new substitutions, proceed as follows: 

1. Position the cursor on a line in which the company code and the time have been entered (you can 

enter the company code and the time via Edit -> New entries). 

2. Then select Environment -> Substitution. You reach the first screen for maintaining a substitution. 

3. Select Substitution -> Create. Enter the required name. After pressing ENTER, you reach the 

overview screen with the substitution activities belonging to substitution. 

4. Select Insert entry. You can describe a new substitution activity on the next screen. You describe 

the substitution requirements and the actual substitution for this. The syntax to be used for this is 

explained in the F1 help for the input fields Requirements and Substitution. 

If you want to change substitutions which already exist, proceed as follows: 

1. Position the cursor on an existing entry and select Goto -> Substitution. 

2. On the next screen, select Substitution -> Display or Substitution -> Change. After pressing 

ENTER, you reach the overview screen with the substitution activities belonging to substitution. If 

you select Insert entry, you can make the required changes. 

15.5.4.2.1.2.1.11 Define Text IDs for Documents 

In this activity you define text IDs for long texts at document header level. When entering a document, you 

can enter texts for every text ID. This means that you can store information on the document that affects 

the whole document. 

Note 

You create text IDs across the system, i.e. for all clients. 

SAP standard settings 

The system is delivered with the text IDs Note, Correspondence, and Payment advice info as standard 

settings. 

Activities 

1. Define the required text IDs. 

2. Select the Relevant text field in the clients in which the text IDs are to be used. 
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15.5.4.2.1.2.1.12 Define Line Layout for Document Posting Overview 

In this activity, you define the line layout variants for document posting by specifying which information 

you want to have available onscreen (i.e., document number, account number, company code).  You can 

also assign a display format to each field. 

Activities 

1. Check the extent to which you can use the standard settings. Change or enhance the settings, if 

Necessary. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user's master 

record. 

15.5.4.2.1.2.1.13 Define Line Layout for Document Change/Display 

In this activity, you define the line layout variants. 

For the functions Change document or Display document, you define which information from the line 

item is displayed on the screen. 

For the function Edit payment proposal, you define the layout for displaying the payments or exceptions. 

Activities 

1. Check whether you can use the standard settings. Change them or add to them as required. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.1.2.1.14 Select Standard Line Layout for Document Change/Display 

In this activity, you select the standard default values for the following functions: 

- Displaying or changing documents 

- Displaying or processing payment proposals 

These variants are used when the display or change functions are first called up if you do not select any 

other variant. 

Activities 

Choose a corresponding line layout variant. 

15.5.4.2.1.2.1.15 Document Change Rules, Document Header 

In this activity, you determine under which circumstances fields within posted documents can be changed. 



 

 

Note 

For a number of fields, the system itself determines that they can no longer be changed after posting. This 

includes all fields which are central to the principles of orderly accounting, for example, the amount posted 

and the account. 

The system also prevents the update objects from being changed in documents which have already been 

posted, independent of the document change rules. Update objects are elements in the system for which 

transaction figures or line items are updated, for example, business area or cost centers (if cost center 

accounting is used in the SAP system). Update objects are entered as additional account assignments during 

posting. 

If you are using the Special Purpose Ledger application, you should ensure that fields which are updated 

there are protected against changes in the document. Document changes do not affect updating in the 

special purpose ledger. 

Activities 

1. Check the default settings. 

2. Change the specifications if necessary. 

15.5.4.2.1.2.1.16 Maintain Fast Entry Screens for G/L Account Items 

In this activity you define screen templates for the fast entry of G/L account items when posting documents.  

You can generate screen templates with the field’s account, amount and company code, for example. 

Activities 

1. Check to what extent you can use the standard settings. If necessary, change or enhance the 

definitions. 

2. If you want to assign a screen template to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.1.2.2 Define Alternative Reconcil.Acct for Bills/Exch.Receivable 

In this activity you define the accounts in which bill of exchange payments are recorded in the general 

ledger. When you post bills of exchange, the system will post the entries to these accounts instead of to the 

normal receivables account (reconciliation account). This way it is possible to keep bills of exchange 

separate from the normal receivables. A transfer posting for balance sheet purposes is no longer necessary. 

Note 

The specification of accounts depends on the account type, special G/L indicator, chart of accounts, and 

reconciliation account for normal receivables. 

Activities 

1. Enter your bill(s) of exchange account(s) in the field for the alternative reconciliation account. 

2. Make sure that the account has been created. 
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Additional information 

You can find additional information on the alternative reconciliation account in the "FI Accounts 

Receivable and Accounts Payable" document under "Special G/L transactions". 

15.5.4.2.1.2.3 Define Accounts for bill of exchange Transactions 

In this step, you define the account numbers and the posting keys for automatic postings which the 

system makes when posting the payment by bill of exchange and bill of exchange usage. For some 

transactions (posting a bill of exchange payment request, for example) you only need posting keys. 

Note 

You store the accounts depending on the chart of accounts. For some transactions you can also break them 

down according to tax codes. 

Activities 

1. Specify the accounts for the required transactions. 

The posting keys are specified for all transactions. Only change this default setting if you do not work 

with the standard posting keys. 

2. Make sure that the specified accounts have been created. 

15.5.4.2.1.2.4 Define bill of exchange Tax Codes 

Bill of exchange tax codes are used to be able to determine the taxes automatically when posting a bill of 

exchange receivable. The tax codes are defined at client level. Later you can specify, on the basis of the 

company code, whether the bill of exchange tax is to be posted and which tax code is to be used. 

Standard settings 

Examples of tax codes have been defined. 

Activities 

1. Check the standard tax codes. 

2. Add tax codes if necessary. 

15.5.4.2.1.2.5 Prepare bill of exchange Charges Statement 

In this step, you define the default values for the bill of exchange charges dependent on company code. 

These values are proposed when entering a bill of exchange receivable. These include: 

- Discount percentage rate 

- Collection charges in local currency 



 

 

- Tax code for taxes on sales/purchases 

- Bill of exchange tax code 

Note 

If no bill of exchange charges are calculated in a company code, an entry is not necessary. The fields for 

the bill of exchange charges are then not displayed when entering a bill of exchange. 

In the accounts for the bill of exchange charges, specify the bills of exchange for which taxes on 

sales/purchases are calculated. If you fill the Tax category field with a corresponding code, the taxes on 

sales/purchases are calculated. 

Requirements 

If you want to define a bill of exchange tax code, you must have defined it previously. 

Standard settings 

Default values without bill of exchange tax codes are stored in the system for the standard German 

company code. A bill of exchange tax code has also been specified for the standard Austrian company 

code. 

Recommendation 

The default values make entering a transaction easier for the accounts receivable clerk. Therefore you 

should use the default values as an entry tool. 

Activities 

1. Check the default values stored for the bill of exchange charges statement. 

2. Change or add to these values if necessary. 

3. The bill of exchange charges are posted automatically. The corresponding accounts are to be defined 

for automatic posting. 

4. You can define a separate payment term for the bill of exchange charges and store it in the customer 

master record. Find out whether a special payment term is needed and define one if necessary. 

5. Make sure that the required payment terms have been entered in the corresponding customer master 

records. 

15.5.4.2.1.2.6 Make and Check Settings for Correspondence 

You can make new settings for correspondence here, or check existing settings: 

- If you have already made settings for correspondence in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that these settings are correct here. 

- If you have not yet made any settings, you can do so here. 
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15.5.4.2.1.2.6.1 Define Correspondence Types 

In this activity, you create your own correspondence types or change the specifications for the standard 

correspondence types. A correspondence type represents the type of letters in the system. You must create 

a correspondence type for the possible correspondences for each type of letter which you need. 

Example 

In the standard system there are the correspondence types "Payment notice with line items", 

"Payment notice without line items", "Document extract" or "Account statement". You can define 

further correspondence types for payment notices, such as payment notices especially for 

payments which are made for invoices already cleared, or for credit memos cleared twice. 

The correspondence types are 

- Offered to the user by the system for selection when processing business transactions or 

- Created automatically according to rules defined by the user or 

- Always created automatically by the system 

Example 

You can select the correspondence type "Payment notice" when entering incoming payments. Bill of 

exchange charges statements are created automatically for your customers' payments by bill of 

exchange if charges to be passed on were posted. 

You determine which data is necessary for creating the letters for the correspondence types. The following 

data is necessary for the correspondences: 

Correspondence Necessary data 

  

Payment notices Document number 

Account statements Account number and date specifications 

Bill/exch.charges statements Document number 

Internal documents Document number 

Individual letters Account number 

Document extracts Document number 

This data is either entered manually by the user or is determined automatically by the system after he/she 

has selected the relevant correspondence type. 

Example 

If you select the correspondence type "Payment notice without line items" in the account display, 

then you must specify a document number since the correspondence type requires this. If you have 

specified in the customer master record that the payment notices are to be created automatically, then 

the system determines the necessary data when posting an incoming payment. 

Standard settings 

Correspondence types are delivered with the standard system. Their keys begin with SAP. 

Note 



 

 

You can use the standard correspondence types. If you want to make changes to them, copy the required 

correspondence type and change the new correspondence type accordingly. This is necessary since the 

standard correspondence types could be overwritten during the next change of release. 

Activities 

1. Find out which letters were sent to your customers/vendors previously. 

2. Find out whether a correspondence type is already defined for these in the standard system. 

3. Define your own correspondence types if necessary. 

15.5.4.2.1.2.6.2 Create Report Variants for Correspondence 

In this activity you can define the selection variants for the correspondence that you require. 

You define the selection variants independently of the company code and the type of correspondence. 

Example 

Correspondence type internal document, program RFKORD30, variant SAP09 

Recommendation 

Usually only the fields in the output control and print control areas, as well as the field correspondence 

in the test run area, are of interest for a selection variant. 

The remaining fields in the test run area are used if the documents are to be output directly with the print 

program. 

Activities 

1. Find out the name of the appropriate print program. You can get an overview of the existing programs 

using the function Tools -> Program search. To search for standard programs, enter RFKORD*, 

or to search for customer-defined programs ZFKORD*, for example. An up-to-date list of programs 

is displayed. 

2. Select the required program from the list and run it. The system takes you to the selection screen. 

Here you can either change an existing variant or create one of your own. 

To change a standard variant, you can display the variant using the function fetch variant. You can 

then change these variants and then save them under your own name (customer name range). To 

create your own variant, enter the selection criteria directly and then save this variant under your own 

name (customer name range). 

3. In Customizing, specify the report name and the variant for the report assignment for the 

correspondence type. You can do this in the activity Assign Programs for Correspondence Types. 

Additional information 

There are report variants for the different correspondence types in client 000. For more information about 

the system settings, see the corresponding program documentation. 
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15.5.4.2.1.2.6.3 Assign Programs for Correspondence Types 

In this activity, you define the print program and the selection variant corresponding to each 

correspondence type. The selection variant is used when printing the requested correspondence. 

Correspondence Print program 

  

Payment notices RFKORD00 

Account statements RFKORD10 

Bill/exch.charges statements RFKORD20 

Internal documents RFKORD30 

Individual letters RFKORD40 

Document extracts RFKORD50 

Customer statement RFKORD11 

You can distinguish your specifications by company code. This is usually necessary for companies with 

several company codes, since you also enter the printer on which you want your correspondence to be 

issued in the selection variant. 

Activities 

Specify the name of the print program and the required variant for each correspondence type. 

You can create the variant using the configuration function. Select Goto -> Maintain variant. 

Additional information 

You can find further information on the selection variants in the sections for the individual types of 

correspondence. 

15.5.4.2.1.2.6.4 Define Forms for Correspondence 

In this activity you can define the forms (layout sets) for your business correspondence. 

Standard settings 

Forms for correspondence are already defined in the standard system. 

Recommendation 

SAP recommends that you accept the settings defined in the standard system. In this case, no action is 

required on your part. 

If you want to make changes to the forms, SAP recommends NOT to change the standard forms, but to 

first copy them and then make changes to the copied version. 

Activities 

If you are using the standard forms, you do not need to make any settings here. 

Proceed as follows to define your own forms: 



 

 

1. Enter the standard form you want to copy. 

2. Choose Layout set -> Create/Change. 

You will then see the header data screen for the layout set. 

3. Choose Layout set -> Save as... and enter a new name. 

The name of the new layout set should start with the letter "Z" or "Y" in order to ensure that it is not 

overwritten during upgrades. Assign the layout set to the layout set class FKOR. 

4. Edit and activate the new form. 

15.5.4.2.1.2.6.5 Define Form Names for Correspondence Print 

In this activity, you define the names of the forms which are to be used for printing the correspondence. 

The system attempts to create the letters for your customers/vendors in the language specified in the 

customer/vendor master record. Internal documents are issued in the company code or logon language. To 

do this, the corresponding form must be available in the required language in the system. You should 

therefore translate the forms into the required languages if they are not already available in the standard 

system. 

You define the form names depending on the company code, print program and a form ID. With the help 

of the form ID, it is possible to store different forms for one print report. 

Example 

You want to create account statements with and without displaying the days in arrears. For this, you defined 

a correspondence type. For every account statement type you also create your own form and store the 

names of the forms for the print program "RFKORD10" under your own form ID. 

If you want to use the form IDs, you should note that you must enter them in the selection variants for the 

print reports. You need the corresponding number of variants. 

Example 

You are to be able to create payment notices with and without an individual text. To do this, you store 

a form without form ID for the program RFKORD00. This form does not have any individual texts 

defined for it. You store another form under a form ID. This form does have an individual text defined 

for it. You create two selection variants for the print program and store these variants for the relevant 

correspondence types in the system. 

Text elements are contained in the standard forms. Text elements offer the option of storing different, 

alternative texts in a form which are then printed depending on the posting procedure. 

Example 

In the standard form for payment notices, a text element is stored for the case that a credit memo was 

to be posted and another text element for the case that a partial payment was to be posted for an 

incoming payment. 

For your information, the individual text elements are commented on in the standard forms. 

Note 
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In the letter, you can display the segment text (posting text) of an item. An asterisk (*) must be at the 

beginning of the text field. 

To define your own forms, copy the standard ones and change them. Delete the print texts you do not need. 

Make sure the numbers of the available text elements and the commentary lines remain for each text 

element. The commentary lines contain the character /* in the form column. 

Activities 

1. Find out the names of the standard forms. 

2. Check whether you can use these forms. 

3. Define and activate your own forms and translate them, if necessary. 

4. Store the names of the forms. 

 

 

15.5.4.2.1.2.6.6 Define Sender Details for Correspondence Form 

In this activity, you define which texts are to be used in the letter window and the signature line for each 

company code. This applies to the following: 

- letter header 

- letter footer 

- sender address 

Note 

This procedure is useful if you use a form for several company codes, since you do not need to define these 

details in the form or use pre-printed writing paper. In this case, the company code-specific texts must be 

stored separately. 

Activities 

1. Create your standard texts. 

The text ID is ADRS. 

2. Specify which texts are to be 

used for the individual 

company codes. 

To transport the texts from the Customizing system to the productive system, include them in a transport 

request. 

1. Choose Tools -> ABAP Workbench -> ABAP Editor. 

2. Enter the program name RSTXTRAN. 

3. Enter the name of the correction and the text ID, and then execute the transport. 



 

 

15.5.4.2.1.2.6.7 Determine Call-Up Functions 

In this activity, you specify which correspondence types can be selected online within which functions. 

The following functions are included: 

- document entry 

- functions for payment settlement 

- document display and document change 

- Account editing (balance display and line item processing). 

Example 

Payment notices can only be selected for payment transactions, whilst account statements can be selected 

in all of the above functions. 

Note 

You do not make a specification for the bill of exchange charges statement. You cannot select the statement 

of bill of exchange charges - it is created automatically for your customers if bill of exchange charges were 

posted. 

Make your specifications dependent on company code. If no entry exists for a company code, the 

correspondence types specified without company code are offered. 

Activities 

1. Check the standard specifications. 

2. Change them if necessary. 

If you defined your own correspondence types, you must include them here and make your 

specification. 

15.5.4.2.1.2.6.8 Develop Enhancements for Correspondence 

The following SAP enhancements are available for the "Correspondence" area: 

- RFKORIEX for automatic correspondence 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 

to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 
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In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 

For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

 

 

 

15.5.4.2.1.2.6.9 Define Sort Variants for Correspondence 

In this activity, you define sort variants for printing letters for all of the various correspondence types. 

Activities 

1. Check to what extent you can use the standard settings. Change or enhance the settings, if necessary. 

2. Enter the sort variants in the printing program for correspondence. 

15.5.4.2.1.2.6.10 Define Sort Variants for Line Items 

In this activity, you define correspondence sort variants for the line item output sequence in letters. 

Activities 

1. Check to what extent you can use the standard settings. Change or enhance the settings, if necessary. 

2. You specify sort variants in the payment method layout set data for the company code, so that the 

print program carries out the sorting for that payment method as you require.  Select customizing for 

the print program to make these settings. 

15.5.4.2.1.2.7 Define bill of exchange Status 

In this step you can specify an additional indicator which gives information on the processing status of a 

bill of exchange. This is a requirement in Japan for example. 

You must define the following information for this: Company code (if necessary), indicator for the bill of 

exchange status and, if necessary, a name for the bill of exchange status. 

Example 

A bill of exchange can, for example, have one of the following processing statuses: 

- The customer pays an invoice with a bill of exchange. 

- The main administration receives the bill of exchange. 



 

 

- The main administration presents the bill of exchange to the bank for discounting. 

Note 

If a status is to be valid for all company codes, enter it without specifying a company code, otherwise 

specify the company code for which it is valid. 

Requirements 

In order to be able to manage the bill of exchange, you must define the "BSED-WSTAT" field as 

changeable. Otherwise you cannot alter the status when entering a bill of exchange. You make this setting 

in the step ""Define document change rules" in the "Financial accounting global settings" Implementation 

Guide. 

Activities 

Determine your bill of exchange status. 

15.5.4.2.1.2.8 Bill or Exchange Portfolios 

15.5.4.2.1.2.8.1 Define bill of exchange Portfolios 

Use 

In this activity you define the bill of exchange portfolios. 

Activities 

Enter the bill of exchange portfolio, the bill receivable account, the bill type (check or bill of exchange), 

and the two accounts that the system uses when you transfer a bill from one portfolio to another ( G/L 

account for transferring bills between portfolios, interim account for bills of exchange presented to 

vendors). 

15.5.4.2.1.2.8.2 Transaction Records 

15.5.4.2.1.2.8.2.1 Define Number Ranges 

Use 

In this IMG activity, you maintain the number ranges for the bill of exchange transaction records that are 

created by the following programs: 

- Bill of exchange payment 
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- Bill of exchange transactions 

- Reversal of bill of exchange transactions 

These programs cover a total of eleven transactions where the system creates a transaction record (for 

example, the presentation of a bill of exchange to a bank or the posting of a bounced bill). A separate 

record is created for each transaction. 

Standard settings 

You transport number range objects as follows: 

Choose Interval -> Transport in the accounting document Number Range screen. 

All intervals for the selected number range object are deleted in the target system first. After the import, 

only the intervals you export are present. The number statuses are imported with their values at the time 

of export. 

Dependent tables are not transported or converted. 

Activities 

Maintain a number range for all types of transaction record (see table below). Use the numbers shown so 

that the programs can identify the number ranges correctly. 

When you reverse a bill of exchange transaction that requires a transaction record, the system uses the 

number range from the bill's new status. For example, if you reverse a bill from Cleared at Bank to 

Reversed at Bank, the system uses number range 06. However, if you reverse a bill to from any status 

to Customer Invoice, the system uses a separate number range, 29. 

Number bill of exchange transaction record 

01 Payment by bill of exchange 

02 Presented to a bank 

03 Presented to a vendor 

04 Cleared at bank 

05 Cleared at vendor 

06 Bounced at bank 

07 Bounced at vendor 

08 Bounced and cleared 

09 Removed from bill of exchange portfolio 

10 Added to bill of exchange portfolio 

29 Reversals (to Customer Invoice) 

Note 

Although the system does not create any transaction records for bills that are cleared at a bank or 

vendor (numbers 04 and 05), you must create these number ranges for technical reasons. 

For every number range, enter the following information: 



 

 

- No. (Number) 

The number of the number range, as above. 

- From number and To number 

The first and last numbers in the number range. 

- Ext (External numbering) 

The type of number assignment. Do not select this checkbox, as the system is to number the records 

automatically. 

15.5.4.2.1.2.8.2.2 Specify SAP script Form 

Use 

In this IMG activity, you specify which SAP script form you want to print transaction records on. 

Standard settings 

The standard system comes with a sample form, which you can use if it meets your requirements. 

If not, create a copy of the form and change the copy as required. 

15.5.4.2.1.2.8.3 Business Add-Ins 

15.5.4.2.1.2.8.3.1 Dynamic Selections in bill of exchange Transactions Program 

Use 

This Business Add-In enables you to change the selection criteria that the user enters in the dynamic 

selections in the Bill of Exchange Transactions program. 

This is particularly useful for improving performance when you look for a bill of exchange (or check) using 

just the bill of exchange number. For more information, see the example below. 

Standard settings 

In the standard system, the Add-In is not activated. It is not filter-dependent and it is not reusable. 

Activities 

After calling up the IMG activity, a dialog box appears, in which you can enter a name for the 

implementation. 
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If you have already made other implementations for this BAdI, another dialog box appears, in which the 

existing implementations are displayed. In this case, choose Create, and proceed as follows: 

1. In the dialog box, enter a name for the BAdI implementation in the Implementation field, and choose 

Create. 

The screen for creating BAdI implementations is now displayed. 

2. Enter a short text for the implementation in the Short text for implementation field. 

3. From the tab index, choose Interface. 

The Name of implemented class field is already filled on the tab page, as a class name was 

automatically assigned to the implementation when you named it. 

4. Save your entries, and assign the implementation to a development class. 

5. Place the cursor on the method, and double-click to enter method processing. 

6. Enter the code for the implementation between the statements method <Interface name> ~ 

<Name of method> and end method. 

7. Save and implement your code. Return to the Edit Implementation screen. 

8. Save the entries on the Edit Implementation screen. 

Note: You can also create an implementation, and then activate it at a later time. In such a case, end 

the processing stage at this point. 

9. Choose Activate 

The code you stored in the method will be run when the application program is executed. 

Example 

Assume that a clerk enters a bill of exchange in the system. Two weeks later, one of your accountants 

inquires about the bill, so you look it up in the system. To do so, you run the program and, on the selection 

screen, you enter the selection criteria: the company code, the fiscal year, and the bill of exchange number 

When you execute the program, the system requires a long time to find the bill, because the bill of exchange 

number is not a key field in the table where the bills of exchange are stored, BSED. 

You can improve performance as follows: 

10. Create a copy of table BSED called ZBSED, and, in the copy, define the bill of exchange number as 

a key field. 

11. Modify the system so that whenever a clerk enters a bill of exchange receivable, the system saves it 

in table BSED and in ZBSED. 

12. Implement this Add-In, following the instructions under "Activities" above and using the sample code 

(see below), so that when you run the program: 

a) The program exports the bill of exchange number to the Add-In implementation. 

b) The implementation checks the table ZBSED to find out the document number of the bill of 

exchange. 

c) The implementation exports the document number to the program. 

d) The program uses the document number as an additional selection criterion. Since the document 

number is a key field in the table BSED, the performance improves considerably. 



 

 

If you use the sample code, change all references to table BSED to ZBSED. To display the sample 

code, choose Goto -> Sample Code -> Display. 

See also 

Methods 

Change Dynamic Selections 

15.5.4.2.1.2.8.3.2 Dynamic Selections in bill of exchange Reversals Program 

Use 

This Business Add-In enables you to change the selection criteria that the user enters in the dynamic 

selections in the Reversal of Bill of Exchange Transactions program. 

This is particularly useful for improving performance when you look for a bill of exchange (or check) using 

just the bill of exchange number. For more information, see the example below. 

Standard settings 

In the standard system, the Add-In is not activated. It is not filter-dependent and it is not reusable. 

Activities 

After calling up the IMG activity, a dialog box appears, in which you can enter a name for the 

implementation. 

If you have already made other implementations for this BAdI, another dialog box appears, in which the 

existing implementations are displayed. In this case, choose Create, and proceed as follows: 

1. In the dialog box, enter a name for the BAdI implementation in the Implementation field, and choose 

Create. 

The screen for creating BAdI implementations is now displayed. 

2. Enter a short text for the implementation in the Short text for implementation field. 

3. From the tab index, choose Interface. 

The Name of implemented class field is already filled on the tab page, as a class name was 

automatically assigned to the implementation when you named it. 

4. Save your entries, and assign the implementation to a development class. 

5. Place the cursor on the method, and double-click to enter method processing. 

6. Enter the code for the implementation between the statements method <Interface name> ~ 

<Name of method> and end method. 

7. Save and implement your code. Return to the Edit Implementation screen. 

8. Save the entries on the Edit Implementation screen. 

Note: You can also create an implementation, and then activate it at a later time. In such a case, end 

the processing stage at this point. 

9. Choose Activate 
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The code you stored in the method will be run when the application program is executed. 

Example 

Assume that a clerk enters a bill of exchange in the system. Two weeks later, one of your accountants 

inquires about the bill, so you look it up in the system. To do so, you run the program and, on the selection 

screen, you enter the selection criteria: the company code, the fiscal year, and the bill of exchange number 

When you execute the program, the system requires a long time to find the bill, because the bill of exchange 

number is not a key field in the table where the bills of exchange are stored, BSED. 

You can improve performance as follows: 

10. Create a copy of table BSED called ZBSED, and, in the copy, define the bill of exchange number as 

a key field. 

11. Modify the system so that whenever a clerk enters a bill of exchange receivable, the system saves it 

in table BSED and in ZBSED. 

12. Implement this Add-In, following the instructions under "Activities" above and using the sample code 

(see below), so that when you run the program: 

a) The program exports the bill of exchange number to the Add-In implementation. 

b) The implementation checks the table ZBSED to find out the document number of the bill of 

exchange. 

c) The implementation exports the document number to the program. 

d) The program uses the document number as an additional selection criterion. Since the document 

number is a key field in the table BSED, the performance improves considerably. 

If you use the sample code, change all references to table BSED to ZBSED. To display the sample 

code, choose Goto -> Sample Code -> Display. 

See also 

Methods 

Change Dynamic Selections 

 

 

15.5.4.2.1.2.8.3.3 Dynamic Selections in bill of exchange List 

Use 

This Business Add-In enables you to change the selection criteria that the user enters in the dynamic 

selections in the Bill of Exchange List. 

This is particularly useful for improving performance when you look for a bill of exchange (or check) using 

just the bill of exchange number. For more information, see the example below. 

Standard settings 

In the standard system, the Add-In is not activated. It is not filter-dependent and it is not reusable. 



 

 

Activities 

After calling up the IMG activity, a dialog box appears, in which you can enter a name for the 

implementation. 

If you have already made other implementations for this BAdI, another dialog box appears, in which the 

existing implementations are displayed. In this case, choose Create, and proceed as follows: 

1. In the dialog box, enter a name for the BAdI implementation in the Implementation field, and choose 

Create. 

The screen for creating BAdI implementations is now displayed. 

2. Enter a short text for the implementation in the Short text for implementation field. 

3. From the tab index, choose Interface. 

The Name of implemented class field is already filled on the tab page, as a class name was 

automatically assigned to the implementation when you named it. 

4. Save your entries, and assign the implementation to a development class. 

5. Place the cursor on the method, and double-click to enter method processing. 

6. Enter the code for the implementation between the statements method <Interface name> ~ 

<Name of method> and end method. 

7. Save and implement your code. Return to the Edit Implementation screen. 

8. Save the entries on the Edit Implementation screen. 

Note: You can also create an implementation, and then activate it at a later time. In such a case, end 

the processing stage at this point. 

9. Choose Activate 

The code you stored in the method will be run when the application program is executed. 

Example 

Assume that a clerk enters a bill of exchange in the system. Two weeks later, one of your accountants 

Inquires about the bill, so you look it up in the system. To do so, you run the report and, on the selection 

screen, you enter the selection criteria: the company code, the fiscal year, and the bill of exchange number 

When you execute the report, the system requires a long time to find the bill, because the bill of exchange 

number is not a key field in the table where the bills of exchange are stored, BSED. 

You can improve performance as follows: 

10. Create a copy of table BSED called ZBSED, and, in the copy, define the bill of exchange number as 

a key field. 

11. Modify the system so that whenever a clerk enters a bill of exchange receivable, the system saves it 

in table BSED and in ZBSED. 

12. Implement this Add-In, following the instructions under "Activities" above and using the sample code 

(see below), so that when you run the report: 

a) The report exports the bill of exchange number to the Add-In implementation. 
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b) The implementation checks the table ZBSED to find out the document number of the bill of 

exchange. 

c) The implementation exports the document number to the report. 

d) The report uses the document number as an additional selection criterion. Since the document 

number is a key field in the table BSED, the performance improves considerably. 

If you use the sample code, change all references to table BSED to ZBSED. To display the sample 

code, choose Goto -> Sample Code -> Display. 

See also 

Methods 

Change Dynamic Selections 

15.5.4.2.1.3 Present bill of exchange Receivable at Bank 

15.5.4.2.1.3.1 Define Bank Subaccounts 

You specify the bank subaccounts that display the bill of exchange liability from the point of view of the 

bank. The bill of exchange liability results from the bill of exchange usage. 

Note 

You can break down your specification according to usage indicator, special G/L indicator, and 

reconciliation account for receivables. 

Activities 

1. Specify the bank subaccounts. 

2. Make sure that the accounts are created. 

15.5.4.2.1.3.2 Maintain Account Determination 

In this step you maintain the types of charges for each house bank and each transaction. You can define as 

many types of charges as you require for each bank and account or in general. 

To post the charges, you have to specify the expense account to which the system charges the fees. You 

can also have the system just calculate the fees. 

With the tax code, you specify the tax rate used to tax the charges that are liable to tax. 

You need the bank account details to post the expense from bank debit memos or charges. You can also 

specify interim accounts so that you can check whether the posted amounts were calculated correctly. 

Once you have checked the amounts, you can transfer the interim postings to the G/L account. 

Activities 



 

 

Define the criteria necessary for account determination. 

15.5.4.2.1.3.3 Define bill of exchange Types 

In this step you enter the various types of bills of exchange. 

There are various bill of exchange types in France and Spain. 

The system displays only the payment methods that are defined as bills of exchange. That is, all payment 

methods defined in the payment program for bills of exchange are displayed. 

In the BT field (bill of exchange types), specify the type of bill of exchange you are using. You need these 

specifications for presenting bills of exchange using DME files. 

Activities 

Enter the bill of exchange types. 

15.5.4.2.1.3.4 Assign Payment Method to Bank Transaction 

In this activity, you assign a payment method (such as bank bill or check) to each house bank-related 

transaction. You define the payment method in the customer and vendor master records to specify which 

procedure can be used for making payments. 

Define the following information for each house bank and each account: 

- Payment method 

- Transaction type 

You need the transaction type to be able to distinguish between payment methods (for example, bill 

of exchange for discount or bill of exchange for collection). 

- Bank group of the customer/vendor 

You need the bank group of the customer/vendor because the transaction type results from the house 

bank and the bank group of the customer/vendor. You can also enter a dummy entry here (="blank"). 

- House bank-related transaction and transaction name 

Requirements 

You have already defined payment methods. For more information, see the activities Set up Payment 

Methods per Country for Payment Transactions and Set up Payment Methods per Company Code for 

Payment Transactions. 

Activities 

1. Assign a payment method to each house bank-related transaction for each house bank and each 

account. 

2. Ensure that the payment method is defined in the customer and vendor master records. 
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15.5.4.2.1.3.5 Maintain House Bank Details 

In this step, you define the details for the house bank. These details are dependent on the company code 

and house bank. 

You can make specifications about the maturity of a bill of exchange, for example, the minimum days till 

maturity when presenting for collection. 

You can also specify whether the amounts in a collection or in discounting are posted first to a subaccount 

or directly to a G/L account. 

The account specifications for debit memos from presented bills of exchange and for debt memos from 

failed bills of exchange are country-specific, and are required only for Spain. 

When presenting bills in Spain using DME, you can also enter alternative bank accounts for debit memos 

(e.g. from charges) and for the debit memos from failed or partially paid bills of exchange. 

Activities 

Enter the data required for the house bank specifications. 

15.5.4.2.1.3.6 Define Available Amounts 

In this activity you define a maximum amount that must not be exceeded in any one bill of exchange 

presentation transaction. This amount is dependent on the company code, the house bank account, the type 

of bill of exchange presentation (such as collection), and the currency. You can only collect bills of 

exchange via the specified bank account, for example, up to the amount specified here. 

Activities 

Enter the available amounts per bank account. 

15.5.4.2.1.3.7 Define Value Date Rules 

In this activity, you make the following specifications for certain bank-related transactions (for example, 

bill of exchange presentation, and incoming checks) for each house bank and each account: 

- Reference date for determining the value date 

This date forms the basis of the agreement made with the bank as to when the value date is to occur. 

- Rules for determining the precise value date 

The value date is determined as follows: You first enter a certain number of days. The system 

determines the value date from this number of days starting from the reference date. 



 

 

It is also possible to determine this date according to a calendar identification (= K1) you have 

defined. If you enter a calendar ID, only working days are taken into account when determining the 

date. If you do not enter a calendar, the system not only takes working days but also weekends and 

public holidays into account. 

In a second step, the date determined by the system is now checked according to a second calendar 

ID as to whether it is a Sunday or public holiday. This can be the case: 

- If you did not proceed according to a certain calendar ID when determining the date, that is, all 

days, including weekdays and public holidays were taken into account when determining the 

date 

- If a certain day (for example, Corpus Christi) is a working day according to the first calendar 

ID (for example, in Berlin), and yet is a public holiday according to the second calendar (for 

Example, in Bavaria). 

If it is actually a weekend day or a public holiday, the system moves forwards or backwards within a 

given time until it finds a working day according to the second calendar ID you entered. The system 

has thus calculated the final value date. 

Activities 

Define the necessary data for each house bank, account, and transaction for determining the value date. 

15.5.4.2.1.3.8 Define General Charges 

In this step you specify the general properties for charges. 

General charges are country-dependent. 

The following explain the most important properties for general charges: 

- Bill of exchange usage: You have to specify this because charges usually depend on the use. 

- Valid from: Here you specify from when the fees amount is valid. 

- Charges type: You can define as many types of fees as you require for each bank and account or in 

general. 

- Min/Max amount: Here you enter the amount as of which the charge is imposed. 

- Payment method: Here you specify the means of payment (check, bill of exchange, bank transfer, 

etc.). 

Activities 

Define the criteria necessary for general charges. 
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15.5.4.2.1.3.9 Enter Bank Charges 

In this step, you define the fees for bill of exchange deposit for each house bank account and bill of 

exchange usage. You can define either a percentage or a fixed amount for the fees. 

Activities 

Define your fees for the check deposit. 

15.5.4.2.1.3.10 Define Charge Accounts 

In this step, you define a charges account for each house bank account and bill of exchange usage (example: 

collection). 

Activities 

Specify the required charges account and bank account. 

15.5.4.2.1.3.11 Enter Bank Assignments 

In this activity you define bank accounts per company code and currency for the presentation of bills of 

exchange. 

Activities 

Enter the required bank accounts. 

 

15.5.4.2.1.3.12 Define DME User IDs 

In this activity, you define the user ID for bank transactions (for example, bill of exchange presentation) 

by means of data medium exchange (=DME) for France, Italy, and Spain. The DME identification is 

assigned by the house bank and must be stated in the DME file so that the presenting party can be identified 

by the bank. 

The following DME identifications must be defined: 



 

 

- "Identification del Cedente" for Spain 

- "Numero d'Emmeteur de Virements" for France 

- "Numero D'Emetteurer de Remises LCR" for France 

- "Codice Rapporto del Presentatore" for Italy 

Activities 

Define the DME identification per house bank and per account ID for the required bank transactions. Your 

house bank will tell you your DME identification. 

15.5.4.2.1.3.13 Check DME Files for bill of exchange Presentation 

You can present your bills of exchange to the bank in a data medium exchange file (DME file). In this 

table, the system notes all the DME files with bills of exchange that have already been presented to a bank. 

When bills of exchange are presented, the system checks whether the specified DME file corresponds to 

any of the files saved here, thus preventing you from inadvertently presenting the same DME file at several 

different banks. 

Note 

The following country formats are supported: 

- France 

- Spain 

- Italy 

Activities 

If you wish to present a DME file again, you must delete the relevant entry. 

 

 

15.5.4.2.1.3.14 Define User-Specific Settings 

In this activity you make specifications per user and company code that are defaulted when you run the 

transaction for bill of exchange presentation (transaction FBWE). 

Note 

When you run the transaction for bill of exchange presentation for the first time, the system saves your 

entries and defaults them next time you use the transaction. If you change any entries at a later date, the 

changed entries are then saved. 

If you always wish to work with the same entries, do not set the indicator "Automatically record". 
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Activities 

Make entries in the required fields. 

15.5.4.2.1.3.15 Assign Forms for Bills of Exchange Receivable 

In this step you define the forms for bank correspondence. 

You can enter a special form in the Fo.ID field (form identification). If you do not make any more 

specifications, the system uses the standard form created in customizing for this company code. 

Activities 

Enter the criteria for maintaining the form. 

15.5.4.2.1.3.16 Define Sender Details for Form for bill of exchange Presentation 

In this step you define the corresponding text IDs, if the system accesses standard texts for the sender 

information in the forms. 

You can, for example, create a separate variant with a separate ID for each accountant. 

&EXAMPLE 

Activities 

You must first create the standard texts you want to use. 

Create Standard Texts 

15.5.4.2.1.4 Bill of Exchange Receivable: Reverse Contingent Liability 

15.5.4.2.1.4.1 Define bill of exchange Payment Period 

In this step, you define the bill of exchange payment period for bills of exchange receivable. This is the 

period which is allowed for bill protest. The system determines the date at which the bill liability can be 

charged off by means of the bill of exchange due date and the bill of exchange payment period. You define 

the period depending on the country of the drawee. 

Activities 

Determine the required payment periods. 



 

 

15.5.4.2.1.4.2 Define Additional Days for Remaining Risk 

In this step you define additional days for the remaining risk posting for a particular postal code/zip code 

area. The days entered here are added to the due date of the bill of exchange during the remaining risk 

posting, depending on the postal code/zip code area to which the customer belongs. 

Note 

You can also make generic entries, for example "1". In this case all postal codes/zip codes from 10000 to 

19999 are covered. If you enter "134", then all postal codes/zip codes from 13400 to 13499 are covered 

etc. 

You can create a dummy value for all customers who cannot be assigned to a particular postal code/zip 

code area. This only contains the days while "blank" is to be entered for the postal code/zip code area. 

The specifications under "blank" are valid for everything which is not defined explicitly. 

Activities 

Specify the additional days required for a postal code/zip code area. 

 

 

15.5.4.2.1.5 Bill of Exchange Receivable: Failed Payment Transactions 

15.5.4.2.1.5.1 Define Failed Payment Transactions (Bills of Exchange) 

Example 

You have presented a bill of exchange at your house bank to be discounted or for collection. Your customer 

or your house bank then inform you that this bill of exchange cannot be paid. 

You define this (failed) bill of exchange in this activity. 

Requirements 

Before further processing can take place (posting a new receivable with the same amount as the failed bill 

using program RFBITB01) the bill of exchange must first be cleared. 

Recommendation 

Refer to the documentation on program RFBITB01. 

Activities 

Enter the data for the failed bill of exchange including at least the company code, document number and 

fiscal year. 



 

WHATSAPP +255738656506 

 

15.5.4.2.1.5.2 Make and Check Settings for Correspondence 

You can make new settings for correspondence here, or check existing settings: 

- If you have already made settings for correspondence in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that these settings are correct here. 

- If you have not yet made any settings, you can do so here. 

15.5.4.2.1.5.2.1 Define Correspondence Types 

In this activity, you create your own correspondence types or change the specifications for the standard 

correspondence types. A correspondence type represents the type of letters in the system. You must create 

a correspondence type for the possible correspondences for each type of letter which you need. 

Example 

In the standard system there are the correspondence types "Payment notice with line items", 

"Payment notice without line items", "Document extract" or "Account statement". You can define 

further correspondence types for payment notices, such as payment notices especially for 

payments which are made for invoices already cleared, or for credit memos cleared twice. 

The correspondence types are 

- Offered to the user by the system for selection when processing business transactions or 

- Created automatically according to rules defined by the user or 

- Always created automatically by the system 

Example 

You can select the correspondence type "Payment notice" when entering incoming payments. Bill of 

exchange charges statements are created automatically for your customers' payments by bill of 

exchange if charges to be passed on were posted. 

You determine which data is necessary for creating the letters for the correspondence types. The following 

data is necessary for the correspondences: 

Correspondence Necessary data 

  

Payment notices Document number 

Account statements Account number and date specifications 

Bill/exch.charges statements Document number 

Internal documents Document number 

Individual letters Account number 

Document extracts Document number 

This data is either entered manually by the user or is determined automatically by the system after he/she 

has selected the relevant correspondence type. 

Example 



 

 

If you select the correspondence type "Payment notice without line items" in the account display, 

then you must specify a document number since the correspondence type requires this. If you have 

specified in the customer master record that the payment notices are to be created automatically, then 

the system determines the necessary data when posting an incoming payment. 

Standard settings 

Correspondence types are delivered with the standard system. Their keys begin with SAP. 

Note 

You can use the standard correspondence types. If you want to make changes to them, copy the required 

correspondence type and change the new correspondence type accordingly. This is necessary since the 

standard correspondence types could be overwritten during the next change of release. 

Activities 

1. Find out which letters were sent to your customers/vendors previously. 

2. Find out whether a correspondence type is already defined for these in the standard system. 

3. Define your own correspondence types if necessary. 

15.5.4.2.1.5.2.2 Create Report Variants for Correspondence 

In this activity you can define the selection variants for the correspondence that you require. 

You define the selection variants independently of the company code and the type of correspondence. 

Example 

Correspondence type internal document, program RFKORD30, variant SAP09 

Recommendation 

Usually only the fields in the output control and print control areas, as well as the field correspondence 

in the test run area, are of interest for a selection variant. 

The remaining fields in the test run area are used if the documents are to be output directly with the print 

program. 

Activities 

1. Find out the name of the appropriate print program. You can get an overview of the existing programs 

using the function Tools -> Program search. To search for standard programs, enter RFKORD*, 

or to search for customer-defined programs ZFKORD*, for example. An up-to-date list of programs 

is displayed. 

2. Select the required program from the list and run it. The system takes you to the selection screen. 

Here you can either change an existing variant or create one of your own. 

To change a standard variant, you can display the variant using the function fetch variant. You can 

then change these variants and then save them under your own name (customer name range). To 

create your own variant, enter the selection criteria directly and then save this variant under your own 

name (customer name range). 
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3. In Customizing, specify the report name and the variant for the report assignment for the 

correspondence type. You can do this in the activity Assign Programs for Correspondence Types. 

Additional information 

There are report variants for the different correspondence types in client 000. For more information about 

the system settings, see the corresponding program documentation. 

 

 

15.5.4.2.1.5.2.3 Assign Programs for Correspondence Types 

In this activity, you define the print program and the selection variant corresponding to each 

correspondence type. The selection variant is used when printing the requested correspondence. 

Correspondence Print program 

  

Payment notices RFKORD00 

Account statements RFKORD10 

Bill/exch.charges statements RFKORD20 

Internal documents RFKORD30 

Individual letters RFKORD40 

Document extracts RFKORD50 

Customer statement RFKORD11 

You can distinguish your specifications by company code. This is usually necessary for companies with 

several company codes, since you also enter the printer on which you want your correspondence to be 

issued in the selection variant. 

Activities 

Specify the name of the print program and the required variant for each correspondence type. 

You can create the variant using the configuration function. Select Goto -> Maintain variant. 

Additional information 

You can find further information on the selection variants in the sections for the individual types of 

correspondence. 

15.5.4.2.1.5.2.4 Define Forms for Correspondence 

In this activity you can define the forms (layout sets) for your business correspondence. 

Standard settings 

Forms for correspondence are already defined in the standard system. 

Recommendation 



 

 

SAP recommends that you accept the settings defined in the standard system. In this case, no action is 

required on your part. 

If you want to make changes to the forms, SAP recommends NOT to change the standard forms, but to 

first copy them and then make changes to the copied version. 

Activities 

If you are using the standard forms, you do not need to make any settings here. 

Proceed as follows to define your own forms: 

1. Enter the standard form you want to copy. 

2. Choose Layout set -> Create/Change. 

You will then see the header data screen for the layout set. 

3. Choose Layout set -> Save as... and enter a new name. 

The name of the new layout set should start with the letter "Z" or "Y" in order to ensure that it is not 

overwritten during upgrades. Assign the layout set to the layout set class FKOR. 

4. Edit and activate the new form. 

15.5.4.2.1.5.2.5 Define Form Names for Correspondence Print 

In this activity, you define the names of the forms which are to be used for printing the correspondence. 

The system attempts to create the letters for your customers/vendors in the language specified in the 

customer/vendor master record. Internal documents are issued in the company code or logon language. To 

do this, the corresponding form must be available in the required language in the system. You should 

therefore translate the forms into the required languages if they are not already available in the standard 

system. 

You define the form names depending on the company code, print program and a form ID. With the help 

of the form ID, it is possible to store different forms for one print report. 

Example 

You want to create account statements with and without displaying the days in arrears. For this, you defined 

a correspondence type. For every account statement type you also create your own form and store the 

names of the forms for the print program "RFKORD10" under your own form ID. 

If you want to use the form IDs, you should note that you must enter them in the selection variants for the 

print reports. You need the corresponding number of variants. 

Example 

You are to be able to create payment notices with and without an individual text. To do this, you store 

a form without form ID for the program RFKORD00. This form does not have any individual texts 

defined for it. You store another form under a form ID. This form does have an individual text defined 

for it. You create two selection variants for the print program and store these variants for the relevant 

correspondence types in the system. 

Text elements are contained in the standard forms. Text elements offer the option of storing different, 

alternative texts in a form which are then printed depending on the posting procedure. 
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Example 

In the standard form for payment notices, a text element is stored for the case that a credit memo was 

to be posted and another text element for the case that a partial payment was to be posted for an 

incoming payment. 

For your information, the individual text elements are commented on in the standard forms. 

Note 

In the letter, you can display the segment text (posting text) of an item. An asterisk (*) must be at the 

beginning of the text field. 

To define your own forms, copy the standard ones and change them. Delete the print texts you do not need. 

Make sure the numbers of the available text elements and the commentary lines remain for each text 

element. The commentary lines contain the character /* in the form column. 

Activities 

1. Find out the names of the standard forms. 

2. Check whether you can use these forms. 

3. Define and activate your own forms and translate them, if necessary. 

4. Store the names of the forms. 

15.5.4.2.1.5.2.6 Define Sender Details for Correspondence Form 

In this activity, you define which texts are to be used in the letter window and the signature line for each 

company code. This applies to the following: 

- letter header 

- letter footer 

- sender address 

Note 

This procedure is useful if you use a form for several company codes, since you do not need to define these 

details in the form or use pre-printed writing paper. In this case, the company code-specific texts must be 

stored separately. 

Activities 

1. Create your standard texts. 

The text ID is ADRS. 

2. Specify which texts are to be 

used for the individual 

company codes. 

To transport the texts from the Customizing system to the productive system, include them in a transport 

request. 



 

 

1. Choose Tools -> ABAP Workbench -> ABAP Editor. 

2. Enter the program name RSTXTRAN. 

3. Enter the name of the correction and the text ID, and then execute the transport. 

15.5.4.2.1.5.2.7 Determine Call-Up Functions 

In this activity, you specify which correspondence types can be selected online within which functions. 

The following functions are included: 

- document entry 

- functions for payment settlement 

- document display and document change 

- Account editing (balance display and line item processing). 

Example 

Payment notices can only be selected for payment transactions, whilst account statements can be selected 

in all of the above functions. 

Note 

You do not make a specification for the bill of exchange charges statement. You cannot select the statement 

of bill of exchange charges - it is created automatically for your customers if bill of exchange charges were 

posted. 

Make your specifications dependent on company code. If no entry exists for a company code, the 

correspondence types specified without company code are offered. 

Activities 

1. Check the standard specifications. 

2. Change them if necessary. 

If you defined your own correspondence types, you must include them here and make your 

specification. 

15.5.4.2.1.5.2.8 Develop Enhancements for Correspondence 

The following SAP enhancements are available for the "Correspondence" area: 

- RFKORIEX for automatic correspondence 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 
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to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 

In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 

For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

15.5.4.2.1.5.2.9 Define Sort Variants for Correspondence 

In this activity, you define sort variants for printing letters for all of the various correspondence types. 

Activities 

1. Check to what extent you can use the standard settings. Change or enhance the settings, if necessary. 

2. Enter the sort variants in the printing program for correspondence. 

15.5.4.2.1.5.2.10 Define Sort Variants for Line Items 

In this activity, you define correspondence sort variants for the line item output sequence in letters. 

Activities 

1. Check to what extent you can use the standard settings. Change or enhance the settings, if necessary. 

2. You specify sort variants in the payment method layout set data for the company code, so that the 

print program carries out the sorting for that payment method as you require.  Select customizing for 

the print program to make these settings. 

 

 

15.5.4.2.1.6 Country-Specific Settings 

15.5.4.2.2 Bill of Exchange Payable 

In the following activities, you make settings for bills of exchange payable. 



 

 

15.5.4.2.2.1 Create bill of exchange Payable 

In the following steps, you make the settings for bills of exchange payable. 

15.5.4.2.2.1.1 Make and Check Document Settings 

You can make new document settings here, or check existing settings, so that they correspond to the 

business transaction you are currently processing: 

- If you have already made document settings in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that those settings are correct here. 

- If you have not yet made any document settings, you can do so here. 

15.5.4.2.2.1.1.1 Define Document Types 

In this activity you create document types for customer, vendor and general ledger business transactions in 

Financial Accounting. Document types differentiate business transactions and control document filing. 

You specify a number range for each document type. Document numbers are chosen from this number 

range. You can use one number range for several document types. 

Document types are valid for all clients. You specify a number range key for each document type. You 

create the desired number range intervals for each number range key based on the company code. This 

means that you can specify intervals of different sizes for the same number range. 

Example 

You defined a document type for incoming invoices. In company code 0001 there are a lot of invoices to 

be posted. Thus you create a large number interval for the number range in this company code. In another 

company code there are only a few incoming invoices that need to be posted. For this company code you 

can define a small number interval for the same number range. 

If a document type is not used in a company code, do not store a number interval for that company code. 

Note 

To use the net method of posting documents, you need a net document type (for example, KN). In this 

document type, you have to set the "Net document type" indicator found under the "Control" area. You 

can define a common document type (for example, AB) and a common number range for clearing open 

items in accounts receivable, payable and G/L accounts. 

For automatic posting transactions (for example, transfer postings with clearing), you have to define a 

clearing document type (for example, AB). If you do not want to use the standard setting AB for the 

clearing document type, you can delete it and define your own. Under the document type properties, you 

can assign an individual reverse document type to each document type. For document types with external 

number ranges, you have to define an individual reverse document type because the system can make 

automatic reverse entries only in document types that have internal number assignment. 

Standard settings 

The pre-set document types cover business transactions 
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- in Financial Accounting for: 

- General ledger accounting 

- Accounts receivable 

- Accounts payable 

- Asset accounting 

- Consolidation 

- in Materials Management and Sales and Distribution for: 

- Goods receipt and issue 

- Incoming and outgoing invoices 

- Physical inventory ( stocktaking ) 

- Invoicing 

Activities 

1. Find out whether you can use the standard settings. 

2. Change or extend the default settings, if necessary. 

3. Check the specified document number ranges via the "Define document number ranges" activity if 

you use the standard document types. 

These number ranges must be created for your company codes and contain the number intervals you 

require. 

 

15.5.4.2.2.1.1.2 Define Posting Keys 

In this activity you define posting keys. Users specify a posting key before entering a line item. The posting 

key controls how the line item is entered and processed. 

For each posting key, you define among other things: 

- which side of an account can be posted to, 

- which type of account can be posted to, and 

- Which fields the system displays on the entry screens and whether an entry must be made (field 

status). 

Note 

The system also uses the field status group you specify in a G/L account to determine the status of fields 

in document entry. Field status groups are defined within a field status variant. 

Recommendation 

Use the posting keys delivered with the standard system. 



 

 

Activities 

1. Check the standard settings. 

2. Modify them if necessary. 

In particular, you may need to make changes to customer and vendor posting keys if a different field 

status is required. 

15.5.4.2.2.1.1.3 Validation in Accounting Documents 

In this activity, you define additional checks for accounting documents in the form of validations for each 

of your company codes. You can assign a validation for the document header and one for the line items to 

each company code. The assigned validations are valid both for manual entry of documents as well as for 

the automatic creation of documents (for example, payment program). 

For every company code to which you want to assign a validation, you store the following information: 

- Validation callup point 

Here you enter key "1" for "Check document header" and key "2" for "Check line item". 

- Validation 

Here there are the names of validations which already exist which you can display or change. A new 

Validation must firstly be created by you. Afterwards the name appears in the overview. 

- Description of the validation 

- Activation level 

Here you enter key "0" for inactive, key "1" for active and key "2" for active except for batch input. 

Example 

For example, you can use the validation for the following situation: You want to make sure that postings 

to the expense account "Telephone costs" can only be posted to the services cost center "Telephone". You 

can carry out the checks needed for this by using the validation. 

Activities 

If you want to define new validations, go through the following activities: 

1. Place the cursor on a line in which company code and callup point are entered (you can enter company 

code and validation callup point via Edit -> New entries). 

2. Afterwards select Environment -> Validation. You reach the first screen for maintaining a 

validation. 

3. Select Validation -> Create. Enter the required name. After pressing ENTER, you come to an 

overview screen of the validation activities belonging to the validation. 

4. Select Insert entry. On the next screen you can describe a new validation activity. You describe the 

check requirements and the actual check for this. The syntax to be used for this is described in the 
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online help (F1 help) for the input fields for Requirements and Check. You can also define a 

message (warning or error message) which is sent if the check is not successful. 

If you want to change validations which already exist, proceed as follows: 

1. Place the cursor on an already existing entry and select Goto -> Validation. 

2. On the next screen select Validation -> Display or Validation -> Change. After pressing ENTER, 

you get to the overview screen of the validation activities belonging to the validation. If you select 

Insert entry, you can carry out changes if necessary. 

15.5.4.2.2.1.1.4 Define Texts for Line Items 

In this activity, you can store texts under keys which can be transferred to the line item. When entering a 

document, the key is entered in the text field. 

Note 

If you wish, the texts can be transferred to the customers in payment notices. 

Activities 

1. Find out which texts are to be stored. 

2. Enter these texts into the system under a key. 

15.5.4.2.2.1.1.5 Define Default Values 

In this activity, you define default values for document types and posting keys which otherwise must be 

entered by the user when processing business transactions. Your specifications depend on the function 

code. 

Example 

When posting outgoing invoices, you use the document type "DR" and posting key "01". You can store 

these specifications in the system. They are proposed by the system when you call up the corresponding 

transaction. 

Activities 

Define the required default values. 

15.5.4.2.2.1.1.6 Define Field Status Variants 

In this activity you can define and edit field status variants and groups. You group several field status 

groups together in one field status variant. You assign the field status variants to a company code in the 

activity Assign Company Code to Field Status Variants. This allows you to work with the same field status 

groups in any number of company codes. 



 

 

You can also define and process field status groups. You must define a field status group in the company 

code-specific area of each G/L account. The field status group determines which fields are ready for input, 

which are required entry fields, and which are hidden during document entry. Bear in mind that additional 

account assignments (i.e. cost centers or orders) are only possible if data can be entered in the 

corresponding fields. 

Standard settings 

Field status variant 0001 is entered for company code 0001 in the standard SAP software. Field status 

groups are already defined for this variant. 

Note 

You cannot attach a field status to some fields, such as those in the document header. You can, however, 

switch between required and optional entry field designations in the document type for some of these 

header fields. 

The field status group you enter in the reconciliation accounts affects postings to the related customer or 

vendor accounts. You cannot enter a field status group in the customer or vendor accounts. Field status 

groups are determined for customer and vendor accounts from their respective reconciliation accounts, via 

the G/L account number in their master records. 

There are other factors, besides the field status group itself, which have an influence on the field status. 

Among these are: 

- The field status defined for the posting key. 

The status "optional entry field" was assigned to posting keys 40 and 50 in the standard system. These 

are the standard posting keys for G/L account postings. The "optional entry field" status has no effect 

on the field status. 

- Specifications for the document type. 

You can specify here that a reference number and document header text must always be entered, for 

example. 

Recommendation 

Designate field status via the field status groups in the G/L accounts. This allows you a more account-

specific screen layout. You cannot differentiate by posting key, since there are only two such keys for 

postings to G/L accounts. 

The situation with reconciliation accounts is different. You do not make any differentiated field status 

definition via the master record for these special G/L accounts. You use the debit and credit posting keys 

instead. 

Activities 

1. Create new field status variants using Edit -> New entries. You can also use the copy function to 

create new field status variants. To do this, select Edit -> Copy as. When copying field status 

variants, the accompanying field status groups are also copied. 

2. Look at the standard field status groups. 

3. Find out which fields on the entry screens should be 
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- ready for input 

- required entry fields 

- Hidden for the G/L accounts in your company. 

You do not make this definition for each account, but rather for groups of accounts. This is why you 

may want to adapt the field status groups included in the standard system. 

4. If necessary, change the standard field status groups, or define your own for each field status variant. 

5. You can delete field status variants that are no longer required via Edit -> Delete. The accompanying 

field status groups will also be deleted. 

 

 

 

 

15.5.4.2.2.1.1.7 Assign Company Code to Field Status Variants 

Use 

In this IMG activity, you assign the company codes in which you want to work with identical field status 

groups to the same field status variant. 

You define your field status group per field status variant. For more information, see Define Field Status 

Definition Groups. 

Standard settings 

In the SAP standard, a field status variant of the same name is assigned to company code 0001. 

Activities 

Assign the company codes concerned to the same field status variant. 

15.5.4.2.2.1.1.8 Screen Variants for Document Entry 

The screen variant which you specify for each company code addresses special screens for documents for 

several specific functions. You determine the screen variant dependent on the company code. 

Example 

In an Italian company code, for example, a screen with fields for withholding tax is required when entering 

a vendor item. You therefore have to select a special screen variant for Italian company codes. 

Standard settings 

A corresponding variant was selected for the standard company codes. 



 

 

Activities 

Check whether the required variants have been selected for your company codes. 

 

15.5.4.2.2.1.1.9 Define Subscreens for Coding Blocks 

Use 

In this IMG activity, you can define your own subscreens for posting transactions. In posting transactions, 

the account assignment objects are displayed on subscreens. If the fields on a subscreen are not sufficient 

for your purposes, you can define your own subscreen. 

Note 

For more information about defining your own subscreens, see the general section Define Subscreens for 

Account Assignment Block. 

15.5.4.2.2.1.1.10 Substitution in Accounting Documents 

In this activity, you define possible changes regarding your accounting documents in the form of 

substitutions of individual fields for your company codes. You can make changes both in the document 

header and in the line item. The substitutions are valid for both the manual entry of documents and for the 

automatic creation of documents (for example, payment program). 

For each company code to which you want to assign a substitution, define the following information: 

- Time of substitution 

Here you enter the key "1" for substitution within the document header, the key "2" for substitution 

within the line item and the key "3" for the whole document. 

- Substitution 

Here you can change or display the names of substitutions which already exist. You have to create a 

new substitution. The name then appears in the overview afterwards. 

- Name for the substitution 

- Activation level 

Here you enter the key "0" for inactive, the key "1" for active and the key "2" for active (except for 

in batch). 

Activities 

If you want to define new substitutions, proceed as follows: 

1. Position the cursor on a line in which the company code and the time have been entered (you can 

enter the company code and the time via Edit -> New entries). 
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2. Then select Environment -> Substitution. You reach the first screen for maintaining a substitution. 

3. Select Substitution -> Create. Enter the required name. After pressing ENTER, you reach the 

overview screen with the substitution activities belonging to substitution. 

4. Select Insert entry. You can describe a new substitution activity on the next screen. You describe 

the substitution requirements and the actual substitution for this. The syntax to be used for this is 

explained in the F1 help for the input fields Requirements and Substitution. 

If you want to change substitutions which already exist, proceed as follows: 

1. Position the cursor on an existing entry and select Goto -> Substitution. 

2. On the next screen, select Substitution -> Display or Substitution -> Change. After pressing 

ENTER, you reach the overview screen with the substitution activities belonging to substitution. If 

you select Insert entry, you can make the required changes. 

15.5.4.2.2.1.1.11 Define Text IDs for Documents 

In this activity you define text IDs for long texts at document header level. When entering a document, you 

can enter texts for every text ID. This means that you can store information on the document that affects 

the whole document. 

Note 

You create text IDs across the system, i.e. for all clients. 

SAP standard settings 

The system is delivered with the text IDs Note, Correspondence, and Payment advice info as standard 

settings. 

Activities 

1. Define the required text IDs. 

2. Select the Relevant text field in the clients in which the text IDs are to be used. 

15.5.4.2.2.1.1.12 Define Line Layout for Document Posting Overview 

In this activity, you define the line layout variants for document posting by specifying which information 

you want to have available onscreen (i.e., document number, account number, company code).  You can 

also assign a display format to each field. 

Activities 

1. Check the extent to which you can use the standard settings. Change or enhance the settings, if 

Necessary. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user's master 

record. 



 

 

15.5.4.2.2.1.1.13 Define Line Layout for Document Change/Display 

In this activity, you define the line layout variants. 

For the functions Change document or Display document, you define which information from the line 

item is displayed on the screen. 

For the function Edit payment proposal, you define the layout for displaying the payments or exceptions. 

Activities 

1. Check whether you can use the standard settings. Change them or add to them as required. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.2.1.1.14 Select Standard Line Layout for Document Change/Display 

In this activity, you select the standard default values for the following functions: 

- Displaying or changing documents 

- Displaying or processing payment proposals 

These variants are used when the display or change functions are first called up if you do not select any 

other variant. 

Activities 

Choose a corresponding line layout variant. 

15.5.4.2.2.1.1.15 Document Change Rules, Document Header 

In this activity, you determine under which circumstances fields within posted documents can be changed. 

Note 

For a number of fields, the system itself determines that they can no longer be changed after posting. This 

includes all fields which are central to the principles of orderly accounting, for example, the amount posted 

and the account. 

The system also prevents the update objects from being changed in documents which have already been 

posted, independent of the document change rules. Update objects are elements in the system for which 

transaction figures or line items are updated, for example, business area or cost centers (if cost center 

accounting is used in the SAP system). Update objects are entered as additional account assignments during 

posting. 

If you are using the Special Purpose Ledger application, you should ensure that fields which are updated 

there are protected against changes in the document. Document changes do not affect updating in the 

special purpose ledger. 

Activities 
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1. Check the default settings. 

2. Change the specifications if necessary. 

15.5.4.2.2.1.1.16 Maintain Fast Entry Screens for G/L Account Items 

In this activity you define screen templates for the fast entry of G/L account items when posting documents.  

You can generate screen templates with the field’s account, amount and company code, for example. 

Activities 

1. Check to what extent you can use the standard settings. If necessary, change or enhance the 

definitions. 

2. If you want to assign a screen template to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.2.1.2 Define Alternative Reconciliation Account for Bills of Exchange 
Payable 

In the following step, you make specifications which are necessary for posting bills of exchange. 

If you wish to post and create bills of exchange with the payment program, you have to carry out further 

steps when you configure the payment program. 

In this case, you define an account in which the bill of exchange payments are managed in the general 

ledger. In the case of bill of exchange payments, the posting is automatically made to this account instead 

of the normal payables account (reconciliation account). 

Note 

The specification is dependent on account type, special G/L indicator, chart of accounts and reconciliation 

account. 

Activities 

1. Specify the number of the alternative reconciliation account. 

2. Make sure that the account is created. 

15.5.4.2.2.2 Returned Bills of Exchange Payable 

In the following step, you make all the settings you need for returned bills of exchange. 

This includes maintaining: 

- exception types, 



 

 

- house bank details, 

- forms, and 

- Sender details. 

15.5.4.2.2.2.1 Define Exception Types 

In this step you define the allowable exception types. 

In addition, exception types are defined as default exception types if after the automatic check, the system 

enters them as a default when you select using DME. 

Maintain the following exception types in the standard system for France: 

Exception DME indicator 

  

Bill of exchange not found  13  

Other bank in bill of exchange  9  

Accepted bills of exchange only  39  

Drawee of bill of exchange is incorrect 70   

Bill of exchange already paid  71  

Acceptance indicator incorrect  72  

Bill of exchange amount incorrect 73   

Bill of exchange due date incorrect 74   

Request for extension   75 

Delayed bill of exchange protest 76 

Partial payment after conferring with drawer 90 

Activities 

Define the appropriate criteria for exception types. 

15.5.4.2.2.2.2 Define Account for Returned Bills of Exchange 

In this step you define the house bank details. These details are dependent on the company code and house 

bank. 

You must define the G/L account to which the system posts the bank debit memo. This account can be the 

actual bank account or an interim account. 

Activities 
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Enter the data you need for the house bank details. 

Further notes 

See bill of exchange presentation for additional house bank details. 

15.5.4.2.2.2.3 Define User-Specific Settings 

In this activity you make specifications per user and company code that are defaulted when you run the 

transaction for returned bills of exchange payable (transaction FBWD). 

Note 

When you run the transaction for returned bills of exchange payable for the first time, the system saves 

your entries and defaults them next time you use the transaction. If you change any entries at a later date, 

the changed entries are then saved. 

If you always wish to work with the same entries, do not set the indicator "Automatically record". 

Activities 

Make entries in the required fields. 

15.5.4.2.2.2.4 Assign Forms for Returned Bills of Exchange Payable 

In this step you define the form for bank correspondence. 

You can specify a special form in the Fo.ID field. If you do not make any further specifications, the system 

uses the standard form created for this company code in customizing. 

You must define the SAP script forms if you want to create a payment advice using SAP script. 

Activities 

Enter the criteria for maintaining the form. 

15.5.4.2.2.2.5 Define Sender Details for Form for Returned Bills of Exchange 

In this step you define the corresponding text IDs, if the system accesses standard texts for the sender 

information in the forms. 

You can, for example, create a separate variant with a separate ID for each accountant. 

Activities 



 

 

Define and store the required sender information. 

15.5.4.2.3 Check/Bill of Exchange 

In the following activities, you make settings for checks/bills of exchange. 

15.5.4.2.3.1 Check/Bill of Exchange Transactions Received 

In the following steps, you make the settings for reverse bills of exchange received. 

 

 

15.5.4.2.3.1.1 Make and Check Document Settings 

You can make new document settings here, or check existing settings, so that they correspond to the 

business transaction you are currently processing: 

- If you have already made document settings in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that those settings are correct here. 

- If you have not yet made any document settings, you can do so here. 

15.5.4.2.3.1.1.1 Define Document Types 

In this activity you create document types for customer, vendor and general ledger business transactions in 

Financial Accounting. Document types differentiate business transactions and control document filing. 

You specify a number range for each document type. Document numbers are chosen from this number 

range. You can use one number range for several document types. 

Document types are valid for all clients. You specify a number range key for each document type. You 

create the desired number range intervals for each number range key based on the company code. This 

means that you can specify intervals of different sizes for the same number range. 

Example 

You defined a document type for incoming invoices. In company code 0001 there are a lot of invoices to 

be posted. Thus you create a large number interval for the number range in this company code. In another 

company code there are only a few incoming invoices that need to be posted. For this company code you 

can define a small number interval for the same number range. 

If a document type is not used in a company code, do not store a number interval for that company code. 

Note 

To use the net method of posting documents, you need a net document type (for example, KN). In this 

document type, you have to set the "Net document type" indicator found under the "Control" area. You 

can define a common document type (for example, AB) and a common number range for clearing open 

items in accounts receivable, payable and G/L accounts. 
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For automatic posting transactions (for example, transfer postings with clearing), you have to define a 

clearing document type (for example, AB). If you do not want to use the standard setting AB for the 

clearing document type, you can delete it and define your own. Under the document type properties, you 

can assign an individual reverse document type to each document type. For document types with external 

number ranges, you have to define an individual reverse document type because the system can make 

automatic reverse entries only in document types that have internal number assignment. 

Standard settings 

The pre-set document types cover business transactions 

- in Financial Accounting for: 

- General ledger accounting 

- Accounts receivable 

- Accounts payable 

- Asset accounting 

- Consolidation 

- in Materials Management and Sales and Distribution for: 

- Goods receipt and issue 

- Incoming and outgoing invoices 

- Physical inventory ( stocktaking ) 

- Invoicing 

Activities 

1. Find out whether you can use the standard settings. 

2. Change or extend the default settings, if necessary. 

3. Check the specified document number ranges via the "Define document number ranges" activity if 

you use the standard document types. 

These number ranges must be created for your company codes and contain the number intervals you 

require. 

15.5.4.2.3.1.1.2 Define Posting Keys 

In this activity you define posting keys. Users specify a posting key before entering a line item. The posting 

key controls how the line item is entered and processed. 

For each posting key, you define among other things: 

- which side of an account can be posted to, 

- which type of account can be posted to, and 



 

 

- Which fields the system displays on the entry screens and whether an entry must be made (field 

status). 

Note 

The system also uses the field status group you specify in a G/L account to determine the status of fields 

in document entry. Field status groups are defined within a field status variant. 

Recommendation 

Use the posting keys delivered with the standard system. 

Activities 

1. Check the standard settings. 

2. Modify them if necessary. 

In particular, you may need to make changes to customer and vendor posting keys if a different field 

status is required. 

15.5.4.2.3.1.1.3 Validation in Accounting Documents 

In this activity, you define additional checks for accounting documents in the form of validations for each 

of your company codes. You can assign a validation for the document header and one for the line items to 

each company code. The assigned validations are valid both for manual entry of documents as well as for 

the automatic creation of documents (for example, payment program). 

For every company code to which you want to assign a validation, you store the following information: 

- Validation callup point 

Here you enter key "1" for "Check document header" and key "2" for "Check line item". 

- Validation 

Here there are the names of validations which already exist which you can display or change. A new 

validation must firstly be created by you. Afterwards the name appears in the overview. 

- Description of the validation 

- Activation level 

Here you enter key "0" for inactive, key "1" for active and key "2" for active except for batch input. 

Example 

For example, you can use the validation for the following situation: You want to make sure that postings 

to the expense account "Telephone costs" can only be posted to the services cost center "Telephone". You 

can carry out the checks needed for this by using the validation. 

Activities 

If you want to define new validations, go through the following activities: 
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1. Place the cursor on a line in which company code and callup point are entered (you can enter company 

code and validation callup point via Edit -> New entries). 

2. Afterwards select Environment -> Validation. You reach the first screen for maintaining a 

validation. 

3. Select Validation -> Create. Enter the required name. After pressing ENTER, you come to an 

overview screen of the validation activities belonging to the validation. 

4. Select Insert entry. On the next screen you can describe a new validation activity. You describe the 

check requirements and the actual check for this. The syntax to be used for this is described in the 

online help (F1 help) for the input fields for Requirements and Check. You can also define a 

message (warning or error message) which is sent if the check is not successful. 

If you want to change validations which already exist, proceed as follows: 

1. Place the cursor on an already existing entry and select Goto -> Validation. 

2. On the next screen select Validation -> Display or Validation -> Change. After pressing ENTER, 

you get to the overview screen of the validation activities belonging to the validation. If you select 

Insert entry, you can carry out changes if necessary. 

15.5.4.2.3.1.1.4 Define Texts for Line Items 

In this activity, you can store texts under keys which can be transferred to the line item. When entering a 

document, the key is entered in the text field. 

Note 

If you wish, the texts can be transferred to the customers in payment notices. 

Activities 

1. Find out which texts are to be stored. 

2. Enter these texts into the system under a key. 

15.5.4.2.3.1.1.5 Define Default Values 

In this activity, you define default values for document types and posting keys which otherwise must be 

entered by the user when processing business transactions. Your specifications depend on the function 

code. 

Example 

When posting outgoing invoices, you use the document type "DR" and posting key "01". You can store 

these specifications in the system. They are proposed by the system when you call up the corresponding 

transaction. 

Activities 

Define the required default values. 



 

 

15.5.4.2.3.1.1.6 Define Field Status Variants 

In this activity you can define and edit field status variants and groups. You group several field status 

groups together in one field status variant. You assign the field status variants to a company code in the 

activity Assign Company Code to Field Status Variants. This allows you to work with the same field status 

groups in any number of company codes. 

You can also define and process field status groups. You must define a field status group in the company 

code-specific area of each G/L account. The field status group determines which fields are ready for input, 

which are required entry fields, and which are hidden during document entry. Bear in mind that additional 

account assignments (i.e. cost centers or orders) are only possible if data can be entered in the 

corresponding fields. 

Standard settings 

Field status variant 0001 is entered for company code 0001 in the standard SAP software. Field status 

groups are already defined for this variant. 

Note 

You cannot attach a field status to some fields, such as those in the document header. You can, however, 

switch between required and optional entry field designations in the document type for some of these 

header fields. 

The field status group you enter in the reconciliation accounts affects postings to the related customer or 

vendor accounts. You cannot enter a field status group in the customer or vendor accounts. Field status 

groups are determined for customer and vendor accounts from their respective reconciliation accounts, via 

the G/L account number in their master records. 

There are other factors, besides the field status group itself, which have an influence on the field status. 

Among these are: 

- The field status defined for the posting key. 

The status "optional entry field" was assigned to posting keys 40 and 50 in the standard system. These 

are the standard posting keys for G/L account postings. The "optional entry field" status has no effect 

on the field status. 

- Specifications for the document type. 

You can specify here that a reference number and document header text must always be entered, for 

example. 

 

Recommendation 

Designate field status via the field status groups in the G/L accounts. This allows you a more account-

specific screen layout. You cannot differentiate by posting key, since there are only two such keys for 

postings to G/L accounts. 

The situation with reconciliation accounts is different. You do not make any differentiated field status 

definition via the master record for these special G/L accounts. You use the debit and credit posting keys 

instead. 

Activities 
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1. Create new field status variants using Edit -> New entries. You can also use the copy function to 

create new field status variants. To do this, select Edit -> Copy as. When copying field status 

variants, the accompanying field status groups are also copied. 

2. Look at the standard field status groups. 

3. Find out which fields on the entry screens should be 

- ready for input 

- required entry fields 

- Hidden for the G/L accounts in your company. 

You do not make this definition for each account, but rather for groups of accounts. This is why you 

may want to adapt the field status groups included in the standard system. 

4. If necessary, change the standard field status groups, or define your own for each field status variant. 

5. You can delete field status variants that are no longer required via Edit -> Delete. The accompanying 

field status groups will also be deleted. 

15.5.4.2.3.1.1.7 Assign Company Code to Field Status Variants 

Use 

In this IMG activity, you assign the company codes in which you want to work with identical field status 

groups to the same field status variant. 

You define your field status group per field status variant. For more information, see Define Field Status 

Definition Groups. 

Standard settings 

In the SAP standard, a field status variant of the same name is assigned to company code 0001. 

Activities 

Assign the company codes concerned to the same field status variant. 

15.5.4.2.3.1.1.8 Screen Variants for Document Entry 

The screen variant which you specify for each company code addresses special screens for documents for 

several specific functions. You determine the screen variant dependent on the company code. 

Example 



 

 

In an Italian company code, for example, a screen with fields for withholding tax is required when entering 

a vendor item. You therefore have to select a special screen variant for Italian company codes. 

Standard settings 

A corresponding variant was selected for the standard company codes. 

Activities 

Check whether the required variants have been selected for your company codes. 

15.5.4.2.3.1.1.9 Define Subscreens for Coding Blocks 

Use 

In this IMG activity, you can define your own subscreens for posting transactions. In posting transactions, 

the account assignment objects are displayed on subscreens. If the fields on a subscreen are not sufficient 

for your purposes, you can define your own subscreen. 

Note 

For more information about defining your own subscreens, see the general section Define Subscreens for 

Account Assignment Block. 

 

15.5.4.2.3.1.1.10 Substitution in Accounting Documents 

In this activity, you define possible changes regarding your accounting documents in the form of 

substitutions of individual fields for your company codes. You can make changes both in the document 

header and in the line item. The substitutions are valid for both the manual entry of documents and for the 

automatic creation of documents (for example, payment program). 

For each company code to which you want to assign a substitution, define the following information: 

- Time of substitution 

Here you enter the key "1" for substitution within the document header, the key "2" for substitution 

within the line item and the key "3" for the whole document. 

- Substitution 

Here you can change or display the names of substitutions which already exist. You have to create a 

new substitution. The name then appears in the overview afterwards. 

- Name for the substitution 

- Activation level 

Here you enter the key "0" for inactive, the key "1" for active and the key "2" for active (except for 

in batch). 

Activities 

If you want to define new substitutions, proceed as follows: 
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1. Position the cursor on a line in which the company code and the time have been entered (you can 

enter the company code and the time via Edit -> New entries). 

2. Then select Environment -> Substitution. You reach the first screen for maintaining a substitution. 

3. Select Substitution -> Create. Enter the required name. After pressing ENTER, you reach the 

overview screen with the substitution activities belonging to substitution. 

4. Select Insert entry. You can describe a new substitution activity on the next screen. You describe 

the substitution requirements and the actual substitution for this. The syntax to be used for this is 

explained in the F1 help for the input fields Requirements and Substitution. 

If you want to change substitutions which already exist, proceed as follows: 

1. Position the cursor on an existing entry and select Goto -> Substitution. 

2. On the next screen, select Substitution -> Display or Substitution -> Change. After pressing 

ENTER, you reach the overview screen with the substitution activities belonging to substitution. If 

you select Insert entry, you can make the required changes. 

 

 

15.5.4.2.3.1.1.11 Define Text IDs for Documents 

In this activity you define text IDs for long texts at document header level. When entering a document, you 

can enter texts for every text ID. This means that you can store information on the document that affects 

the whole document. 

Note 

You create text IDs across the system, i.e. for all clients. 

SAP standard settings 

The system is delivered with the text IDs Note, Correspondence, and Payment advice info as standard 

settings. 

Activities 

1. Define the required text IDs. 

2. Select the Relevant text field in the clients in which the text IDs are to be used. 

15.5.4.2.3.1.1.12 Define Line Layout for Document Posting Overview 

In this activity, you define the line layout variants for document posting by specifying which information 

you want to have available onscreen (i.e., document number, account number, company code).  You can 

also assign a display format to each field. 

Activities 

1. Check the extent to which you can use the standard settings. Change or enhance the settings, if 

necessary. 



 

 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user's master 

record. 

15.5.4.2.3.1.1.13 Define Line Layout for Document Change/Display 

In this activity, you define the line layout variants. 

For the functions Change document or Display document, you define which information from the line 

item is displayed on the screen. 

For the function Edit payment proposal, you define the layout for displaying the payments or exceptions. 

Activities 

1. Check whether you can use the standard settings. Change them or add to them as required. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.3.1.1.14 Select Standard Line Layout for Document Change/Display 

In this activity, you select the standard default values for the following functions: 

- Displaying or changing documents 

- Displaying or processing payment proposals 

These variants are used when the display or change functions are first called up if you do not select any 

other variant. 

Activities 

Choose a corresponding line layout variant. 

15.5.4.2.3.1.1.15 Document Change Rules, Document Header 

In this activity, you determine under which circumstances fields within posted documents can be changed. 

Note 

For a number of fields, the system itself determines that they can no longer be changed after posting. This 

includes all fields which are central to the principles of orderly accounting, for example, the amount posted 

and the account. 

The system also prevents the update objects from being changed in documents which have already been 

posted, independent of the document change rules. Update objects are elements in the system for which 

transaction figures or line items are updated, for example, business area or cost centers (if cost center 

accounting is used in the SAP system). Update objects are entered as additional account assignments during 

posting. 
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If you are using the Special Purpose Ledger application, you should ensure that fields which are updated 

there are protected against changes in the document. Document changes do not affect updating in the 

special purpose ledger. 

Activities 

1. Check the default settings. 

2. Change the specifications if necessary. 

 

15.5.4.2.3.1.1.16 Maintain Fast Entry Screens for G/L Account Items 

In this activity you define screen templates for the fast entry of G/L account items when posting documents.  

You can generate screen templates with the field’s account, amount and company code, for example. 

Activities 

1. Check to what extent you can use the standard settings. If necessary, change or enhance the 

definitions. 

2. If you want to assign a screen template to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.3.1.2 Prepare Reverse Bill of Exchange Posting (Customers) 

In this activity you specify the posting keys and special G/L indicator for posting bill of exchange 

payments. This is only necessary if you do not use the standard posting keys and the standard special G/L 

indicators for the check/bill of exchange transaction. 

In addition to these specifications, you define the following in the system: 

- Alternative reconciliation account 

When posting a check/bill of exchange, the posting is not made to the normal reconciliation account 

as when posting all other bills of exchange, but to an alternative reconciliation account. You must 

therefore specify an alternative reconciliation account for the checks/ bills of exchange. 

- Account for offsetting entry 

When posting a check/bill of exchange, the offsetting entry to the bill of exchange posting is made 

automatically. For this posting, define the number of a G/L account. 

Activities 

1. Define the number of the alternative reconciliation account. 

2. Define the posting keys and the special G/L indicator for the bill of exchange posting if you do not 

use the default settings. 

3. Define the number of the account for the automatic offsetting entry. 

 



 

 

 

15.5.4.2.3.1.3 Define Alternative Reconcil. Account for Reverse Bill/Exch. 

In this activity you define the accounts in which bill of exchange payments are recorded in the general 

ledger. When you post bills of exchange, the system will post the entries to these accounts instead of to the 

normal receivables account (reconciliation account). This way it is possible to keep bills of exchange 

separate from the normal receivables. A transfer posting for balance sheet purposes is no longer necessary. 

Note 

The specification of accounts depends on the account type, special G/L indicator, chart of accounts, and 

reconciliation account for normal receivables. 

Activities 

1. Enter your bill(s) of exchange account(s) in the field for the alternative reconciliation account. 

2. Make sure that the account has been created. 

Additional information 

You can find additional information on the alternative reconciliation account in the "FI Accounts 

Receivable and Accounts Payable" document under "Special G/L transactions". 

15.5.4.2.3.1.4 Define Accounts for Automatic Offsetting Entry 

In this activity you define the G/L accounts to which the system posts the offsetting entry for specific 

special G/L transactions, for example, guarantees or bills of exchange. 

The account specification is differentiated by the chart of accounts and a key that contains the account type 

and the special G/L indicator. 

Standard settings 

The standard system contains posting keys for all transactions. 

Activities 

1. Specify the accounts for the necessary transactions. Only change the posting keys if you are not using 

the posting keys delivered with the system. 

2. Make sure that the specified accounts are created. 

15.5.4.2.3.2 Check/Bill of Exchange Transactions Issued 

In the following steps, you make the settings for reverse bills of exchange issued. 
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15.5.4.2.3.2.1 Make and Check Document Settings 

You can make new document settings here, or check existing settings, so that they correspond to the 

business transaction you are currently processing: 

- If you have already made document settings in the "Financial Accounting Global Settings" 

Implementation Guide, you can check that those settings are correct here. 

- If you have not yet made any document settings, you can do so here. 

15.5.4.2.3.2.1.1 Define Document Types 

In this activity you create document types for customer, vendor and general ledger business transactions in 

Financial Accounting. Document types differentiate business transactions and control document filing. 

You specify a number range for each document type. Document numbers are chosen from this number 

range. You can use one number range for several document types. 

Document types are valid for all clients. You specify a number range key for each document type. You 

create the desired number range intervals for each number range key based on the company code. This 

means that you can specify intervals of different sizes for the same number range. 

Example 

You defined a document type for incoming invoices. In company code 0001 there are a lot of invoices to 

be posted. Thus you create a large number interval for the number range in this company code. In another 

company code there are only a few incoming invoices that need to be posted. For this company code you 

can define a small number interval for the same number range. 

If a document type is not used in a company code, do not store a number interval for that company code. 

Note 

To use the net method of posting documents, you need a net document type (for example, KN). In this 

document type, you have to set the "Net document type" indicator found under the "Control" area. You 

can define a common document type (for example, AB) and a common number range for clearing open 

items in accounts receivable, payable and G/L accounts. 

For automatic posting transactions (for example, transfer postings with clearing), you have to define a 

clearing document type (for example, AB). If you do not want to use the standard setting AB for the 

clearing document type, you can delete it and define your own. Under the document type properties, you 

can assign an individual reverse document type to each document type. For document types with external 

number ranges, you have to define an individual reverse document type because the system can make 

automatic reverse entries only in document types that have internal number assignment. 

Standard settings 

The pre-set document types cover business transactions 

- in Financial Accounting for: 

- General ledger accounting 

- Accounts receivable 



 

 

- Accounts payable 

- Asset accounting 

- Consolidation 

- in Materials Management and Sales and Distribution for: 

- Goods receipt and issue 

- Incoming and outgoing invoices 

- Physical inventory ( stocktaking ) 

- Invoicing 

Activities 

1. Find out whether you can use the standard settings. 

2. Change or extend the default settings, if necessary. 

3. Check the specified document number ranges via the "Define document number ranges" activity if 

you use the standard document types. 

These number ranges must be created for your company codes and contain the number intervals you 

require. 

15.5.4.2.3.2.1.2 Define Posting Keys 

In this activity you define posting keys. Users specify a posting key before entering a line item. The posting 

key controls how the line item is entered and processed. 

For each posting key, you define among other things: 

- which side of an account can be posted to, 

- which type of account can be posted to, and 

- Which fields the system displays on the entry screens and whether an entry must be made (field 

status). 

Note 

The system also uses the field status group you specify in a G/L account to determine the status of fields 

in document entry. Field status groups are defined within a field status variant. 

Recommendation 

Use the posting keys delivered with the standard system. 

Activities 

1. Check the standard settings. 
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2. Modify them if necessary. 

In particular, you may need to make changes to customer and vendor posting keys if a different field 

status is required. 

15.5.4.2.3.2.1.3 Validation in Accounting Documents 

In this activity, you define additional checks for accounting documents in the form of validations for each 

of your company codes. You can assign a validation for the document header and one for the line items to 

each company code. The assigned validations are valid both for manual entry of documents as well as for 

the automatic creation of documents (for example, payment program). 

For every company code to which you want to assign a validation, you store the following information: 

- Validation callup point 

Here you enter key "1" for "Check document header" and key "2" for "Check line item". 

- Validation 

Here there are the names of validations which already exist which you can display or change. A new 

validation must firstly be created by you. Afterwards the name appears in the overview. 

- Description of the validation 

- Activation level 

Here you enter key "0" for inactive, key "1" for active and key "2" for active except for batch input. 

Example 

For example, you can use the validation for the following situation: You want to make sure that postings 

to the expense account "Telephone costs" can only be posted to the services cost center "Telephone". You 

can carry out the checks needed for this by using the validation. 

Activities 

If you want to define new validations, go through the following activities: 

1. Place the cursor on a line in which company code and callup point are entered (you can enter company 

code and validation callup point via Edit -> New entries). 

2. Afterwards select Environment -> Validation. You reach the first screen for maintaining a 

validation. 

3. Select Validation -> Create. Enter the required name. After pressing ENTER, you come to an 

overview screen of the validation activities belonging to the validation. 

4. Select Insert entry. On the next screen you can describe a new validation activity. You describe the 

check requirements and the actual check for this. The syntax to be used for this is described in the 

online help (F1 help) for the input fields for Requirements and Check. You can also define a 

message (warning or error message) which is sent if the check is not successful. 

If you want to change validations which already exist, proceed as follows: 

1. Place the cursor on an already existing entry and select Goto -> Validation. 



 

 

2. On the next screen select Validation -> Display or Validation -> Change. After pressing ENTER, 

you get to the overview screen of the validation activities belonging to the validation. If you select 

Insert entry, you can carry out changes if necessary. 

15.5.4.2.3.2.1.4 Define Texts for Line Items 

In this activity, you can store texts under keys which can be transferred to the line item. When entering a 

document, the key is entered in the text field. 

Note 

If you wish, the texts can be transferred to the customers in payment notices. 

Activities 

1. Find out which texts are to be stored. 

2. Enter these texts into the system under a key. 

15.5.4.2.3.2.1.5 Define Default Values 

In this activity, you define default values for document types and posting keys which otherwise must be 

entered by the user when processing business transactions. Your specifications depend on the function 

code. 

Example 

When posting outgoing invoices, you use the document type "DR" and posting key "01". You can store 

these specifications in the system. They are proposed by the system when you call up the corresponding 

transaction. 

Activities 

Define the required default values. 

15.5.4.2.3.2.1.6 Define Field Status Variants 

In this activity you can define and edit field status variants and groups. You group several field status 

groups together in one field status variant. You assign the field status variants to a company code in the 

activity Assign Company Code to Field Status Variants. This allows you to work with the same field status 

groups in any number of company codes. 

You can also define and process field status groups. You must define a field status group in the company 

code-specific area of each G/L account. The field status group determines which fields are ready for input, 

which are required entry fields, and which are hidden during document entry. Bear in mind that additional 

account assignments (i.e. cost centers or orders) are only possible if data can be entered in the 

corresponding fields. 

Standard settings 
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Field status variant 0001 is entered for company code 0001 in the standard SAP software. Field status 

groups are already defined for this variant. 

Note 

You cannot attach a field status to some fields, such as those in the document header. You can, however, 

switch between required and optional entry field designations in the document type for some of these 

header fields. 

The field status group you enter in the reconciliation accounts affects postings to the related customer or 

vendor accounts. You cannot enter a field status group in the customer or vendor accounts. Field status 

groups are determined for customer and vendor accounts from their respective reconciliation accounts, via 

the G/L account number in their master records. 

There are other factors, besides the field status group itself, which have an influence on the field status. 

Among these are: 

- The field status defined for the posting key. 

The status "optional entry field" was assigned to posting keys 40 and 50 in the standard system. These 

are the standard posting keys for G/L account postings. The "optional entry field" status has no effect 

on the field status. 

- Specifications for the document type. 

You can specify here that a reference number and document header text must always be entered, for 

example. 

Recommendation 

Designate field status via the field status groups in the G/L accounts. This allows you a more account-

specific screen layout. You cannot differentiate by posting key, since there are only two such keys for 

postings to G/L accounts. 

The situation with reconciliation accounts is different. You do not make any differentiated field status 

definition via the master record for these special G/L accounts. You use the debit and credit posting keys 

instead. 

Activities 

1. Create new field status variants using Edit -> New entries. You can also use the copy function to 

create new field status variants. To do this, select Edit -> Copy as. When copying field status 

variants, the accompanying field status groups are also copied. 

2. Look at the standard field status groups. 

3. Find out which fields on the entry screens should be 

- ready for input 

- required entry fields 

- Hidden for the G/L accounts in your company. 

You do not make this definition for each account, but rather for groups of accounts. This is why you 

may want to adapt the field status groups included in the standard system. 



 

 

4. If necessary, change the standard field status groups, or define your own for each field status variant. 

5. You can delete field status variants that are no longer required via Edit -> Delete. The accompanying 

field status groups will also be deleted. 

15.5.4.2.3.2.1.7 Assign Company Code to Field Status Variants 

Use 

In this IMG activity, you assign the company codes in which you want to work with identical field status 

groups to the same field status variant. 

You define your field status group per field status variant. For more information, see Define Field Status 

Definition Groups. 

Standard settings 

In the SAP standard, a field status variant of the same name is assigned to company code 0001. 

Activities 

Assign the company codes concerned to the same field status variant. 

15.5.4.2.3.2.1.8 Screen Variants for Document Entry 

The screen variant which you specify for each company code addresses special screens for documents for 

several specific functions. You determine the screen variant dependent on the company code. 

Example 

In an Italian company code, for example, a screen with fields for withholding tax is required when entering 

a vendor item. You therefore have to select a special screen variant for Italian company codes. 

Standard settings 

A corresponding variant was selected for the standard company codes. 

Activities 

Check whether the required variants have been selected for your company codes. 

15.5.4.2.3.2.1.9 Define Subscreens for Coding Blocks 

Use 
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In this IMG activity, you can define your own subscreens for posting transactions. In posting transactions, 

the account assignment objects are displayed on subscreens. If the fields on a subscreen are not sufficient 

for your purposes, you can define your own subscreen. 

Note 

For more information about defining your own subscreens, see the general section Define Subscreens for 

Account Assignment Block. 

 

 

 

15.5.4.2.3.2.1.10 Substitution in Accounting Documents 

In this activity, you define possible changes regarding your accounting documents in the form of 

substitutions of individual fields for your company codes. You can make changes both in the document 

header and in the line item. The substitutions are valid for both the manual entry of documents and for the 

automatic creation of documents (for example, payment program). 

For each company code to which you want to assign a substitution, define the following information: 

- Time of substitution 

Here you enter the key "1" for substitution within the document header, the key "2" for substitution 

within the line item and the key "3" for the whole document. 

- Substitution 

Here you can change or display the names of substitutions which already exist. You have to create a 

new substitution. The name then appears in the overview afterwards. 

- Name for the substitution 

- Activation level 

Here you enter the key "0" for inactive, the key "1" for active and the key "2" for active (except for 

in batch). 

Activities 

If you want to define new substitutions, proceed as follows: 

1. Position the cursor on a line in which the company code and the time have been entered (you can 

enter the company code and the time via Edit -> New entries). 

2. Then select Environment -> Substitution. You reach the first screen for maintaining a substitution. 

3. Select Substitution -> Create. Enter the required name. After pressing ENTER, you reach the 

overview screen with the substitution activities belonging to substitution. 

4. Select Insert entry. You can describe a new substitution activity on the next screen. You describe 

the substitution requirements and the actual substitution for this. The syntax to be used for this is 

explained in the F1 help for the input fields Requirements and Substitution. 

If you want to change substitutions which already exist, proceed as follows: 

1. Position the cursor on an existing entry and select Goto -> Substitution. 



 

 

2. On the next screen, select Substitution -> Display or Substitution -> Change. After pressing 

ENTER, you reach the overview screen with the substitution activities belonging to substitution. If 

you select Insert entry, you can make the required changes. 

 

 

15.5.4.2.3.2.1.11 Define Text IDs for Documents 

In this activity you define text IDs for long texts at document header level. When entering a document, you 

can enter texts for every text ID. This means that you can store information on the document that affects 

the whole document. 

Note 

You create text IDs across the system, i.e. for all clients. 

SAP standard settings 

The system is delivered with the text IDs Note, Correspondence, and Payment advice info as standard 

settings. 

Activities 

1. Define the required text IDs. 

2. Select the Relevant text field in the clients in which the text IDs are to be used. 

15.5.4.2.3.2.1.12 Define Line Layout for Document Posting Overview 

In this activity, you define the line layout variants for document posting by specifying which information 

you want to have available onscreen (i.e., document number, account number, company code).  You can 

also assign a display format to each field. 

Activities 

1. Check the extent to which you can use the standard settings. Change or enhance the settings, if 

necessary. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user's master 

record. 

15.5.4.2.3.2.1.13 Define Line Layout for Document Change/Display 

In this activity, you define the line layout variants. 

For the functions Change document or Display document, you define which information from the line 

item is displayed on the screen. 

For the function Edit payment proposal, you define the layout for displaying the payments or exceptions. 

Activities 
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1. Check whether you can use the standard settings. Change them or add to them as required. 

2. If you want to assign a line layout variant to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.3.2.1.14 Select Standard Line Layout for Document Change/Display 

In this activity, you select the standard default values for the following functions: 

- Displaying or changing documents 

- Displaying or processing payment proposals 

These variants are used when the display or change functions are first called up if you do not select any 

other variant. 

Activities 

Choose a corresponding line layout variant. 

15.5.4.2.3.2.1.15 Document Change Rules, Document Header 

In this activity, you determine under which circumstances fields within posted documents can be changed. 

Note 

For a number of fields, the system itself determines that they can no longer be changed after posting. This 

includes all fields which are central to the principles of orderly accounting, for example, the amount posted 

and the account. 

The system also prevents the update objects from being changed in documents which have already been 

posted, independent of the document change rules. Update objects are elements in the system for which 

transaction figures or line items are updated, for example, business area or cost centers (if cost center 

accounting is used in the SAP system). Update objects are entered as additional account assignments during 

posting. 

If you are using the Special Purpose Ledger application, you should ensure that fields which are updated 

there are protected against changes in the document. Document changes do not affect updating in the 

special purpose ledger. 

Activities 

1. Check the default settings. 

2. Change the specifications if necessary. 

 

 

15.5.4.2.3.2.1.16 Maintain Fast Entry Screens for G/L Account Items 

In this activity you define screen templates for the fast entry of G/L account items when posting documents.  

You can generate screen templates with the field’s account, amount and company code, for example. 



 

 

Activities 

1. Check to what extent you can use the standard settings. If necessary, change or enhance the 

definitions. 

2. If you want to assign a screen template to a user, enter the value as a parameter in the user master 

record. 

15.5.4.2.3.2.2 Prepare Reverse Bill of Exchange Posting (Vendors) 

In this step, you can enter the posting keys and the special G/L indicator for posting payments by bill of 

exchange. This is only necessary if you do not use the standard posting keys and the standard special G/L 

indicator for checks/bills of exchange. 

In addition to these specifications, the following is to be defined in the system: 

- Alternative reconciliation account 

When posting a check/bill of exchange, the posting is not made to the normal reconciliation account 

as for posting all other bills of exchange, but to an alternative reconciliation account. For the checks/ 

bills of exchange, you therefore specify an alternative reconciliation account. 

- Account for offsetting entry 

When posting a check/bill of exchange, the offsetting entry to the bill of exchange posting is made 

automatically. For this posting, store the number of a G/L account. 

Activities 

1. Define the number of the alternative reconciliation account. 

2. Define the posting keys and the special G/L indicator for the bill of exchange posting if you do not 

use the default values. 

3. Define the number of the account for the automatic offsetting entry. 

15.5.4.2.3.2.3 Define Alternative Reconcil. Account for Reverse Bill/Exch. 

In this activity you define the accounts in which bill of exchange payments are recorded in the general 

Ledger. When you post bills of exchange, the system will post the entries to these accounts instead of to 

the normal receivables account (reconciliation account). This way it is possible to keep bills of exchange 

separate from the normal receivables. A transfer posting for balance sheet purposes is no longer necessary. 

Note 

The specification of accounts depends on the account type, special G/L indicator, chart of accounts, and 

reconciliation account for normal receivables. 

Activities 

1. Enter your bill(s) of exchange account(s) in the field for the alternative reconciliation account. 
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2. Make sure that the account has been created. 

Additional information 

You can find additional information on the alternative reconciliation account in the "FI Accounts 

Receivable and Accounts Payable" document under "Special G/L transactions". 

15.5.4.2.3.2.4 Define Accounts for Automatic Offsetting Entry 

In this activity you define the G/L accounts to which the system posts the offsetting entry for specific 

special G/L transactions, for example, guarantees or bills of exchange. 

The account specification is differentiated by the chart of accounts and a key that contains the account type 

and the special G/L indicator. 

Standard settings 

The standard system contains posting keys for all transactions. 

Activities 

1. Specify the accounts for the necessary transactions. Only change the posting keys if you are not using 

the posting keys delivered with the system. 

2. Make sure that the specified accounts are created. 

15.5.4.3 Payment Transactions 

In this section you make system settings for payment transactions with payment requests. 

 

 

 

 

15.5.4.3.1 Payment Request 

In the following activities you make the settings for payment requests. 

15.5.4.3.1.1 Define Number Ranges for Payment Requests 

In this section you create the number range for the payment request. To do so, you use the key '01' and 

enter the following: 

- a number interval, from which the key number of the payment request is taken 

- the type of number assignment: internal 

Standard settings 



 

 

A standard interval has been defined for internal number assignment. 

Further notes 

The key numbers of payment requests have no business relevance. 

15.5.4.3.1.2 Define Payment Blocking Indicators for Accounting Documents 

In this activity you define the payment blocking indicators for the accounting documents which correspond 

to payment requests. 

If transactions are to be paid using payment requests, rather than being based on open items (financial 

accounting documents), you must prevent the accounting documents from being processed any further (i.e. 

paid). To this end, payment blocking indicators which cannot be changed are defined for the documents. 

Standard settings 

The payment blocking indicator 'P' has been created for payment requests. 

Recommendation 

The payment blocking indicator must have the following properties: 

- Cannot be changed in the payment proposal 

- Blocks manual payments 

- Cannot be changed 

-  

15.5.4.3.1.3 Define Clearing Accts for Receiving Bank for Acct. Transfer 

In this activity you define the offsetting accounts for the receiving bank accounts for bank account transfers 

(payments between house bank accounts) which should be posted to when payment is made. 

The entries are necessary when payment requests are created for cash management payment advice notes 

that result from cash concentration, for example. The offsetting accounts for the paying house bank are 

determined by the payment program specifications and the payment methods used. The offsetting accounts 

for the receiving house bank cannot be determined from these specifications, however, but can be defined 

in this section. 

15.5.4.3.1.4 Define Clearing Accounts for Cross-Country Bank Account 

Transfers 

Use 

In this IMG activity you define a technical clearing account for each company code. 

For payment processes from Treasury (TR), payment orders are sent to Bank Accounting (FI-BL). At 

the same time, a document is created in Treasury, and this document contains an item to be cleared in a 

technical clearing account from Bank Accounting. In the payment program for payment orders 
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(transaction F111), the payment order is selected and executed. The payment document created clears the 

technical clearing account and posts to the bank subaccount. In the final process step, the electronic account 

statement clears this item in the bank subaccount against the bank account. 

Note: The technical clearing account is also used for automatically posting cross-country bank account 

transfers. 

Requirements 

You have created the technical clearing account in the general ledger. 

15.5.4.3.2 Payment Handling 

In the following activities you make settings for handling payments with payment requests. 

 

 

 

 

15.5.4.3.2.1 Define Global Settings 

In this activity you define the account types for which payments should be made for the payment program 

for payment requests. 

You can configure the payment program to settle payment requests for customers, vendors and bank 

accounts (G/L accounts). 

You also specify whether the payment data should be distributed to other systems using ALE. It only makes 

sense to do so if the general ledger accounting is in a central system and if the payment transactions are to 

be carried out in the central system. 

Standard settings 

The default setting is payment transactions with customers and between bank accounts. 

15.5.4.3.2.2 Enter Origin Indicators 

Use 

In this activity, you enter the settings for the origin indicator. In so doing, you specify (per origin) whether, 

for payment transactions based on payment requests: 

- The payment program should check available amounts 

- The account determination of the application is used, or that of the payment program 

- Existing attributes of an origin are to be used for combining payment requests from different origins 



 

 

Requirements 

The origins, from which payment requests can be combined, have to be assigned to each other. You do this 

in Customizing for Bank Accounting in the activity Assign Origin to Combination of Payments. 

Standard settings 

SAP delivers the origin indicator. 

Activities 

Make the required settings for each origin. 

Further notes 

For additional information on the payment program for payment requests, see the SAP library under 

Financial Accounting -> Bank Accounting. 

15.5.4.3.2.3 Assign Origin to Combination of Payments 

Use 

In this activity you assign origins to each other. In so doing, you are specifying that payments from these 

sources can be combined (treated as one payment). 

Further notes 

For more information on the payment program for payment requests, see the SAP Library under Financial 

Accounting -> Bank Accounting. 

15.5.4.3.2.4 Bank Clearing Account Determination 

15.5.4.3.2.4.1 Define Account Determination 

In this activity you can define the bank sub-accounts to be posted to in the general ledger for payment 

transactions with bank accounts. The accounts are specified by house bank account, payment method and 

currency. If a currency is not specified, the account applies to all currencies. 
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Requirements 

The bank sub-accounts must be created for the company code and be fully maintained. 

Recommendation 

This account determination is only used when payment transactions are made between bank accounts. If 

the bank sub-account is directly specified in the payment request, this entry overrides the account 

determination. 

Because the bank sub-account is always specified for transactions in Treasury Management, this table 

Must be maintained mainly for the use of cash management and forecast (bank account transfers, cash 

concentration). 

Further notes 

Because this can lead to inconsistencies with account determination in the FI payment program (see next 

section), we recommend that you create and uses separate payment methods (after consulting the 

accounting department) for payment transactions between house bank accounts. 

15.5.4.3.2.4.2 Check Account Determination 

In this activity you check the bank sub-accounts defined in the last activity for inconsistencies. 

Inconsistencies may arise if entries are made in the account determination which have already been defined 

for payment transactions with customers and vendors. If there are inconsistencies, you should change the 

entries accordingly, or check the specifications against Financial Accounting (FI payment program, bank 

selection, accounts). 

Example 

If inconsistencies do occur, the system will display the relevant entries as part of the check: 

Company code    House bank ID Pmnt. Meth Curr.  Account ID 

0001            DB             S          DEM    GIRO 

15.5.4.3.2.5 Value date 

15.5.4.3.2.5.1 Define Diff. in Days Betw. Value Date of House/Partner Bank 

In this activity you can define the processing period for payments. If only the value date for the receiving 

bank is specified in the payment request, the value date for the sending bank can be calculated from the 

processing period. The days specified are working days. To calculate the value date you need the factory 

calendar, which is defined in the next activity. 

Example 

Refer to the example in the next section. 



 

 

Requirements 

Only the value date for the receiving bank is specified in the payment request. 

Activities 

If necessary, define the difference in days for the countries of the receiving banks. If no entries are made 

Here, the value dates are set straight away. 

Further notes 

A value date can also be calculated individually by SAP partners and customers. The Business Transaction 

Events process interface 00001610 is available for this purpose. 

15.5.4.3.2.5.2 Define Number of Days between Payment Run Date and Value Date 
at House Bank 

In this activity you define the runtime for a payment. The payment program uses this run time to determine 

the due date of a payment for payment requests. 

15.5.4.3.2.5.3 Define Factory Calendar per Currency 

In this step you define factory calendars for the payment currencies. The calendars should include the 

public holidays which are applicable in the country in which the currency is used. 

Example 

You need to make an outgoing payment in US dollars to a bank in the USA. The value date at the receiving 

bank is to be Monday, 07.07.1997. A difference of two days has been defined for the USA (processing 

period between partner and house bank), and the factory calendar defined for US dollars is the factory 

calendar for the USA. The value date at the house bank is calculated as follows: 

Value date 07.07.1997 at the receiving bank minus 2 days run time brings us to 07.05.1997. The 07.05.1997 

is a Saturday and therefore not a working day. This takes us to 07.04.1997, which is also not a working 

day in the USA. So this invoice determines the value date at the house bank as the 07.03.1997. 

Standard settings 

The relevant calendars have already been defined for a number of currencies. 
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Further notes 

SAP partners and customers can calculate the value date individually. The Business Transaction Events 

interface 00001610 is available for this purpose. 

 

 

15.5.4.3.2.6 Define ALE-Compatible Payment Methods 

In this section you can specify which payments should be distributed using ALE. You define the payment 

methods for which distribution should take place. 

Requirements 

You only make entries here if you wish to distribute payment data using ALE and have made that 

specification in the global settings. 

15.5.4.3.2.7 SEPA Direct Debits 

15.5.4.3.2.7.1 Determine Local Instrument Code and Lead Times 

Use 

In this Customizing activity, you define the rules that the payment programs use to determine the following 

values necessary for SEPA direct debits: 

- Local Instrument Code 

- Lead Time for SEPA Direct Debits 

- Calendar that is to be used to calculate the lead time. 

Standard settings 

No rules are delivered in the standard SAP system. The system determines the following values: 

- For B2B Mandates: 

Local instrument code B2B 

Lead time 1 day 

- For other mandates: 

Local instrument code CORE 

Lead time 5 days for the first use of a mandate 

Or two days for the subsequent use of a mandate 

If you do not define a calendar, the payment program uses a standard logic to determine the calendar. In 

the FI payment programs (transaction F110 and F111) the calendar is determined for example using the 

Payment Program Configuration -> Edit -> Value Date -> With Bank Calendar. If you have not 

entered a calendar there, the system uses the EU calendar, which you still may need to define. 

Activities 



 

 

You determine the local instrument code using these rules -

 for the countries of the house banks or for the house banks, 

- For the bank countries of the payers or for the banks or the payers. 

When you determine the lead times, you can also differentiate between first and subsequent direct debit of 

mandates used multiple times, and also between one-time use mandates. You can also define different lead 

times for B2B mandates. 

When maintaining the rules, you do not need to fill all key fields. If you leave the values empty, the system 

interprets the entries generically. You determine the order in which the generic entries are to read by the 

payment program in the Customizing activity Change Priority Rules for Local Instrument Code and Lead 

Times. 

You can test which entries the payment program selects in which situations in the activity above using the 

Simulate button. You enter the house bank and determine the bank details of the payer either using a 

mandate, or using the bank key and IBAN. 

Example 

Entry for a country 

You can define with the following entry that all German banks (for example) accept the local instrument 

code COR1, and consequently use it for all direct debits within Germany. 

Bank Country House Bank DE 

Payer Bank Country DE 

Local instrument code COR1 

Lead time 1  Day 

Additional entry for an exception 

If a particular bank in Germany does not yet support the local instrument code COR1, then you add the 

three entries for the local instrument code CORE with the related bank key for this bank (two entries for 

first and subsequent usage of mandates with multiple use, and one for one-time mandates). This entry can, 

depending on the circumstances, be useful for both the bank of the payer and for the house bank. The 

payment program then uses first the entry for which more key fields are specified, and only selects the 

generic entry if no specific entries are found. 

Adjustment of the lead time 

If you always schedule the payment runs two days before presenting the payment file (for example, to have 

enough time to check the payment data), you would in turn have to increase the lead days by two 

Days. Alternatively, you could move the baseline date in business add-in (BAdI) 

SAPF110S_SEPA_ADD_DAYS_ADJUST two days back. 

 

 

15.5.4.3.2.7.2 Change Priority Rules for Local Instrument Code and Lead Times 

Use 

In this Customizing activity, you specify how the entries in the settings to determine the Local Instrument 

Code and Lead Times are to be read by the payment program. 

Standard settings 
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A usable reading priority is delivered in the system, being stored in delivery client 000. You can find out 

how you can copy these standard settings to the current client, so you can then adapt them to your particular 

requirements, in the Message that is displayed when you access the Customizing activity, provided no 

entries have been maintained. 

Activities 

If you want to use the priority rules delivered by SAP, no action is required. 

Once you have decided that the standard settings delivered need to be adapted, copy the entries as described 

above from client 000, and change the settings. 

No entries are delivered in the standard system that use the IBAN to decide how the local instrument code 

is determined. If, when using the IBAN without BIC, the country of the IBAN is insufficient as a criterion, 

you can activate the use of the IBAN as the criterion in this activity. If this is the case, add the 

corresponding entries. 

Example 

The settings in this Customizing activity can be important, for instance, if your house bank 123 supports 

local instrument code COR1 but bank 456 of a payer only allows CORE. If you have made entries under 

Determine Local Instrument Code and Lead Times for both banks, then the entries for this activity 

determine the order in which the entries are used in the payment process: 

House bank Payer bank Local instrument code 

   

DE 123 DE COR1 

DE DE 456 CORE 

   

The second entry would be found first using the standard settings, as the priority of the reading accesses 

there is as follows: 

Priority Country House Bank Key House Bank Payer Bank Country Payer Bank Key 

 

4 X   X X 

9 X X X 

 

15.5.4.3.2.7.3 Business Add-Ins (BAdIs) 

15.5.4.3.2.7.3.1 BAdI: Determining the Lead Times for SEPA Direct Debits 

Use 

This Business Add-In (BAdI) is used in the Payment Transactions (FI-AR-AR-PT and FI-BL-PT-AP) 

component. You can use this BAdI to assist you in determining the data required for SEPA direct debits. 

In the payment run (F110 for customer items or F111 for payment assignments), the system determines 

this data as follows: 

- In the Customizing activity Determine Local Instrument Code and Lead Times, you define the rules 

for determining the Local Instrument Code and the related lead times. 



 

 

- The system uses the current date as the baseline date for determining the lead times in the case of a 

payment run for SEPA direct debits. For Payment Runs for Direct Debit Pre-notification (F110 only), 

the system uses the posting date as the baseline date. 

- The system also uses the posting date of the payment run as the clearing date of the payment 

documents. 

You can use this BAdI to influence the determination of these date entries: 

- If the Customizing settings are insufficient, you can adjust the days for the lead times, the local 

instrument code, and the calendar. 

To do this, you change the CV_SEPA_ADD_DAYS, CV_INST_CODE, or CV_CALID parameters. 

- You can cause the baseline date for the calculation of the lead times to be in the future. This can be 

useful if, for instance, one or more days elapse between the proposal run and sending the payment 

media to the bank. 

To do this, change parameter CV_CURRENT_DATE. 

- You can fill the clearing date with the run date of the payment. 

To do this, fill parameter EV_SET_CLEARING_DATE with the value X. 

There are entries for the current payment in the interface, including house bank account, payment method, 

payer bank, mandate used and the payment run identification that you can use as a basis for making a 

decision. You can distinguish between payment runs using the run identification: 

- For F110 IS_PAYRUN-LAUFI+5 is empty. 

- For F111 IS_PAYRUN-LAUFI+5 has the value R. 

Requirements 

For the payment processes, you use payment program F110 in accounts receivable accounting or payment 

program F111 for payment assignments. 

Standard settings 

For more information about the standard settings (filters, single or multiple uses), see the Enhancement 

Spot Element Definitions tab in the BAdI Builder (transaction SE 18). 

Activities 

After you call the IMG activity, the system displays a dialog box where you enter a name for the 

implementation. 

If implementations of this Business Add-In have already been created, the system displays them in a dialog 

box. You then choose one of them by choosing Create, and continue as follows: 

1. In the dialog box, enter a name for the implementation of the Add-In and choose Create. The system 

displays the initial screen for creating Business Add-In implementations. 

2. On this screen, enter a short description for your implementation in the Implementation Short Text 

field. 

3. If you choose the Interface tab, you will notice that the system has populated the Name of the 

Implementing Class field automatically, by assigning a class name based on the name of your 

implementation. 

4. Save your entries and assign the Add-In to a package. 
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5. To edit a method, double-click its name. 

6. Enter your implementation code between the methods <Interface Name>~<Name of 

Method>. And end method. Statements. 

7. Save and activate your code. Navigate back to the Change Implementation screen. Note: You can 

also create an implementation for an Add-In and not activate it until later. If you want to do this, do 

not perform the following step: 

8. Choose Activate. 

When the application program is executed, the code you created is run through. 

Example 

You can find example implementations in the BAdI Builder on the Enh. Spot Element Definitions tab 

under Implementation Example Classes. 

The following example implementations are available: 

- CL_SEPA_ADD_DAYS_ADJUST_DEMO 

See also 

For information about how to implement BAdIs in the Enhancement Framework, see SAP Library for the 

SAP NetWeaver Platform on the SAP Help Portal at http://help.sap.com/nw_platform. Select a release and 

then choose Application Help. In SAP Library, choose SAP NetWeaver Library: 

Function-Oriented View -> Application Server -> Application Server ABAP -> Application 
Development on AS ABAP -> ABAP Customer Development -> Enhancement Framework. 

 

 

15.5.4.3.2.7.3.2 BAdI: Influencing the Selection of SEPA Mandates 

Use 

This Business Add-In (BAdI) is used in the Payment Transactions (FI-AR-AR-PT and FI-BL-PT-AP) 

component. 

For SEPA direct debits, the payment program determines a mandate which the payer has used to authorize 

the direct debit. If the payment program finds several active mandates when doing this, it uses the first of 

these mandates for the direct debit. 

You can use this BAdI to influence the selection of the mandates, either by sorting the list of mandates 

found or deleting entries. This way you can accomplish that one payment run only uses new mandates, 

while another payment run only selects mandates already used. 

There are entries for the payment run and payment method and also selection conditions for the mandate 

selection in the interface to assist you in deciding how the mandates are selected. You can distinguish 

between payment runs using the run identification: 

- For F110 IS_PAYRUN-LAUFI+5 is empty. 

- For F111 IS_PAYRUN-LAUFI+5 has the value R. 

Requirements 



 

 

For the payment processes, you use payment program F110 in accounts receivable accounting or payment 

program F111 for payment assignments. 

If you want to influence the mandate selection for each item in payment program F110, then you should 

use BAdI: Assignment of a SEPA Mandate to an Item. 

Standard settings 

For more information about the standard settings (filters, single or multiple uses), see the Enhancement 

Spot Element Definitions tab in the BAdI Builder (transaction SE 18). 

Activities 

After you call the IMG activity, the system displays a dialog box where you enter a name for the 

implementation. 

If implementations of this Business Add-In have already been created, the system displays them in a dialog 

box. You then choose one of them by choosing Create, and continue as follows: 

1. In the dialog box, enter a name for the implementation of the Add-In and choose Create. The system 

displays the initial screen for creating Business Add-In implementations. 

2. On this screen, enter a short description for your implementation in the Implementation Short Text 

field. 

3. If you choose the Interface tab, you will notice that the system has populated the Name of the 

Implementing Class field automatically, by assigning a class name based on the name of your 

implementation. 

4. Save your entries and assign the Add-In to a package. 

5. To edit a method, double-click its name. 

6. Enter your implementation code between the methods <Interface Name>~<Name of 

Method>. And end method. Statements. 

7. Save and activate your code. Navigate back to the Change Implementation screen. Note: You can 

also create an implementation for an Add-In and not activate it until later. If you want to do this, do 

not perform the following step: 

8. Choose Activate. 

When the application program is executed, the code you created is run through. 

Example 

You can find example implementations, including for separating payment runs between new and already 

used mandates, in the BAdI Builder on the Enh. Spot Element Definitions tab in the Implementation 

Example Classes section. 

The following example implementations are available: 

- CL_SEPA_MANDATE_FILTER_DEMO 

See also 

For information about how to implement BAdIs in the Enhancement Framework, see SAP Library for the 

SAP NetWeaver Platform on the SAP Help Portal at http://help.sap.com/nw_platform. Select a release and 

then choose Application Help. In SAP Library, choose SAP NetWeaver Library: 

Function-Oriented View -> Application Server -> Application Server ABAP -> Application 
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Development on AS ABAP -> ABAP Customer Development -> Enhancement Framework. 

15.5.4.3.3 Online Payments 

15.5.4.3.3.1 Define Process Steps 

Use 

In this IMG activity, for each origin, you define the order in which the steps of the online entry for payment 

requests are to take place: Starting with entering a payment request, through processing by the payment 

program, to the creation of the payment media via the Payment Medium Workbench 

The following origins are available in the system: 

FI-AP-PR Vendor payment requests 

FI-AR-PR Customer payment requests 

FI-BL Free form payments 

Standard settings 

If you do not make any settings, the process ends with the creation of the payment requests released for 

payment. 

15.5.4.3.3.2 Define document types 

Use 

In this IMG activity, you define the document types permitted for the corresponding accounting documents. 

Standard settings 

If you have not defined a document type, the program uses the document type defined for the payment 

method from the payment program Customizing. 

15.5.4.3.3.3 Define Identification for Cross-Payment Run Payment Media 

Use 



 

 

In this IMG activity, you define the identifications that you use to summarize payments from different 

payment runs in one payment medium. In order to process these payment runs, you only use the program 

for creating cross-payment run payment media SAPFPAYM_MERGE. You can use this function for the 

following payments: 

1. Group I 

- Payments from the payment program for Accounts Receivable/Accounts Payable 

Accounting ( transaction F 110) 

- Payments from the payment program for payment orders (transaction F111), in particular 

- online payments 

- payments with Repetitive Code 

2. Group II 

- Personnel payments 

- Payments from Travel Expenses 

Note that in the system, you are not permitted to summarize payments from the first group with payments 

from the second group in one payment medium. 

Requirements 

This function is most useful in connection with payment methods that use the Payment Medium 

Workbench. You can also use the classic payment media, although you have to deactivate the configurable 

message FZ113 first. 

Example 

The identifications from the online payments are numbered sequentially. Specifying the identifications 0*, 

1*, 2*,..., 9* together with the corresponding Online Payment Settings has the effect that the system posts 

the payment documents that belong together in individual payment runs when you enter the online 

payments, and program SAPFPAYM_MERGE groups the payment media. 

If you enter * or a blank space as the identification, all of the payment runs for the selected run ID are 

summarized in cross-payment run payment media. 

15.5.4.3.4 Manual Bank Statement 

In the following steps you make all the settings necessary for the manual bank statement. 

15.5.4.3.4.1 Create and Assign Business Transactions 

In this step you store an indicator for each business transaction and allocate a posting rule to each business 

transaction. Several business transactions usually refer to the same posting rule. 

Example 
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To differentiate business transactions, you assign to the "Credit memo, domestic" transaction an indicator 

different from the one for "Credit memo, foreign" or” Credit memo, rent". Since posting is the same for 

these transactions, you can allocate all three to one posting rule (credit memo). 

Account Modification 

As long as no modification key is specified, the posting method directs all postings represented by the 

posting rule "Credit memo" to a standard account. 

In order to direct the "Credit memo, rent" transaction to a different account, create an account modification, 

"Rent received", for this transaction. 

Account determination is then controlled so that the transaction is posted not to the standard account but 

to the "Rent received" account. 

For details on account determination, refer to the section "Define posting rules for manual bank statement". 

Actions 

1. Assign a transaction key to each business transaction. 

2. Allocate a posting rule to each business transaction. 

3. Set up an account modification for those transactions that should not be posted to the standard 

account. 

15.5.4.3.4.2 Define Posting Keys and Posting Rules for Manual Bank Statement 

In this activity you store the posting keys and posting rules for check deposit. 

Creating Keys for Posting Rules 

Under this node, you define all the posting rules you need for bank statement entry, including a key for 

each rule. The key determines the posting rules for general ledger and sub ledger accounting. The posting 

rule represents the business transactions recorded in the bank statement, such as: 

- Incoming check 

- Credit memo 

- Debit memo 

Defining Posting Rules 

In this step you define posting rules for each posting transaction you defined for bank statement entry. 

You specify posting rules for one or two posting areas, depending on whether a posting transaction 

concerns only the general ledger or also affects the sub ledger. 

Example 

With the "check credit memo" transaction, you only need posting rules for the G/L accounts, since 

customer clearing occurs during check deposit. 



 

 

But to clear a customer making a transfer, you will have to specify a second posting area in addition to 

specifying the posting rules for G/L accounts. 

Account Determination 

You then select the account determination and set up an account symbol for each posting transaction. 

Depending on various modification factors, account determination involves replacing the account symbol 

with an account to post to. 

Account symbols are used to group together similar business transactions (e.g., check deposit) and direct 

them to different accounts according to a predefined differentiation. This facilitates flexible account 

determination when clearing accounts are posted to differently. 

Examples of Flexible Account Determination 

1) You want to record incoming foreign currency checks (e.g., DEM) in a clearing account different from 

the one for incoming checks in the local currency (e.g., US$). You do this with the following setup: 

Account symbol Currency G/L account  

Incoming checks + ++++++++09  ( LC cash inflow ) 

Incoming checks DEM ++++++++14  ( FC cash inflow ) 

A fully masked entry (++++++++++) in the "G/L account" field would lead to an outgoing account entered 

during bank statement entry. 

2) You want to record the transaction "credit memo, rent" in an account different from the one set up for 

"credit memo" posting rules. To do this, you must create an account modification for this transaction and 

enter the account to be posted to: 

Account symbol Account modification G/L account  

Incoming checks Rent received 0000099999 ( Credit memo, rent ) 

Incoming checks + ++++++++08 ( LC cash inflow ) 

Actions 

1. Create one or two posting areas, depending on the posting transaction: 

a) one for the bank posting 

b) one for the sub ledger posting 

2. Store the posting rules for each posting area. 

3. Create the account symbols for the required transactions. 

4. Store the rules of account determination for the account symbols. 

Additional Information 

For general information on account determination see the text on the posting interface. 

15.5.4.3.4.3 Define Variants for Manual Bank Statement 

In this step you can create separate account assignment variants for the manual bank statement in order to 

adapt the arrangement and/or the selection of account assignment fields to your company-specific 

requirements. 
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One variant is delivered as a default. It cannot be modified. 

If you do not want to work with the standard variant, you can deactivate it. New variants must be 

Activated after you create them. 

Activities 

1. To create a new variant, choose Variant --> New variant --> Create.... 

2. In the pop-up window enter the variant ID, description and the number of account assignment lines. 

On the next screen you see the possible account assignment fields in the right column. You enter the 

fields of the current account assignment variant in the left column. The account assignment fields 

Amount, Transaction and Value date are predefined as required fields. 

3. Choose the fields you need from the column of possible fields. 

The account assignment fields you select are transferred to the column of the current field’s one after 

the other (up to 80 characters). The offset column provides information on how many characters are 

needed in an account assignment field. 

4. Save your account assignment variants and then activate them. 

Changing a Variant 

New variants can be modified at any time. 

1. To delete an account assignment field, choose Edit --> Delete field. 

2. To add a new account assignment field, place the cursor in the previous field and select the field you 

need from the possible account assignment fields in the right column. 

You might have to adapt the field positions by using the "Change offset" function. 

15.5.4.3.5 Electronic Bank Statement 

In the following activities you make all the settings necessary for electronic bank statements. 

15.5.4.3.5.1 Make Global Settings for Electronic Bank Statement 

Use 

In this Customizing activity, you can make basic settings for the account statement. There are six main 

steps to be carried out: 

1. Create account symbol 

Specify G/L accounts (such as bank, cash receipt, outgoing checks) to which postings are to be made 

from the account statement. You assign account symbols to the G/L account numbers. These are 

required for the posting rules in step 2. 

2. Assign accounts to account symbols 



 

 

Define postings to be triggered by possible transactions in the account statement (such as bank 

Transfer, debit memo). 

Note: In the posting specifications debit -> credit that you define here, use the account symbols from 

step 1, not the G/L account numbers. This prevents similar posting rules being defined several times, 

the only difference between them being the accounts to which postings are made. 

3. Create keys for posting rules 

Assign the posting rules to the possible transactions in the account statement file. A list of such 

assignments where one external transaction code is assigned to one posting rule is called a 

transaction type. 

4. Define posting rules 

Create a posting specification for each posting rule. You thereby specify how a given business 

transaction is to be posted. 

5. Create a transaction type 

Create the names and descriptions of the various transaction types you require. 

In this activity you assign (external) business transaction codes to an (internal) posting rule. As a 

result, you can use the same posting specifications for different business transaction codes. 

6. Assign bank accounts to transaction types 

Assign the bank details to a transaction type, for which the account statements are to be imported. 

All the house bank accounts at a particular bank are usually assigned to the same transaction type. 

Requirements 

You have already entered your house bank data for the account details. If not, define your house bank data 

in Customizing under Bank Accounting -> Bank Accounts -> Define House Banks. 

Create account symbols 

In this activity you create the account symbols that you later need for defining the posting specifications. 

Before the posting rule is used, the account symbols are replaced with the relevant accounts to which 

posting is to be made. 

Example 

Create the account symbols BANK and CASH RECEIPT so that you can later define a posting rule for 

cash receipt. 

Activities 

1. Define an ID for each account symbol. 

2. Enter a description in the text field. 

Assign accounts to account symbols 

In this activity you define the account determination procedure for each individual account symbol. 

Example 1: 

Assigning G/L account 113100 to account symbol BANK Chart 

of Accounts: INT (sample chart of accounts): 

Account symbol Acct mod. Currency G/LAcct 
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BANK + + 113100 

Example 2: 

To avoid having to define a separate account symbol for every single house bank account (with a different 

G/L account in each case), the G/L account field can contain a masked output. 

Chart of Accounts: INT (sample chart of accounts) 

Account symbol Acct mod. Currency G/LAcct 

   

BANK + + ++++++++++ 

Here, the account determination replaces the account symbol BANK with the G/L account number of the 

house bank account defined in the house bank master data. The appropriate masking can also be used for 

the bank subaccounts. 

Example 3: 

Standard procedure for defining bank subaccounts 

Chart of Accounts: INT (sample chart of accounts) 

Account symbol G/LAcct 

  

BANK ++++++++++ 

CASH RECEIPT ++++++++01 

INCOMING CHECKS ++++++++09 

You can influence account determination further by making entries in the Account modification and 

Currency fields. 

Example 4a: 

You wish to manage incoming checks in foreign currency (such as USD) in a different clearing account to 

incoming checks in local currency (such as EUR). You can do so by making the following setting. 

Chart of Accounts: INT (sample chart of accounts) 

Account symbol Acct mod. Currency G/LAcct 

   

INC. CHECKS + + ++++++++09 

INC. CHECKS 

Example 4b: 

+ USD ++++++++14 

You wish to process the business transaction credit memo for rent in a different account than is 

otherwise used for the credit memo posting rule. For this business transaction, you specify an account 

modification and the account to which posting is to be made (such as 99999). 

Chart of Accounts: INT (sample chart of accounts) 

Account symbol Acct mod. Currency G/LAcct 



 

 

   

INC. CHECKS + + ++++++++09 

INC. CHECKS RENT + 0000099999 

In addition, the field FEBEP-KFMOD has to be filled for the given transactions, either in the function 

enhancement for the electronic accounts statement (see the Customizing activity Develop Enhancements 

for Electronic Bank Statement (General)), or by using the search string search with the target field Account 

Modification (see the Customizing activity Define Search String for Electronic Bank Statement). 

Note 

Note that masked entries (using a plus sign +) are always based on a ten character account number. If you 

are using a shorter account number (six characters, for example), the entries must be right-aligned. 

Create keys for posting rules 

In this activity you enter descriptions for the necessary posting rules. Each posting rule represents a 

business transaction from the SAP System that is included in the account statement, such as: 

- Incoming check 

- Credit memo 

- Debit memo 

- and so on 

Example 

You create the posting rule 0001 (cash receipt via interim account) for cash receipt. 

Activities 

1. Define an ID for each posting rule. 

2. Enter a description in the text field. 

Define posting rules 

In this activity you create posting specifications for each posting rule. You use the posting specifications 

to specify how a certain business transaction (such as a credit memo) is to be posted. 

Posting specifications consist of one or two posting records debit -> credit, where the first posting record 

is called posting area 1, and usually represents a G/L account posting (BANK -> CASH RECEIPT, for 

example). The optional second posting record is called posting area 2 (CASH RECEIPT -> CUSTOMER, 

for example). 

Depending on whether a posting transaction affects bank accounting only, or also affects sub ledger 

accounting, define the posting rules either for the first posting area only, or for both the first and the second 

posting areas. 

Example  

For the transaction "check credit memo", you only need posting rules for G/L accounts because the 

customer account has already been cleared as a result of the check deposit. For a bank transfer, however, 

you will need a second posting area in addition to the posting rules for the G/L accounts in order to clear 

the customer account. 

Activities 
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Define the posting rules for posting area 1 and 2: 

1. Enter the posting type (posting or clearing G/L accounts or sub ledger accounts, reversing clearing). 

2. Enter the accounts (that is, the account symbols) and posting keys for both the debit and credit sides 

of the posting record. Depending on the type of posting (clearing/posting), it may be necessary to 

leave the fields on either the debit or credit side blank. For example, with posting type 8 (credit 

clearing for sub ledger accounts), the system uses the note to payee information to try to identify and 

clear an appropriate open item. In this case, there is no need to specify the account and posting key 

beforehand since they will be determined automatically during the open item search. 

3. Specify the document type. 

4. If required, make entries in the optional fields for compression, special G/L indicators, and posting 

keys for payment on account. 

Example 

Posting rule 0001 

Pare PK (D): Account (Deb.) PK (C): Account (Cred.) DT PstType 

1 40 BANK50 CASH RECEIPT SB 1 

2 40 CASH RECEIPT DZ 8 

Create a transaction type 

In this activity you create the names and descriptions of the various transaction types you require. House 

banks that use identical lists of business transaction codes (external transactions) can be assigned to the 

same transaction type later. 

Example 

You create transaction type MC for account statements in MultiCash format. 

Activities 

Create the names and descriptions of the various transaction types you require. 

Assign external transaction codes to posting rules 

In this activity you assign (external) transactions to an (internal) posting rule. This means that the same 

posting specifications can be used for different business transaction codes. 

Example 

1. Business transaction code 004 is for debit memos by direct debit 

2. Business transaction code 005 is for debit memos by automatic debit 

3. Business transaction code 020 is for debit memos by transfer order 

From the point of view of your organization, the external business transactions listed above use identical 

posting procedures and must therefore be assigned to the same posting rule (for debit memos). The same 

posting rules can also be used for different bank details, even if different business transaction codes are 

used (if different file formats are used, for example). 

Activities 



 

 

1. For each transaction type, assign a posting rule to each external transaction key. 

2. In the +/- Sign field, enter + or - to indicate whether payments are incoming or outgoing. 

3. If necessary, define an interpretation algorithm if open items are to be cleared automatically as a result 

of the posting. 

Remark 

The Processing Type field is currently only used for the formats BACS (England), BAI (USA), and 

BRADESCO/ITAU (Brazil). 

For business transaction codes for messages in format camt.054, you have to place the prefix <54> before 

the business transaction code of the bank. Example for a business transaction code in the statement file: 

<BkTxCd><Domn><Cd>PAYM</Cd><Fmly><Cd>0001</Cd><SubFmlyCd>0005</SubFmlyCd></F

m ly></Domn><Prtry><Cd>051</Cd></Prtry></BkTxCd> 

For this example, you would make the entry <54>PAYM00010005 in Customizing. 

Note regarding unknown external transactions 

If the bank uses an external transaction that you have not yet entered in Customizing, the system terminates 

the processing of the account statement. 

In order to ensure that the processing of the account statement does not terminate, you can define the 

external transaction UNALLOCATED. 

Example 

To have the system post the unknown external transaction in bank accounting, but assign them to the work 

list for post processing in the sub ledger, proceed as follows (for example): 

Create two posting rules UNA1 (unknown cash receipt transaction) and UNA2 (unknown cash 

disbursement transaction): 

Posting rule Posting area Debit Account Credit Account Posting type 

UNA11 40 Bank 50 Cash Receipt 1  

UNA12 40 Cash Receipt    5  

UNA21 40 Cash disbursement 50 Bank 1  

UNA22     50 Cash disbursement 4  

Then set up the external transaction UNALLOCATED for each of the transaction types you use, as follows: 

External transaction +/- Sign Posting rule Interpretation algorithm 

UNALLOCATED + UNA1000 No interpretation 

UNALLOCATED - UNA2000 No interpretation 

Assign bank accounts to transaction types 

In this activity you assign each of your bank accounts to a transaction type. 

You can specify a work list of G/L accounts. This enables you to search several bank subaccounts for open 

items that the system could not clear during posting of the account statement when you post process the 

account statement. 

If you select the field No Automatic Clearing, an open item remains, even if the amount of the open item 

agrees with that in the account statement. 
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Example 

- In the account statements you receive from bank X and bank Y, the business transaction code 051 

indicates that the transaction involves a credit memo. This transaction is represented by the posting 

rule 1000 in your organization. 

- Bank Z uses different business transaction codes than banks X and Y. A different posting rule should 

be used for business transaction code 051 in this case. It is also possible that a totally different business 

transaction code is used for credit memos for the file formats used by bank Z, and that posting rule 

1000 must be assigned to this code. 

In this scenario, you would use two transaction types: One transaction type for bank Z and another 

transaction type for banks X and Y. 

In addition, you can assign your house bank accounts to a currency class. This setting is necessary for the 

Spanish CSR format. 

Activities 

Assign your banks to a transaction type and, if necessary, a currency class. The banks are identified by 

their bank key and external account number. 

Further notes 

For more information, see the SAP Library under Financials -> Financial Accounting -> Bank 

Accounting -> Electronic Bank Statement. 

15.5.4.3.5.2 Settings for the Data Import 

15.5.4.3.5.2.1 Make Settings for Import 

Use 

You make the following settings in Customizing only if you are using report Bank Statement Processing: 

Import and Forward (Automatically) (FEB_FILE_HANDLING) to import your bank statements. 

If you are using the report for the manual import of bank statements, Bank Statement: Various Formats 

(SWIFT, MultiCash, BAI...) (RFEBKA00), you do not need to make any settings here. 

For more information about which of the two transactions you use for which format, see the corresponding 

report documentation: 

- Import and Forward ( Automatically ) 

- Import 

Activities 

If you are using the report Bank Statement Processing: Import and Forward (Automatically) 

(FEB_FILE_HANDLING), make the following settings required for the import: 

1. Define logical paths from which the bank statement files are imported or in which processed bank 

statements are stored (see Define Logical Paths). 



 

 

2. Specify the import parameters in the Customizing activity Define Import Parameters. 

If you want the bank statement to be downloaded to bank data storage and processed further, you have to 

process Customizing activity. 

3. Define House Banks 

4. Define Posting Parameters 

Customizing activity Define Transfer Information is optional. This activity supports you in correctly 

forwarding the bank statements in the system if you define additional parameters there. 

A bank statement file to be processed is first split into individual bank statements. If such a split is not 

possible, the file is stored in the error directory, otherwise stored in the storage directory. 

After the split, the bank statements are further processed individually in accordance with your settings: 

- If the bank statement bank account is a house bank account and you have defined posting parameters, 

the bank statement is downloaded to bank data storage and posted in accordance with your settings. 

- If the bank statement is incorrect or cannot be downloaded, it is stored in the error directory. You can 

define this error directory in customizing activity Define Import Parameters for the bank statement 

file. If you would like to specify a different error directory for the individual bank statement, you can 

enter this in the optional Customizing activity Define Transfer Information. 

- Storing a bank statement in transfer directories is independent of downloading and posting. In 

addition, the bank account in the statement must not be a house bank account. If you want to provide 

a bank statement for retrieval by a different system, carry out the Customizing activity Define 

Transfer Information. 

Note 

To split a bank statement file and download an individual bank statement, you must have implemented the 

methods in BAdI: Bank Statement Processing. 

15.5.4.3.5.2.2 Define Logical Paths 

Use 

In this Customizing activity, you can define logical paths from which bank statement files are read, or 

stored in the processed bank statements. 

On the detail screen for a logical path, you specify whether you want to import from the directory or to 

write to the directory. Further, you enter information about the Physical Directory and the File Name. 

Requirements 

You only process this Customizing activity if you want to import the bank statement data automatically. 

For the automatic import of bank statement data, on the SAP Easy Access screen choose Accounting -> 

Financial Accounting -> Banks -> Incomings -> Bank Statement -> Import (Automatically). 

These Customizing settings are required to be able to start the automatic import of bank statements. 

Note 

Note that you cannot maintain logical paths for the automatic import using transaction FILE. 
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15.5.4.3.5.2.3 Define Import Parameters 

Use 

In this Customizing activity you define the directories from which the system should import the bank 

statement files. When you do so, you must also specify where the files are to be stored following successful 

or unsuccessful processing. 

In addition, you have to specify the bank statement format (for example, MT940) providing it is not 

determined using Business Add-In (BAdI) BAdI: File Processing. The BAdI is not implemented in the 

standard system. Files with only one format should be provided for each directory: define this format here. 

You can define a code page for reading and writing files should they differ from the system code page. 

Alternatively, you can use the SET/GET parameter UCP (see SAP Notes 758870 and 928965). Once the 

code page has been defined in both Customizing and as a SET/GET parameter, the system takes the value 

from Customizing. 

Requirements 

You have defined logical paths in customizing activity Define Logical Paths. 

These Customizing settings are required to be able to start the automatic import of bank statements. 

15.5.4.3.5.2.4 Define Posting Parameters 

Use 

In this Customizing activity, you have to define how the bank statements are to be processed once they 

have been imported to your system. 

You can choose the following settings: 

- Only import account statement (the posting report is only called in test mode) 

- Import and Post 

- Import and Post Bank Accounting 

- Import and create batch input (if you are using transaction FEB_BSPROC this is not recommended) 

for more detailed information, read the documentation on the Posting Mode. 

The system searches for a Customizing entry in the following order, where the first one found is used for 

processing: 

- Company code, house bank and account ID 

- Company code and house bank 

- Company code 



 

 

- Company code, house bank and account ID have not been filled 

If the system does not find an entry, the bank statement is not downloaded to bank data storage. 

Requirements 

- The account is defined in the SAP system as a house bank account (Customizing activity Define 

House Banks). 

- You have defined import parameters in the Customizing activity Define Import Parameters. 

- The Customizing settings are required for the automatic import. 

 

15.5.4.3.5.2.5 Define Transfer Information 

Use 

In this Customizing activity, you can define which directories you want bank statements for particular bank 

accounts stored in so they can later be processed by other systems. 

In addition, you can specify for these bank statements where they should be stored if they have been 

processed with errors. If you have specified a directory for this here, it overrides the directory you entered 

in Customizing activity Define Import Parameters. 

The system first determines whether the bank account to which the bank statement was sent has been 

created in the SAP system as a house bank account. If this is the case, the system determines the SWIFT 

code and bank number for this house bank account, and searches for suitable entries in the following order, 

where the first one found is used for processing: 

- Bank country, SWIFT, IBAN 

- Bank country, bank number, account number 

- Bank country, SWIFT, account number 

- Bank country, bank number, alternative account number 

- Bank country, SWIFT, alternative account number 

- Only bank country, SWIFT 

- Only bank country, bank number 

- Only bank country 

- Empty key fields only 

If the system is unable to determine a house bank for the entries found in the bank statement for the bank 

account, the entries are read in the following order: 

- Bank number from the bank statement, IBAN/account number from the bank statement 

- Only bank number from the bank statement 

- Empty key fields only 

This enables you to import and forward bank statements for bank accounts that have not been defined in 

the system as house bank accounts. 

Requirements 
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You have processed the Customizing activity Define Import Parameters. 

The Customizing settings are optional for automatic import. 

 

 

 

15.5.4.3.5.2.6 Business Add-Ins (BAdIs) 

15.5.4.3.5.2.6.1 BAdI: File Processing 

Use 

This Business Add-In (BAdI) is used in the Electronic Bank Statement (FI-BL-PT-BS-EL) component. 

You only process this Customizing activity if you want to import the bank statement data automatically. 

You can schedule an automatic import of bank statement data using the appropriate transaction. On the 

SAP Easy Access screen, choose Accounting -> Financial Accounting -> Banks -> Incomings -> 

Bank Statement -> Import and Forward (Automatically). 

Format determination 

You can specify the format for a bank statement by implementing method 

DETERMINE_FILE_FORMAT. The format specified in customizing activity Define Import Parameters 

is then overwritten. 

The method is called before a file is processed. 

Blocking mechanism for files 

When importing, you must ensure that the bank statement file is complete, and nothing more is written to 

the file. You can set up various blocking mechanisms for this, for example: 

- By assigning a temporary file name during file creation, so that the file is ignored when reading the 

directory (the name does not match the search pattern from Customizing). 

- By the existence of an indicator file 

- By changing the file size or change date 

You can implement the following methods for checking such blocking mechanisms: 

- Method CHECK_FILE_BEFORE_READING is called directly before importing the file 

- Method CHECK_FILE_BEFORE_RPROCESSING is called directly before processing the logical 

bank statements 

You can terminate processing of the current file using exception SKIP_FILE. The file remains in the source 

directory and is read again when you next call the program. 

Standard settings 

The BAdI is not filter-dependent. 

There is an example implementation in the standard system: FEB_BSIMP_FILE. Method File Check 

before Processing Start (CHECK_FILE_BEFORE_PROCESSING) checks the change to the file size 

and the change date. 



 

 

For more information about the standard settings (filters, single or multiple uses), see the Enh. Spot 

Element Definitions tab in BAdI Builder (transaction SE18). 

Activities 

For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for SAP 

NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

15.5.4.3.5.2.6.2 BAdI: Bank Statement Processing 

Use 

This Business Add-In (BAdI) is used in the component Electronic Bank Statement (FI-BL-PT-BS-EL). 

You only process this Customizing activity if you want to import and forward the bank statement data 

automatically. You can schedule an automatic import of bank statement data using the appropriate 

transaction. On the SAP Easy Access screen, choose Accounting -> Financial Accounting -> Banks -> 

Incomings -> Bank Statement -> Import and Forward (Automatically). 

With this BAdI, for each format you implement how a file containing the bank statements in this format is 

processed. 

By implementing method GET_BANK_STATEMENTS, you define how a bank statement file is split into 

individual bank statements. You define bank account, account number, bank statement number and date, 

currency, and opening and closing balance for each statement. 

By implementing method SAVE_BANK_STATEMENT, you define how bank statements for a particular 

format are uploaded to bank data storage (tables FEBxx). 

Standard settings 

The BAdI is filter-dependent. 

The standard system contains the following implementations: 

- Formats I, S, G - corresponds to MT940 and MT942 

- Format A - corresponds to BAI 

You can obtain details about these implementations from the documentation for classes 

CL_FEB_BSIMP_IMPL_BS_MT940 and CL_FEB_BSIMP_IMPL_BS_BAI. 

You can create a new format with transaction SM30 in table/view FEBV_IMP_FORMAT. For format-

specific parameters, such as you have created for format BAI, you can create a new structure that you 

then register with transaction SM30 in table/view FEBV_IMP_STRUCT. 

For more information about the standard settings (filters, single or multiple uses), see the Enh. Spot 

Element Definitions tab in the BAdI Builder (transaction SE 18). 

Activities 
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For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for SAP 

NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

15.5.4.3.5.3 Define Search String for Electronic Bank Statement 

When importing an electronic bank statement, the system identifies the business transactions and uses the 

settings you have already made to determine how each should be recorded. In most cases, the system uses 

the document number entered in the "note to payee" lines of the bank statement to determine the 

appropriate clearing transaction. For example, a cash receipt clears customer open items. 

The information in the note to payee may be incomplete - for example, the first characters in the document 

number may be cut off or new characters may be added. The interpretation algorithm then reaches the 

limits and cannot find the appropriate document numbers. This means the document cannot be cleared and 

you must post- process the transactions manually. 

In addition to the search for clearing information, you can use the search string to fill other fields (such as 

the cost center or posting rule, depending on the content of the note to payee. 

It is the "Target Field" which determined which field is filled in each case. The target field in the bank data 

store indicates to where the result of the search is written. The target field must always be the note to payee 

when you are searching for clearing information (document number, reference document number. (Unlike 

other fields, it is not necessary to repeatedly change the note to payee field - the information in it is 

temporarily "enriched" while the interpretation algorithm is running.) The explanations and examples that 

follow all refer to the search for clearing information (meaning that the note to payee is the target field), 

but they can also be applied to most other fields (such as "Cost Center"; see the section on "Other Target 

Fields"). 

To increase the number of hits in the document number search, you can use this step to define strings for 

the search. The system uses this string to conduct the search before the interpretation algorithm comes into 

effect. 

- Step one is to define the search string. The end of this section gives definitions of some special 

characters. 

Having defined the search string, you must then define "mapping". Mapping is used, for example, to 

eliminate characters that customers have added to document numbers. 

To illustrate which sign in the search string is assigned to which character in mapping, the example 

which follows gives vertical representations of the search strings and associated mapping. See the 

end of this section for definitions of some special characters. These characters cannot be entered in 

mapping. 

In the example, the symbol "#" means any figure between 0 and 9. A blank in mapping causes the 

system to delete the respective item. 

Example: Search string 

Mapping 

... 

# -> # 

. ->          (Blank in mapping: '.' eliminate) 

# -> # 

# -> # 

# -> # 

... 



 

 

So: you can assign a different character to each character in the search string (example: a blank to a 

period). If you are recreating a search string, the system first defaults the unchanged search string as 

mapping. You can then change the characters as you wish. 

You can test the search strin in the detail screen for search string definition. To this end, enter any 

chain of characters you like, as it could appear in the "Note to payee" field in the bank statement, and 

choose Test. The system displays the search result. 

- In the second step, you stipulate the note to payee for the search string. 

You can define as many strings as you like per bank account and interpretation algorithm. 

In addition, you can also enter a mapping basis and select the ID flag. 

Notes 

- You have to activate the strings before the system can use them in the document number search. 

- Be sure to enter start and finish characters (' ', ^, $) in search strings to eliminate incorrect hits. 

Example: A string with no start and finished characteristics is called "###". The number in the note 

to payee in the bank statement is 12345678. The sting search then finds no fewer than six hits in the 

note to payee, namely: 123, 234, 345, 456, 567, and 678. This is not usually desirable because it may 

lead to a defective selection of items if the matching document numbers actually exist in the system. 

Special Characters in Search Strings 

Character Definition Example 

  

| or abs finds a or b 

() Group c(ac|b)d finds cacd or cbd 

+ Repetition (ab)+ finds, for example, ab or ababababab 

* Repetition ab* finds a or ab or abbbbbbb 

? Wild card a?b finds aQb or a1b 

# Figures 0-9  

\ Escape character \#\#\# finds ### and not,for example, 

 123 (looks for special characters) 

^ Start of line 

$ End of line 

 

Special Characters in Mapping 

Character Definition Example 

  

' '  Blank Character is eliminated. 

/ Slash See under Example 2 

Example 

Example 1 

You enter search string (^|) ### (|$) with Mapping ###. 

The system searches for a document number which starts at the beginning of the line or with a blank, then 

has three figures and ends with a bland or at the end of the line. 

You enter 18000000 as the mapping basis. 
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The system replaces the last three characters of the basis with 123 so that the searchy result is 18000123. 

The system looks for document 18000123 to clear the open items. 

Example 2 

You specify search string (^|) #####/###/### (|$) with mapping #####/###/###. 

The system searches for a document number consisting of five figures followed by two sets of three figures, 

all the sets being separated by "/". (Example: 80429/234/123). The "/" is of special significance in mapping: 

the chain of characters is not interpreted as one document number, but as three. The three strings of 

characters are separated and the last three in the first string replace by strings 2 and 3 respectively, giving 

three document numbers in the search result: 80429, 80234, and 80123. If you defined a mapping basis, it 

is now applied to the three numbers to bring them up to the number of characters required for the document 

number. 

The system verifies that the first number is at least as long as the following. If it is shorter, the hit is rejected. 

No replacement is made. 

You can also search for any other character used to separate document number in your bank statements. 

The character in question must be in the search string. 

More Search String Examples 

Search String Mapping Description 

   

(^|)### ####($| ) ### #### 7 characters, blank at position 4 

(^|)#(.|)######($| ) # ###### 7 characters, period/blank at pos.2 

(|^)############## (|$) ####### 14 char. number, take first 7 

(|^)############( |$)        #### 12-char., take last 4 

(|^)#+(/#+)+( |$) #/# Sequence, separated by slash 

Activities 

Defining and Simulating Strings 

Define string 

1. Double click in the tree Search string definition. 

2. Choose "New entries". 

3. Enter a search string name (example: STRING1), a description ("Five digit document number") and 

a search string (example: (^|) ###. ## (|$)), then choose Enter. 

4. In the Mapping area, assign a character to each character in your string. 

The system proposes the unchanged search string as initial mapping. Change the characters as you 

want. 

Test the string 

5. In the Test area, enter a text under Input text. The text must include the document number as it would 

appear in the electronic bank statement. Then choose Test. 

You then see the document number the system uses to find document so that it can post the business 

transaction in the system. (Any mapping basis you may have entered in addition is ignored in this 

test.) 

Assign Search String to Interpretation Algorithm 



 

 

6. Go back and double click in the tree Note-to-payee search string 

7. Choose new entries. 

8. Enter the company code, house bank, account, interpretation algorithm, and a name for the string. If 

you leave all or one of the fields Company code, House bank, or Account, the system uses the 

specified search string to search in all company codes, house banks, and/or accounts. 

9. If you want to use the string in the document number search, select Active and "Note to Payee" as 

the target field. 

10. Enter a mapping basis if required. Select the ID indicator if required. 

Other Target Fields 

Cost Center 

If the search string is "6227747474???? TELECOM" with mapping "1000" and the character string 

"6227747474 03 98 TELECOM" appears in the note to payee, "1000" is always entered in the cost 

center field. 

Expenses in Account Currency 

You can use this target field if you want to have the system automatically adopt fee information contained 

in the note to payee field and use it in the posting. A prerequisite for this is usually that the appropriate fee 

amount is always flagged with a unique key word (such as "Bank Charges"). In this case, you could use, 

for example, a search string of type Bank Charges: *#+, ##" with mapping”       #. ##" . Note 

that you must use a period, not a comma, as the decimal point. 

BDC Fields 

The BDC fields are a means of filling screen fields if there is no suitable target field in the bank data store. 

You must know the technical name of the relevant screen field (if you do not know it, use the F1 help to 

find it out). 

For example, if you want to transfer a control indicator in the event that the key word "TELECOM" appears 

in the note to payee, you can proceed as follows: 

Use the search string TELECOM with mapping "       " (all blanks) for the three target fields "BDC 

Field Value 1", "BDC Field Name 1" and "BDC Account Type 1". The constants to be entered in the 

individual BDC fields are always stored in the "Mapping Basis" field: 

BDC Field Value 1 = "V1" 

BDC Field Name 1 = "BSEG-MWSKZ" 

BDC Account Type 1 = "0" 

If you want to transfer the content of only one particular line, you can use the "BDC Account Type" field 

to control the process. If you enter the constants 0, 1, 2, or 3 in this field, the transfer only takes place as 

specified. The constants here mean the following: 

0:  First line, posting area 1 

1:  First line, posting area 2 

2:  Second line, posting area 1 

3:  Second line, posting area 2 
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If you do not control the transfer in this way, the system tries to transfer the screen field defined under 

"Field Name" in all the posting lines in posting areas 1 and 2. This cause an error on the grounds that the 

field does not exist (for example, because a control indicator for a particular account does not accept input. 

In the control indicator example, note that you must set the "Calculate Tax" indicator too, so that the posting 

can be made automatically. You then need the following settings in addition: 

BDC Field Name 2 = "BKPF-XMWST" 

BDC Field Value 2 = "X" 

BDC Account Type 2 = "0" 

Further notes 

For more information on the electronic bank statement, go to the SAP Library and choose Financial 

Accounting -> Bank Accounting -> FI - Electronic Bank Statement. 

15.5.4.3.5.4 Simulate Document Number Search Using Strings 

In this step, you can simulate a set of search strings which you have created in the step Define Search 

String for Document Numbers for a particular set of bank details. This makes it easier for you to find the 

search strings best suited to the document number search in your electronic bank statements. 

Requirements 

You must import the bank statement first (transaction FF.5). During the import, the data is written to the 

bank data store. The simulated string search is carried out on the data in the bank data store. 

Activities 

1. Enter the company code, house bank, account, and statement number. 

If required, use F4 to obtain a list of the bank statements in the bank data store. 

2. If required, enter the document number interval or the reference document number interval. To obtain 

comparable results, use the same number intervals you used when importing the electronic bank 

statement. 

The system proposes number intervals leading to the highest possible number of hits. 

3. Choose Simulate. 

This gives you the following result: 

- Item number field 

Number of the line item in the electronic bank statement, as you would see it in the bank 

statement display. 

To display the statement, choose Simulation -> Display statement. 

- In the string hit field: 

String of characters found using the string search in the "note to payee" field in the electronic 

bank statement. 



 

 

- In the mapping hit field: 

Search result, after the search string was applied to mapping and the mapping base (example: 

1800000206). 

- In the Document number found field: 

Document number found by the system after it applies the interpretation algorithm to the note 

to payee and the mapping hits. 

This means that such a document number actually exists in the system. However, the simulation 

does not conduct any further checks (for example, as to whether the amount is correct). This 

may mean that the corresponding items cannot be cleared automatically. That is, the document 

numbers displayed here are used for the automatic update, but the actual posting may still fail. 

In addition to the string hits, document numbers from the standard document number search 

may also appear - for example, if the note to payee contains document numbers which are 

complete and correct. 

A reference document number only appears if the relevant items have not yet been cleared. 

- The Type field shows the type of document number (for example, the document number or 

reference document number). 

- The Business partner shows the key for the business partner (for example, customer). 

- The business partner type field shows, for example whether this is a customer (D) or vendor 

(K). 

Notes on the String Search 

- New or changed strings take effect for automatic updating of newly imported bank statements. 

The reference information for bank statements (which is already in the bank data store) can no 

longer be enhanced with the addition of newly defined strings. Conversely, changes made to the 

string during simulation of a string search take effect angereichert werden. Im Gegensatz hierzu 

wirken sich Änderungen van den immediately - that is, without data having to be imported 

again. 

- By activating/deactivating the search string (which you can do in the previous step), you can 

change the set of search strings the system runs through during the simulation and analyse the 

effect on the number of hits. 

- Performance Note The combination of "or" (|) with the repetition character (+, *) may lead to 

long search times. Avoid search strings like (.|#+) +, or test first that the search time is acceptable 

in each case. 

Further notes 

For more information on the electronic bank statement, go to the SAP Library and choose Financial 

Accounting -> Bank Accounting -> FI - Electronic Bank Statement. 

15.5.4.3.5.5 Define Transaction 

Use 

With this Customizing activity, you can define transactions according to business perspectives for the post 

processing of bank statement items, so that the system can appropriately scan the note to payee. 

You can also hide or overwrite transactions delivered by SAP. 
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Requirements 

To post process bank statement items, you use the transaction Edit Bank Statement Item. 

Activities 

Define separate transactions 

1. Enter a transaction and a description. 

2. Enhance the required interpretation algorithm with which the note to payee of the bank statement 

items is to be scanned when using the corresponding transaction. 

3. Define which tabs the system should show or hide when post processing bank statement items for the 

relevant transaction. 

4. If you use the Assignment tab for the transaction, then specify which document fields can be selected 

as search criteria for open items. 

5. Define which account types are relevant for this transaction. 

Hide or overwrite transactions delivered by SAP 

1. Create an entry with the key of a transaction delivered by SAP. The system transfers the properties 

of the standard entry. You can find an overview of the transactions delivered by SAP for the electronic 

bank statement in the Definition of Transaction view. 

2. If you want to hide the transaction, select the indicator as appropriate. Transaction 0050 (unknown 

transaction) cannot be hidden, as it is always used by the system if no transaction can be determined. 

3. If you want to overwrite the transaction, change the properties transferred. 

Example 

In the standard system you can, for example, find transactions 0010 und 0020 that search for invoice 

numbers and read electronic payment advice notes. Correspondingly, the related interpretation algorithms 

001 or 003 are assigned, and the tabs for clearing and creating customer line items and vendor line items 

and also for creating G/L account items are shown in transaction Edit Bank Statement Item 

- If you do not work with electronic payment advice notes, you can hide entry 0020. 

- If you also work with EDI payment advice notes, you can create an additional entry in the customer 

namespace with interpretation algorithm 032. 

- If you only work with EDI payment advice notes, you can overwrite entry 0020 that was delivered 

by SAP and use interpretation algorithm 032 in your entry. 

15.5.4.3.5.6 Define Program and Variant Selection 

In this step, you can specify which programs the system offers for electronic bank statement processing. 

The programs are used for the transactions under the menu option Cash Management -> Input -> Elect. 

Bank statement. 

Under transaction FF.5, you can specify the programs for the menu option Import. The programs for 

transaction FF.6 represent the menu option Display. 



 

 

You can also specify a variant for each program. 

If you select the PND field (program not to be displayed) for the programs you do not need, the system 

will not display them on the screen for these menu options. 

If, for example, you use only one program to process English BACS formats, you can select the PND field 

for all the other programs. When you then access Import, the system displays only the selection screen for 

this program with the data of the variant you specify. 

Activities 

Specify the criteria needed for program and variant selection. 

Further notes 

For more information on electronic bank statements, see the "FI Electronic Bank Statement" 

documentation found in the SAP Library under Financial Accounting. 

15.5.4.3.5.7 Develop Enhancements for Electronic Bank Statement (General) 

Use 

For the electronic account statement, you can use the following SAP enhancement: 

- FEB00001 to analyse each transaction in your bank accounts per clearing information (such as 

document number); to change the posting rule; to use account modifications to influence account 

determination; to distribute postings to different batch input sessions. 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 

to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 

In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 

For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

Further notes 

For more information about the electronic account statement, see the SAP Library under Financial 

Accounting -> Bank Accounting. 
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15.5.4.3.5.8 Develop Enhancements for Elec.Bank Statement (Format Spec.) 

Use 

You can use the following SAP enhancement for the Electronic account statement: 

- EDI format 

You can use the FEDI0005 enhancement to generate EDI IDocs for the bank statement. This 

enhancement is used for processing IDocs of the FINSTA01 category. 

- TITO format (Finland) 

You can use the FEB0003 enhancement to enhance program RFEBKA00. The program creates 

electronic bank statements in TITO format. The following record types are not processed directly: 

a) Cumulative records (T50 and T51) 

b) Special records (T60) 

c) Message records (T70) 

d) Notifications (T80 and T81) 

This enhancement makes the data available for further processing. 

Activities 

1. Create your enhancement. To do this, either create a new project or use an existing one. Modify 

the source code for a transaction delivered by SAP by adding the elements you need. SAP provides 

you with the necessary function modules with short text, interface, and documentation to be able 

to do this. A sample source code created by SAP may exist for user exits which can be copied (and 

changed) if required. 

2. Activate the project. 

This allows the ABAP source code to run. Enhancements will not have any effect beforehand. 

Further notes 

In contrast to modifications, enhancements can generally be transferred between Releases since they are 

carried out within a name range reserved for the customer rather than in the SAP original. 

For more information about creating enhancements, see the SAP Library BC - Changing the SAP Standard. 

Every enhancement is documented. To call up the documentation, choose Utilities -> Display req.docu 

from the project management screen for SAP enhancements. 

Further notes 

For more information about the Electronic Account Statement, see the SAP Library under Financial 

Accounting. 

15.5.4.3.5.9 Error Codes 

The Brazilian BRADESCO format contains error codes, and you can define the appropriate texts for these 

codes in this activity. The error texts are then displayed on the note to payee. 



 

 

Error codes are returned by the bank as an explanation for the rejection of specific items. 

Example 

The maximum payment value was exceeded. 

Activities 

Define error codes that are dependent on the transaction type, such as for the specific bank file layout used 

for DME. 

15.5.4.3.5.10 Create Planning Types per Bank Account 

In this activity, you assign planning types to certain transactions made in the bank account. 

This determines the bank accounts for which cash management payment advices are generated by certain 

information from the bank. This activity is only necessary if you use account statements from the present 

day that update cash management and forecast, but do not update accounting. This type of account 

statement can currently only be processed using the American BAI format or IDoc interfaces (logical 

message FINSTA - document type ACP). 

The system can generate a cash management payment advice for the following information: 

- Current account balance 

- Total of first debit of checks presented on that day (checks within the state) 

- Total of second debit of checks presented on that day (checks outside the state) - Adjustment 

amounts relating to the check presentation amounts from the previous day 

If a planning type is not entered for certain cases, an advice note is not created. 

You can also define a standard planning type for the individual transactions in the account statement. In 

the activity Assign External Transactions to Posting Rules, you can define a planning type per 

transaction. Cash management records are not automatically generated when the data is loaded; you can 

choose when to generate them using a report program (RFEBKA 40). 

Requirements 

You must have already carried out the following activities in Customizing for the Electronic Bank 

Statement: 

- Create Transaction Types 

- Create Currency Classes 

- Define Currency Classes 
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- Assign Banks to Transaction Types and Currency Classes 

Recommendation 

Different planning types should be used for different information, since the oldest information in each case 

will otherwise be overwritten. 

Activities 

You must enter a planning type for each case in which a cash management payment advice is to be created. 

Further notes 

For more information, see the SAP Library under Financials -> Financial Accounting -> Bank 

Accounting -> Electronic Bank Statement. 

15.5.4.3.5.11 Create Currency Classes 

Use 

In this activity you create currency classes (CSR format only). 

Currency classes are necessary if you import bank statements containing currency keys that are different 

from the ISO currency keys which SAP delivers with its standard system. You can combine alternative 

currency keys in a single class. The alternative currency keys within a currency class are assigned to the 

SAP currency key. 

Activities 

Define the currency classes you require. 

Further notes 

For more information about the Electronic Account Statement, see the SAP Library under Financial 

Accounting. 

 

 

15.5.4.3.5.12 Define Currency Classes 

Use 

In this activity you define your currency classes by assigning the alternative currencies within a currency 

class to a currency that corresponds to the SAP currency key. 

This assignment is required so that the electronic bank statement program can process the currency keys 

transmitted by your house bank and customers. 

Activities 



 

 

Choose a currency class and assign its alternative currencies to the SAP currency code. 

Further notes 

For more information about the Electronic Account Statement, see the SAP Library under Financial 

Accounting. 

15.5.4.3.5.13 Configure Returns Processing 

Use 

You define how the electronic account statement processes returned debit memos. 

- Assign internal returns reasons to external returns reasons. 

You assign an internal returns reason to a combination of external transaction code and external 

returns reason dependent on bank details. 

If you want to make the same assignments for all bank details of a transaction type, you can specify 

the transaction type and leave the fields for the bank details blank. 

If you do not specify a returns reason in the account statement, or you want to define the same 

returns activities for all returns reasons, enter the external transaction code and leave the field 

External Returns Reason empty. 

- Returns activities 

You define the accounts to which returns line items and charges are to be posted and whether clearing 

is to be reset for the returns line item. 

- Changing opened items 

If you select the field Reset Clearing, you can have the system automatically change the customer 

items that are reopened for each company code. You can set a dunning or payment block, or change 

or delete the payment method. 

If you leave the fields blank, the system does not change the documents. 

 

 

 

15.5.4.3.5.14 XML Format and Bank-Specific Formats 

15.5.4.3.5.14.1 Define Mapping Procedure 

Use 

In this Customizing activity, you define how a bank statement in XML format or in a bank-specific format 

is mapped to internal structures. 

Requirements 

You have created an XSL transformation or implemented method MAPP_BANK_STATEMENT of 

Business Add-In (BAdI) FIEB_MAPPING_X. 

Standard settings 
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The following settings have been made in the standard system: Transformation 

FIEB_CAMT053001_TO_FEB is made for a bank statement with format camt.053.001.02 

Activities 

For each bank statement format required, enter the name of the XSL transformation or the filter value of 

your BAdI implementation. If you specify a format for both, the system first runs through the 

transformation, and then the BAdI method. 

15.5.4.3.5.14.2 Define Mapping Format 

Use 

In this Customizing activity, you can define whether the system is to import the electronic bank statement 

in a different format from the format specified in the bank statement. You can decide this, for example, for 

a particular bank or a particular bank account. 

The system determines the mapping format, meaning the format in which the bank statement is to be 

imported, as follows: 

1. It uses the bank statement data to identify additional account information in the system (transaction 

FI12). 

2. In the table there it looks for an entry that matches this information. In doing so, it checks the data in 

The following order, and uses the first entry it finds for further processing: 

a) Bank country, SWIFT, IBAN 

b) Bank country, bank number, account number 

c) Bank country, SWIFT, account number 

d) Bank country, bank number, alternative account number 

e) Bank country, SWIFT, alternative account number 

f) Bank country, SWIFT 

g) Bank country, bank number 

h) Bank country 

i) All key fields are empty 

If the system does not find an entry, it uses the bank statement format. 

Requirements 

You have created an entry for each mapping format under Define Mapping Procedure. 



 

 

15.5.4.3.5.14.3 Business Add-Ins (BAdIs) 

15.5.4.3.5.14.3.1 BAdI: Split and Parse 

Use 

This Business Add-In (BAdI) is used in the component Electronic Bank Statement (FI-BL-PT-BS-EL). 

It supports you in the processing of file formats. If you want to import bank statement data in XML format 

or in a bank-specific format, a BAdI implementation must exist for the following functions: 

- Report RFEBKA00 for the manual import of bank statements: Bank Statement: Various Formats 

(SWIFT, MultiCash, BAI...) 

- Transaction for automatically scheduling the import. In the SAP Easy Access screen, choose 

Accounting -> Financial Accounting -> Banks -> Incomings -> Bank Statement -> Import 

and Forward (Automatically). 

The system runs through the following two BAdI methods in order: 

1. Method SPLIT defines how a bank statement is to be split into logical bank statements. The bank 

statement file is transferred in parameter I_STRING. 

2. Method PARSE determines the detail information from a logical bank statement. This data is 

Required in order to be able to read the mapping information for Customizing activity Define 

Mapping Format. 

Requirements 

You want to import bank statement data in XML format or in a bank-specific format. 

Standard settings 

For more information about the standard settings (filters, single or multiple uses), see the Enhancement 

Spot Element Definitions tab in the BAdI Builder (transaction SE 18). 

BAdI Implementations 

The following implementations exist in the standard system: 

- Implementation for XML format camt.053.001.02 

The filter value is camt.053.001 and the implementing class is CL_FIEB_GET_BS_CAMT053001. 

- Implementation for XML format camt.054.001.02 

The filter value is camt.054.001 and the implementing class is CL_FIEB_GET_BS_CAMT054001. 

If you want to process other formats then you have to create a new implementation. 

See also 

For information on how you implement BAdIs in the Enhancement Framework, see SAP Library for the 

SAP NetWeaver Platform on the SAP Help Portal under http://help.sap.com/nw_platform. Choose a 

Release and then Application Help. In the SAP Library, choose SAP NetWeaver Library: 

Function-Oriented View -> Application Server -> Application Server ABAP -> Application 
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Development on AS ABAP -> ABAP Customer Development -> Enhancement Framework. 

15.5.4.3.5.14.3.2 BAdI: Mapping the Bank Statement to Internal Structures 

Use 

This Business Add-In (BAdI) is used in the component Electronic Bank Statement (FI-BL-PT-BS-EL). 

You can use this BAdI to import bank statement data in XML format or in a bank-specific format. 

You can use the BAdI with the following functions: 

- Report RFEBKA00 for the manual import of bank statements: Bank Statement: Various Formats 

(SWIFT, MultiCash, BAI...) 

- Transaction for automatically scheduling the import. In the SAP Easy Access screen, choose 

Accounting -> Financial Accounting -> Banks -> Incomings -> Bank Statement -> Import and 

Forward (Automatically). 

By a filter-dependent implementation of method MAPP_BANK_STATEMENT, you can define how a 

bank statement in an XML format or a bank-specific format is to be mapped to internal ABAP structures. 

The bank statement file is transferred in parameter I_STRING. 

As an alternative to the BAdI implementation, you can define the mapping using an XSL transformation. 

In this instance, the implementation is not a requirement, but you can if you need to still use it, for example, 

if the amount display in the file does not correspond to the ISO norm. In the mapping result, the display of 

date fields, amounts and currency codes must correspond to the ISO standard. 

Requirements 

The BAdI is called if the following conditions have been met: 

- There is an entry in customizing activity Define Mapping Procedure for the format of the bank 

statement to be downloaded (for example, camt.053.001.02). 

There SAP and customers can define the required mapping procedure in separate key areas. 

- The appropriate entry defines a filter value for the BAdI. 

Standard settings 

For more information about the standard settings (filters, single or multiple uses), see the Enhancement 

Spot Element Definitions tab in the BAdI Builder (transaction SE 18). 

BAdI Implementations 

For bank statement format camt.054, there is BAdI implementation FIEB_MAPPING_CAMT054001 in 

the standard system. It is called following the XSLT (transformation FIEB_CAMT054_V2_TO_FEB). 

The implementation checks and enhances the data that the transformation supplies as necessary, in 

accordance with the following aspects: 

- It checks whether all items in the bank statement file have the status Posted (meaning it checks 

<Sts>BOOK</Sts> at the level<Ntry>). 

- If the file does not contain a bank statement number, a number is automatically assigned. 



 

 

- If the IBAN of the house bank account is missing and in addition the bank number and account 

number in the <Acct><ID><Othr><ID> field are without a separator, then the implementation 

determines the bank number and account number using the house bank master data. 

See also 

For information on how you implement BAdIs in the Enhancement Framework, see SAP Library for the 

SAP NetWeaver Platform on the SAP Help Portal under http://help.sap.com/nw_platform. Choose a 

Release and then Application Help. In the SAP Library, choose SAP NetWeaver Library: 

Function-Oriented View -> Application Server -> Application Server ABAP -> Application 

Development on AS ABAP -> ABAP Customer Development -> Enhancement Framework. 

 

 

15.5.4.3.5.15 Business Add-Ins (BAdIs) 

15.5.4.3.5.15.1 Business Add-In: Processing of Returns 

Use 

This Business Add-In (BAdI) is used in the component Electronic bank statement (FI-BL-PT-BS-EL). 

With this BAdI you can control the processing of returns. On the basis of the bank statement data (Import 

Parameter I_FEBKO (header data), 

I_FEBEP (Line item) and the table T_FEBRE (Payment note)) you can decide if a line item is a return and 

if there are bank charges. You can also search for the returns reason and charges in the payment note. 

The BAdI is called up directly after importing the bank statement data. 

Standard settings 

The Business Add-In is not active in the standard system. 

Activities 

After calling up the IMG activity, a dialog box appears, in which you can enter a name for the 

implementation. 

If you have already made other implementations for this BAdI, another dialog box appears, in which the 

existing implementations are displayed. In this case, choose Create, and proceed as follows: 

1. In the dialog box, enter a name for the BAdI implementation in the Implementation field, and choose 

Create. 

The screen for creating BAdI implementations is now displayed. 

2. Enter a short text for the implementation in the Short text for implementation field. 

3. From the tab index, choose Interface. 

The Name of implemented class field is already filled on the tab page, as a class name was 

automatically assigned to the implementation when you named it. 

4. Save your entries, and assign the implementation to a development class. 
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5. Place the cursor on the method, and double-click to enter method processing. 

6. Enter the code for the implementation between the statements method <Interface name> ~ 

<Name of method> and end method. 

7. Save and implement your code. Return to the Edit Implementation screen. 

8. Save the entries on the Edit Implementation screen. 

Note: You can also create an implementation, and then activate it at a later time. In such a case, end 

the processing stage at this point. 

9. Choose Activate 

The code you stored in the method will be run when the application program is executed. 

Example 

To display example coding, select Goto -> Example coding -> Display. 

If the standard program finds a return reason, then only the charge in the payment note is searched for in 

the example coding. 

If the standard program finds no return reason, then the return reason is also searched for in the example 

coding. 

Also see: 

Method 

Return in bank statement 

15.5.4.3.5.15.2 Add-In: Notes to Payees 

Use 

This Business Add-In is used in the application component Electronic Bank Statement (FI-BL-PT-PT-

BS-EL) and is only relevant for Austria. 

This Add-In enables you, when you import an electronic bank statement using the Creation of an MT940 

File with Data from the V3 Return Data Carrier program, to change the notes to payees in the line items. 

The program calls the Add-In after it has imported the two bank statement files sent you by the bank (one 

in MT940 format, one in V3 format). The Add-In then changes the notes to payees and exports them back 

to the program. The program then creates the bank statement file with the new notes to payees. 

Standard settings 

In the standard system, the Business Add-In is not activated. It is not filter-dependent and it is not reusable. 

Activities 

After calling up the IMG activity, a dialog box appears, in which you can enter a name for the 

implementation. 



 

 

If you have already made other implementations for this BAdI, another dialog box appears, in which the 

existing implementations are displayed. In this case, choose Create, and proceed as follows: 

1. In the dialog box, enter a name for the BAdI implementation in the Implementation field, and choose 

Create. 

The screen for creating BAdI implementations is now displayed. 

2. Enter a short text for the implementation in the Short text for implementation field. 

3. From the tab index, choose Interface. 

The Name of implemented class field is already filled on the tab page, as a class name was 

automatically assigned to the implementation when you named it. 

4. Save your entries, and assign the implementation to a development class. 

5. Place the cursor on the method, and double-click to enter method processing. 

6. Enter the code for the implementation between the statements method <Interface name> ~ 

<Name of method> and end method. 

7. Save and implement your code. Return to the Edit Implementation screen. 

8. Save the entries on the Edit Implementation screen. 

Note: You can also create an implementation, and then activate it at a later time. In such a case, end 

the processing stage at this point. 

9. Choose Activate 

The code you stored in the method will be run when the application program is executed. 

Example 

To display the sample code, choose Goto -> Default Code -> Display. 

See also 

Methods 

Change Note to Payee in Field 86 

15.5.4.3.5.15.3 Add-In: EDIFACT File Authentication 

Use 

The Read EDIFACT Files/Convert into MultiCash Format program uses this Add-In to: 

- Verify digital signatures attached to incoming EDIFACT files 

- Attach your company's own digital signature to outgoing EDIFACT files 

Prerequisites 

Since SAP does not offer the appropriate authentication software, you must obtain a suitable solution from 

a third party. BBS (Bankenes BetalingsSentral) offers a software package that comprises authentication 

software and an implementation for this Add-In. 
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Standard settings 

The Add-In is not implemented in the standard system. The Add-In is reusable, but it is not 

Filter-dependent. 

Activities 

Create an implementation as described in the method documentation listed below, using the instructions. 

See also 

Methods 

Call Authentication Software 

15.5.4.3.6 Lockbox 

In the following activities, you store the specifications for the lockbox procedure. This procedure is used 

to process incoming payment transactions (normally checks) in the USA. The Lockbox program will 

process a file of payment transactions from the bank, create general ledger posting for cash received and 

clear Accounts Receivable open items. 

Further readings: 

- Define control parameters 

- Define posting data 

15.5.4.3.6.1 Define Control Parameters 

In this activity you store control data for the lockbox procedure. Currently, only the procedure LOCKBOX 

is supported.  This data is needed for importing lockbox files sent by banks. Currently, only BAI and BAI2 

file formats are supported by SAP.  It includes the following: 

BAI Record Format:  Specify the length of the document numbers (10 in the standard SAP System) and 

the number of document numbers in record types 6 and 4 of the BAI file. Your bank must agree on this 

format information. 

BAI2 Record Format: It is not necessary to specify the length of the document or the number of document 

numbers in record types 6 and 4. This is because BAI2 file is designed that each document number is on a 

different record type 4 with its corresponding payment and deduction amounts.  Your bank must agree on 

this format information. 

NOTE:  while the BAI and BAI2 formats are supposedly standard, experience has shown that they 

can vary by bank and many SAP clients have contracted for a customized format.  The format 

received will need to be mapped to reconcile with the SAP delivered data dictionary layout (Tables 

FLB01, FLB05, FLB06, etc.) to ensure proper processing.  If the format does not reconcile and the 

user does not want to have the bank change the format, SAP recommends that a user-written ABAP 

be used to reformat the file or alternatively the SAP data dictionary can be modified ( this is a repair 

that will need to be re-applied in future releases). 



 

 

 

Batch Input Sessions [Posting Functions]:  

 Specify which postings the system creates (general ledger cash postings and/or customer cash application).  

It is recommended that both choices are selected if you are using the general ledger and accounts receivable 

modules.  For the general ledger you can decide whether to post one aggregate amount to the incoming 

cash account or one line per check. This depends on your reconciliation with the bank.  In addition, you 

can choose to create and name a batch input session to insert any missing or new customer bank details 

into the customer master records (this can only be done if the system identifies a valid document number). 

Important Note: The lockbox  program first attempts to identify the customer with unique bank 

information in the customer master record matching to MICR information on the check, so 

maintenance of unique customer MICR information is important to ensure success.  If there is more 

than one customer with the same MICR bank and account, then the program cannot apply the check 

to an account.  This situation usually means that either the same customer has been set up twice, or 

maybe what should have been only Ship-to or Sold-to customers for the same Payer have actually 

been set up as separate Payers. Alternatively, it may be necessary to set up a relationship where one 

customer is identified as the main Payer and has MICR info, and the related customers do not have 

MICR info but instead have the main Payers customer number in the Alternate Payer field of the 

customer master record. 

The payment information provided in the bank data file will create a payment advice per check.  This 

payment advice will be used by the lockbox procedure to clear sub ledger open items.  For more 

information on payment advices, please read accounts receivable/accounts payable Payment Advice Notes 

in the IMG or On-Line Help. 

Activities 

Enter the necessary data. 

15.5.4.3.6.2 Define Posting Data 

In this activity you store information needed to process particular lockbox data and generate postings. The 

Destination and Origin are routing information and defined by your bank.  For every unique 

destination/origin, posting information is needed to create the following postings: 

- G/L posting - Debit bank account (incoming checks) and credit payment clearing account 

- A/R posting - Debit payment clearing account and credit customer account 

To do this enter the following posting details: 

Specify a company code who holds the lockbox.  Enter in Bank account number [Bank (clearing) acct] 

field the general ledger account number which corresponds to the lockbox (clearing) bank account. Enter 

in Bank clearing acct [Payment clearing acct] field the general ledger account number which corresponds 

to the AR clearing account (the balance in this account will represent all unapplied ( lockbox) payments) . 

In addition, specify the document types and posting keys for these postings. 

Activities 

Enter the necessary data. 
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15.5.4.3.7 Payment Service Provider 

15.5.4.3.7.1 Define Payment and Dunning Block for Each Payment Service 
Provider 

Use 

In this activity, you can assign a fixed payment block and dunning block to each payment service provider 

stored in the system. 

If a purchase is paid for in SAP Web Channel Experience Management using one of these payment 

service providers, both blocks are automatically updated to the Financial Accounting documents that are 

created for this. 

Requirements 

In Customizing for payment and dunning, you must create the payment blocks and dunning blocks you 

want to assign. 

Standard settings 

You can only use payment blocks that cannot be changed in the payment proposal. 

You should create new payment blocks and dunning blocks for each payment service provider. This makes 

it easier to identify the blocks when they are used for other purposes in Financial Accounting. 

Activities 

If one of these automatically updated payment or dunning blocks is manually changed during a document 

change or in the customer line item list, the system issues a corresponding warning message. 

15.5.4.3.7.2 BAdI: Import Settlement Files for Each Payment Service Provider 

Use 

This Business Add-In (BAdI) is used in the SAP Web Channel Experience Management component. 

You can use this BAdI to import settlement files from different payment service providers into the system. 

Further processing takes place in the Electronic Account Statement. 

- The BAdI is always called when a user executes the following transaction: Import Settlement File 

of Payment Service Provider (transaction code FEBPS). 

- To import the settlement file, the READ_PAYSP_SETTLEMENT_FILE method must be 

Implemented. The payment service provider's ID serves as a filter value in the implementation. 

Requirements 



 

 

You have defined a payment service provider ID in the Customizing activity Create Payment Service 

Provider. You have specified this ID as a filter value in your BAdI implementation. 

Standard settings 

The BAdI is filter-dependent. There is one implementation per payment service provider ID. 

There is no active implementation in the standard system. 

Activities 

For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for SAP 

NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

15.5.4.3.8 Prepare Payment Authorization/POR Procedure 

In this step, you store information needed for automatically posting incoming customer payments during 

the ISR/OSR procedure. To do this, you specify a company code, the document type, the incoming 

payment account and the payment clearing account for each subscriber number. 

Activities 

Specify the necessary data. 

15.5.4.3.9 Activate Orbian Payments 

In this activity, you activate the payment method Orbian for all company codes in your client. 

15.5.4.4 Cash Journal 

You make the settings for setting up the cash journal in the following activities. 

15.5.4.4.1 Create G/L Account for Cash Journal 

In this activity, you create a G/L account, for example 100000, for the cash journal in the required 

company code. Note 

Ensure that the account 

- Can only be posted to automatically 

- Displays a unique account currency 

If you want to run several cash journals with different currencies in this account, make sure that 

- The indicator Balances in local currency only is not set 

- The account currency corresponds to the company code currency 
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15.5.4.4.2 Amount Limit 

Use 

You use these functions to define limit values for the FI cash journal; where these limits are reached and 

exceeded, the user is prompted (in an information dialog box) to run certain activities. The check is always 

performed in the first local currency of the company code. 

In the countries of the European Union, these functions are used to draw attention to the legal requirement 

for identifying the payer (money laundering law § 3 para.  1). 

Activities 

Company code: 

You do not have to enter a company code. The entry is then valid for all company codes within a client 

that use the currency specified as the first local currency. 

Currency: 

Each amount must be specified by the classification of the currency. If you specify a company code, the 

currency of the company code is entered in the currency field and you cannot change this. 

Date and amount: 

The amount limits are defined time-dependent ("Valid From"). 

15.5.4.4.3 Define Document Types for Cash Journal Documents 

You can select existing document types for cash journal documents, or define new document types in this 

activity. 

You must have document types for the following postings: 

- G/L account postings 

- Outgoing payments to vendors 

- Incoming payments from vendors 

- Incoming payments from customers 

- Outgoing payments to customers 

Note 

Ensure that on the detail screen, the selection fields under Permitted account types, your postings are 

selected accordingly. Useful selections are for example, account types customer, vendor, and G/L account. 



 

 

15.5.4.4.4 Define Number Range Intervals for Cash Journal Documents 

You have to define a number range interval for cash journal documents. Each document then receives a 

unique number that does not clash with the G/L document number. 

Requirements 

Determine whether the number range interval 01 has already been predefined by the system. 

Activities 

If number range interval 01 has not been predefined, define the interval in the company code required, 

usually with a document number interval from 1000000000 to 1499999999. 

Note This number range assigns a unique number per company code to each cash journal document. In 

addition, the cash journal documents are numbered sequentially per company code and cash journal. 

Example 

Standard settings 

Recommendation 

Activities 

Further notes 

15.5.4.4.5 Define Numbering Groups 

Use 

In this activity, you define numbering groups for the cash vouchers in a cash journal. 

If you do not set up document numbering groups, the system numbers the cash documents sequentially 

when they are created. Therefore, incoming and outgoing cash documents are part of the same numbering 

sequence. 

If you want the system to number incoming and outgoing cash payments using separate number ranges, 

you can define numbering groups for the incoming and outgoing cash payments. 

Each cash journal can have two cash document groups. One is used for the incoming cash payment, and 

the other is used for the outgoing cash payment. 

Activities 

To set up the system to number the documents for incoming and outgoing cash payments, you enter both 

numbering groups in the activity Set up Cash Journal. 
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15.5.4.4.6 Define Number Ranges for Numbering Groups 

Use 

In this Customizing activity, you define number ranges for the cash document numbering groups that you 

have created. 

Requirements 

You must use 01 as the number range interval for the number range objects. 

15.5.4.4.7 Set up Cash Journal 

To set up a new cash journal for a company code, enter the appropriate data for the following fields: 

- Company code 

Company code in which you want to run the cash journal 

- Number 

Random number for cash journal identification; 

You can run several cash journals in each company code 

- G/L account 

G/L account to which you want to post the cash journal business transactions, usually the petty cash 

account. 

- Currency 

Currency in which you want to run the cash journal. You are free to choose the cash journal currency. 

If you want to run a cash journal whose currency does not correspond to that of the company code, 

you have to consider the following details in the corresponding cash journal G/L account master data: 

- The indicator Balances in local currency only should not be set 

- The account currency must correspond to the company code currency 

You can run several cash journals with different currencies in one cash journal G/L account. Several 

cash journals with the same currency in one G/L account is however not possible. If you want to run 

several cash journals in the same currency in one company code, you have to select different cash 

journal G/L accounts. 

- Cash Journal Closed? 

Indicator that a cash journal is closed 

- Document types for 

- G/L account postings 

- Outgoing payments to vendors 



 

 

- Incoming payments from vendors 

- Incoming payments from customers 

- Outgoing payments to customers 

- Numbering group for - Payments 

- Receipts 

- Name 

Automatic language-dependent cash journal identification name, 

for example, Cash journal 1 SAP AG 

- Authorization group 

Enables access protection for specific objects 

- Person 1, Person 2 

Contains the names of important people for the cash journal, for example, the name of the cashier 

- Text 

Contains additional information for the cash journal 

Note: 

If you use extended withholding tax in your company code, you have to make the corresponding settings 

for posting payments. 

15.5.4.4.8 Create, Change, Delete Business Transactions 

In this activity, you can create, change, and delete business transactions for the cash journal. 

Note 

Alternatively, you can create the business transactions online using the cash journal document entry. From 

the SAP Easy Access screen, select Accounting -> Financial accounting -> Banking -> Input or 

Outgoings -> Cash journal. 

Activities 

Enter the appropriate date for the following fields: 

- Company code 

The company code in which the business transactions should be created 

- Business transaction number 

Random number that uniquely identifies the business transaction (these numbers are automatically 

assigned by the system) 

- Business transaction type 

E (Expense) 

R (Revenue) 

B (Cash transfer cash journal to bank) 

C (Cash transfer bank to cash journal) 

D (Customers-incoming/outgoing 
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payment) K (Vendors-

outgoing/incoming payment) 

- G/L account 

Expense or revenue account for the offsetting postings of G/L account postings, for example 400000 

or 800000; 

Caution: You must not make entries in the fields for business transaction types D and K. 

- Tax code 

Determines the business transaction control 

Caution: You may only make entries in this field for business transaction types E and R. 

- Cash journal business transaction 

Random, automatic language-dependent indicator for the business transaction, for example, SAP 

Shop or Taxi. 

- Business transaction block 

Indicator that a business transaction is blocked for additional postings. 

Russia 

To assign a special general ledger indicator to business transactions for down payments, select the 

transaction and choose Edit -> Special General Ledger Indicator. 

15.5.4.4.9 Set up Print Parameters for Cash Journal 

In order to print the cash journal and the cash journal receipts, you have to set up the corresponding print 

program parameters per company code. 

Activities 

1. Enter the appropriate company code. 

2. Specify the following print program parameters per company code: 

- For the cash journal: 

- Print program usually RFCASH00 

- Report variant 

For example, with entries FI_CASH_BB (Opening balance text), FI_CASH_EB (Closing 

balance text), FI_CASH_CF (C/F text), FI_CASH_SI (Signature text) 

- For the cash journal receipts: 

- Correspondence type 

For example 

- SAPC1 Accounting document 

If you set the indicator Accounting documents, the receipts are printed based on the FI 

documents. If you do not set the indicator, you can print all the documents saved in the cash 

journal based on the cash journal documents. Not setting the indicator is therefore 

recommended. 



 

 

15.5.4.4.10 Country-Specific Functions 

15.5.4.4.10.1 Russia 

15.5.4.4.10.1.1 BAdI: Form T-53A 

Use 

This Business Add-In (BAdI) is used in the Financial Accounting (FI) component. 

You use this BAdI before you print the Form T-53A. 

This BAdI allows you to modify the content of the report after data selection but before the PDF form is 

printed. 

Standard settings 

In the standard system, there is no activated BAdI implementation. The BAdI is not filter-dependent and 

it is designed for single use. 

Activities 

For information about implementing BAdIs as part of the Enhancement Concept, see SAP Library for SAP 

NetWeaver under BAdIs - Embedding in the Enhancement Framework. 

See also 

This BAdI uses the interface J_3RF_T53A_BADI_INTERFACE. For more information, display the 

interface in the Class Builder. 

15.5.5 Bank Directory Data Transfer 

You can find the settings for bank directory data transfer under Cross-Application Components -> Bank 

Directory Data Transfer. 



 

 

  



 

 

 


