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INTRODUCTION 
Welcome to the fascinating world of SAP. This book helps you crack the tricks of mastering SAP HANA 

Customization 

  



 

 

Activity-Based Costing 
In the following IMG activities you make mandatory and custom default settings for the Activity-Based 

Costing component ( CO-OM-ABC ). 

After completing the settings, save and check them. 

Further notes 

For more information on the following activities, see the Implementation Guide documentation (IMG) 

in the Application Help for Activity-Based Costing (CO-ABC) and the SAP Library under "CO - 

General System Administration: Overhead Cost Controlling". 

 Requirements 

Before you make default settings for the Activity-Based Costing component ( CO-OM-ABC), complete 

the following IMG activities: 

Implementation Guide "Controlling: General" 

Organization 

Implementation Guide "Cost and Revenue Element Accounting" 

Settings for cost elements 

Implementation Guide "Cost Center Accounting" 

Settings for cost centers 

 Activate Activity-Based Costing in Controlling Area 

In this IMG activity you activate Activity-Based Costing using the indicator in the Controlling 
area. 

You can use the indicators to activate or deactivate specific Controlling subfunctions related to 

the fiscal year. 

The indicators are valid from the selected fiscal year. They are valid to the fiscal year for which 
you maintain the new indicator. 

Requirements 

Complete the IMG activity Maintain Controlling Area. 

Activities 

Select the controlling area in which you want to activate Activity-Based Costing. 

Choose "Activate component/Control indicator". 

Determine the fiscal year. 
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Activate Activity-Based Costing. 

Notes for transport 

To transport controlling area settings, see the IMG activity under "Controlling: General". 

Further notes 

For more information on how to activate subcomponents in the controlling area, see the SAP 

Library under "Controlling -> General Controlling > Organization of Controlling > Controlling 
Areas." 

 Maintain Standard Hierarchy for Controlling Area 

In this IMG activity, you assign the highest node of a standard hierarchy of business processes to a 

controlling area. 

The standard hierarchy of business processes displays the organizational grouping of business processes 

and serves moreover as a foundation for evaluations. When creating business processes during master 

data maintainence for the application menus, you must assign these to a previously defined profit center 

group. 

In the event that a standard hierarchy is not yet available during the maintainance of assignments to a 

controlling area, the R/3 System will create the highest node. 

You can set up the structure of the standard hierarchy by defining the business process groups in 

customising as well as in the application menus. 

Direct assignment to the controlling area guarantees that all business processes of a controlling area are 

included in the standard hierarchy. 

Requirements 

You must first fully create a controlling area. 

Activities 

Assign your standard hierarchy to the controlling area by taking the following steps. 

Find the controlling area in the list. 

Enter the desired standard hierarchy of business processes for your controlling area. 

Save your entries. 

Note on transport 

To transport controlling area settings, see the IMG activity under "Controlling: General". 

 Master Data 

In these IMG activities you make default settings for the following master data: 

Business processes and business process groups 



 

 

Cost objects and cost object groups 

Note 

Keep in mind the effects of the structure of your business process and cost object groups on planning and 

reporting. 

 Business Processes 

In this section you can 

Define business process types 

Determine business process allocation types 

Determine the ranking order for value added 

Define business process groups 

Define business processes 

 Maintain Standard Hierarchy of Business Processes 

In this IMG activity you maintain the corresponding standard hierarchy for your controlling area. 

You can create a new hierarchy or change an existing one, as well as create or edit business processes 

and business process groups. 

Prerequisites 

Complete the IMG activity Maintain Controlling Area. 

Activities 

Structure the processes in your organization and use this structure to derive the business 

processes and the business process structures. 

For more detailed documentation on processing possibilities, refer to the Application help or to the SAP 

Library under Financials -> Controlling -> Activity-Based Costing -> Master Data in Activty-Based 

Costing -> Business Process -> Standard Hierarchy of Business Processes. 

Note on transport 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 

 Define Attributes 

In this IMG activity, you determine possible values for business process attributes. 
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The R/3 System offers the following attributes: 

Process category 

Cost behavior 

Value added (external, internal) 

Additional attribute 

A later R/3 System release will support inherited attributes for allocation, including sender, receiver, or 

manually-set attributes. At this time, you can maintain time-based dependency, but not allocation. 

In addition, you can maintain the text fields "First attribute" and "Second attribute". The R/3 System does 

not valuate these fields. 

Activities 

Process Category 

Determine the criteria according to which your organization classifies business processes. 

Check whether the standard process categories satisfy your requirements. 

If necessary, create new process categories. 

Choose "Process categories". 

Choose "New entries". 

Enter a number key and a name for each category. 

Save your entries. 

Cost Behavior 

Determine which cost behaviour values you require. 

Check whether the standard values satisfy your requirements. 

If necessary, create new values. 

Choose "Cost behavior". 

Choose "New entries". 

Enter a number key and a name for each value. 

Save your entries. 

Value Added 

Determine how differentiated you wish to rank value added. 

Check whether the standard values satisfy your requirements. 

If necessary, create new values. 

Choose "Value added ranking". 

Choose "New entries". 

Enter a number key and a name for each value. 

Save your entries. 

Note on transport 



 

 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 

 Maintain Business Process Groups 

In this step you create new business process groups or maintain existing groups. 

You can define groups of similar business processes. Business process groups themselves can be 

combined into groups, resulting in a business process hierarchy. 

The highest node of the standard hierarchy is normally the first business process group you created (see  

Maintain Standard Hierarchy of Business Processes). The groups you create thereafter form the 

remaining nodes of the standard hierarchy. 

You can also create independent business process groups that are not part of the standard hierarchy. A 

business process can only be assigned to one hierarchy group. However, it can be assigned to any 

number of independent business process groups. 

You can create independent business process groups only in this transaction or in the Activity-Based 

Costing menu under Master Data -> Business Process Groups -> Create. 

You use business process groups in: 

The information system 

Processing multiple processes in one transaction (such as allocations) 

Requirements 

You must already have created a controlling area and fully defined it. 

Activities 

Structure the activities in your company and derive from them your business processes and the structure 

of the business processes. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 
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If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup node, 

the value, or the value interval, and choose Edit -> Selected entry -> Remove. The affected node 

is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 



 

 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 
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In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 



 

 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 

 Define Selection Variants for Business Processes 

A selection variant contains the fields that are to be evaluated in your selection report. These fields 

determine the content and structure of a selection variant. 

The following selection reports are available: 

For cost elements     RKKOASEL 

For cost centers     RKKSTSEL 

For activity types    RKLSTSEL 

For business processes RKPRZSEL 

For internal orders RKOSEL00 

For projects     RKPSEL00 

You enter the selection values in the corresponding fields, and can overwrite these in the application. 

You can hide the fields that you do not require. 

When you process "variant attributes", you can specify variables for selection variant fields, and so on. 

Example 

If you wish to select your objects by time, then define a selection variant, which only contains master 

data fields for times. 

Standard settings 

The following selection variants are defined for internal orders: 

SAP_01 - SAP_02 - SAP_03 

Activities 

If you wish to create your own selection variants, proceed as follows: 

Enter a name for your variant in the "ABAP: Initial screen for variants" 

Confirm the "Values" default setting in the "Subobjects" group box, and choose "Create". In the "Variant 

maintenance: Report <your selection report>" screen, the system displays the selection fields for the 

corresponding master data. 

Enter the values or variables in the fields that you wish the system to use for selection. 

Choose Continue. 

This takes you to the Attribute maintenance screen for the selection variants. 

You can assign the following field attributes: 

Protected 

The value that you specified for the field can no longer be overwritten in the application. 

Invisible 

The system hides this field from the selection variant. 
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Selection variable 

You can define a variable for a field, such as a user-defined selection rule ( compare with the 

"Define selection rule" section). The field is filled with the corresponding value during 

runtime. 

Enter a short text in the "Description" field. 

Save your entries. 

This variant is now available for the corresponding selection report. 

Transport notes 

You can transport selection variants manually by proceeding as follows: 

Choose "Utilities -> Transport request..." in the "ABAP: Variants - Initial screen" 

Enter the program name 

Enter the name of the variant to be transported 

 Define List Variants for Group Processing 

In this IMG activity, you create variants for organizing lists in group processing of business processes. 

You can determine which fields appear in which order for the individual business processes. 

Standard settings 

The standard R/3 System includes the following list variants: 

Standard one row 

Standard two rows 

Standard three rows 

Standard four rows 

You cannot change these variants. The R/3 System offers these variants and any variants defined by you 

when you choose "Possible entries". 

Actions 

Check whether the standard variants satistfy your requirements. 

If necessary, create new list variants: 

Choose "Create". 

Enter a key and a name for the variant and determine how many rows appear per business process. 

Select the fields you require from the list of possible fields displayed by the R/3 System. 

Note that the fields "Marking" and "Business process" are mandatory. 

Change the offset to adjust the spacing between the fields in a row. 

Save your entries and activate the new list variant. 



 

 

Further notes 

Ensure in IMG activity Maintain Controlling Area that cost accounting is active for the list variant 

objects during the relevant fiscal year. 

 Maintain Business Processes 

In this IMG activity you define business processes. 

Requirements 

Before defining business processes, determine business process categories, the cost behavior, and the 

ranking order for value added processes because these fields are important for defining business process 

attributes. 

Note on transport 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 

 Activate Inactive Business Processes 

In this IMG activity, you can activate the inactive version of a master record. 

The following master data can be either active or inactive versions: 

Cost centers 

Profit centers 

Business processes 

Note on Active and Inactive Master Record Versions 

Choose the corresponding objects using one of the following criteria: 

<Object> or <object> interval 

<Object> group 

All <objects> in a controlling area 

Decide whether to activate immediately, or in a test run first. 

Decide whether to activate in the background, or online. 

To activate the objects, choose Execute. 

Note 

You can go from the activation of one object into the activation for another object. This means 

that you can go from Activation of cost centers to Activation of profit centers. 

Further notes 
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For more information, see the SAP Library, under Financials -> CO - Controlling -> Methods in 

Controlling -> Enterprise Organization -> Processing Enterprise Organization -> Activate 
Inactive Master Data. 

 Delete Inactive Business Processes 

In this IMG activity, you can delete the inactive version of one of the following master records: 

Cost centers 

Profit centers 

Business processes 

Note on Active and Inactive Master Record Versions 

Activities 

Choose the corresponding objects using one of the following criteria: 

<Object> or <object> interval 

<Object> group 

All <objects> in a controlling area 

Decide whether to delete immediately, or in a test run first. 

Decide whether to delete in the background, or online. 

To delete the inactive master record versions, choose Execute. 

Note 

You can go from the deletion transaction for one object to that of another object. This means 

that you can go from Deleting cost centers to Deleting business processes and Profit 

centers. 

Further notes 

For more information, see the SAP Library under Financials -> CO - Controlling -> Enterprise 

Organization -> Processing the Enterprise Organization -> Delete Inactive Master Data. 



 

 

 Determine Time-Based Fields for Business Processes 

In this step you determine on the client level, independently of organizational units such as controlling 

area or chart of accounts, whether master data table fields are historically relevant or not. 

You can maintain master data for cost centers, cost elements, activity types, and business processes as 

time-based. Changes to any other time interval are possible at any given time. Data storage is also time-

based. In this way, you can store multiple database records for a master data record, each holding 

different information. 

The time-based dependencies are determined by SAP and cannot be changed. The following 

dependencies are possible: 

Not time-based 

Day-based 

Period-based 

Fiscal Year-based 

In the "Time Dependency" column, you have an overview of the time-based dependencies for individual 

master data fields as set by SAP. 

For day-based fields, you can set an indicator determining whether fields are historically relevant or not. 

Period-based and year-based fields are always historically relevant. 

If you change fields during master data maintenance which were marked as historically relevant, and 

redefine a new analysis period, the system creates new database records, for the new analysis period and 

for any following periods, and simultaneously restricts the validity period of the existing database 

records. 

Example: 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

Then you change the object by defining other field characteristics from 011997 to 312997. In 

Customizing, you defined the Manager field as historically relevant. 

The SAP system stores three records. You can view them in master data maintenance by placing the 

cursor on the field and choosing Expand: 

One record for the interval 011996 to 312996 Manager: Miller 

One record for the interval 011997 to 312997 Manager: Wang 

One record for the interval 011998 to 312999 

Manager: Miller 

If you change fields during master data maintenance not marked as historically relevant, but without a 

new analysis period, the entire database record changes for the entire analysis period. These changes 

appear in the change log. 

If you change day-based fields not marked as historically relevant, the existing database record also 

changes for the entire selected analysis period. Definition of a new period is not possible. These changes 

appear in the change log. 

Example 

You create an object (cost center, cost element, activity type, business process) from 011996 to 312999. 

You then change the object by defining another cost center manager. In Customizing, you defined the 

Manager field as not historically relevant. 



 

WHATSAPP +255738656506 

The SAP system changes the record for the Manager field: 

Record for the interval 011996 to 312999 Manager: Wang 

The SAP system documents the changes with date and user name in a change document. 

Fields without time-based dependencies may be changed at any time, with the change applying to the 

entire validity period of the master data. 

Note 

Remember that time-based storage consumes large amounts of data storage space. Designate only 

important fields for time-based dependencies. 

If consecutive fields have identical historically relevant definitions, the SAP system replaces the database 

records with a single record valid for the existence of the individual records. 

Further Notes 

Time-based master data storage minimizes maintenance effort. You can create master data crossing fiscal 

year boundaries without having to recreate them every year. Changes affecting a single time only can be 

made without direct effects on the other times involved. 

Example: 

You create a cost center with the following data: Cost Center: 41 

Validity Dates: 011996 to 312000 

This entry remains available in the SAP system until 312000. 

However, you may also create: 

Cost Center: 41 

Validity Dates: 011996 to 312996 

The disadvantage here is that you must recreate the cost center for the following years, each year, if 

you still require the cost center. 

The example above uses the yearly borders of a calendar year. However, you can determine validity 

periods that are independent of any given calendar year. This is particularly useful if you define a fiscal 

year variant in Financial Accounting with delayed, extended, or shortened fiscal years, because master 

data is not oriented along fiscal year variant lines. 

Actions 

Determine which fields you want to designate as historically relevant. 

Activate or deactivate the indicators according to your requirements. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Define Search Aids for Business Processes 

In this IMG activity you can revise or redefine the existing search_help for business processes. 



 

 

Notes 

Maintaining search help requires technical knowledge of the ABAP dictionary. Leave search 
help maintenance to your system administrator. 

Note that a large number of search helps can adversely affect system performance. Check 

whether you want to use search helps in your work area. You can deactivate any search helps 
you do not use. 

Search helps are created across clients. 

Requirements 

Before you edit search help, read the documentation in the SAP Library under SAP NetWeaver 

-> Application Platform (SAP Web Application Server) -> ABAP Technology -> ABAP 

Workbench -> ABAP Dictionary. 

This section tells you how search help is structured in the SAP system and how you can create 
a search help in the ABAP Dictionary. 

Standard settings 

The standard SAP system includes the following search helps o

 N - Search for business process number o H - Search via 

the business process standard hierarchy 

Activities 

Check whether the standard search helps meet your requirements. 

If necessary, change existing search help objects or create new search helps. 

 Create Extensions for Business Process Master Data 

You can enhance business process master data with your own additional fields. To do this, you can use 

the following SAP enhancement: 

COOMBP01  Business process: user-defined additional fields in the master record This 

enhancement contains the following enhancement components: 

EXIT_SAPLKWM3_001 

CO-OM Customer Exit for the PBO date for the user-defined subscreen "0399" in 

SAPLKWM3. 

EXIT_SAPLKWM3_002 

CO-OM Customer Exit for the PAI date for the user-defined subscreen "0399" in 

SAPLKWM3. 

Activities 

Create the enhancement 

Either create a new project or use an existing project. 

Activate the project. 

The enhancement is effective only after activation. 
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Further notes 

Enhancements, in contrast to modifications, are basically release- insensitive, as they are executed in a 

name space reserved for the customer, and not in the standard R/3 System. 

For more information on how to use enhancements, see the documentation for enhancement transaction 

CMOD by choosing "Utilities -> Online Handbook" in the section "Function Exits". 

For more general information, see the documentation for enhancement transaction CMOD by choosing 

"Display SAP Docu". 

 Templates 

This section explains how to use the templates. 

You maintain the functions that the template accesses (see Maintaining environments and Function 

Trees ). 

Create and maintain these templates (see Maintaining Templates). 

You assign templates to the receiver object. See: 

Assigning Templates for Cost Objects and Calculations 

Assigning Templates for Profitability Segments 

Assigning Templates for Business Processes - Assigning Templates for Cost Centers. 

For more information on the use of 

Templates see the Application help under Business Process Planning -> Period Based Allocations -

> Template Allocation in Plan or Period-end Closing -> Period Based Allocation -> Template 
Allocation in Actual. 

 Define Environments and Function Trees 

In this step you maintain: 
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Function trees 

Structure nodes - Function references - Functions. 

The basis for the maintenance of the object is always the chosen environment. 

Environment 

The Template's environment determines the information of the SAP-environment and the external system 

that can be accessed. Basically, the functions relevant to each context are already provided in the 

corresponding environment. Environments always contain a row of sub-environments which group 

functions by theme; these include material, BOM, routing, and others. 

The standard system delivers the following environments: 

Template allocation (for cost objects, profitability segments, 

business processes, cost centers/activity types) 

Formula planning (business processes, cost centers, profit centers) 

Standard cost estimates 

Process quantity determination ( SOP/LTP ) 

Easy Cost Planning/Internal Service Request 

Recommendation 

Use the sub-environments provided by SAP as much as possible. When you assign an function to a sub-

environment, it is automatically available in all the main environments containing this sub-environment. 

Further notes 

For more information on environments and a list of these and their sub-environments go to the help for 

applications of Activity-Based Costing under "Template -> Template Environment". 

Function Tree 

A function tree is a user-defined hierarchy which structures or groups functions. With the Help for 

function trees, you can structure groups of functions available in each environment according to their 

their theme or emphasis. Functions are then processed from here on. 

A function tree is assigned to an environment and consists of nodes and function nodes. 

Environments: all environments are displayed when you call up the n transaction. Environments 

themselves cannot be changed or deleted. The creation of new environments is also not possible. 
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Function trees: the first level under environments. You can subordinate nodes or function nodes to a 

function tree. 

Nodes: nodes are always subordinate to function trees or other nodes. You can subordinate other nodes to 

a node or function node. In function trees SAP1, nodes contain sub-environments. 

Function nodes are always subordinate to function trees or nodes. They always refer to a function. 

SAP standard delivery for all environments includes function tree SAP1 (for example, for environment 

001, function tree SAP1-001). This contains all standard nodes ( sub-environments ) and function nodes 

(with reference to the respective function). 

Activities 

The transaction provides you with left and right screens. The left one displays the existing environments. 

You can expand the hierarchy and view the function trees, nodes and function nodes in their hierarchical 

structure. Place the curser on an object you want to process. 

The right screen details of the chosen object (environment, function tree, nodes or function nodes) in list 

form. If you double click on a funciton node you will see the maintenance screen for the functions. 

Further notes 

For more information see Application help for Activity-Based Costing: 

AC-Financials -> CO-Controlling -> Activity-Based Costing -> Template -> 

Function tree -> Maintain function tree or Template -> Template environment -> Maintain 

functions 

AC-Financials -> CO-Controlling -> Cost center accounting -> Cost center planning -> Aids -> 

Formula planning -> Template -> Template environment. 

 Maintain Templates 

Here you maintain templates. 

Applications 

Each purpose (application) of a template requires a special environment. Before creating a template, 

choose an environment. The environment determines which row and column types are available, for 

example. 
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The available applications include the following: 

Template allocation to cost objects, or use in standard cost estimates for cost objects and materials 

(environments 001 - 012) 

Template allocation to business processes, cost centers, or cost centers/activity types 

(environments SBP, SCI, SCD) 

Template allocation to profitability segments (environment PAC) 

Formula planning (environments CPI, CPD, BPP, PCA) 

Calculation of output quantities (environment SOP) 

Easy Cost Planning/Internal Service Requests (environment 200 - 299) 

Structure 

A template consists of rows (items) and columns. The row and column types available to you depend on 

the environment. 

Columns available include: 

Type of row, such as business process, cost element subtemplate, or calculation row 

Name of the item 

Object, such as the name of the process, cost element, subtemplate, or calculation row 

Quantity (actual/plan), such as the process quantity or statistical key figure quantity 

Activation ( actual/plan ) 

Allocation event (template for cost objects) 

Activities 

To maintain a template, you must edit the initial and overview screens, from which you can access 

various editors. 

Initial screen 

Enter the name of the template that you want to create or edit. 

Enter the environment of the template. 

Choose Enter. 

Overview screen 

If the template is new, enter a name for it. 

Select the row type. 
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Enter a name for the row. 

Edit the other columns. Use the mouse or the tab key to reach the individual columns. Double-clicking on 

particular column types (such as object, quantity, activation, or allocation event) brings you to the 

editor or function selection. 

Once you have entered or edited all rows, choose Template -> Save. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 27 

Further notes 

Detailed information is available in the Application Help for the transaction, or in the SAP Library under 

Financials -> Controlling -> Activity-Based Costing -> Template -> Maintaining Templates. 

 Assign Templates for Cost Objects and Costing 

In this IMG step you maintain the assignments for your templates. for cost objects and calculations. 

As templates are not dependent on materials or orders, you must select the appropriate template at the 

time of evaluation. This selection must meet the following assignment logic: 

For product cost planning: 

Select an overhead structure through the valuation variant, which is selected through the costing 

variant. 

Select the overhead key through the overhead group in the master record for the material to be 

costed. 

The R/3 System determines the environment based on the method of costing (unit or product 

costing). 

For cost object costing and cost object allocations: 

The R/3 System selects the overhead structure and the overhead key from the master record for the 

cost object, and determines the environment based on the cost object. 

For material transfer from PP: 

You can assign the template using the overhead key or the product group and overhead key. The R/3 

System always uses SOP as the environment. 

Requirements 

Create the environment and the template. Additionally, you must maintain the assignment criteria 

described above in the corresponding objects 

Recommendation 

To call up assignment maintenance using the maintenance transaction for the template, choose 

"Environment". 

Activities 

Enter the controlling area, costing sheet, overhead key and environment. 

Further notes 
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For more information, see the Application help: "AC - Financials -> CO - Controlling  -> 

Activity-Based Costing -> Business Process planning -> Period-Based Allocations -> Template 

Allocation in Plan -> Template Allocation for Cost Objects, or Template Allocation in Plan Calculation," 

or "Period-end Closing Period-Based Allocations ->  Template Allocation in Actual -> Template 

Allocation for Cost Objects. 

 Assign Templates for Profitability Segments 

Assigning templates for profitability segments. 

The profitability analysis (CO-PA) allows you to carry out periodic controlling at the product level. Here 

you can establish multi-dimensional market segments (profitability segments) that distinguish themselves 

through several characteristics. 

You can choose business processes or cost centers/activity types as senders using template allocation for 

profitability segments. You can define profitability segments as receivers: this allows you to allocate 

costs directly to corresponding market segments. 

Because templates for profitability segments depend on the characteristics of the objects, they must be 

selected during the time of evaluation. The necessary settings are made in the IMG for profitability 

analysis. 

For more information in IMG on profitability analysis, see: "Set Up Template Allocation". 

The Application help for Activity-Based Costing provides further information on template allocations for 

profitability segments: "Business Process Planning -> Period Based Allocations -> Template Allocation 

in Plan -> Template Allocation for Profitability Segment". 

 Assign Templates for Business Processes 

Along with profitability segments and cost objects, business processes receiver objects can also take part 

in template allocations. A template allocation can be executed only in business processes that have an 

allocation template assigned to them in the master data. You do this in this step. 

Requirements 

- You have already created templates in the template environment SBP. 

Activities 

In IMG of Activity-Based Costing choose "Templates -> Assign templates for business processes" or in 

the menu for Activity-Based Costing, "Master data -> Business process -> Individual processing -> 

Change". 
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In the initial screen "Change business process" choose the process that to which you want to assign a 

template. 

Choose tab "Template". 

In field "Allocation template" choose a template. All templates in environment SBP are available here. 

Save your work. 

Further notes 

Only one template can be assigned to each business process. However, each process can be used several 

times as sender process in various templates. 

The assignment results for the entire year: the template assignment to the business process cannot be 

changed within the year (for periods shorter as the fiscal year). Changes can be made in the structure set 

for the fiscal year by activating or deactivating time dependent entries in the template. 

 Assign Templates for Cost Centers 

You create the link between cost center and formula planning in the master record of the cost center in 

question. 

You assign templates to those cost centers for which you want to determine planned values using 

formulaplanning, or which are to be receiver objects for template allocations. 

Activities 

You can also define templates when maintaining master data. 

In the cost center master record, choose the Templates tab. 

On the Templates tab, choose Create. 

You can now change or display existing templates or display an allocation structure with the 

template. 

If you have already defined templates, you can enter these on corresponding tab. 

If you want to determine activity-independent planned costs for the relevant cost center, enter an 

activity-independent template in the Aty-ind. formula temp. field. 

If you want to determine activity-dependent planned costs for the relevant cost center, enter an 

activity-dependent template in the Aty-dep.formula tmp. field. 
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If you want to carry out an activity-dependent activity allocation for the cost center in question, 

enter an activity-dependent template in the Aty-dep.alloc.tmp field. 

If you want to carry out an activity-independent activity allocation for the cost center in question, 

enter an activity-independent template in the Aty-ind.alloc.tmp field. 

Save your entries. 

Further notes 

For more information on cost center master data, see the "SAP Library" under Financials -> CO 

Controlling -> Cost Center Accounting -> Master Data in Cost Center Accounting -> Cost 
Centers -> Cost Center Master Data. 

 Planning 

In this IMG activity ou make settings for planning in the Activity-Based Costing component ( CO-OM-

ABC ). 

 Maintain Versions 

Versions enable you to have independent sets of planning and actual data. 

In planning, you use versions to configure alternative scenarios based on different assumptions. For 

example, the different versions can represent different employment markets, price and wage increases, or 

sales programs. 

You normally configure the most likely scenario in version 000. The plan data you enter there forms the 

basis for calculating planned prices for activity types, and determines the rates with which activities 

containing actual amounts can be settled. Version 000 also contains all actual data postings. The plan and 

actual data for version 000 can be used in plan/actual comparisons and variance analysis. 

You make settings for version maintenance on a hierarchical basis. 

In this IMG activity, you make the following settings: 

Controlling area settings 

Fiscal year settings 

Note 

The term "version" replaces the earlier term "plan/planning version". 

You can record planning and/or actual data in a version. 

In planning, you must maintain fiscal-year dependent parameters. 
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If you use parallel valuations and transfer prices, you define parallel actual versions alongside operational 

version 000 in order to separate different valuations. To do this, you must maintain valuations, by 

carrying out the activity Create Versions for Valuation 

Methods in Customizing under General Controlling -> Multiple Valuation Approaches/Transfer 

Prices 

In Activity-Based Costing, you can manage actual data in different delta versions of activity-based 

costing. To do so, you must specify a version that can be referenced. Once you specify this version, 

the current version is marked as a delta version. 

Complete the IMG activity Maintain Controlling Area. 

Complete the IMG activity Maintain Versions. 

Standard Settings 

When you create a controlling area, the SAP system automatically creates version 000, valid for five 

fiscal years. The first fiscal year depends on the control indicator you set when you created the 

controlling area: 

If the indicator is set for the current year or earlier, the five-year period begins with the current year. 

If the indicator is set for future years, the five-year period begins with the earliest of these years as the 

first year. 

Recommendation 

If you want to plan in a single version only, use version 000. 

Actual primary cost data entry and actual data from internal acitivty allocation all post to version 000. 

SAP therefore recommends you use this version for all plan/actual comparisons. 

Activities 

To assign versions to authorization groups, define the groups first. These groups determine which users 

can maintain which versions. To assign authorizations, use authorization object "Controlling: 

Version" ( K_KA09_KVS ). Maintain Authorizations 

Make the version settings in the current controlling area. To switch to another controlling area, choose 

Extras -> Set controlling area...  

Change an existing version to meet your requirements. 

Enter a key and a name. 

Specify whether plan and/or actual data may be recorded in the version and activate the 

corresponding indicator. 

You cannot activate the actual data recording indicator for version 001. 
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If necessary, enter an authorization group. 

To create a delta version in the Activity-Based Costing component, enter a valid version as the 

reference version. 

Maintain the fiscal year-dependent version parameters. 

If you use a delta version in Activity-Based Costing, use  Reference version to determine which 

transactions the system reads from the reference. The system does not execute these transactions in 

the delta version, but transfers the values from the reference instead. 

Note on transport 

To transport versions, a separate function exists in Customizing under Controlling -> General 

Controlling. ( Transport Settings for Organization. 

Further information 

For more information, see: 

Notes on Version Maintenance 

Fiscal Year-Dependent Version Parameters. 

Delta Versions in Activity-Based Costing 

Further notes 

Notes on Version Maintenance 

The following should be taken into account when maintaining a version: 

In general version definition you decide whether a version is allowed for 

Panning (with the Plan indicator) 

Actual data update (with the Actual indicator) 

Note: In Overhead Cost Controlling, actual data is updated in operational version 0. 

Actual versions different from 0 are found at present only for delta versions in Activity Based Costing 

(CO-ABC), and when you work with parallel assesment (additional versions): 

A data version from results and WIP determination manages (indicator WIP) 

Another version from variance determination manages (indicator Variance) 

A version for exclusive use (field exclusive application) 

You must maintain the version basic settings for each controlling area in which you want to update 

transaction data. General version definition restricts the settings possible for the controlling area: 

If general version definition does not allow plan and/or actual data update for version, this applies to the 

version in all controlling areas. If plan and/or actual data updating is allowed for a version in general 

definition, this can be reset for each controlling area separately (unmark the plan or actual indicator). 
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Delta versions in ABC may not be used for parallel valuations in the actual; the same goes for versions 

with exclusive applications. In both cases, the valuation fields may not be maintained. 

To set indicators WIP/Results- or Variance-determination the following conditions apply: 

Both indicators may be set only during setup for the controlling area, when they are already established in 

the higher level general version definition 

If either indicator is already active in the data bank, then the actual indicator may not be subsequently 

activated 

If the actual indicator is inactive and either of these indicators is active, then the valuations in the 

corresponding versions and in version "000" must agree 

If the actual indicator is active, then both indicators must be activated 

Versions 0 and 1 are used regularly for various purposes by the system, which sets the following 

limitations/restrictions: 

Version 0 must always be available. It cannot be used exclusively. The plan and actual indicators must 

always be active. 

The actual indicator may not be activated in version 1. 

If these conditions are violated during version maintenance, error messages are issued. There are three 

types of error message: 

While maintaining the general version definition, you can only make changes if they do not violate the 

conditions outlined above. 

While maintaining the basic settings in the controlling area, the entries must remain consistent with the 

higher level entries. 

You want to maintain version 0 or 1. The restrictions outlined above apply. 

Use the "Extras" menu option to display the structure of the entries in the complex data object version: 

Select a version and choose Extras -> Version use. 

The SAP System shows which controlling areas use this version. 

Select Extras -> Versions in CO area 

This displays all versions used in the current controlling area. 

The subordinate entries in the hierarchy (settings for each fiscal year, strategic Activity-Based Costing: 

transactions for a delta versions) will also be shown for both cases. 

Fiscal-Year-Dependent Version Parameters 

In a version you define defaults for the following parameters based on the fiscal year: 

Planning 

Lock version 
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Integrated planning 

Copying allowed 

Exchange rate type 

Value date 

Integrated planning with Cost Center Accounting and Activity Based Costing 

Version for indirect activity allocation for non-integratedorder/project planning 

Receiver version 

Valuation Variant for CO Resource Planning 

Price Calculation 

Purely iterative price 

Plan price calculation: Determination method 

Actual price calculation: Determination method 

Recalcuation with actual prices 

Cost component structure 

Delta Versions in Activity-Based Costing 

A delta version is an additional statistical version that is linked to a reference version. You create the 

delta version to be able to carry out other allocations for selected transactions. Allocations within a delta 

version do not affect the operative value flow in the system. It follows that you cannot allocate process 

costs within costing, cost object controlling, and Profitability Analysis. Referencing can take place at 

several levels. The reference version can also be a delta version and in turn be linked to another version. 

 Manual Planning 

In this section you undertake settings for manual planning. 

 User-Defined Planning Layouts 

In this IMG activity you define new planning layouts or change existing ones. 

Using the planning layout you specify what contents appear in the header, rows, and columns (elements) 

of your planning screens depending on the specific management requirements made by cost center 

planning. 
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The SAP system contains standard SAP planning layouts that satisfy most planning requirements. Only if 

this is not the case do you require your own layouts. 

Standard SAP planning layouts 

SAP offers the following standard planning layouts: 

Cost Center Accounting 

Cost Element/Activity Input Planning 

1-1 CCtr: Cost elements, activity-dependent/-independent 

1-2 CCtr: Activity inputs, activity-dependent/-independent 

1-3 CCtr: Costs/revenues/consumption 

1-4 CCtr: Primary/secondary order costs 

1-161 CCtr: Cost elements, simplified 

1-162 CCtr: Cost element central planning, simplified 

1-151 CCtr: Cost elements in transaction currency 

1-152 CCtr: Cost element comparison, 2 quarters 

1-153 CCtr: Cost element planning, 2 versions 

1-154 CCtr: Cost elements with display of previous year 

1-155 CCtr: Activity output from sender viewpoint 

1-156 CCtr: Cost element central planning 

1-157 CCtr: Cost element plan/actual comparison 

Activity/Activity Price Planning 

1-201 CCtr: Activity types/prices, standard 

1-201C CCtrs: Activity types/prices, central planning 

1-202 PP planning: Activity types/prices 

1-203 ATyp: Actual activity price indicator and switch structure 

1-204 CCtr: Activity types/prices, attributes 

1-261 CCtr: Activity price, simplified 

1-262 CCtr: Activity price, centralized 

Manual Actual Prices 

1-N01 CCtr: Manual actual prices, cost centers 

Resource Planning 
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1-1R1 CCtr: Resource planning 

1-4R1 Orders: Resource planning 

1-7R1 WBS elements: Resource planning 

Dependency planning 

1-1R2: CCtr:   Value-based recipe planning 

1-1R3: KoStellen:   Quantity-based recipe planning 

Statistical Key Figure Planning 

1-301 CCtr: Statistical key figures, standard 

1-302 CCtr: Statistical key figures, activity-dependent 

1-3C CCtr: Statistical key figures, central 

1-361 CCtr: Statistical key figures, simplified 

1-362 CCtr: Statistical key figures, centralized 

Internal Orders 

Cost/Revenue Element Planning 

1-401 Orders: Cost elements, standard 

1-402 Orders: Activity inputs, standard 

1-402P: Orders: Process inputs 

1-404 Orders: Primary/secondary order costs 

Cost Planning/Activity Input Planning 

1-461 Cost elements: Simplified layout 

1-462 Cost elements: Simplified layout, central 

Statistical Key Figure Planning 

1-601 Orders: Statistical key figures, standard 

1-603C: Orders: Statistical key figures, central 

1-661 Statistical key figures, simplified 

1-662 Statistical key figures, simplified, central 

Project Cost Controlling 

Cost Element/Activity Input Planning 
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1-701 WBS elements: Cost element planning 

1-702 WBS elements: Activity inputs 

1-702P: WBS elements: Process inputs 

1-703 WBS elements: Revenues, revenue cost elements 

1-704: WBS elements: Primary/secondary order costs 

Statistical Key Figure Planning 

1-901 WBS elements: Statistical key figures, standard - 1-903C WBS elements: Statistical key figures, 

central 

1-C01 Networks: Statistical key figures 
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1-C02 Networks: Statistical key figures 

1-C03C Networks:Statistical key figures, central 

Activity-Based Costing 

Cost Planning/Activity Input Planning 

1-4P Processes: Primary/secondary order costs, processes 

1-2P Processes: Activity-dependent/-independent process inputs 

1-D01 Processes: Cost elements 

1-D02 Processes: Activity inputs 

1-D02P Processes: Process inputs 

Quantities and Prices 

1-E01 Processes: Quantity planning/price planning 

1-E02 Processes: Tax codes 

Statistical Key Figure Planning 

1-F01 Processes: Statistical key figures, standard - 1-F03C Processes: Statistical key figures, 

central 

Manual Actual Prices 

1-Q01 Processes: Manual actual prices, business processes 

Cost Object Accounting 

Cost/Activity Input Planning 

1-G01 Cost object: Primary costs 

1-G02 Cost object: Activity inputs, standard 

1-G02P Cost object: Process inputs 

Statistical Key Figure Planning 

1-I01 Cost objects: Statistical key figures, standard 

1-I03C  Cost objects: Statistical key figures, central 

Real Estate 

Cost element allocation/activity allocation 

1-J01-1 Business entity: Cost elements, standard 
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1-J01-2 Buildings: Cost elements, standard 

1-J01-3 Property:  Cost elements, standard 

1-J01-4 Rental unit: Cost elements, standard 

1-J01-5 Rental agreement: Cost elements, standard 

1-J01-6 Management contract: Cost elements, standard 

1-J02-1 Business entity: Activity inputs, standard 

1-J02-2 Buildings: Activity inputs, standard 

1-J02-3 Property: Activity inputs, standard 

1-J02-4 Rental unit: Activity inputs, standard 

1-J02-5 Rental agreement: Activity inputs, standard 

1-J02-6 Management contract: Activity inputs, standard 

Further notes 

Procedures for Layout Definition 

With some exceptions, defining planning layouts is similar to defining reports with the Report Painter. 

The following is essential information on defining a planning layout. For a detailed description of 

functions, see the SAP Library under Financials -> Controlling -> Cost Center Accounting -> 

Information System -> Define Reports -> Creating Reports with Report Painter, or in the 

Implementation Guide for Cost Center Accounting under Information System -> Own Reports -> 

Create reports . 

A planning layout consists of the following components: 

Header 

Lead and value columns ( elements ) 

Header 

Defining a planning layout begins by entering general selection criteria (Edit -> General selection 

-> Display/Change). These criteria control which characteristics and which characteristic values 

are in the header of the planning layout. 

The General Selections characteristics apply to the whole planning layout. This reduces the 

time required for defining the planning layout and also improves the response times when you 

execute the planning, since the SAP system has to read less data. You have the option of defining 

the characteristics and the lead and value columns as variables. Defining them as variables means 

that these fields are ready for input on the initial screen when you execute the planning. 

In a layout for cost element planning, you would (under general selections) choose the 

characteristics version, period, fiscal year, and cost center. The lead column contains the 
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characteristics activity type and cost element. The value columns contain key figures like e.g. 

Plan costs in object currency and actual costs in object currency. 

In a layout for a quarterly comparison, you would for example choose the characteristics Version 

and Fiscal year as general selections. You would enter the period and the cost center  in the lead 

column or value columns. 

In a further step, you can determine the hierarchical order in which characteristics in the 

general selection criteria are used (Edit -> General selection -> Header). Without header entries, 

the hierarchical order given by the SAP system as a default is retained. 

Lead columns and value columns 

You now define the content of the lead and value columns in the planning layout. The layout of the 

columns and rows is based on the selection of particular characteristics that are preset by SAP. You 

assign an attribute to each characteristic. 

Definition of Lead Columns 

When defining lead columns you have two options: 

Definition of one or more lead columns above the column heading 

Definition of one lead column only above the rows 

Definition of one or more lead columns above the column heading 

Under this type of definition, the system proposes all the possible combinations of characteristic 

values of the lead columns defined for planning. 

You define the first lead column by selecting the column heading, or by placing the cursor on the 

lead column and choosing Edit -> Element -> Define element. By choosing Edit -> Columns -> 

New lead column  you can insert further lead columns. 

Note that the system inserts each new lead column in front of the other lead columns. 

Under this definition method, you can select exactly one characteristic per lead column. 

Example Primary cost planning, 

fast entry 

1st lead column 2nd lead column   1st value column 

Cost center   Cost element Plan costs 

4711 - 4719 400000 - 403000 

420000 - 429000 

The system calculates the rows from the Cartesian product of the values from all lead columns. 
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Defining exactly one lead column above the rows 

In this type of definition you must define every row by double-clicking on the row description. The 

definition of the first row determines whether all rows are defined through a key figure with 

characteristics or just with characteristics. You can choose one or more characteristics per row. 

If, for example, you want a complete overview of all key figures in the planning layout, you define 

the lead columns via key figures with characteristics. 

Rows of element type Characteristics are defined by choosing the characteristics and assigning 

them characteristic values. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 42 

Rows of element type Key figure with characteristics are defined by first choosing exactly one key 

figure from the list of all possible key figures. Afterwards, you decide on the characteristics and 

characteristic values. 

The procedure is similar to that for defining value columns. 

Example 

Quarterly planning in several versions 

1st lead column 1st value column 

Version/Quarter Plan costs 

Version1/Quarter1 

Version2/Quarter1 

Version1/Quarter2 

Version2/Quarter2   

... 

Note on cost element planning 

If you wish to plan activity-dependent and activity-independent costs together in a planning layout, you 

must enter initial for the characteristic activity type. 

The Initial value is set: 

In layout maintenance by entering "#" as the characteristic value 

In the group maintenance dialog window Maintain values... by choosing the Set initial value function 

On the initial screen for planning by entering "*" in the From field if you assigned a group variable for 

the activity type. The system selects all characteristic values for the Activity type field, including 

the initial value. 

Definition of Value Columns 

To define the first value column, select the column heading. Define other value columns by selecting the 

empty space next to the first value column. 

You may also select the corresponding column and choose Define element. 

You can also hide rows and columns from later display. This is useful for those elements necessary for 

calculations but not necessary for report displays. 

You have several options for defining value columns: 

Define column with either a key figure with characteristics or just characteristics 

Define formula column 

Define attribute column 

Define Column with Either a Key Figure with Characteristics or Just Characteristics 

To define a value column, select the column heading. 
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The definition of the first value column determines whether all rows are defined by a key figure 

with characteristics or just with characteristics. 

If you defined lead columns with rows using key figures with characteristics, you can define value 

columns only with characteristics. 

If you defined lead columns with characteristics or through the column header, you can define value 

columns only with characteristics. 

The procedure is similar to that for defining lead columns with rows. 

Define Formula Column 

A formula column is a value column made up of values from previously defined columns. When 

defining a formula, the SAP system provides you with a selection of value columns in a dialog 

box. The system calculates the values for these columns once the value columns used in the 

formula contain values. In the dialog window, choose the element type Formula. 

In the following screen you can create a formula using previously defined value columns with the 

aid of the formula components found in the screen. 

Example 

Planning layout with formula column as 3d value column 

Lead column Value column 1 Value column 2 Formula column 

Cost element Plan curr. year Plan prev. year Variance 

Curr. year 

Prev. year 

Indirect Formulas 

Indirect formulas allow you to enter values in formula columns during planning that the R/3 System 

uses to determine values in another layout column. 

To define indirect formulas: 

Define the planning layout with the desired formula column and save. 

Set the indicator for the column to "Not ready for entry". 

To do so, select the column in question and choose Format -> Entry ready on/off. 

Set the formula column to "Entry ready" in the same manner. 

Generate the indirect formula by choosing Extras -> All indirect formulas -> Generate formulas. 

The SAP system determines the values for the non-entry ready column. 

Example 
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You plan a wage increase for employees as a percentage surcharge. The SAP system should 

determine the plan value of the current year from the surcharge and the plan value of the previous 

year. 1. Planning Layout 

Define the following layout: 

Key ColumnValue Col. 1 Value Col. 2 Formula Column 

CElm Plan Cur. Year Plan Pre. Year % Raise 

((Plan cur. year - 

Plan pre. year) 

/Plan pre. year) 

X 0 

Indicate the column "Plan Cur. Year" as not ready for input , the column "% Raise" as ready for 

input. 

Afterwards, generate the reverse formula. 

2. Planning ( Example ) 

If, before manual planning starts, the previous year plan values are copied to the current year (via 

Planning -> Planning aids -> Copy planning), the new plan costs can be calculated then by 

entering the percentage raise. 

After copying planning: 

CElm Plan Cur. Year Plan Pre. Year % Raise 

430000 50,00050,000 

After calculating the new plan costs: 

CElm Plan Cur. Year Plan Pre. Year % Raise 

430000 55,00050,000 

Define Attribute Column 

When defining an attribute column, you have two options, depending on the attributes used: 

Attribute columns with direct reference to a value column 

Attribute columns with no direct reference to a value column 

Attribute columns with direct reference to a value column 

You set the Unit, Distribution key and Action attributes in conjunction with a value column. 
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You have options for definition: 

Select a previously defined value column and choose Edit -> Columns -> Attach add. fields. This 

inserts selected attribute columns into the planning layout. 

This method establishes a direct reference between the attribute column and the value column. 

If you wish to change characteristics and characteristic values for the value column, the SAP 

system confirms whether the dependent attributes are to be changed and, if so, adjusts the 

attribute column accordingly. 

You can also define characteristic and characteristic values in the attribute column 

independently of the value column. 

Select the free field next to an existing value column and choose the element type Attribute from the 

dialog window. 

The attribute column so defined has no direct connection to a value column. Changes in the 

characteristic values of value columns have no further effects on the attribute column. 

Attribute columns with no direct reference to a value column 

Define other attributes by selecting the free field beside an existing value column, or by choosing 

Define element. 

Having selected the element type Attribute, the system provides you with a list of possible 

attributes, from which you can select one attribute. 

There are two kinds of attribute - display attributes and those that can be maintained during the 

planning process. 

Attributes for all planning areas 

- Unit, maintainable with restrictions 

Depending on the attribute of the corresponding value column, the SAP system displays either 

the currency unit or the quantity unit. 

Example 

Key figure Plan activity 

Unit: Activity unit from the activity unit master record 

The following units exist: 

Consumption unit in cost element planning, maintainable with restrictions. The consumption 

unit is useful in the activity-dependent and activity- independent planning of both primary and 

secondary costs (without sender reference) and in revenue planning.The SAP system takes the 

value from the cost element master record as the default value. In planning at cost center/cost 

element level, you can overwrite the consumption unit, provided no dependent data exists. 

Activity unit in activity input planning, display attribute. 

The system automatically uses the activity unit belonging to the sender activity type. 

Currency units in cost element planning, display attribute. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 46 

The controlling area, object, and transaction currency are useful where you plan with foreign 

currencies or the object currency differs from the controlling area currency. The different 

currencies cannot be displayed unless you have activated the All currencies indicator in your 

controlling area. Only if you have done this does the system update all currencies. 

Activity unit in activity type planning, display attribute. 

For the key figures plan activity, capacity and scheduled activity the SAP system 

automatically uses the activity unit entered in the activity type master record. 

Output unit in activity type planning, maintainable with restrictions. For the key 

figure plan output you can maintain the output unit at cost center/activity 

type/fiscal year level, provided no dependent data exists. 

Currency units for prices, display attribute. 

Controlling area, object, and transaction currency are especially useful if you plan with 

foreign currency or the object currency differs from the controlling area currency. To be able 

to display the different currencies, you must have activated the All currencies indicator in 

your controlling area, since only then does the system update all currencies. 

Units in statistical key figure planning, display attribute. The SAP system automatically uses 

the unit entered in the key figure master record as the unit for statistical key figures in 

planning. 

- Distribution key, maintainable. 

The SAP System stores plan data per period. If, when planning, you enter an annual value on 

the overview screen, the SAP system distributes this value to the individual periods 

according to a rule that is stored in the distribution key. The standard system includes fixed 

non-changeable distribution keys ( standard distribution keys). 

If you want to use a particular season distribution, you can also define any number of 

individual distribution keys. 

You can define distribution keys per key figure. 

Example 

Fixed plan costs + distribution key for plan costs ( fixed ) Variable plan 

costs + distribution key for plan costs ( variable ). 

Action, maintainable. 

The action determines how the SAP system is to process the values entered. You can add, 

subtract, or replace the entry value for the existing value. 

Caution 

You can define the action per plan record only, and not per key figure. 

Long text exists, display attribute. 

This indicator tells the user that a long text exists for the planning item. This text may be an 

explanation, or a description of the origin of the plan data. 
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Attributes for cost element planning -

 Transaction, display attribute. 

This indicator shows the business transaction under which the corresponding plan record is 

stored. 

It has two further important functions: 

Document number assignment control 

Lock option per version, fiscal year, and transaction 

Exchange rate type, display attribute. 

If you plan in foreign currencies, you can use the exchange rate type to follow the currency 

translation. The type is determined per version and fiscal year. 

Value date, display attribute. 

If you plan in foreign currencies, you can use the value date to follow the currency translation. 

The date with which the exchange rates are read depends on the contents of the Value date 

field: 

If it is not filled in version maintenance, calculation takes place by period. Each period's 

starting date is used to calculate its own rate, to take possible rate swings within a fiscal year 

into account. 

If a value date is entered, all periods are processed with the same exchange rate calculated with 

this date. 

Record quantites, maintainable. 

This indicator shows whether consumption quantities are recorded on the cost center. 

Cost element attributes, display attribute. 

A cost element can be characterized independently of the account framework by entereing a 

maximum of eight attributes. The attributes can be drawn upon within reporting for use in 

evaluations. 

In addition, they have no access to control information. 

An indicator is assigned for each attribute. A cost element can be given the following as 

indicators: D  for service costs 

W  for costs affecting payment 

The attribute indicators and their valid combinations are maintained in customizing for 

Cost Center Accounting under Cost 

Element Attributes and Attribute 

Mix. 

A valid combination of the permitted attributes can be defined as follows: 

In the cost element's master data record 

Within cost center planning for the combination cost center/ activity type and varying from the 

entry in the cost element master data record. 

Note that you must always specify one of the attributes valid for the first item 
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Detailed planning exists 

The calculation number is the internal number under which detailed planning is stored. 

Value calculation type, maintainable. 

This displays whether plan values are entered manually (1) or through detailed planning (4). 

Since the indicator is maintainable within planning, further manual editing of plan records 

entered via detailed planning is possible. In this case, change the indicator "Value calculation 

type" accordingly. 

Allocation cost element, display attribute. 

Allocation cost elements are used exclusively in activity input planning as attributes. Because 

the cost element characteristic is optional for activity input planning, it can be left out of a 

planning layout for secondary cost planning. By inserting the attribute of the same name, you 

can nevertheless display the allocation cost element. 

Cost element type, display attribute. 

The cost element type determines for which transactions a cost element may be used. 

The following types are differentiated: 

   Primary cost elements Type 01 

   Secondary cost elements Type 21, 41, 43 

   Revenue elements Type 11, 12 

Dependency type, maintainable. 

The dependency type is available only in value-based or quantity-based dependency planning. 

Dependency source type, display attribute 

The system sets the dependency source type according to the dependency type. 

Attributes for activity type planning 

Along with the attributes for unit, distribution key, action type, long text available, 

transaction, exchange rate type, value date, and cost element attribute, the following 

attributes are available in activity type planning: Two transactions are differentiated here, 

those for: 

Manual and non-allocatable activities 

Automatically allocatable activitites 

The transaction results from the activity type category. 

Production factor, maintainable. 

The production factor gives the relationship of activity quantity to output quantity by means of 

the following formula: 

    Output quantity = Activity quantity x Output factor 

In planning, the output quantity can be calculated with the formula using the function 

Calculate output. 
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You may select individual or groups of planning lines for use and begin the calculation. 

Allocation cost element, maintainable with limitations. 

The SAP system automatically uses the allocation cost element from the activity type master 

record as a default value in planning. You can overwrite the default as long as no debit and 

credit records have been posted for the allocation cost element. 

Activity type category, maintainable with restrictions. 

You can maintain the category in the activity type master data record as well as in planning on 

the cost center/activity type/version/fiscal year level. The category serves as a default setting 

for planning. You can switch between the allocatable activity type categories (1, 2, 3) as long 

as no debit and credit records have been posted. 

Actual activity type category, maintainable. 

You can determine a category deviating from plan categories for actual allocations. If no 

actual activity type category is maintained, the SAP system automatically uses the plan 

activity type category. A variant actual category is useful for a planning layout when, for 

example, the plan values must be indirectly calculated due to missing results (such as from 

the power plant), but where the actual values were registered. 

Activity price indicator, maintainable. 

The indicator contains the calculation basis for the plan activity price of a cost center's activity 

type. 

The activity price indicator can take the following values: 

001: 

The activity type's activity price is automatically calculated on the basis of plan activity 

for the cost center to be planned. Fixed activity price: Fixed plan costs / Plan activity 

Variable activity price:Variable plan costs / Plan activity Total activity price:

 Fixed activity price + Variable activity price 

002: 

The activity type's activity price is automatically calculated on the basis of the capacity of the 

cost center to be planned. The capacity serves only for fixed costs as a basis for activity price 

calculation. This is relevant for cost centers that must continually be prepared for maximum 

activity quantity output, such as costs for supplying energy from a power plant. The total 

costs are fixed. Fixed activity price: Fixed plan costs / Capacity 

Variable activity price:Variable plan costs / Plan activity 

Total activity price: Fixed activity price + Variable activity price 

Note 

If you set values 001 or 002, you must carry out plan activity price calculation. 

003: 

The activity type's activity price is set manually. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 50 

If you activate the indicator "ItAcPr" (purely iterative activity price) in the version, the system 

calculates a purely iterative activity price along with the activity price resulting from planning. 

- Actual activity price indicator, maintainable. 

This indicator shows how the activity price's actual activity price for a cost center is calculated. 

If you do not maintain this indicator, the system automatically uses the plan activity price 

indicator value. 

The activity price indicator can take the following values: 

005: 

The actual activity price is calculated by the system on the basis of actual activity. 

If you set this value, you must carry out actual activity price calculation. Indicators 005 and 

006 are useful in planning only if you set revaluation of actual activity with actual activity 

prices in the version. 

006: 

The actual activity price is calculated by the system on the basis of capacity. Cost center 

capacity serves only for fixed costs as a basis for activity price calculation. This is relevant for 

cost centers that must continually be prepared to supply the maximum activity quantity output, 

such as costs for supplying energy from a power plant. The total costs are fixed. 

If you want to execute activity price calculation, you must determine the actual activity price 

indicator. In planning layouts for activity type planning, you must set the attribute for this 

situation. 

- Average activity price, maintainable. 

This indicator ensures that cost center/activity type activity prices remain constant for the 

entire fiscal year. 

This determination takes place on two levels: 

Version/fiscal year 

For a version, all cost center/activity type activity prices in a fiscal year are held constant. 

During activity price calculation, only plan total costs and total activity for the timeframe are 

used. Monthly swings are ignored. 

Cost center/activity type/version/fiscal year 

If no average activity price is determined for the version, individual cost centers/activity types 

may be assigned a constant allocation activity price for a fiscal year. Activity price calculation 

averages the price swings for this cost center/activity type. Insert the corresponding attribute in 

the activity type planning layout and maintain the indicator in activity type planning. 

Switching layout, maintainable. 

Within price calculation with cost component split, the switching layout is used to change the 

cost component assignment. 

In activity price calculation, cost component splitting utilizes a cost component structure, in 

which is defined which cost elements are steered to which components. You define the layout 

during version maintenance, and per fiscal year. For allocations between cost centers, this cost 

component layering is usually retained. There are, however, cases in which the sender 

components are not to be retained, but where the allocation is to other receiver components. 

Here is where the switching layout is used. The layout stores which sender components are 
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allocated to which receiver components. You determine the switching layout in activity type 

planning for the sender, but it must have been defined in Customizing first. 

Fixed cost predistribution, maintainable. 

If you carry out standard costing on a marginal costing basis, the fixed costs are not distributed 

to the cost objects in proportion to the operating rate. In this case, you must work with fixed 

cost predistribution in order to credit fixed costs to the cost centers accepting activity inputs. 

You can overwrite the default value in the indicator Fixed cost predistribution, which 

controls whether the fixed costs (that is, the activity-independent preparation costs) are 

distributed to the cost centers or not. 

Attributes for statistical key figure planning 

In addition to the attributes unit, distribution key, action type, and long text available, the following 

attributes are available for statistical key figure planning: 

Variant, display attribute 

Key figure type, display attribute. 

This indicator controls the entry and updating of statistical key figures. It can take the 

following values: 

Fixed value 

The key figure values are valid as of the period entered for all following periods in the fiscal 

year. Average values are planned. 

Total value 

The key figure values are not carried over from the period entered to the following periods. 

You can enter new plan values for each period. 

Variant, display attribute 

Origin, display attribute 

Key figure, display attribute 

These attributes are useful in the planning layout when you transfer key figures from the 

Logistics Information System ( LIS ). 

Afterwards, you determine characteristics and characteristic values for the attribute columns. 

Characteristics and characteristic values 

When defining headers, lead columns, and value columns, you must enter one or more characteristics. 

Characteristics are predefined by the SAP system for the corresponding planning area. 

Characteristics 
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The following section is a list of the possible characteristics. 

These are divided into optional and required characteristics. 

Version 

Enter one or more individual values or one or more intervals. 

Planning period 

Enter an individual value or an interval. 

Fiscal year 

Enter one or more individual values or one or more intervals. 

Cost center 

Enter one or more individual values, one or more intervals, or one or more cost center groups. 

Version, planning period, fiscal year, and cost center are required characteristics in all planning 

areas. 

Activity type: Required characteristic for activity type planning, optional characteristic for cost 

element and statistical key figure planning 

Enter either one or more individual values, several intervals, or one activity type group. The 

following transactions do not require the characteristic: 

Primary cost planning, activity-independent 

Activity input planning, activity-independent 

Revenue planning 

Settlement cost planning, activity-independent 

Secondary order cost planning, activity-independent 

Cost element: Relevant only for cost element planning, where it is an optional characteristic which 

can be ignored if plan records only are entered for activity inputs in the affected planning 

layout. 

There the cost element is the sender allocation cost element. 

In primary cost planning the cost element is a required characteristic. 

Enter one or more individual values, one or more intervals, or a cost element group. 

Resource 

This is important for resource planning, where it is a required characteristic. Resource planning is 

primary cost planning on a quantity basis. You can valuate planned consumption quantities and 

determine resulting costs. Resource planning can thus sub-divide cost element planning. You can 

plan on orders and WBS structures. You cannot use resources in the Actual. Use Define resources to 

maintain resources. Enter one or more single values or intervals. 

Sender cost center: Relevant only for cost element planning, where it is an optional characteristic 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 53 

The characteristic can be ignored if you do not wish to plan activity inputs with the relevant layout. 

For the following transactions, you do not require the characteristic: 

Primary cost planning, activity-independent and activity-dependent 

Revenue planning 

Settlement cost planning, activity-independent and activity- dependent without sender reference 

Planning credits as surcharges 

Enter one or more individual values, one or more intervals, or a cost center group. 

Sender activity type: Relevant only for cost element planning, where it is an optional characteristic 

The characteristic can be left aside if you do not wish to plan activity inputs with the relevant layout. 

For the following transactions, you do not require the characteristic: 

Primary cost planning, activity-independent and activity-dependent 

Revenue planning 

Settlement cost planning, activity-independent and activity- dependent without sender reference 

Planning credits as surcharges 

Enter one or more single values, one or more intervals, or an activity type group. 

The characteristics sender cost center and sender activity type are only useful in tandem. 

Transaction currency: Relevant only for cost element planning, where it is an optional characteristic. 

Enter one or more individual values or one or more intervals. 

If you do not select the characteristic, the controlling area currency will be set for the field. 

Note 

If you define a value column in your planning layout for cost element planning via the key figures 

"Total actual costs in controlling area currency" or "Total actual costs in object currency", you must 

include the transaction currency as an additional characteristic in the key columns if actual cost 

postings use a transaction currency which is not the same as the controlling area currency. 

Statistical key figure: Required characteristic for statistical key figure planning Enter one or more 

single values, one or more intervals, or an activity type group. 

After specifying the characteristic, you must determine the characteristic value controlling the data 

selection. 

Characteristic Values 

When defining characteristic values, you have the following options: 

Entry of fixed characteristic values 

You set characteristic values for each element to be used as selection criteria by the SAP system to 

generate the planning screen. 
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You can specify a single value, an interval, or a group of values. By choosing More you can enter 

more than one single value or interval. 

Characteristic value parameterization 

You can also use varaibles for the characteristic values. 

Variables enable flexible shaping of the planning layout. The content is determined only after 

planning is executed. 

Note that the system distinguishes between local and global variables, but that you may only use 

local variables for the planning layout. 

Local variables are not permanently in the system, but are valid only in the affected planning layout. 

They may be used more than once the layout. 

Example: 

You create a layout with the following three value columns: 

Column 1: Version, Variable 1 Fis.Y, 1996 

Column 2: Version, Variable 1 Fis.Y, 1995 

Column 3: Version, Variable 2 Fis.Y, 1995 

Local variable 1 is used twice, variable 2 only once. 

You enter a variable for the characteristic value by choosing Indicator for entering variables 

(variables on/off) on the screen Define Element. 

The system changes the size of the input field and marks the field. The local 

variable designation can be set as desired. 

Additionally, you can also parameterize texts under Edit -> Element -> Change text (text 

variable). On the screen Enter Text, enter a local variable beginning with special character "$". 

According to your setting per text variable, the SAP system determines the text automatically from 

the selection of the assigned characteristics. 

If you set characteristic values as variables, the user will be asked during planning callup to replace 

the variables with values. 

Notes 

Calculated variables 

Variables based on numerical fields may be changed with additive operations. The variable is 

extended with a "+" or "-" and a number (no more than two places). In a formula, for example, 

variable "A" is used in a fiscal year column. The second column should display the previous year. 

Parameter "A-1" is thus maintained as the fiscal year characteristic. In the planning transactions, the 

fiscal year variable "A" is called up as a control date, and the previous year is calculated 

automatically. 

Mandatory/optional variables 

For variables in optional characteristics, you have the choice between 

Replacement through mandatory entry 

Replacement through optional entry 
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Use the menu path Extras -> Variables -> Define variable. Choose a variable for an optional 

characteristic and you thereby replace the default Mandatory  with Optional. 

Example 

You set  Activity type as the optional characteristic in the planning layout Cost elements/Activity 

inputs and activate the Optional setting. On the initial planning screen, you have the option of 

selecting activity-dependent and activity-independent planning. Only when you fill the field Activity 

type on the initial screen will activity-dependent planning be executed. 

3. Names/key values of variables 

To give each variable a name, use Extras -> Variables -> Define variables -> Name and use the 

name when prompted in the initial planning screen. 

Examples 

You use 2 versions for an optimistic/pessimistic planning comparison. Using the naming function 

identifies the variables in the different versions. 

You define a period interval. To distinguish between the "From" period and the "To" period on the 

initial planning screen, save the appropriate names for the variables. 

For more information about variables, see the SAP Library under Cross-Application Components -> 

CA - Drilldown Reporting -> Reports -> Variables -> Variables for Characteristic Values, 
Variables for Texts, or Variables for Formulas. 

 Maintain Planning Layouts for Business Processes - Cost 

Planning 

To be able to plan for cost elements, you first need to define the planning layout. In the planning layout, 

you specify the format of the planning screens. 

Requirements 

In the standard SAP System, planning layouts are found only in client 000. To use them as models for 

user-defined planning layouts, they must be taken from client 000 and imported to your production client. 

Use the IMG General Controlling under the section Prepare Production Startup -> Transport 

System Settings -> Transport Planning Settings -> Import Standard Planning Layouts. 

Recommendation 

After installing a new release or update, you should repeat the import of standard planning layouts from 

client 000 in order to access the latest layouts. 

Activities 
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Create planning layouts for cost element planning 

based on your requirements. 

Change an existing planning layout. Further 

notes 

Procedure for Creating Planning Layouts 

Notes on transport 

For the transport of planning layouts, an individual function is available in Customizing under 

Controlling -> General Controlling -> Production Startup Preparation -> Transport System 

Settings -> Transport System Settings -> Transport Planning Layouts. 

  

 Maintain Planning Layouts for Business Processes - 

Quantities/Prices 

In this IMG activity you define or change planning layouts for quantities and prices for business 

processes. 

Requirements 

In the standard SAP System, planning layouts are found only in client 000. To use them as models for 

user-defined planning layouts, they must be taken from client 000 and imported to your production client. 

Use the IMG General Controlling under the section Prepare Production Startup -> Transport 

System Settings -> Transport Planning Settings -> Import Standard Planning Layouts. 

Recommendation 

After installing a new release or update, you should repeat the import of standard planning layouts from 

client 000 in order to access the latest layouts. 

Activities 

Based on your requirements, create planning layouts for planning quantities and processes for your 

business processes. 

Change an existing planning layout if necessary. 

Further notes 

Procedure for Creating Planning Layouts  

Note on transport 

To transport planning layouts, see the transport function in the IMG activity under "Controlling: 

General". 
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 Maintain Planning Layouts for Business Processes - Statistical Key Figures 

To be able to plan statistical key figures, you first need to define planning layouts for planning statistical 

key figures. You specify the layout of the planning screens in these planning layouts. 

Requirements 

In the standard SAP System, planning layouts are found only in client 000. To use them as models for 

user-defined planning layouts, they must be taken from client 000 and imported to your production client. 

Use the IMG General Controlling under the section Prepare Production Startup -> Transport 

System Settings -> Transport Planning Settings -> Import Standard Planning Layouts. 

Recommendation 

After installing a new release or update, you should repeat the import of standard planning layouts from 

client 000 in order to access the latest layouts. 

Activities 

Create planning layouts according to your requirements 

for the planning of statistical key figures. 

Change an existing planning layout. Additional 

Notes 

Procedure for Creating Planning Layouts 

Note on transport 

For the transport of planning layouts, an separate function is available in Customizing for Controlling -> 

General Controlling -> Production Start-Up Preparation -> Transport System Settings -> 

Transport Settings for Planning -> Transport Planning Layouts. 

 Maintain User-Defined Planner Profiles 

You use planner profiles to control the way planning is carried out. In a planner profile, you specify per 

planning area which planning layout is to be used with which default values. Per planning area, you can 

create as many planning layouts as you require. The profile item determines the order of the planning 

layouts within a planning area and can be used to assign the same planning layout to a planner profile in 

multiple areas, but with a different default setting each time. 

Planner profiles are hierarchically structured as follows: 

Planner Profile 

General Controlling 

Layouts Controlling 
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Default Parameters 

Planner Profile 

You can assign an  authorization group to every standard profile and every planner profile that you 

create in the Profile planning overview. 

The combination of authorization groups and locked default settings (see Default layout) results in 

highly detailed authorization assignments for entering planning data. All the planner profiles in the 

system are defaulted. This is regardless of the component in which you wish to call up planner 

profile processing. This enables you to define allowed entries of planner profiles from other 

components, for each component chosen. 

General Controlling 

For each planner profile, the system recommends different planning areas, depending on the 

application component. You can create additional planning areas. 

In CuDK you can enter a default value for a distribution key for currency amounts. 

In QtDK you can enter a default value for a distribution key for quantities. The system uses these 

default values for combinations that have not yet been planned, even if you have not selected a 

distribution key in the definition of the planning layout. 

Layout Controlling 

In each planning area, you determine which planning layouts appear in which sequence. For each 

planning area, you must define at least one profile item and assign a planning layout. 

The Deflt indicator shows whether settings already exist (see: Default settings layout). If you 

deactivate the Over. (=Default settings not protected) indicator, the user must use the entries given 

in planning and may use only the defaulted variables. If the indicator is active, the entries are default 

values which can be overwritten when entering planning. The Excel integration indicator gives you 

the option of entering planning data in an Excel worksheet. If the indicator is active, you can use 

Excel to make your entries. The file description influences the layout of the worksheet. If you move 

the planning data (that you entered in the system) within the worksheet, the file description creates 

the link between the old data and the new location. 

You can also find further information on preparation for planning with Excel in the SAP 

Library under Financials -> CO Controlling -> Cost Center Accounting -> Cost Center 

Planning -> Manual Planning -> Techniques for Supporting Manual Planning -> Integrated 

Excel in Planning. 

- Default parameters 

You can enter default parameters for the selection of planning data of each item in the assigned 

planning layout. 

All variables defined in a layout are referenced during planning as parameters, which you can set 

with values per profile item. 

If you undertake decentralized planning in your organization, the planner profiles assist the organizational 

aspects of the planning process. You can assign particular user groups to profiles in which objects have 

already been preset and precisely delimited. 

Example 

You set general selection criteria (fiscal year, version, periods and transaction currency) in your planning 

layout PRIMARY. 
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From an organizational perspective, it was decided that the cost center managers decentrally plan the 

material expenses first, followed by the personnel expenses. 

In the Planning profile overview create the planning profile "PLAN01". 

Choose the planning profile "PLAN01" and CO General Settings. 

Choose the planning area "Cost centers: Cost elements/acty inputs" and Layouts CO general. 

Enter the planning layout "PRIMARY" with both item number 0 and item number 020. 

Choose the item "0" and Default parameters and enter the cost element group for material expenses. 

Choose the item "020" and Default parameters and enter the cost element group for personnel expenses. 

Also assign the cost center managers in the user parameters to planner profile PLAN01 via the parameter 

ID "PPP". To do so, choose System -> User profile -> User parameters. 

When the cost center manager calls up planning by choosing "Planning -> CElems/Actvty input -> 

Change", the system suggests profile PLAN01 and branches to planning layout PRIMARY with the plan 

costs for material expenses. The cost center manager can now enter the plan data and, after it is saved, 

can go to other planning by choosing Next layout. 

Requirements 

To create entire planner profiles, the planning layouts used must be available. Complete the IMG activity 

Create Planning Layout. 

Standard settings 

The standard system includes several defined planner profiles. The names of the profiles begin with SAP. 

These are protected, meaning you cannot create custom profiles beginning with "SAP". 

Note 

Note that as of Release 4A, the planner profile SAP1, SAP2, SAP3, and SAP4 and the planning layouts 1-

1 to 1-4 contained in these profiles are no longer maintained by SAP. 

Activities 

To assign planner profiles to authorization groups, create the necessary groups in the IMG activity 

Create Custom Authorization Groups. You can use the authorization groups to control which users 

have access to which planner profiles. Assign authorizations with the authorization object "CO: Planner 

Profiles" ( K_TKA 50). 

To create planner profiles, proceed as follows 

CO Planner Profile Overview 

To create a new planner profile, choose New entries. 

To copy an existing profile, select a reference and choose Edit -> Copy as. 
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Enter a name and explanatory short text for the object. 

If necessary, assign an authorization group to the planner profile. 

General Controlling 

Select the suggested planning area for which you want to make settings and choose Settings for 

General Controlling. 

To create a new planning area, choose New entries. 

Layouts for Controlling 

Select a planning area for which you want to make settings and choose Layouts for General 

Controlling. 

Choose New entries and enter an item and previously defined layout. 

Activate the indicator Default settings not protected if users may overwrite the defaulted 

variables. 

Activate Excel integration if you want to enter your planning data in an excel worksheet. 

Enter a name for the file description. 

If you do not enter a name, the system automatically assigns a name when you save the file. 

Save your entries and return to the layout overview screen. 

Layout Default Settings 

Select a planning area for which you want to make settings and choose Layout Controlling. 

Set the parameters of the defined variables per profile item for the planning layout. 

Notes 

To define the excel worksheet, at least one row must exist on the screen. For this reason, you 

need to enter example data as dummy data in the SAP System using the planning layout. 

To be able to plan directly using the corresponding planning layout, you may need to reset any 

planner profile that has been set under Planning -> Set planner profile. 

Optional steps: 

Authorizations 

In the IMG activity Authorization Management, set authorizations as required for object 

K_TKA50 and assign the authorizations to the authorization profiles of the appropriate users. 

User parameters 

Assign parameter ID PPP to the users who are to work with the profile in the user parameters 

(choose System -> User profile -> User parameters). 

Deleting planner profiles 

When you delete a planner profile, the system checks whether the profile is also used in other 

components. If it is, you first need to delete the dependent entries for the planner profile in all 

components, before you can delete the planner profile itself. 

Note on transport 
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To transport planner profiles, see the General Controlling Customizing -> Production 

Start-Up Preparation -> System Configuration Transport -> Planning Configuration Transport -> 
Transport Other Planning Configurations. You can use this function to transport the complete set of 

planner profiles from a test to a productive client. 

Planner profile maintenance is connected to the automatic recording of transport data. 

This also includes the settings for integrated Excel. The system includes file descriptions and Excel sheet 

templates in the transport request, provided you have created them in Customizing. 

The system also transports the settings for integrated Excel if you have manually included a planner 

profile in - or manually deleted a planner profile from - a transport request (you do both by choosing 

Table View -> Transport). 

Warning 

When performing the transport, ensure that you have not manually created any integrated Excel settings 

in the target system. 

Only supply the target system by means of transports, otherwise inconsistencies could arise. When 

importing the Excel sheet templates from the source system, the system does not overwrite the 

settings already made in the target system. 

If, however, planner profiles with corresponding Excel sheet templates already exist in the target system, 

you have to delete them before performing any imports. In planner profile maintenance, you can 

delete these Excel sheet templates for specific planner profiles or profile items. 

Further notes 

You can find more information on planner profiles in the SAP Library under Financials -> 

CO Controlling -> Cost Center Accounting -> Cost Center Planning -> Manual Planning -> 
Planning Techniques -> Planning Screen Layout -> Planner Profiles. 

 Maintain User-Defined Distribution Keys 

You use distribution keys to both simplify and speed up the entry of monthly plan values. The following 

options are available for defining your own distribution keys: 

Distribution keys that refer to a standard distribution key (1, 2, 3, 4, 5, 6, 7). 

Note 

The system also saves distribution keys in the object currency. 

You can also change the distribution key during the runtime. 

Note 

You define a distribution key in which you save the number of shifts (relative factor) per month (period). 

In cost center planning you enter the annual plan activity and combine this with your distribution key. 
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Five workers work seven hours per shift. Multipling 35 hours per shift with 680, the maximum number of 

shifts per year, results in annual plan activity of 23,800 hours. 

The following table shows the distribution of activity according to the distribution key used. 

   ------------------------------------------------------------------ 

   |                 Plan Activity: 23,800 hours                    | 

   ----------------------------------------------------------------- 

   | Period  | Relative Factor  | Calculation       | Plan Activity | 

   ------------------------------------------------------------------ 

   |    1    |        40        | 23,800 : 680 X 40 =    1,400      | 

   |    2    |        40        | 23,000 : 680 X 40 =    1,400      | 

   |    3    |        40        | 23,800 : 680 X 40 =    1,400      | 

   |    4    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |    5    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |    6    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    7    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    8    |        80        | 23,800 : 680 X 80 =    2,800      | 

   |    9    |        60        | 23,800 : 680 X 60 =    2,0      | 

   |       |        60        | 23,800 : 680 X 60 =    2,0      | 

   |   11    |        40        | 23,800 : 680 X 40 =    1,400      | 

   |   12    |        40        | 23,800 : 680 X 40 =    1,400      | 

   ----------------------------------------------------------------- 

   |         |       680        |                   |   23,800     | 

   ----------------------------------------------------------------- 

Standard settings 

The standard SAP System includes unchangeable default distribution keys. 

Distribution key 0 

Enter the values manually for each period. 

Distribution key 1 

Given plan value is distributed equally to the plan periods. 

Distribution key 2 

Given plan value is distributed according to the previous distribution. 

Distribution key 3 

The value entered is interpreted as a percentage and applied to the previous values. 

Distribution key 4 

The periods containing a value not equal to zero are distributed to the following empty periods. 

Distribution key 5 
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The periods containing a value not equal to zero are copied to the following periods. 

Distribution key 6 

The period value entered is copied to the following period 

Distribution key 7 

The total value is distributed to the periods according to the number of calendar days in each period. 

Distribution key 11 

Used only in the Cost Center Controlling component for activity-dependent cost planning or 

activity-dependent statistical key figure planning. 

The given value is distributed based on the plan activity quantity of a cost center. The system uses 

the activity quantities planned at the time you create the distribution key. If you change activity 

quantities afterwards and copy the plan values to another version, the system does not create a new 

distribution automatically. 

Recommendation 

If the SAP standard keys do not meet your requirements completely, but you want to use certains parts of 

them, you should copy the distribution key and save it as your own key after making changes to it. 

Position the cursor on the standard distribution key you want to use and choose Copy using the context 

menu. 

Enter a new name for your own distribution key. 

Maintain and save your settings. 

Activities 

If necessary, define distribution keys that meet your requirements. 

Place the cursor on 

Referenced, if you want to refer to one of the standard distribution keys (except 11). 

Independent, if you want to create a new distribution key. 

Choose Create or Change using the context menu. 

Assign a key and a description for the new distribution key. 

Maintain the number of posting periods and a relative distribution factor. The system distributes the input 

value to the individual posting periods according to the relative distribution factor. 

Via Suppress zero factor, you can suppress posting periods to which you have assigned a relative 

distribution factor "0". You can display these posting periods again by choosing Display zero 

factor. 

If you subsequently want to set a relative distribution factor in a period to "0", you can recalculate 

the factors of the remaining periods by choosing Calculation. 

You can compare the original version of the distribution key with the new one by choosing 

Compare. 
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Notes on transport 

To transport distribution keys, a separate function is available in Customizing under  

Controlling -> General Controlling -> Production Start-Up Preparation -> Transport System 
Settings -> Transport Settings for Planning -> Transport Other Planning Settings. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost Center 

Accounting -> Cost Center Planning -> Manual Planning -> Techniques for Supporting Manual 
Planning -> Distribution Keys. 

 Actual Postings 

In this IMG activity you define periodic actual allocations in the Activity-Based Costing component ( 

CO-OM-ABC ). 

 Manual Actual Postings 

In this IMG activity you make settings for manual actual postings. 

 Define Own Screen Variants for Postings in Controlling 

You use screen variants to define the layout of the screen on which you make one of the 
following postings: 

Manual reposting of costs 

Manual reposting of revenues 

Activity allocation 

Manual cost allocation 

Statistical key figures 

A screen variant consists of variants for the individual transactions in manual actual postings (reposting 

costs or activity allocation for example). 

Note: 

Authorization object K_PVARIANT controls whether the screen variants can be accessed. 
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Example 

Requirements 

Check the settings in activity Maintain Controlling Area to check that cost accounting for the objects 

that you want to include in the screen variant is active in the relevant fiscal year. Examples of these 

objects include: 

Cost centers 

Order management 

Projects 

Cost objects 

Sales and distribution documents 

Standard settings 

SAP supplies a wide variety of screen variants for the postings mentioned above. 

Note 

You cannot make changes to the standard system. If, however you need to make only minor changes, you 

should copy the standard delivery and adjust the copy to meet your requirements. 

Recommendation 

Activities 

The screen variants supplied by SAP are displayed on the initial screen. 

To create your own screen variants, proceed as follows: 

Creating screen variants 

Determine what postings you want to make. 

Choose New entries. 

Enter a key and an explanatory text for the screen variant. 

Save your entries. 

Assigning variants for individual transactions 

Select a screen variant and, in the navigation tree, double-click on Define screen variants per 

business transaction. 
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Choose New entries. 

Choose the transaction you require. 

Select the fields that you want to have included on the entry screen for the posting. 

The system provides different fields depending on the transaction 

Field selection is broken down into General fields, Sender fields and Receiver fields. 

Specify whether you want to use Individual entry or List entry. 

To do so, select the appropriate option in the  Initial screen field under Additional data. 

Recommendation 

For complex postings, choose Individual entry. If you have selected a lot of fields for the entry 

screen, individual entry helps you retain a better overview. 

Selecting display variants for lists 

For the Overview list, you can select all line items for a display variant. To do so, under Additional data 

choose a variant. 

You can access the overview list from either the individual entry screen or the list entry screen. 

You can select a display variant for the navigation list by choosing a variant under Further data. 

Under individual entry, you can switch between posting records using the navigation list. 

Note 

In the display variant for the overview list and the navigation list you specify what columns are 

to be displayed, their width, and the order in which they are displayed. You can create your own 

display variants in the respective entry transaction. These are then displayed here and can be 

selected. 

You can select a transaction variant. 

To do so, under Further data choose a variant. 

Using the transaction variant and for both individual entry and list entry you can 

Define default values for particular fields 

Display or hide fields 

Change the order of the fields 

Save your entries. 

Further notes 

You can transport the screen variants straight away. 

To do so, choose Table view -> Transport and enter the screen variants in a Customizing request. 

 Actual Data Transfer 

In this IMG activity you transfer actual statistical key figures from the Logistics Information System 

(LIS) for activity types, business processes, and cost objects. 
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 Statistical Key Figure Transfer From LIS 

In this section you assign different objects (business process, activity type, cost object) a statistical key 

figure that can be given corresponding actual values from the Logistics Information System (LIS) as an 

alternative to manual entry of the key figures for the objects. 

 Maintain Statistical Key Figures (Link to LIS) 

In this IMG activity you create a link between a statistical key figure in the Activity-Based Costing 

component (CO-OM-ABC) and the corresponding key figure in the Logistics Information System ( LIS ). 

For example, statistical key figure REPOS can indicate the number of calculation items automatically 

updated in the LIS. 

You can activate the interface in the statistical key figure's master data in the Activity-Based Costing 

component. This ensures the requirement for later automatic transfer of LIS key figures to the Cost 

Center Accounting component ( CO-OM-CCA ). 

To find key figures in the LIS, two methods are available: 

Find via info-structures 

Info-structures are database tables administered by the SAP System and automatically updated with 

the different LIS key figures from a particular area or application. 

Find via info-sets 

Info-sets also serve to divide the LIS key figures. Here, however, even finer differentiation can take 

place. 

Info-structures and info-sets are defined within Logistics Controlling. 

Prerequisites 

Complete the step Maintain Controlling Area. 

Activities 

Enter the statistical key figure for which you want to create a link to the LIS. 

Choose the pushbutton "Link LIS". 

Decide whether to use info-structures or info-sets in the search for the key figure in the LIS. 

Find the desired key figure in the LIS. 

The search via info-structures takes place through the choice of application and info-structure. 

The serarch via info-sets takes place through the continuing choice of info-sets. 

The information on the corresponding LIS key figure are displayed in the statistical key figure basic 

screen. 



______________________________________________________________S

AP System  

______________________________________________________________  

SAP AG 68 

Note on transport 

To transport statistical key figures, see the IMG activity under "Controlling: Genreral". 

 Maintain Assignments of Business Processes to Statistical Key 

Figures 

In this IMG activity, you assign one or more statistical key figures to a business process. The R/3 System 

automatically supplies the key figures with values if you arrange for statistical key figure transfer to the 

Activity-Based Costing component (CO-OM-ABC) from the Logistics Information System ( LIS ). 

With this function you can define automatic entry of plan and actual data for statistical key figures for this 

object. In planning, you can overwrite values transferred from the LIS. 

Example 

You define the key figure ORDER and link it with the LIS key figure NPOIT "Number of purchase order 

items". 

You assign ORDER to one or more business processes by using an existing variant or by creating a new 

one. To limit the data selection for the key figure, enter the corresponding selection criteria in the 

characteristic values for the variant. 

Requirements 

Activate and maintain the Logistics component functions that supply data to the LIS. 

Define the business process. 

Define and link the relevant key figures with the LIS. 

Activities 

Assign one or more statistical key figures to the affected business process by entering a version and the 

fiscal year. 

You must enter a variant for each key figure if you want to limit data selection for the key figure. 

If you do not enter a variant in the characteristic values, the R/3 System selects all the key figure 

data from the LIS database. 

Save your entries. 

Note on transport 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 
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 Data Transfer from External Systems 

During external data transfer, the system distinguishes between 

plan data 

actual data 

The SAP system checks the data to be transferred just as in the corresponding dialog functions. 

Transferring external data to the SAP system requires ABAP programming experience, as you have to 

create your own transfer program. SAP provides sample programs to make this task easier. These sample 

programs contain callups for function modules that control the data transfer. 

Further information 

Detailed information on the procedures and execution of external data transfer can be found in the SAP 

Library under Financials -> Controlling (CO) -> Controlling -> CO External Data Transfer. 

 Period-End Closing 

In this IMG activity, you create period-end closing activities, which are period-based actual allocations in 

the form of sender-receiver relationships defined in cycles: 

Distribution 

Assessment 

Indirect activity allocation 

 Distribution 

In this segment you carry out the adjustments for the allocations in the actual. 

 Specify Receiver Types for Distribution 

When making distributions you can specify which table fields are active and whether, in cycles, a single 

value, an interval, or a group can be entered for these fields. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 

If you change intervals with "From" values, the "To" values are deleted from the table. 
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Example 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 

Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 
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Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 

 Define Distribution 

In this activity, you define distributions in the form of cycles by specifying rules for the settlement of 

primary costs on a cost center. 

Recommendation 

Check whether distribution can be replaced here by periodic reposting or assessment in order to achieve 

better system performance. 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 
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The following numbers of sender and receiver totals records result from the different allocations that must 

be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 

Create a plan distribution cycle by proceeding as follows: 

Determine a name for the cycle. 

Determine a validity period for the cycle. 

Maintain the header data for the cycle by entering the following. 

Which currencies are to be used in the allocations 

Whether consumption is to be allocated or not 

Whether negative tracing factors are scaled or not 

Whether cycle processing is to be iterative 

In which version the allocation is to take place 

Define cycle segments in which you store the following information. 

Sender cost element to be distributed 

Criteria for cost distribution to the receiver 

Sender objects 

Receiver objects 

Save the cycle. 
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Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Distribution 

During distribution, the following information remains: 

Original primary cost element. 

Information on the sender cost center is noted in the receiver cost center or receiver order. 

Information on the receiver cost center or order is noted in the sender cost center. 

For more information, see the "SAP Library" under Financials -> CO Controlling -> Cost Center 

Accounting -> Period-End Closing -> Defining Periodic Repostings or Periodic Allocations. 

 Assessment 

In this IMG activity you make settings for carrying out assessments from business 

processes to other processes or to cost objects. 

Requirements 

Complete the IMG activity Create Assessment Cost Elements. 

Further notes 

Further Notes 

 Determine Assessment Receiver Category (Business Processes) 

When making assessments you can specify which table fields are active and whether, in cycles a single 

value, an interval, or a group can be entered for these fields. 

You make these settings per controlling area and separately for plan and actual data respectively. 

If you change the attributes for a field that is already used in cycles then: 

If you change individual values, groups, and intervals that have a "to" value, the system deletes the 

corresponding data records from the table. 
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If you change intervals with "From" values, the "To" values are deleted from the table. 

Example 

You use assessments on cost centers, but would always only like to touch upon cost center groups as a 

receiver. 

By deleting the character of the table field  'Cost center' in the fields for input-readiness as a single value 

and in the interval in the area of receiver, you discover that only one group can be entered with the 

definition of the assessment cycle as a receiver for cost centers.  

Allocation type Assessment 

 Act./Plan Act. 

Field properties 

Field Cost center 

Activ ind. Input ready Input ready Input ready 

+ Sender X  Single value X  Interval  X  Group 

+ Receiver _  Single value _  Interval X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an assessment as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 
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Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 

Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport assessment field attributes manually, choose Table view -> Transport. 

 Create Assessment Cost Elements 

In assessment, the R/3 System converts the original cost elements cumulatively or in groups into 

assessment cost elements. The original cost elements are lost in this process. 

Assessment cost elements are secondary cost elements. 

Requirements 

- Complete the IMG activity Maintain Controlling Area, found in the General Controlling section of 

the IMG under Organizaton. 

Activities 

Create secondary cost elements of category 42 (assessment cost element). 

Note 

For more information, see Maintain Cost Element. 

Note on transport 

To transport cost elements, see the IMG activity under "Controlling: General". 
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 Maintain Allocation Structures 

If the assessment for each segment is not made with a pre-defined assessment cost element, you can 

assign the source cost elements to the desired assessment cost element in the allocation structure. During 

cycle definition, enter the allocation structure instead of an assessment cost element in the segment. 

An allocation structure for the assessment consists of at least one assignment, stating the assessment cost 

element to which the source element is assigned. The original cost elements will already have 

assignments in the source. 

Requirements 

To define the assessment cost elements required for the allocation structures, you must first complete the 

IMG activity "Create Assessment Cost Elements". 

Activities 

Creating an allocation structure. 

To create an allocation structure, proceed as follows: 

Choose "New Entries". 

Enter a name and text for the allocation structure. 

Save the allocation structure. 

Enter the assignments for each allocation structure. To make the assignments, proceed as follows: 

Select the allocation structure, and then choose "Assignments". 

Choose "New Entries". 

Enter a name and text for the assignment. 

Save the assignment. 

Specify the source for each assignment. 

To specify the source for an assignment, proceed as follows: 

Select the assignment, then choose "Source". 

Enter a cost element interval or a cost element group. 

Save the source. 

Enter the assessment cost element for each assignment. 

To specify an assessment cost element for an assignement, proceed as follows: 

Select the assignment, then choose "Assessment cost element". 

Enter the assessment cost element you require. 

Save your entries. 

Further notes 
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For further information on allocation template go to the SAP Library under Accouting -> CO-Controlling 

-> Overhead-Controlling -> Activity-Based Costing -> Period end closing ->Periodic allocations -> 

Assessment (Cost centers, business processes). 

 Maintain Process Assessment 

In this IMG activity you determine rules in the form of cycles for the allocation of primary and 

secondary costs of business processes on cost objects or other actual business processes. 

Process costs allocated through assesment of cost centers to business processes were allocated further to 

cost objects or other business processes. The costs calculated in the resource assessment example are 

allocated here to cost objects EP1 and EP2. The following cycle was defined: 

Segment 

Sender 

SEG_1 

CostElem Amount Rule Tracing Factor Receiver 

TP1 

SEG_2 

520000 2000 posted amt. fixed % rate EP1, EP2  

TP2 

SEG_3 

5000 2000 posted amt fixed % rate EP1  

TP3 

SEG_4 

5000 2000 posted amt fixed % rate EP2  

TP4 5000 6000 posted amt var. prcntg. EP1, EP2  

TP1 allocates its costs in a 50:50 ration to EP1 and EP2. 

TP2 and TP3 allocate 0% of their costs to EP1 and EP2. TP4 allocates 

on the basis of statistical key figure 'STCK'. 

On the basis of statistical key figure "number of finished pieces", the costs of final checking are allocated 

to cost objects EP1 and EP2. The following key figures are allotted to the cost objects: 

EP1 0 pieces 

EP2 200 pieces 

Receivers EP1 and EP2 are charged with the following costs from assessment cost element 422154: 

Cost Object Costs 

EP1 00 + 2000 + 6000 * (0/300) = 5000 

EP2 00 + 2000 + 6000 * (200/300) = 7000 

Prerequisites 

Carry out the steps in "Create assessment cost element". 

When using an allocation template, you must carry out the steps in Arbeitsschritt "Maintain allocation 

tempplate". 

Recommendation 
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When using assessment, distribution, and periodic reposting, note the following: 

You can use assessment if the origin of the primary costs is not important. If required, you can use 

multiple assessment cost elements for differentiation. 

Periodic reposting is recommended if the origin of primary costs is important, but the partner object does 

not need to be displayed directly. The partner information, however, is not lost. Proof of origin is 

always possible via the line item document. 

If you do need to show the partner object directly in the report, you must use distribution. The data 

volume will grow significantly for the proof of the partner objects, particularly in large distributions. 

Note that the data volume generated for past periods will grow with increased numbers of periods. 

Especially in reporting and for data backups, it is important to keep the data volume generated by 

allocation to a minimum. For this reason, assessment or periodic reposting are to be recommended. 

For performance reasons, you should not use more than 50 segments in one cycle. If necessary, define 

multiple cycles. A larger number of segments per cycle is only necessary for extensive iterations. 

Also: For performance reasons, never use more than ,000 relationships in an allocation cycle. If you 

require more than that, you must plan a mass test of the allocations beforehand. 

Example 

From a sender cost center with 0 sender cost elements, allocations are made with one segment to 500 

receiver cost centers. 

The following numbers of sender and receiver totals records result from the different allocations that must 

be written in the processed period: 

Allocation                Sender totals recds     Receiver totals recds 

-------------------------- 

 

Assessment                500                     500 

Periodic reposting        0                     500 x 0 

Distribution              500 x 0               500 x 0 

--------------------------------------------------------- 

--------------- 

This simple example already demonstrates that 

far more sender totals records are written for distribution than for periodic reposting 

far more receiver totals records are written for periodic reposting than for assessment 

In practice, because of the far higher number of senders and receivers, the advantages of assessment and 

periodic posting are even more apparent. 

Activities 
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Create an assessment cycle as follows: 

Determine a name for the cycle. 

Determine a validity period for the cycle. 

Maintain the header data for the cycle: 

what currency should be applied 

whether consumption/usage should be allocated 

whether to scale negative tracing factors 

whether the cycle changes should be iterativ 

which version of the cycles should be valid 

Define cycle segments with the following information: 

the allotted cost element of the sender 

the criteria for cost distribution per sender 

the sender 

the receiver object 

Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

 Indirect Activity Allocation 

In these IMG activities you make default settings for indirect activity allocation in actual. 

 Determine Send/Recv Categories for Indirect Acty Allocation 

For indirect activity allocation  you can determine which table fields are active and whether, in cycles you 

can enter a single value, an interval, or a group for these fields. 

You make these settings per controlling area, and separately for plan and actual data respectively. 
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Example 

You use indirect activity allocation for cost centers, but want to use only cost center groups as 

receivers. 

Remove the table field indicator "Cost Center" in the fields for individual value entry readiness 

and in the receiver area interval to ensure that you can only enter groups as cost center 

receivers during cycle definition. 

 Allocation Cat: Indirect Activity Allocation 

 Actual/Plan:  Actual 

Field Characteristics: 

Field:  Cost Center 

Active Indicator Entry-Ready   Entry-Ready   Entry-Ready 

+ Sender X  Indv. Valu X  Interval  X  Group 

+ Receiver  _  Indv. Valu _  Interval  X  Group 

Requirements 

Complete the IMG activity Maintain Controlling Area in the Implementation Guide under General 

Controlling -> Organization. 

Standard settings 

Initially, standard values are defaulted as to whether single values, intervals, or groups can be entered. In 

order to ensure overall data consistency, not all the standard values can be changed. 

Activities 

Change the field attributes of an indirect activity allocation as follows: 

Select the controlling area for which you want to change the field characteristics by entering the CO area 

in the dialog box offered. If the dialog box does not appear, you can change the CO area by 

choosing Extras -> Set CO area. 

Mark the rows from the list of fields offered for which you want to maintain field attributes. 

Depending on the field selected, one or more of the following maintenance options are offered in the 

detailed screen: 

Field attributes in cycle 

Field attributes in cycle sender control 

Field attributes as sender 

Field attributes as sender tracing factor 

Field attributes as receiver 

Field attributes as receiver tracing factor 

In the detail screen, maintain the following table fields: 
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Active indicator 

Ready-for-input as single value 

Ready-for-input as interval 

Ready-for-input as group 

To reverse changes you have made to field attributes, choose Get standard values in the detail screen. 

This retrieves the original standard values for a table field. 

Save your changes. 

Notes on transport 

To transport indirect activity allocation field attributes manually, choose Table view -> Transport. 

 Maintain Indirect Activity Allocation 

In this IMG activity you determine rules for indirect activity allocation in the form of cycles. 

In indirect activity allocation you define the use of sender activities (cost center/activity type) from the 

point of view of the activity receiver by means of tracing factors. 

You define tracing factors here as in assessment or distribution. 

Activities 

To create a cycle for indirect activity allocation: 

Determine a name for the cycle. 

Determine a time as of which the cycle will be valid. 

Maintain the header data for the cycle: 

An explanatory text 

The time to which the cycle will be valid 

Whether to scale negative tracing factors 

Define cycle segments in which you store the following information: 

A name and a text for each segment 

Sender values 

Tracing factor 

Selection criteria (sender and receiver objects) 

If necessary, attributes of business process(es) 
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Save the cycle. 

Notes for Transport 

If, in your client, you have not selected the automatic recording of changes for client-specific objects (in 

Customizing under Basis Components -> System Administration -> Change and Transport 

System -> Configure Clients),  you can transport your settings to the target system in a user-defined 

activity. 

To do this, in Customizing, choose Controlling -> General Controlling -> Production Start-Up 

Preparation -> Transport System Settings and then process the relevant activity. 

Further notes 

Conceptional Information on Indirect Activity Allocation 

Indirect activity allocation consists of two subfunctions which you can enter as required in a cycle. 

However, one segment can cover only one subfunction in each case: 

Sender activity quantities are known and can be entered as totals. Using indirect activity allocation, the 

posted activity quantities are distributed from senders to receivers according to the tracing factors 

defined in the segment. 

segment uses this method if Posted quantities (rule 1) is the sender rule and Fixed quantities 

(rule 2) is NOT a receiver rule. 

In a segment to distribute posted sender amounts, you can use activity types of category 3 manual 

entry, indirect allocation only. 

Sender activity quantities are not known because measurement is either impossible or not feasible (for 

example, a joint office working for several cost centers). However, the SAP system can derive 

sender activity quantities indirectly, based on receiver tracing factors adjusted with a sender-specific 

weighting factor. 

segment uses this method if Indirectly determined quantities (rule 3) is the sender rule, or if 

Fixed quantities (rule 2) is a sender or receiver rule. Using the Sender values function, you can 

determine sender-specific weighting factors for the sender rule Indirectly determined quantities. 

The default value is "1". 

In segments for indirect calculation of sender activity quantities you can only use activity types of 

category 2 indirect entry, indirect allocation. 

Senders and receivers in indirect activity allocation 

In indirect activity allocation for actual and plan data, senders  can be objects of the category cost 

center/activity type or business processes. 

In a given segment, you can use category 2 or category 3 activity types only. 

In indirect activity allocation for plan data, all usual CO objects are possible (cost center, cost 

center/activity type, orders, projects, etc.) as receivers 

All of these receiver categories can appear in a cycle. However, cost objects of the category cost 

center/activity type may not be combined with other receiver categories. 
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In indirect activity allocation for actual data, you can use the same cost objects as receivers as in 

manual activity allocation, meaning no cost centers/activity types. 

Fixed and variable activity references; evaluating activity quantities 

In indirect activity allocation for actual data, all quantities are posted as total quantities. The division 

into fixed and variable quantity parts is carried out through actual cost splitting. 

In indirect activity allocation for plan data, the determination of fixed and variable quantity quotas 

depends on the receiver category: 

Receivers of the category cost center/activity type post all activity quantities as variable quantities, with 

tracing factors dividing actual and plan activity into fixed and variable quantity parts. 

For all other receivers the receiver quantities are posted as fixed. 

If an activity price is available for a sender object, the activity quantities of the sender and the 

corresponding receivers are valuated using this activity price. 

Updating the databases 

The activity quantity updated on the senders is determined either from read/posted sender 

quantities (subfunction 1) or from indirectly calculated activity quantities based on receiver tracing 

factors or predefined sender quantities/receiver quantities (subfunction 2). The activity quantity 

thus determined is posted to the respective sender as activity output (quantity credit) and to the 

respective receiver as activity-dependent or activity-independent activity input in relation to their 

tracing factors (quantity debit). The indefinite credit rate is updated for plan data as well (with 

activity type category 2). 

Additionally, the following activity postings are based on the sender activity quantities: 

If available quantities are distributed (subfunction 1), the scheduled quantity are updated. If the 

sender activity quantities are indirectly determined or fixed, the activity quantity is also updated in 

addition to the scheduled quantity. 

In actual indirect activity allocation, all quantities are treated as fixed quantities. 

You use indirect activity allocation in activity price calculation. 

 Price Calculation 

In this section you make the following settings for price calculation: 

Basic Settings for Price Calculation 

Cost Component Structure 

Switching Structure 

 Change Basic Settings for Price Calculation 

You can change the following SAP default control parameters for price calculation. 

Indicator Generate. 

Controls report generation for iterative price calculation. 
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Before running price calculation, the system generates the corresponding report on the execution. 

The number of entries in the associated internal tables is generated, as well as the parallel 

processing of field groups. 

By entering realistic figures during performance problems, the storage capacities and runtimes can 

be improved significantly. 

Because generation also requires some time, you should activate this indicator only for very large 

processing runs when problems occur. If the indicator is active, entering numbers in the fields 

mentioned above can be left aside. 

Number of senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of relationships between senders/receivers 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of cost centers in the controlling area 

The number of entries in the internal tables is also set if the generation indicator is activated itself. 

Number of significant digits in the price unit 

To achieve more accurate results, the price unit can be set. The activity price is thereafter not based 

on units of 1, but on units of , 0, 00, or 000. If the activity price per unit is already relatively high, 

but you nevertheless want greater accuracy for your prices, this results in even higher values. With 

the number of significant digits, you can limit this development. The moving of digits takes place 

until the number of significant digits is reached. 

Example 

If the price per unit is 333333333, and the significant digit number was set to 6, the price unit 

remains 1 and the price 333. For 12 significant digits, the unit would be 000 and the price 

,333,333333. 

Indicator for deactivating the optimization of the price unit 

Deactivates the significant digit settings mentioned in the previous point. If this is chosen, 

the price unit is 1. 

Tolerance percentage for reconciliation of actual and scheduled activity Activity planning should be 

reconciled when price calculation is called up. The plan activity of the activity type should equal the 

scheduled receiver activity quantity. Only in this way will a sensible price be determined. All 

activity types are checked for reconciliation and, if necessary, issues warnings or error messages. 

Due to planning rounding differences, especially in period distribution, minimal variances may 

occur nevertheless. 

Enter the percentage by which plan activity may vary from scheduled activity. 

Indicator Post anyway. 

Indicator for posting of price calculation results even if errors occur. 

Exceptions are serious system errors resulting in program termination and errors occurring in 

update preparation (such as integration or document assignment problems). Normally, errors 

prevent update booking of postings. In online processing, the update can be repeated from the 

results list. In background processing, this is not the case. 

Standard settings 
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Use the function Set standard to set the parameter values defaulted by the SAP system. 

Recommendation 

SAP recommends using the standard settings unchanged. 

Changing settings to meet the requirements of your organization is useful only if your results vary greatly 

from the SAP default values. 

The changes in generation factors can worsen the runtimes of price calculation. 

Activities 

Maintain the settings for price calculation according to your requirements. 

Additional Notes 

For more information about price calculation, see the SAP Library under Financials -> Controlling 

(CO) -> Cost Center Accounting -> Cost Center Planning -> Periodic Allocations -> Plan Price 

Calculation. 

Note on transport 

To transport basic settings for price calculations, see Customizing under Controlling -> General 

Controlling. 

 Settings for Cost Component Split 

In this section you make settings for price calculation using cost component splitting. 

 Define Cost Component Structure 

You require a cost component structure to calculate prices using cost component split. 

For each cost component structure you define a cost component such as energy, personnel, or raw 

materials. The components combine all costs occuring for a particular cost element area. In this way, you 

ensure greater cost transparency in activity price calculation when putting together the activity type prices 

- for example, it becomes easier to find how much of the activity price is taken up by the material costs. 

In activity allocation, the cost component structure remains constant, meaning that the receiver takes on 

the sender cost elements and that the allocated costs are posted in the same cost components in the 

receiver as in the sender. 

A cost component structure can have a maximum of 40 defined cost components. 

Cost components are assigned to cost elements. You thereby determine which cost elements go to which 

rows in the structure, and how these components are updated in price calculation. 

The cost component structure must be stored independently of fiscal year in the version. 
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You can transfer cost component splitting directly as primary cost splitting to product costing, or you can 

use a transfer structure to transport it to the Product Cost Controlling component ( CO-PC ). 

Note 

You need only carry out the steps named in "Activity". Further settings for cost components are not 

necessary, as they are relevant for product costing only. 

Activities 

To use cost component splitting for price calculation: 

Create a cost component structure or change an existing one. 

To create a new structure, enter a two-character key and an explanatory text. 

Otherwise, choose an existing structure and maintain it in the following steps. 

Save the cost component structure. 

Define cost components 

Select the structure and choose the navigation level "Cost components with characteristics". 

If no components exist, choose "New entries". Otherwise, maintain the existing elements. 

Enter the structure, a key, and a short text for the component. 

Save your entries. 

Assign the cost elements to the cost components. 

Branch to the navigation level "Assign Cost Component - Cost Element Interval". 

If no assignments exist, choose "New entries". Otherwise, maintain the existing elements. 

For each component, enter the structure, the chart of accounts, and the relevant cost element or cost 

element interval. 

Save your entries. 

Enter the cost component structure in the fiscal year dependent part of the version's detailed information. 

Further notes 

For more information about the cost component structure, and price calculation using cost component 

splitting, see the SAP Library under Financials -> CO Controlling -> Cost Center Accounting - 

Period-End Closing -> Actual Price Calculation -> Price Calculation using Cost Component 
Splitting. 

Note on transport 

To transport of cost component structures, an individual function is available Customizing under CO - 

Controlling -> Controlling. 
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 Define Switching Structure 

You need to define a switch scheme, if within cost component split for price calculation you do not want 

a cost component split for primary costs only. In other words, where for an activity allocation, the 

allocated costs on the receiver are entered on a cost component different from that of the sender. You 

then determine which sender cost element is to be entered on which receiver cost element. 

In price calculation, a cost component structure is used for price component splitting. This structure stores 

which cost elements are to be directed into which component. 

For example, you can note in the cost component structure that material cost elements assigned to the 

sender component "Raw materials" and wage costs assigned to the sender component "Personnel" can be 

directed to the receiver component "Energy". 

As the structure is used only with a specific combination of cost center/activity type, it is entered in the 

activity type planning of the sender. The corresponding planning structure for activity type planning 

using a switching structure is found in planner profile SAP4. 

Activities 

Create a switching structure if you require one To do 

so, proceed as follows: 

Assign an existing cost component structure to a switching structure. 

Assign the structure's components to target components. 

Save your entries. 

Further notes 

For more information and an example, see the SAP Library under Financials -> CO Controlling -> 

Cost Center Accounting -> Period-End Closing -> Actual Price Calculation -> Price Calculation 
with Cost Component Split. 

Note on transport 

You can also transport switching structures manually. To do this, choose Table View -> transport. 

 Variances 

In this section you make the settings for variance calculation. 

Variance calculation in Activity-Based Costing displays the balance between the actual costs 

and the allocated actual costs in different variance categories. The individual categories are 

determined cumulatively. This means that the total of the individual variances corresponds with 
the overall balance for the business process. 
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Variance calculation distinguishes between the input side and the output side of the business 
process. 

The input side contains all the debits and credits for the business process, except the credits 

from activity allocations. On the input side you compare the actual costs (control costs) with the 
target costs. In this way, the following variance categories can be calculated: 

Price variance o Quantity 

variance o Structure 

variance o Remaining 

input variance 

The output side contains the activity allocations for the business process. On the output side 

you also compare the allocated actual costs with the target costs or the plan costs. The 
variance categories on the output side are: 

Output price variance o Fixed-

cost variance 

Volume variance 

Secondary fixed-cost variance o

 Allocation quantity variance 

Remaining variance 

Further notes 

For more information on variances, see the Application help for Activity-Based Costing under 
"Period-End Closing -> Varience Calculation". 

You can also find information in: o

 Create target version 

 Check Units of Measure in Cost Element Master Data 

In order to calculate input price and quantity variances, the system requires the consumption quantities in 

addition to actual and plan costs. Only then can it distinguish between variance categories. 

To assign consumption quantities to an account, you must define a quantity unit in the cost element 

master data. You can also assign quantities to accounts using a quantity unit you define as convertible to 

the unit stored in the cost element master data. 

In addition, if you set the indicator Record quantities in the cost element and cost center master data, the 

system issues an error message if you do not enter quantities. 

The deciding factor for variance calculation, however, is solely the quantity unit. 
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Example of Input Quantity Variance 

To provide the activity type "Machine Hours", you define the consumption of  liters of grease as a ratio of 

the activity quantity. At an operating rate of 1%, actual postings record the consumption of 12 liters. The 

input quantity variance therefore equals 1 liter because the cost center activity consumed more than 

provided for in the adjusted plan (target) costs. Consumption as based on the operating rate equals 11 

liters. 

Note 

Cost elements with frequent price fluctuations require consumption quantities for differentiated 

calculation of input price and quantity variances and their assignment to accounts. 

You can determine input price variances for cost elements with relatively stable prices. To do so, 

complete the IMG activity Determine Primary Cost Input Price Variance. The input quantity variance is 

identified here. 

Activities 

Maintain a quantity unit in the cost element master data for cost elements with frequent price fluctuations. 

Note on transport 

To transport cost elements, there is a separate Customizing function under Controlling -> 

General Controlling available (Transport Settings for Master Data. 

 Define Variance Variants 

In this IMG activity you define the variance variant determining the variance categories to be calculated. 

You can calculate the following variance categories: 

Input Side Variance: 

Input price variance 

Resource-usage variance 

Input quantity variance - Remaining input variance Output Side Variance: 

Output price variance 

Fixed-cost variance, itself divided into: 

Volume variance 

Secondary fixed cost variance 

Remaining variance 

The system calculates variances for all categories chosen. 
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The values from variance categories not chosen are added onto the following variance category. 

Fixed cost variance is calculated as a whole and not sub-divided. 

If you do not select variance categories, the two remaining variance categories hold all the variances as 

totals. 

You define the variance variant in the target version of each controlling area. 

Default settings 

The standard system includes default variance variant 001. 

Actions 

Check whether the standard variance variant meets your requirements. If you require a new variance 

variant: 

Choose New entries and enter a key and a corresponding short text for the new variance variant. 

Select the corresponding variance categories. 

Save the variance variant. 
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Note on transport 

To transport variants, choose "Table view -> Transport". 

Further notes 

For more information on and examples of variance categories, see the SAP Library under Financials -> 

CO - Controlling -> Cost Center Accounting or Activity Based Costing -> Period-End Closing -> 

Variance Calculation -> Variance Categories. 

 Define Cost Element Groups 

In variance calculation, the first splitting step distributes the activity-independent actual costs on the basis 

of the target costs and quantities by cost element to the activity types. If no target costs are given for a 

cost element, the SAP System determines target costs for the corresponding cost element group. These 

target costs are then used as the basis for the first splitting step. 

You may use either the defined cost element groups or define new cost elements for the special 

requirements of variance calculation. 

You can combine similar cost elements into cost element groups. Similar cost element groups can be 

combined to form other cost element groups so as to build a cost element hierarchy. 

You can use cost element groups: 

In the information system 

The row structure of your report is determined by the cost element structure. You can create totals 

for each node in the report. 

When processing of several cost elements in one transaction, such as 

Cost center planning 

If, for example, you wish to display and plan personnel costs in one work transaction, select 

the group "Personnel costs". 

Distribution 

Assessment 

Report totalling takes place via cost element group nodes. To achieve a clear illustration, each node on a 

level must have the same number of subordinate levels. 

Prerequisites 
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In Customizing of Financial Accounting (under General Ledger Accounting -> G/L Accounts -> 

Master Data) you have maintained a chart of accounts. 

You must have completed the Customizing activity Maintain Controlling Area in Customizing of 

General Controlling under Organization. 

Default Settings 

Standard cost element group OAS-INT is created for chart of accounts INT (international chart of 

accounts) in controlling area 0001. 

Actions 

Check whether the standard cost element groups meet your requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, business 

processes or WBS elements, you can also add a selection variant onto an end node. This end node is 

one that you already defined in the implementation guide (IMG) for the corresponding object type. 

To do this, place the cursor on the end node, then choose Insert lower level followed by .+<<)< 

Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 
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You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 
Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup node, 

the value, or the value interval, and choose Edit -> Selected entry -> Remove. The affected node 

is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry -

> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in descending 

order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 
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Node structures 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist 





 

 

in the master data, these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 



 

 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Notes on transporting 

A separate activity for transporting cost element groups exists in Customizing under Controlling -> 

General Controlling. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 



 

 

For more information about creating cost element groups, see SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Processing Master Data and Cost Elements -> Cost 

Element Groups. 

 Define Target Cost Versions 

In this IMG activity you maintain a target cost version for variance calculation. 

To carry out variance calculation in Cost Center Accounting, you must first create a target cost version 

for the respective controlling area. 

You determine the following by means of the target cost version: 

the version from which plan and actual data is read 

the version in which the target costs are calculated 

the version to which the split actual costs are posted 

the version in which the variances are updated 

In the target cost version you also store 

which cost element group is used for the first splitting step 

according to which variant the variances are determined 

Keep in mind that currently only version 000 is allowed as an entry for all versions ( plan, actual, and 

target). The standardization of variance calculation in Cost Center Accounting and Product Cost 

Accounting, however, makes the use of the target cost version necessary. 

Activities 

Create a target cost version. 

Enter a variance variant for your controlling area. 

Activate the target cost version by setting the "Active" indicator on the overview screen of the target cost 

versions. 

Note on transport 

Target versions can be manually transported by choosing "Table view -> Transport". 

 Information System 

In this IMG activity, you create and transfer reports, make settings for the Controlling document display, 

and create custom reports with the Report Writer and Report Painter tools. 

 Group Maintenance 

In this IMG activity, you adapt master data groups to the specific  requirements of the information 

system. 



 

 

For more information on group maintenance, see the SAP Library under Financials -> CO Controlling 

-> Cost Center Accounting -> Cost Center Planning -> Master Data in Cost Center Accounting -
> Master Data Groups -> Processing Master Data. 

 Maintain Business Process Groups 

In this step you create new business process groups or maintain existing groups. 

You can define groups of similar business processes. Business process groups themselves can be 

combined into groups, resulting in a business process hierarchy. 

The highest node of the standard hierarchy is normally the first business process group you created (see  

Maintain Standard Hierarchy of Business Processes). The groups you create thereafter form the 

remaining nodes of the standard hierarchy. 

You can also create independent business process groups that are not part of the standard hierarchy. A 

business process can only be assigned to one hierarchy group. However, it can be assigned to any 

number of independent business process groups. 

You can create independent business process groups only in this transaction or in the Activity-Based 

Costing menu under Master Data -> Business Process Groups -> Create. 

You use business process groups in: 

The information system 

Processing multiple processes in one transaction (such as allocations) 

Requirements 

You must already have created a controlling area and fully defined it. 

Activities 

Structure the activities in your company and derive from them your business processes and the structure 

of the business processes. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 



 

 

- Selection Variants 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing the cursor 

on the selection variant and choosing Extras -> Break down selection variant. The system then 

displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, 

choose Extras -> Where-used list group. You then receive a selection of the areas for which you 

can create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 



 

 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 



 

 

Structure 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 



 

 

Note on transport 

For the transport of settings for Activity Based Costing, an individual function is available in the IMG for 

"General Controlling". 

 Maintain Statistical Key Figure Groups 

You can combine similar statistical key figures to form statistical key figure groups. You can combine 

similar such groups to form further groups, thereby creating a hierarchy of statistical key figures. 

Statistical key figures are used: 

In the Information System, to create reports for particular key figures 

To maintain multiple key figures in Cost Center Accounting transactions: 

Cost center planning 

Distribution 

Assessment 

You may combine statistical key figures used in the distribution/assessment framework as 

tracing factors into a single group. 

Requirements 

You completed the IMG activity Maintain Controlling Area, located under General Controlling -> 

Organization. 

Activities 

Structure your statistical key figure groups in the controlling area based on your controlling 

requirements. 

Enter the group to be created or changed and choose "Enter". 

In the structure screen, select the node from which the group is to be extended and choose "Same level" 

or "Lower level". 

Data fields appear at the selected location in the tree structure. 

Enter a name and a text for the new node. 

Confirm by choosing "Accept changes". 

To assign values to an end node, select the node and choose "Insert value". Data fields appear in the tree 

structure. 

Enter a "From" value and, if necessary, a "To" value. 

Confirm by choosing "Accept changes". 

The selected values appear together with the name. 

Notes on Group Maintenance 

During group maintenance, you can take advantage of the following functions. 

- Selection Variants 



 

 

If you create or change groups of cost centers, cost elements, activity types, internal orders, 

business processes or WBS elements, you can also add a selection variant onto an end node. This 

end node is one that you already defined in the implementation guide (IMG) for the corresponding 

object type. To do this, place the cursor on the end node, then choose Insert lower level followed 

by .+<<)< Name of selection variant> ( or choose the selection variant using input help). 

By double-clicking, you can change each selection variant. 

You cannot create new selection variants while processing a group. 

You can reassign selection variants in the same way as groups. 

You can display a list of the master data that belongs to one selection variant by placing 

the cursor on the selection variant and choosing Extras -> Break down selection variant. The 

system then displays a list of the corresponding master data in a dialog box. 

Expand/collapse 

You can open the entire hierarchy to the individual value level or hide it up to the second level. You 

can thus display and print different summarization levels of the hierarchy. Under Edit, you find 

Expand all and Collapse all. 

Change node 

You can change the location of subgroups or individual nodes in the hierarchy. To do so, select the 

highest subgroup node or individual node, select the reference node, and choose Same level or 

Lower level. 

Remove nodes/values 

You can remove subgroups or values from the structure. To do so, select the highest subgroup 

node, the value, or the value interval, and choose Edit -> Selected entry -> Remove. The 

affected node is thereafter no longer part of the complete group, but remains on the database. 

Delete node from database 

To delete nodes in a database structure, select the highest node and choose Edit -> Selected entry 

-> Delete. 

You can only delete each node if it is not used elsewhere in the system. To check this, choose 

Extras -> Where-used list group. You then receive a selection of the areas for which you can 

create the Where-used list. 

Find values 

Within each group, you can search for particular values using Edit -> Cost element, cost center, 

activity type, statistical key figure, business process, order or WBS structure -> Find. The 

system expands the corresponding subgroup and highlights the single value. 

Sort values 

To sort values, choose Edit -> Cost element/Cost center/Activity type/ Statistical key 

figure/Business process/Order WBS element -> Sort in ascending order or Sort in 

descending order. 

Display master data 

You can branch to displaying master data. To do so, select the value and choose Master data. 

If you entered a value interval, you cannot display master data. 

Report info 

To maintain report information, choose Utilities -> Report settings . 

Maintain defaults 

You can maintain the following defaults using Utilities -> Defaults -> Structur, for: 

Master data 

Node structures 



 

 

You can make the following default settings to compare individual values with master data in the initial 

screen of group maintenance: 

Display texts 

Master data texts of individual values appear in the hierarchy. 

Master data validation 

Checks whether master data exists for the individual values of the hierarchy. If no master data exists, a 

warning message appears. 

You can display individual values with existing master data by entering a search string in the individual 

value field. 

Breakdown interval 

Checks whether at least one individual value exists in master data within an interval of individual 

values. If no individual value exists, a warning message appears. If values exist in the master data, 

these appear instead. 

Key date 

Enter the test date for the master data. The current date is defaulted. 

Notes on Copying Groups 

To copy groups, you have the following options: 

Copy Entire Group Structure 

In the same controlling area/chart of accounts 

To copy the group, you enter a supplementary key as a suffix. The copy receives a new 

name through the attachment of the suffix to the original name of the group node. If a suffix 

already exists, this will be replaced by the new suffix. Copy and original are two separate, 

independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 0001, group HIER997 

To a different controlling area/chart of accounts 

In this case, you create a new group based on a reference group from another controlling area 

or chart of accounts. 

The complete structure and name are copied from the current controlling area/chart of 

accounts. 

Copy and original are two separate, independent structures. 

Example: 

CO area 0001, group HIER 

 -> CO area 9999, group HIER 

This does not apply to order groups because they are not assigned to a controlling area or chart 

of accounts. 

Copy Highest Group Node in Controlling Area/Chart of Accounts and Attach Existing 

Structure 



 

 

In this case, you create a new group based on a reference group from the same controlling area or 

chart of accounts. 

The highest node holds the given group name, and the existing structure attaches to the highest 

node. All changes in the original automatically affect the copy as well. 

Example: 

CO area 0001, group HIER --> CO area 0001, group NEW_HIER 

                    |                            | 

                    +-> Node 1                   +-> Node 1 

                    +-> Node 2                   +-> Node 2 

When copying groups, the system checks whether group nodes with the copy name exist in the system. If 

at least one exists, the system asks whether it should overwrite all existing group nodes or whether it 

should not carry out copying. The standard hierarchy is exempt from this overwriting function. 

Copying groups is especially useful when you want to freeze the characteristics of a group with time-

based dependencies for objects at a given time in order to make changes affecting the following fiscal 

year. 

Example: Copy standard hierarchy for cost centers 

Problem: 

You are using planning functions for cost centers. You want to execute planning for the following 

fiscal year in the current fiscal year, based on the standard hierarchy. 

However, in the new fiscal year, changes will take place in the structure for the standard hierarchy, due 

for example to the removal or addition of cost centers, or because the hierarchy assignment for these 

cost centers has been changed. To be able to plan using the standard hierarchy structure that is valid for 

the next fiscal year, you must make the necessary changes to the standard hierarchy. The previous 

standard hierarchy is required for reporting in the current fiscal year, because it no longer matches the 

structure in the current fiscal year. 

Solution: 

Copy the current standard hierarchy to "freeze" its current state, and carry out the changes to the 

structure. 

There are two hierarchies available for you in the system: 

The current standard hierarchy used for reporting 

The changed standard hierarchy used for planning the next fiscal year Further usages of the copying 

of groups is a possibility. 

Note: 

Remember that the number of groups doubles with each copying transaction. If you have a very large 

hierarchy, you should 

regularly delete those copies you no longer need. Alternatively, you can keep the number of groups low 

by only copying those parts in which changes occur. If you do this, you need to create the backup copy 

manually. 

Note on transport 



 

 

To Transport statistical key figure groups, see General Controlling Customizing. 

Note on Validity Period 

Note that groups have no validity periods. However, most master data is time-based. 

Further notes 

For more information, see the SAP Library under Financials -> CO Controlling -> Cost 

Center Accounting -> Master Data in Cost Center Accounting, then Master Data in Center 

Accounting -> Processing  Master Data -> Master Data Groups or Statistical Key Figures -> 

Statistical Key Figure Groups. 

 Define Selection Variants for Business Processes 

You use selection variants to select master data using one or more master data attributes. The variant 

contains the fields that the SAP system evaluates in your selection report. These fields determine both the 

content and layout of a selection variant. 

The following selection reports exist: 

RKKOASEL  for cost elements 

RKKSTSEL  for cost centers 

RKLSTSEL  for activity types 

RKPRZSEL  for business processes 

RKOSEL00  for internal orders 

RKPSEL00  for projects 

You enter the selection values in the appropriate fields. You can overwrite these fields in the application; 

you can also hide those fields that you do not require. 

When maintaining the variant attributes you can also specify variables for selection variant fields. 

You need enter the selection criteria for selecting the objects only once, and then save these 

criteria as a selection variant. You can then use this variant to call up the master data of the selected 

objects. 

Example 

If you want to display reports in the information system for objects with given selection values, you can 

also enter the <name of the selection variant> under the group. 

If you want to define reports using selection variants, enter the <name of the selection variant> as the 

characteristic value under group. You can then for instance display all the cost centers for a 

company code in the report. 

Activities 



 

 

If you want to define more than one selection variant, proceed as follows: 

Enter a name for your variant in ABAP: Variants: Initial Screen. 

Transfer the Values default in the Subobjects group box and choose Create. The system displays the 

selection fields for the given master data on the screen Variant Maintenance: Report <your 

selection report>. 

Enter the values by which you want to select the desired fields. 

Choose Continue. 

You branch to the attribute maintenance in the selection variant. 

Enter a short text in the Description field. 

Save your entries. 

Notes on transport 

You can transport selection variants manually: 

Choose Variants -> Transport request.. 

Enter the program name. 

Enter the name of the variant to be transported. 

 Standard Reports 

In this activity, you add to the list of standard reports. You do so by: 

Importing standard reports into 

your production system 

Specifying report languages -

 Generating standard 

reports 

 Import Standard Reports 

In this IMG activity, you import SAP standard reports from  client 000, online or in background, to the 

client in which you are working. 

You have the following import options: 

Import some reports 

Select the required standard reports from the list of all report groups offered. 

Import all reports 

Determine a time of low system use to create a background job for importing all reports. 

Repeat the import of standard reports from client 000 after each update or new release. 

Note 

Do not change the standard objects in the target client. Rather, use them as models for your own objects. 

This ensures that changes are not overwritten by the next transport of standard objects. 



 

 

Standard settings 

The standard system includes all default reports for the components. 

Activities 

To import only some of the reports: 

Choose Online. 

Select the standard reports for the system to import. 

Choose Copy. 

To import all reports: 

Determine a time of low system use 

Choose Background 

Enter a job name. 

Transfer reports from the defaulted source client 000. 

Enter the desired start time and date, or activate the Start now indicator to instantly begin the job. 

The system plans the job and selects all available standard reports automatically. 

Further notes 

For more information on the standard reports for Activity-Based Costing, see the corresponding 

Application help under "Controlling -> Activity-Based Costing -> Activity-Based Costing Information 

System -> Important Standard Reports"; also see the selection window of the report or go to "Help -> 

Application help" after executing the report. 

 Specify Report Languages 

Report Writer can generate a report in up to 32 languages simultaneously. When generating a report 

group, the system adopts the language-dependent report parts (such as rows or column texts) in the 

languages set by you in the report. In addition, the logon language is taken into account. 

Note 

The languages that you specify are valid for all Report Writer reports and in all clients. 

To improve performance, only enter the languages required. The more languages specified, the longer it 

takes for the system to execute the report. 

Activities 

Determine the languages you need for your reports. 

Enter the required languages. 

choose New entries 

Enter a language key and the corresponding description. 

Save your entries. 



 

 

 Generate Standard Reports 

SAP standard reports that you have imported must also be generated. Only then is an executable 

program created that can be run in the information system. 

The following generation options are available: 

Generate some reports 

You receive a list of all report groups. From the list of standard reports, you can designate those 

required for your reporting needs. 

Generate all reports 

If you want to generate all reports, create a background job for times of low system use. 

Standard settings 

All standard reports for an application are defaulted in the standard SAP System. 

Activities 

To generate only some of the reports, proceed as follows. 

Choose Online. 

Mark the standard reports that the SAP System is to generate. 

Choose Generate. 

To generate all reports, create a background job for times of low system use. To do so, proceed as 

follows. 

Choose Background 

Enter a job name. 

Enter the desired start time and start date, or activate the indicator Start now to execute the job 

immediately. 

The SAP System plans the job and automatically selects all available standard reports. 

Further notes 

Non-generated reports are generated online automatically during report callup. 

 Enhancements for Line Item Reports 

You can enhance line item reports by adding custom fields. The SAP system includes the following 

standard enhancements: 

COOMEP01  CO-OM: Info System -> Line Items: Custom Fields This 

enhancement includes the following components: 

EXIT_SAPLKAEP_001 

Line Item Report, Actual: Custom Fields in Layout 

EXIT_SAPLKAEP_002 

Line Item Report, Plan: Custom Fields in Layout 



 

 

EXIT_SAPLKAEP_003 

Line Item Report, Commitments: Custom Fields in Layout 

EXIT_SAPLKAEP_004 

Line Item Report Budget/Cost Center Budget: Custom Fields in Layout 

EXIT_SAPLKAEP_005 

Line Item Report, Actual: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_006 

Line Item Report, Plan: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_007 

Line Item Report, Commitment: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_008 

Line Item Report Budget/Cost Center Budget: Customer-specific Authorization Checks 

EXIT_SAPLKAEP_009 

Line Item Reports: Customer-specific Formatting of the Lists. 

You can use this enhancement to protect layouts or to modify column headings. 

You can call up the transaction for reposting actual costs (posted to cost centers) directly from the 

actual line item report and actual document display. The system adds the new records to the reports. 

Activities 

Create the enhancement 

To do so, create a new project or use an existing project. 

Activate the project 

The enhancement is valid only after activation. 

Further notes 

Unlike modifications, enhancements are compatible with all Releases because they are not part of the 

original SAP system but part of the name range reserved for customers. 

For more information on using enhancements, use the enhancement transaction CMOD by choosing 

Utilities -> Online handbook in the section Function Exits. 

For more information on the enhancement, see the enhancement documentation in CMOD by choosing 

Display SAP documentation. 

 Custom Reports 

In this IMG activity you create custom reports. 

 Specify Report Languages 

Report Writer can generate a report in up to 32 languages simultaneously. When generating a report 

group, the system adopts the language-dependent report parts (such as rows or column texts) in the 

languages set by you in the report. In addition, the logon language is taken into account. 



 

 

Note 

The languages that you specify are valid for all Report Writer reports and in all clients. 

To improve performance, only enter the languages required. The more languages specified, the longer it 

takes for the system to execute the report. 

Activities 

Determine the languages you need for your reports. 

Enter the required languages. 

choose New entries 

Enter a language key and the corresponding description. 

Save your entries. 

 Maintain Libraries 

In this IMG activity, you can maintain previously defined libraries or create new ones. You must assign 

each report that you define to a library. 

A library is a selection of characteristics, key figures, and predefined columns from the list of all options 

in the Report Writer table. In Controlling, table CCSS is used. 

A characteristic (in earlier releases field or dimension) is a non-numerical field, for example, Account, 

Cost center, and Business area . 

A key figure (new as of Release 3) is a numerical value field, such as Amount in local currency, Total 

costs, and Activity quantity. 

A default column (in earlier releases Data-set-entry is made up of a key figure and one or more 

characteristics. With default columns, you can define standard columns that can be used more than 

once in your reports, for example, Actual costs in current fiscal year and Plan costs in closed 

fiscal year. 

Four screens are available for library maintenance: 

Header 

Key figures 

Characteristics 

Default columns 

Activities 

Check whether the standard libraries satisfy your requirements. If not, proceed as follows: 

Enter a name for the library and the name of the table to which the library is assigned. 

To copy and change an existing library, enter the name of the reference library in the field of the same 

name. 

Enter a description for your library. 

Determine which key figures are to be used in the library. 



 

 

Determine which characteristics are to be used in the library. 

Determine which default columns are to be used in the library. 

For steps 2 to 4, if necessary, enter the ranking order (position) in which the characteristics, default 

columns, and key figures are to appear in the selection lists of the Report Painter. 

Note on transport 

To transport libraries, an separate function is available, Transport Report Writer Objects, in the IMG for 

Financial Accounting under Special Purpose Ledger -> Tools -> Transport. 

Further notes 

For more information, see the SAP Library under Financials -> Financial Accounting ( FI ) -> 

Special Purpose Ledger -> Libraries. 

 Import Templates 

You import standard SAP templates for report rows or columns from client 000, online or in the 

background, to the client you are using. 

Templates are one-dimensional report modules in which complete row or column blocks are predefined, 

and which can be placed in reports during definition. 

The following options are available: 

Import a certain number of templates 

The system displays a list of all templates, from which you select those required for your 

information system. 

Import all templates 

Importing all templates should be done during times where system usage is at a minimum, using a 

background job. 

After installing a new release or update, repeat the import of templates from client 000 in order to access 

the changes. 

Standard settings 

The standard system defaults all templates. 

Activities 

To import only some of the templates, proceed as follows: 

Choose Online. 

Mark the templates that the SAP system should import. 

Choose Copy. 

To import all templates, create a background job and schedule it as follows: 

Choose Background. 

Enter a job name. 



 

 

Keep the defaulted value "000" as source client. 

Enter the desired start time and date, or use the indicator Start now to execute the job immediately. 

The system plans the job and automatically selects all existing templates. 

Further notes 

For more information, see the SAP Library under  Financials -> CO Controlling -> Cost Center 

Accounting -> Information System -> Report Definition -> Report Painter. 

 Create Reports 

Many reporting requirements are solved by standard system reports. If, however, non-standard 

requirements remain unfulfilled, you can use Report Painter for simple, quick definition of user-defined 

reports. 

You can also use standard references objects to construct your own reports: libraries, standard layouts, 

default columns, and row and column models, all in the standard system, and available for custom 

reports. 

A report can consist of several "logical" pages. This is useful if you wish to construct managerial key 

figures, such as costs per employee. You can switch between logical pages and carry out calculations 

with them. 

Report Painter report definition requires several Preparatory Steps, depending on the complexity of the 

report to be generated. 

Requirements 

To create reports for user-defined libraries with Report Painter, you must maintain the Libraries first. 

Standard settings 

The standard system includes many standard layouts and column and row models, as well as default 

columns for libraries 1VK, 1GK, 1AB, 1RU, and 7KK. As a rule these standard modules are sufficient 

for report definition. 

Recommendation 

Do not change a standard report because any changes will be overwritten when importing new reports 

from client 000 (which supplies standard reports). 

- To make small changes to a standard, use the report as a model, copy it to another name, and 

change the copy only. Choose Report -> Copy. 

You can use reports as models in one library only, but you can copy reports from other libraries. 

Activities 

The procedure when defining a Report Painter report depends on how far the supplied standards satisfy 

your requirements. 

1. If the libraries, layouts, row and column models, and default columns in the standard system are 

sufficient: 

a) Define report columns by using the supplied default columns and characteristics as well as 

formulas and standard layouts in the standard library. 



 

 

You can construct columns from characteristics, formulas, or predefined columns. Predefined 

columns can be changed by inserting further characteristics. You can also use variables, but 

only those already defined in Report Writer. 

Select a column by double-clicking. 

Choose Key figure with characteristics or Default columns for the column structure. 

If you choose Key figure with characteristics, use the dialog box to mark the key figure to 

be used in the report. 

In the following dialog box, choose the characteristics to be used in the column and afterwards 

specify the characteristic values as individual values, groups, intervals, or variables. 

To define all possible values for a chosen characteristic, enter an asterisk (*); to define an 

initial value, enter a pound sign ( # ). 

To use variables, choose Variables on/off. The SAP system automatically indicates the 

appropriate field and automatically adjusts the field length. Choose "Possible entries" to 

display all existing variables. 

If you choose Default columns, specify one of the standard default columns in the dialog 

box. You can then change or expand upon the suggested characteristics and characteristic 

values. 

To define a further report column, select the element type Formula in the dialog box. Use the 

formula editor to select other report columns and predefined cells to define a formula which 

calculates a value for the column. 

Enter a column text. Choose Copy to copy the short text to the fields Middle and Long as 

well. 

You can also use variables in a column text. To store a variable, enter an ampersand (&) 

followed by a variable name. When you activate Key as text type in the standard report layout 

under Column text, the report issues the current value of the variable. If you activate Name, 

the report issues the name of the current value. 

b) Define report rows by using the characteristics or row models available in the standard 

library. 

All steps in row definition are similar to those in column definition. 

If the libraries, layouts, and row and column models do not meet your requirements: 

If necessary, maintain the corresponding library. 

If necessary, create a new layout or change an existing one. 

If necessary, maintain the standard default columns. 

In Report Painter, choose Set maintenance -> Data set entries -> Maintenance. 

If necessary, create new row and column models. 

Proceed as described in the definition of report rows and columns. 

For further report definition proceed as described in step 1. 

Determine general selections 

General selections include the characteristics according to which you select data for a report, but 

which are not to be identified in report rows or columns. 

Save your report. 

Insert your report into a report group. 

Further Notes 

Note the following when defining reports with Report Painter: 



 

 

The SAP System stores reports created with Report Painter in a special storage area, in the same name 

range as Report Writer reports. When generating the related report group or copying to a Report Writer 

report, Report Painter reports are converted to Report Writer format. This results in the following: 

- Report Painter reports can only be changed or displayed with Report Painter. 

To subsequently change a report with Report Writer, first copy the report to a Report Writer report 

under a different name. Then modify the report with Report Writer. The SAP system automatically 

generates the necessary sets during copying. 

It is possible to execute a Report Painter report with Report Writer and to assign Report Painter reports 

to a mixed report group, that is, to a report group that contains both Report Writer and Report Painter 

reports. 

Additional editing functions 

Below is an overview of functions and work techniques in Report Painter that will facilitate you report 

definitions. 

F2 key 

To define individual report columns or rows, select the specific column or row (in the report to be 

defined) by double clicking on the corresponding text (Column1, etc. or Row1 etc.) or with the F2 

key. 

Directories 

You can display existing objects (defined by SAP or yourself) for layouts, libraries, row or column 

models as well as predefined columns. 

Create with model 

If you want to define your own libraries, reports, layouts, row or column models, you can use the 

standard objects delivered by SAP to aid you and then adjust them to your needs. 

The following functions are available to structure and format the rows and columns of your reports: 

Working with row and column models 

When defining multiple reports with similar structure, it is useful to work with models. 

Models are one-dimensional, predefined modules for rows and columns, maintained with the the 

function "Model". To incorporate individual models into your report, choose "Edit -> 

Rows/Columns -> Get row/column model...". 

Formula editor 

You can define formulas to calculate a column, row or cell. 

Changing text 

You can make subsequent changes to column and row texts. Position on the desired object and 

choose the text function. 

Changing characteristic values 

You can make subsequent changes to characteristics of columns and rows. Position on the desired 

object and choose "Edit -> Change char.values". 

Expanding rows 

To expand groups down to the single value level, choose "Edit -> Rows -> Expand". You can then 

maintain totals levels. If you do not provide for expanding groups in the rows, the groups cannot be 

expanded in the report display. 

Note 



 

 

Formatting defined for expanded rows of a group is carried out for all sub-groups of the same summation 

level (indicated by the identical number of asterisks). Formatting includes color and underlining, for 

example. 

Markings for cell calculation undertaken in the expanded rows of a group are always based on the 

highest summation level of the group. If you require a subgroup, you must define an additional 

report row for the subgroup, mark the desired cell, and afterwards hide the additional row again. 

Show or hide rows/columns 

You can show or hide one or more rows or columns. You can show hidden rows/columns again, 

change them or delete them. 

Number formats 

With this function you can define the scaling and the number of decimal places (only for columns). 

Delete 

To delete rows or columns, position on the object to be deleted and choose the delete function. 

Select 

You can select one or more rows or columns to then delete, copy, cut, etc. the selected set. 

Maintain report texts 

You can enter a title page, last page, header or footing for each report. 

Note 

It is much easier to enter report texts in the finished report after you have finished defining it. 

Overview function 

With this function you can create an overview of all characteristics, indicators, predefined columns 

and rows with details (name, last person to change it, date of change). 

Goto 

You can branch between the sections of a report as well as create new sections. You can combine 

multiple rows and columns of a report. 

Format changes 

Report Painter provides five column formats, corresponding to the print classes of Report Writer. 

You can assign a standard layout to a report, as well as additional format changes, such as reversing 

the sign, row format changes or column width. Format changes always affect all columns with the 

same format; this means columms cannot be changed individually. 

Note on transport 

To transport Report Painter reports, see the IMG activity Transport Report Writer Objects in the IMG 

for Financial Accounting under Special Purpose Ledger -> Tools -> Transport. 

For more information on user-defined reports, see the SAP Library under Financials -> CO 

Controlling -> Cost Center Accounting -> Information System -> Defining Reports. 

 Generate Reports 

You must generate the reports that you created in the current client or in a different client. Having 

defined the report, it only by generating it that a program capable of being run in the information system 

is created. 



 

 

Those reports that you created in a different client must first be imported into your current client. 

You have the following generation options: 

Generate some reports 

From a list of all reports, you select those that you want to generate. 

Generate all reports 

To generate all reports, you should create a background job for times of low system use. 

Activities 

Enter one or more report groups for generation. 

Use selection criteria to further delimit the reports to be generated. 

If you want to generate only a small number of reports, proceed as follows: 

Choose Program -> Execute. 

a) Select the report groups that the SAP System is to generate and choose Generate. 

To generate all reports, create a background job by choosing Program -> Execute in background. 

Further notes 

A report created with Report Painter is automatically generated when the report is started from report 

definition using Report -> Execute. In do doing, you assign a report to a report group. 

You can also generate report groups by choosing Report Painter -> Report Writer -> Execute report 

group. 

 Maintain Report Tree 

In this step you define: 

Which reports are contained in the report tree 

How the report tree is structured 

The report tree contains all reports for an application, arranged in a hierarchy. 

If the report tree is active, the tree structure defined in Customizing is displayed when you call up the 

Information System. 

If the report tree has been deactivated, the reports are displayed in a list when you call up the information 

system. 

Standard settings 

The standard system contains a predefined report tree for each application. 

Recommendation 

You should add the reports that are in the report tree to the report list. 

Activities 



 

 

Check the report tree that is supplied in the standard system. 

Define additional report trees as required. 

 User Settings 

In this activity, you define the default settings for calling up Report Painter reports. 

You can store the default settings either as a default setting for all users or as a user-specific setting. 

The user settings include: 

Settings for the report currency and for currency translations (report currency) 

Presettings for the selection criteria during the report call (selection criteria) 

Agreements on the work with extracts during the report call (settings for extract management) 

 Specify User Settings 

In this IMG activity, you specify the following user settings for the information system: 

Basic data 

Planning time frame 

Report time frame 

Report currency 

Other information, such as version and actual valuation 

You can store the basic data, planning and report time frames as user- specific or standard settings. The 

standard settings are valid for all users without user-specific settings. 

You thus determine the default values for the report selection screens. 

These settings are only valid for reports in components within Controlling or Cost Element Accounting. 

In the basic data, you can set the following default values: 

Controlling area 

Report objects, such as cost center groups, statistical key figure groups, activity type groups, cost element 

groups, or individual values or intervals for cost centers. 

You can determine the planning time frame as follows: 

Fiscal year 

The fiscal year can be the current year, previous year, or a year that you defined. 

If you choose No profile, the system takes the user-profile parameters for the selection. 

Note 

Maintain the User profile as follows: 



 

 

Choose System -> User defaults -> User data and the Parameters tab index. 

Period 

The period can be the current period, previous period, or a period interval that you specified. 

You can decide on the interval from period one to the current, or previous period. The current 

period, or the previous period is therefore defaulted for reports that you do not run during a period 

interval. 

If you choose No profile, the system uses the user-profile for parameter selection. 

You can specify the report time frame as follows: 

Fiscal year 

This can be the current fiscal year, the previous year, or an interval that you specify. If you 

choose No profile, the system uses the user-profile for parameter selection. 

Period 

The period can be the current period, previous period, or a period interval that you specified. 

The period can be the interval between period one to the current or previous period. The current or 

previous period is therefore defaulted for reports that you do not run during a period interval. 

If you choose No profile, the system uses the user-profile for parameter selection. 

You can store the report currency, either user-defined, or as a standard setting. The standard setting is 

valid for all users without user-defined settings. 

You use the report currency to specify which currency is used for Report Painter reports, line item 

reports or planning overviews, and to determine how the currency is translated. 

The settings are valid in Controlling and Cost Element Accounting for all planning overviews and Report 

Painter reports that have the Cost, Secondary cost, Actual cost, and Variable cost key figures, in 

which the currency is not defaulted 

In line item reports for Controlling, the settings are valid for the following columns: Cost in report 

currency, Variable costs in report currency, and Fixed costs in report currency. 

These settings are valid, regardless of the component used to define the report currency. 

You can display reports 

in Cost Element Accounting in: 

The company code currency 

The group currency 

The controlling area currency - A target currency that you specified 

The Overhead Cost Controlling components in: 

The controlling area currency 

The object currency 

The transaction currency 

A target currency that you specified 

In totals reports using report currency, if you call up another report using the report-report interface then 

the system displays both reports in the same currency. 



 

 

When you enter a target currency, specify which reference currency is to be used for the currency 

translation. In Cost Element Accounting, the reference currency can be the company code currency, 

group currency, or controlling area currency. In the Controlling components, it can be the controlling 

area currency, the object currency, or the transaction currency. 

You also need to enter the following: 

Key date for translation 

Translation for each exchange rate date 

Translation on a fixed date 

Period-specific translation on the last day of each period 

The exchange rate type that you require 

You can use the exchange rate type to differentiate between buying rate, bank selling rate, or the 

average rate. 

To display reports in euro for all users, for example, you need to specify this in the standard settings. 

Further entries 

Versions 

Default the plan version that you require for the reports. 

Actual valuation 

You enter settings for either legal, group, or profit center valuation. 

Requirements 

You need to process the Currencies IMG activity in the Implementation Guide under Global Settings. 

Activities 

Make default settings 

If you want to create or change default settings, you do not have to enter a user. Choose Execute. 

Choose Change standard. 

Make your entries choose Confirm to exit the dialog box. 

Save your entries. 

Make settings for one, several, or all users 

If you want to create or change the settings for one or more users, enter the corresponding user or users. 

To enter several users, choose Multiple selection. 

The system then displays a list of all users. 

Select the users you want to edit, then choose Copy to leave the dialog box. The settings 

of all selected users can now be edited. 

If you want to edit the settings for all users with user-specific settings, enter "*". The system 

displays a list of all users with user-specific settings. 

Choose Execute. 

If you selected users without any settings, you can transfer the settings from the default settings by 

choosing "Yes". 



 

 

If you want to enter new settings, choose "No". 

To create new user settings, proceed as follows: 

You want to create new settings for a user. 

Choose Create and enter the name of the user. 

You want to copy the settings for a user from those of an existing user. 

Select the existing user. Choose Copy and enter the name of the new user. 

You want to copy the settings for a user from the standard settings. Choose Copy from standard 

and enter the name of the user. 

To change user settings, proceed as follows: 

You want to change the settings of a user. Double-click the relevant line. 

You want to edit the settings of several users. 

Select the relevant lines and double-click one line. In the dialog box, you can display the 

settings for the selected users by choosing Previous user or Next user. 

You want to make the same settings for several users. 

Mark the relevant users. 

You can select all users, for example, with Select all. 

Position the cursor on a line in the column you want to change and choose Multiple replace. 

You want to change a certain setting for all users, who fulfill certain filter criteria. Upon fiscal year 

change, for example, you changed a cost element group and you would like to store the new 

group as a selection criterion for all users, who have used the old cost element group up to 

now. 

Select the column header to apply the filter to that column. 

Choose Set filter. 

Enter the filter criteria and choose Copy. The system displays a list of the users who fulfill the 

filter criteria. Choose Select all. 

Position the cursor on a line in the column you want to change and choose Multiple replace. 

Enter the required settings, and choose Copy to exit the dialog box. 

Save your entries. 

Notes on transporting 

To transport the default settings, choose Default settings -> Transport. 

To transport the settings for individual users, mark the corresponding users, and choose User settings -> 

Transport. 

Further notes 



 

 

To edit lists, use the ABAP List Viewer functions. For information on these, see the SAP Library: 

Cross-Application Components -> General Application Functions ( CA-GTF )-> ABAP List 
Viewer. 

 Authorization Management 

 Maintain Authorizations and Profiles 

Introduction to Procedure for Creating Activity Groups 

The following information describes the standard procedure for creating simple activity groups. 

It covers processing of an activity group with the option Basic maintenance in transaction 

PFCG. 

Step 1 

Create the activity group. 

Step 2 

In the Description field, enter a description of the function the activity group is to perform. 

Step 3 

On the Menu tab, assign transactions to the activity group. 

You can either enter the transactions directly. 

Alternatively, you can use the Menu selection key to assign menu options from the company menu 

(provided that this menu has already been generated in the current release). 

The activities selected from this menu are displayed in the session manager for all users assigned to 

the activity group as a user menu. 

Step 4 

On the Authorizations tab, choose Change authorization data 

Depending on which transactions you selected, a dialog box may appear on which you are 

requested to maintain the Org. levels. These organizational levels are authorization fields that 

appear simultaneously in many authorizations and which can be maintained together this way. 

An example here is the company code, which appears in many authorization objects. By 

assigning values to the organizational levels, you are also maintaining the corresponding 

authorization fields for all authorizations in the overview tree that follows. 

The system displays an overview tree of all authorizations that SAP suggests for the transactions 

selected. Some of these authorizations already contain values. 

For those authorizations where an amber traffic light is displayed, authorization values must be 

manually entered. You enter these values by clicking on the white line to the right of the 

authorization field. Once you have maintained the values, the authorizations are classed as 

manually modified and are not overwritten if you include more transactions and reprocess 

authorizations. By clicking on the traffic lights, you can assign the full authorization for all 

non-maintained fields for the hierarchy level in question. 

A red traffic light indicates that organizational levels exist that do not yet contain any values. You 

can enter/change these values by choosing Org. levels. 



 

 

If you require further functions in the overview tree like copying or combining authorizations, you 

can display additional functions by choosing Utilities -> Settings. 

Generate an authorization profile for the authorizations. To do so, choose Authorizations -> 

Generate. 

The system now asks you to enter a name for the authorization profile that now arises and defaults a 

name that exists in the customer name range. 

Once the profile has been generated, exit the overview tree. 

If you make changes to the menu selections and then call up the overview tree for the 

authorizations, the system tries to add the authorizations for the new transactions to the 

existing authorizations. In so doing, traffic lights can be changed back to amber 

becauseauthorizations that are not fully defined appear once more in the overview tree. You 

then need to enter values manually for these authorizations or to delete them if they are not 

required. 

To delete an authorization you must first deactivate it. 

General authorizations like spool display and printing are not generally defined for the transactions. 

For this reason, authorization templates exist that you can add to the existing data. To do so, 

from the menu choose Edit -> Insert auth. -> From template... and choose one of the 

templates from (for example SAP_USER_B Basic authorization for application users or 

(for example SAP_PRINT Print authorization). Alternatively, you can also create a 

separate activity group for these general authorizations, simplifying handling. 

Step 5 

On the User tab, assign users to the activity group. 

For the users assigned, the menu items belonging to the activity group are displayed in the session 

manager as a user menu. 

In addition, the generated authorization profiles are automatically 

entered in the user master record when you carry out the User master comparison. To do so, 

choose User compare on the User tab and then choose the option Cpmplete compare. 

If you do not narrow down the selections by specifying a particular period, but instead use the 

period defaulted by the system (current date to 12/31/9999) no further action is necessary. If 

you specify a particular period, then you need to ensure the report program 

PFCG_TIME_DEPENDENCY is scheduled periodically every day. This report 

automatically updates the user master records. You also need to schedule this report if using 

Organizational Management (no further details on this are entered into here). 

It is extremely important that you never enter generated authorization profiles directly in the user 

master records (as is the case for manually created authorization profiles). You can only link 

generated profiles to users by assigning the users to the corresponding activity group and then 

running a compare on the user master data. When the system runs the compare, it enters the 

profiles of the activity group for all users belonging to the activity group. 

Step 6 

If you want to transport the activity group into another system, you now need to enter the activity 

group in a transport request. 

To do so, choose Activity group -> Transport.. You can now specify whether the user assignment 

should also be transported. 

The authorization profiles are also transported (unless you specified that you do not want them to 

be transported). 



 

 

Following the import in the target system, you then need to carry out a full user master compare for 

the imported activity groups. You can either start this comparison yourself or it can be carried 

out automatically by report program 

PFCG_TIME_DEPENDENCY (assuming this report is scheduled to run periodically in the 

target system). 

Detail information 

See also the general documentation on the Profile Generator in the SAP Library. Choose: 

Basis Components -> Computing Center Management System -> Users and Roles or in the 

Implementation Guide (IMG), choose: Basis Components -> System Administration -> Users and 

Authorizations -> Maintain Authorizations and Profiles using Profile Generator. 

 Program Enhancements for Periodic Allocation Authorizations 

The R/3 System includes the following extensions for authorization checks of assessments and indirect 

activity allocations: 

SAPMKAL1 Allocations: Authorization Checks for Cycle Maintenance This 

extension includes the following component: 

EXIT_SAPMKAL1_001 

Customer exit for authorization check of cycle maintenance 

SAPMKGA2 Allocations: Execute Authorization Check During Cycle This 

extension includes the following component: 

EXIT_SAPMKGA2_001 

Customer exit for execution of authorization check during cycle 

Activities 

Create the extension. 

To do so, create a new project or use an existing project. 

Activate the project. 

The activation starts the extension in the R/3 System. 

Further notes 

Extensions, unlike modifications, are not affected by release changes because they are stored in a name 

space reserved for the customer. 

For more information on extensions, run extension transaction CMOD, choose "Utilities -> Online 

manual", and read the section "Function Exits". 

To find the documentation for a given extension in extension transaction CMOD, select 

"Documentation" and choose "Display". 

 





 

 

 


